Autor Wątek: GG nie działa na LMDE3  (Przeczytany 5228 razy)

Offline Marsjanin

  • Miętowe nasionko
  • *
  • Wiadomości: 11
  • Punkty: 0
  • Płeć: Mężczyzna
GG nie działa na LMDE3
« dnia: Październik 23, 2018, 00:03:27 am »
Witajcie. Na wstępie przepraszam, jeśli wybrałem zły dział… Mam dystrybucję hmm, eksperymentalną, to znaczy już od dłuższego czasu siedzę na LMDE, jednak ostatnio przeszedłem z LMDE2 na 3, i co za tym idzie z Mate na Cinnamona. Niby nawet jest fajnie, środowisko ogólnie spoko. Ale.

Nie działa GG. Jak działało na LMDE2, tak tutaj nie działa. Z mojego punktu widzenia nic się nie dzieje, odpalanie GG wygląda jak odpalanie pustego skryptu – wykonuje się w ułamku sekundy i nie zwraca żadnych błędów. Sposób dystrybucji GG jest osobliwy – plik .tar.bzip działający jak dotąd pod każdym Linuksem… No, jak dotąd. Napisałem do GG, poprzez GG wskazali maila, na mailu nabrali wody w usta. Jest ktoś chętny, by pomóc mi to rozkminić? Może czegoś brakuje w systemie?
LMDE3C-E7240

Offline dedito

  • Urząd Porządkowy
  • Miętowy krzew
  • *******
  • Wiadomości: 295
  • Punkty: 162
Odp: GG nie działa na LMDE3
« Odpowiedź #1 dnia: Październik 23, 2018, 06:20:58 am »
Uruchom w terminalu i pokaż co zwróci.

Masz też alternatywy w postaci kadu czy webowego gg.
« Ostatnia zmiana: Październik 23, 2018, 06:22:55 am wysłana przez dedito »

Offline Marsjanin

  • Miętowe nasionko
  • *
  • Wiadomości: 11
  • Punkty: 0
  • Płeć: Mężczyzna
Odp: GG nie działa na LMDE3
« Odpowiedź #2 dnia: Październik 23, 2018, 14:37:12 pm »
standardowe polecenie ./gg w terminalu, oczywiście w odpowiednim katalogu, nie zwraca nic. Jak pusty skrypt.
LMDE3C-E7240

Offline dedito

  • Urząd Porządkowy
  • Miętowy krzew
  • *******
  • Wiadomości: 295
  • Punkty: 162
Odp: GG nie działa na LMDE3
« Odpowiedź #3 dnia: Październik 23, 2018, 16:34:09 pm »
No to pokaż wyniki, uruchamiając to oczywiście w odpowiednim katalogu:
sh -x ggldd gghubldd ggapp

Offline Ender

  • Dorodna miętowa sadzonka
  • ***
  • Wiadomości: 155
  • Punkty: 2
  • Płeć: Mężczyzna
Odp: GG nie działa na LMDE3
« Odpowiedź #4 dnia: Październik 23, 2018, 17:59:57 pm »
Ja używam KADU.

Offline Marsjanin

  • Miętowe nasionko
  • *
  • Wiadomości: 11
  • Punkty: 0
  • Płeć: Mężczyzna
Odp: GG nie działa na LMDE3
« Odpowiedź #5 dnia: Październik 25, 2018, 18:04:53 pm »
sh -x gg
$ sh -x gg
+ dirname gg
+ GG_PATH=.
+ ./gghub
Cytuj
ldd gghub
$ ldd gghub
linux-vdso.so.1 (0x00007fff699f5000)
librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007fad8b501000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007fad8b2e4000)
libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007fad8af62000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007fad8ac5e000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007fad8aa47000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fad8a6a8000)
/lib64/ld-linux-x86-64.so.2 (0x00007fad8b709000)
Cytuj
ldd ggapp
$ ldd ggapp
linux-vdso.so.1 (0x00007fffb09a5000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f71ad1ee000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f71acfea000)
libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f71acc68000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f71ac964000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f71ac5c5000)
/lib64/ld-linux-x86-64.so.2 (0x00007f71ad40b000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f71ac3ae000)
LMDE3C-E7240

Offline dedito

  • Urząd Porządkowy
  • Miętowy krzew
  • *******
  • Wiadomości: 295
  • Punkty: 162
Odp: GG nie działa na LMDE3
« Odpowiedź #6 dnia: Październik 25, 2018, 20:42:22 pm »
I jeszcze logi, ale nie pamiętam nazwy, powinny być w katalogu gg o nazwie kończącej się na .log.
Pokazanie zawartości katalogu gg pozwoli namierzyć:
ls -lR
« Ostatnia zmiana: Październik 25, 2018, 20:46:41 pm wysłana przez dedito »

Offline Marsjanin

  • Miętowe nasionko
  • *
  • Wiadomości: 11
  • Punkty: 0
  • Płeć: Mężczyzna
Odp: GG nie działa na LMDE3
« Odpowiedź #7 dnia: Październik 25, 2018, 23:09:25 pm »
~/.gg/logs/*.log
To ostatni, pozostałe 6 właściwie się nie różni.
LMDE3C-E7240

Offline dedito

  • Urząd Porządkowy
  • Miętowy krzew
  • *******
  • Wiadomości: 295
  • Punkty: 162
Odp: GG nie działa na LMDE3
« Odpowiedź #8 dnia: Październik 26, 2018, 06:30:08 am »
ehh ... to pokaż je ... co mi po nazwie.


Offline dedito

  • Urząd Porządkowy
  • Miętowy krzew
  • *******
  • Wiadomości: 295
  • Punkty: 162
Odp: GG nie działa na LMDE3
« Odpowiedź #10 dnia: Październik 26, 2018, 19:27:01 pm »
Niech mnie ktoś zmieni, bo mnie rence opadajom

Offline kris777

  • Dorodna miętowa sadzonka
  • ***
  • Wiadomości: 244
  • Punkty: 52
Odp: GG nie działa na LMDE3
« Odpowiedź #11 dnia: Październik 26, 2018, 21:21:59 pm »
W necie pisze iż GG wymaga:
Biblioteki (w wersji podanej lub nowszej): GTK 2.1, GLib 2.12, Pango 1.14, X.Org 1.7, libstdc++ 4.3
Zainstalowane oprogramowanie Adobe Flash Player (co najmniej) wersja 10.3 firmy Adobe Systems
Ps. zainstalowałem GG tak dla sprawdzenia na LM Mate 18.3 .... gg działa od przysłowiowego strzału  :P
ldd -v /home/kris/Pulpit/GG/ggapp
   linux-vdso.so.1 =>  (0x00007ffec0b8d000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f7f10121000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f7f0ff1d000)
libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f7f0fb9b000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f7f0f892000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f7f0f4c8000)
/lib64/ld-linux-x86-64.so.2 (0x00007f7f1033e000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f7f0f2b2000)

Version information:
/home/kris/Pulpit/GG/ggapp:
libc.so.6 (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/libc.so.6
libc.so.6 (GLIBC_2.3.2) => /lib/x86_64-linux-gnu/libc.so.6
libc.so.6 (GLIBC_2.3.4) => /lib/x86_64-linux-gnu/libc.so.6
libc.so.6 (GLIBC_2.4) => /lib/x86_64-linux-gnu/libc.so.6
libc.so.6 (GLIBC_2.3) => /lib/x86_64-linux-gnu/libc.so.6
libstdc++.so.6 (GLIBCXX_3.4) => /usr/lib/x86_64-linux-gnu/libstdc++.so.6
libstdc++.so.6 (GLIBCXX_3.4.9) => /usr/lib/x86_64-linux-gnu/libstdc++.so.6
libstdc++.so.6 (CXXABI_1.3) => /usr/lib/x86_64-linux-gnu/libstdc++.so.6
ld-linux-x86-64.so.2 (GLIBC_2.3) => /lib64/ld-linux-x86-64.so.2
libpthread.so.0 (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/libpthread.so.0
libdl.so.2 (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/libdl.so.2
libm.so.6 (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/libm.so.6
/lib/x86_64-linux-gnu/libpthread.so.0:
ld-linux-x86-64.so.2 (GLIBC_2.2.5) => /lib64/ld-linux-x86-64.so.2
ld-linux-x86-64.so.2 (GLIBC_PRIVATE) => /lib64/ld-linux-x86-64.so.2
libc.so.6 (GLIBC_2.14) => /lib/x86_64-linux-gnu/libc.so.6
libc.so.6 (GLIBC_2.3.2) => /lib/x86_64-linux-gnu/libc.so.6
libc.so.6 (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/libc.so.6
libc.so.6 (GLIBC_PRIVATE) => /lib/x86_64-linux-gnu/libc.so.6
/lib/x86_64-linux-gnu/libdl.so.2:
ld-linux-x86-64.so.2 (GLIBC_PRIVATE) => /lib64/ld-linux-x86-64.so.2
libc.so.6 (GLIBC_PRIVATE) => /lib/x86_64-linux-gnu/libc.so.6
libc.so.6 (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/libc.so.6
/usr/lib/x86_64-linux-gnu/libstdc++.so.6:
ld-linux-x86-64.so.2 (GLIBC_2.3) => /lib64/ld-linux-x86-64.so.2
libm.so.6 (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/libm.so.6
libgcc_s.so.1 (GCC_4.2.0) => /lib/x86_64-linux-gnu/libgcc_s.so.1
libgcc_s.so.1 (GCC_3.3) => /lib/x86_64-linux-gnu/libgcc_s.so.1
libgcc_s.so.1 (GCC_3.0) => /lib/x86_64-linux-gnu/libgcc_s.so.1
libc.so.6 (GLIBC_2.14) => /lib/x86_64-linux-gnu/libc.so.6
libc.so.6 (GLIBC_2.4) => /lib/x86_64-linux-gnu/libc.so.6
libc.so.6 (GLIBC_2.18) => /lib/x86_64-linux-gnu/libc.so.6
libc.so.6 (GLIBC_2.3.4) => /lib/x86_64-linux-gnu/libc.so.6
libc.so.6 (GLIBC_2.3) => /lib/x86_64-linux-gnu/libc.so.6
libc.so.6 (GLIBC_2.17) => /lib/x86_64-linux-gnu/libc.so.6
libc.so.6 (GLIBC_2.3.2) => /lib/x86_64-linux-gnu/libc.so.6
libc.so.6 (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/libc.so.6
/lib/x86_64-linux-gnu/libm.so.6:
ld-linux-x86-64.so.2 (GLIBC_PRIVATE) => /lib64/ld-linux-x86-64.so.2
libc.so.6 (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/libc.so.6
libc.so.6 (GLIBC_PRIVATE) => /lib/x86_64-linux-gnu/libc.so.6
/lib/x86_64-linux-gnu/libc.so.6:
ld-linux-x86-64.so.2 (GLIBC_2.3) => /lib64/ld-linux-x86-64.so.2
ld-linux-x86-64.so.2 (GLIBC_PRIVATE) => /lib64/ld-linux-x86-64.so.2
/lib/x86_64-linux-gnu/libgcc_s.so.1:
libc.so.6 (GLIBC_2.14) => /lib/x86_64-linux-gnu/libc.so.6
libc.so.6 (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/libc.so.6
przykładowy log:
https://pastebin.com/yGLj4An8

dziwne ale wynika iż jest to raczej jakiś błąd programu GG pod linux-a ?
a może tylko Debian ma takie problemy ?  .... https://www.debian.pl/viewtopic.php?f=18&t=35174
Ps. faktycznie mam drugi system Debian GNU/Linux 9.5 (stretch) 4.9.0-8-amd64
...przypadłość dla GG jak w tym wątku :-) ...
« Ostatnia zmiana: Październik 27, 2018, 13:24:55 pm wysłana przez kris777 »

Offline Marsjanin

  • Miętowe nasionko
  • *
  • Wiadomości: 11
  • Punkty: 0
  • Płeć: Mężczyzna
Odp: GG nie działa na LMDE3
« Odpowiedź #12 dnia: Październik 30, 2018, 00:44:35 am »
GG działało od pierwszego strzału również w LMDE2 pod Mate, nie wiem, z czym tu się żre… Jednak na czystym Debianie (również z Mate) 8.x działało równie dobrze. Manjaro też je strawiło bez oporu o ile pamiętam, tam jest XFCE. Wszystko 64 bity oczywiście. Flasha mam, i dla Firefoksa i dla Chromium. Wygląda więc to na konflikt z Debianem 9 Stretch. :(

Z tego co zrozumiałem z wyjścia ldd, pliki, do których nie ma podanych ścieżek to te brakujące, więc brakuje mi linux-vdso.so.1 – rzeczywiście nie mam tego nigdzie w systemie. Szukam właśnie skąd to pobrać i patrzę w zasoby jak sroka w gnat, nigdzie tak po prostu to nie leży, najprędzej mi jakieś .rpm-y wyskakują. Pobieram, zaglądam, jest katalog vdso ale pliku linux-vdso.so.1 w nim nie widzę (zresztą nigdzie w archiwum .rpm). Jest vdso32.so, vdso64.co i vdsox64.so – próbowałem wypakować plik z 64 w nazwie, zmienić mu ją na żądaną i umieścić w katalogu GG, ale nic to nie dało. Może trzeba go wrzucić gdzie indziej, albo użyć innego pliku? Nie mam pomysłu a błądzę niczym dziecko we mgle.

PS. dedito, nie chciałem Cię zdenerwować, niemniej nie rozumiem powodu Twojej frustracji. Miałem nie używać pastebina tylko kleić logi na forum?
LMDE3C-E7240

Offline dedito

  • Urząd Porządkowy
  • Miętowy krzew
  • *******
  • Wiadomości: 295
  • Punkty: 162
Odp: GG nie działa na LMDE3
« Odpowiedź #13 dnia: Październik 30, 2018, 06:25:46 am »
Jest takie narzędzie.
apt-file search <nazwa_pliku>Jak nie ma to doinstalować apt-file, przykładowo z terminala/konsoli:
apt-get install apt-file
apt-file update
P.S.
Nie zdenerwowałeś mnie, po prostu jak zobaczyłem 8 (słownie osiem!) tych samych (co do merytoryki) logów wklejonych na serwis zewnętrzny (przy krótkich logach wystarczy forum) to dostałem ataku bezsilności :D.
« Ostatnia zmiana: Październik 30, 2018, 06:55:40 am wysłana przez dedito »

Offline Marsjanin

  • Miętowe nasionko
  • *
  • Wiadomości: 11
  • Punkty: 0
  • Płeć: Mężczyzna
Odp: GG nie działa na LMDE3
« Odpowiedź #14 dnia: Listopad 01, 2018, 00:03:28 am »
Jest takie narzędzie.
apt-file search <nazwa_pliku>
apt-file search linux-vdso.so.1 nie zwraca nic. Czy na u kogoś z Was, kto testował GG i działa, jest ten plik?
Cytuj
P.S.
Nie zdenerwowałeś mnie, po prostu jak zobaczyłem 8 (słownie osiem!) tych samych (co do merytoryki) logów wklejonych na serwis zewnętrzny (przy krótkich logach wystarczy forum) to dostałem ataku bezsilności :D.
No toć pisałem, że pozostałe 6 (a później 7) się właściwie nie różni… Nie zrozumieliśmy się.
LMDE3C-E7240