Autor Wątek: Bardzo kiepski internet w Linux Mint  (Przeczytany 751 razy)

Offline bambaryla

  • Miętowe nasionko
  • *
  • Wiadomości: 15
  • Punkty: 0
Bardzo kiepski internet w Linux Mint
« dnia: Listopad 10, 2018, 15:32:10 pm »
Cześć. Mam problem i z mintem i z ubuntu. Mam strasznie kiepski sygnał wi-fi na obu systemach. Sprawa ma się inaczej na Windowsie, bo tam jest wszystko spoko, więc kwestia leży w linuxie (albo nie mam doinstalowanego sterownika albo coś w tym guście, ale totalnie się nie znam).

Jestem nowym posiadaczem Linuxa, nie miałem wcześniej styczności. Jest to dość uciążliwe, bo przechodząc do oddalonego o ścianę pokoju, nie mam już internetu. Wcale nie polepsza się prędkość gdy usiądę przy routerze.

Więc podsumowując: kiepskie wi-fi, na ikonce jedna kreska na pasku zadań. Proszę o pomoc.

Offline yahoob3

  • Grupa Trzymająca Władzę
  • Wielki miętus
  • *****
  • Wiadomości: 912
  • Punkty: 191
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Bardzo kiepski internet w Linux Mint
« Odpowiedź #1 dnia: Listopad 10, 2018, 16:00:35 pm »
Szklana kula zdechła, dlatego musisz podać nam informacje o Twojej karcie sieciowej ;)
Pokaż na początek wynik polecenia:
inxi -N -xxxW sumie to informacja o komputerze też by się przydała:
inxi -Fxz

Wyniki wklej pomiędzy znaczniki code - godnie z instrukcją: https://forum.linuxmint.pl/index.php/topic,6937.msg64458.html#msg64458
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

Offline bambaryla

  • Miętowe nasionko
  • *
  • Wiadomości: 15
  • Punkty: 0
Odp: Bardzo kiepski internet w Linux Mint
« Odpowiedź #2 dnia: Listopad 10, 2018, 16:11:26 pm »
Wyniki:
https://www.upload.ee/image/9173907/6.png
https://www.upload.ee/image/9173942/44444.png

Offline yahoob3

  • Grupa Trzymająca Władzę
  • Wielki miętus
  • *****
  • Wiadomości: 912
  • Punkty: 191
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Bardzo kiepski internet w Linux Mint
« Odpowiedź #3 dnia: Listopad 10, 2018, 16:27:21 pm »
Łatwiej byłoby, gdybyś skopiował tekst z terminala i wkleił na forum jak prosiłem.
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

Offline bambaryla

  • Miętowe nasionko
  • *
  • Wiadomości: 15
  • Punkty: 0
Odp: Bardzo kiepski internet w Linux Mint
« Odpowiedź #4 dnia: Listopad 10, 2018, 16:32:45 pm »
Nie zrozumieliśmy się, soreczka.
Wynik z inxi -N -xxx:
bartek@Bartek:~$ inxi -N -xxx
Network:   Card-1: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 4000
           bus-ID: 07:00.0 chip-ID: 10ec:8168
           Card-2: Realtek RTL8723BE PCIe Wireless Network Adapter
           driver: rtl8723be port: 3000 bus-ID: 0d:00.0 chip-ID: 10ec:b723

Wynik z inxi -Fxz:
bartek@Bartek:~$ inxi -Fxz
System:    Host: Bartek Kernel: 4.15.0-20-generic x86_64 bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.8 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: HP product: HP 250 G4 Notebook PC v: Type1ProductConfigId serial: N/A
           Mobo: HP model: 80C1 v: 96.49 serial: N/A
           UEFI [Legacy]: Insyde v: F.22 date: 04/14/2017
Battery    BAT1: charge: 13.4 Wh 100.0% condition: 13.4/31.1 Wh (43%)
           model: COMPAL PABAS0241231 status: Full
CPU:       Dual core Intel Core i3-5005U (-MT-MCP-)
           arch: Broadwell rev.4 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 7982
           clock speeds: max: 1900 MHz 1: 1556 MHz 2: 1251 MHz 3: 1430 MHz
           4: 1228 MHz
Graphics:  Card: Intel HD Graphics 5500 bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.32hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2)
           version: 4.5 Mesa 18.0.0-rc5 Direct Render: Yes
Audio:     Card-1 Intel Broadwell-U Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Card-2 Intel Wildcat Point-LP High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-20-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 4000 bus-ID: 07:00.0
           IF: enp7s0 state: down mac: <filter>
           Card-2: Realtek RTL8723BE PCIe Wireless Network Adapter
           driver: rtl8723be port: 3000 bus-ID: 0d:00.0
           IF: wlp13s0 state: up mac: <filter>
Drives:    HDD Total Size: 500.1GB (3.1% used)
           ID-1: /dev/sda model: ST500LT012 size: 500.1GB
Partition: ID-1: / size: 37G used: 7.0G (21%) fs: ext4 dev: /dev/sda6
           ID-2: /home size: 16G used: 297M (2%) fs: ext4 dev: /dev/sda8
           ID-3: swap-1 size: 8.00GB used: 0.00GB (0%)
           fs: swap dev: /dev/sda7
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 43.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 219 Uptime: 2:20 Memory: 1948.6/3866.2MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56

Offline kris777

  • Miętowy krzew
  • ****
  • Wiadomości: 367
  • Punkty: 55
Odp: Bardzo kiepski internet w Linux Mint
« Odpowiedź #5 dnia: Listopad 10, 2018, 16:43:41 pm »
To chyba coś nie tak z driverami na Linux-e od Realtek RTL8723BE
Jesteś początkujący a chyba czeka cię kompilacja driverów  ...  głęboka woda, kruchy lód....cienkie szkło :-)
więcej:Realtek RTL8723BE słaby sygnał wifi
How to solve Realtek RTL8723BE weak wifi signal problem in ubuntu
« Ostatnia zmiana: Listopad 10, 2018, 16:51:14 pm wysłana przez kris777 »

Offline bambaryla

  • Miętowe nasionko
  • *
  • Wiadomości: 15
  • Punkty: 0
Odp: Bardzo kiepski internet w Linux Mint
« Odpowiedź #6 dnia: Listopad 10, 2018, 17:01:05 pm »
Dziękuję ci z całego serducha. Działa. @kriss777

Online dedito

  • Urząd Porządkowy
  • Miętowy krzew
  • *******
  • Wiadomości: 435
  • Punkty: 181
Odp: Bardzo kiepski internet w Linux Mint
« Odpowiedź #7 dnia: Listopad 10, 2018, 17:06:18 pm »
Jeśli ten wątek ma komuś w przyszłości posłużyć, warto by było w podsumowaniu napisać jak się problem rozwiązało, a potem odpowiednio oznaczyć wątek :)

Offline bambaryla

  • Miętowe nasionko
  • *
  • Wiadomości: 15
  • Punkty: 0
Odp: Bardzo kiepski internet w Linux Mint
« Odpowiedź #8 dnia: Listopad 10, 2018, 19:45:13 pm »
Jednak nie rozwiązane. Po restarcie systemu wszystko wraca do poprzedniego stanu. Mimo nadpisania permanentnego opcji.

Offline kris777

  • Miętowy krzew
  • ****
  • Wiadomości: 367
  • Punkty: 55
Odp: Bardzo kiepski internet w Linux Mint
« Odpowiedź #9 dnia: Listopad 10, 2018, 20:11:52 pm »
mówisz o opcji :
echo "options rtl8723be ant_sel=2" | sudo tee /etc/modprobe.d/50-rtl8723be.conf
a sprawdź fizycznie czy jest taki plik zapisany i co w nim jest :
/etc/modprobe.d/50-rtl8723be.conf

Offline ciastek1981

  • Globator Moderalny
  • Spamerzy
  • *******
  • Wiadomości: 1338
  • Punkty: 154
  • Płeć: Mężczyzna
Odp: Bardzo kiepski internet w Linux Mint
« Odpowiedź #10 dnia: Listopad 10, 2018, 20:14:50 pm »
To opracowanie jest znane od bardzo dawna, ale nie chce mi się już tego zgłębiać - poradzicie sobie.

https://sites.google.com/site/easylinuxtipsproject/reserve-7#TOC-Realtek-RTL8723BE-chipset

Offline kris777

  • Miętowy krzew
  • ****
  • Wiadomości: 367
  • Punkty: 55
Odp: Bardzo kiepski internet w Linux Mint
« Odpowiedź #11 dnia: Listopad 10, 2018, 20:30:59 pm »
tu jest temat o takim zachowaniu:
RTL8723BE brak załadowanego modułu po ponownym uruchomieniu
chyba powinno pomóc:
sudo update-initramfs -uale można poczytać bo chyba można zainstalować w/w moduły z repo PPA .... jednak jest zagwozdka po każdej aktualizacji kernela wszystko trzeba zrobić od początku :-) ....

Offline bambaryla

  • Miętowe nasionko
  • *
  • Wiadomości: 15
  • Punkty: 0
Odp: Bardzo kiepski internet w Linux Mint
« Odpowiedź #12 dnia: Listopad 10, 2018, 20:40:36 pm »
Tylko tą komendę wyżej po restarcie czy przed restartem systemu?

Offline kris777

  • Miętowy krzew
  • ****
  • Wiadomości: 367
  • Punkty: 55
Odp: Bardzo kiepski internet w Linux Mint
« Odpowiedź #13 dnia: Listopad 10, 2018, 21:21:49 pm »
wydaje mi się że zaraz po dokonaniu kompilacji driverów i sprawdzeniu czy jest wszystko OK.... ale czy to wymaga ponownego przeprowadzenia w/w procedury ?  ... jak można dalej przeczytać komuś pomogło tylko fizyczne skopiowanie skompilowanego modułu do ścieżki:
Cytuj
I fixed it by adding rtl8723be to /etc/modules
Ps. a tu temat z instalacją modułu z repo PPA
https://askubuntu.com/questions/635625/how-do-i-get-a-realtek-rtl8723be-wireless-card-to-work/635629#635629
ta procedura potrzebuje internetu !  ...ale jest metoda offline kopiujesz dwa pliki o .deb i instalujesz w systemie :-)
sudo dpkg -i dkms*.deb rtlwifi*.debjesteś bystry dasz sobie radę :-) .... najwyżej jeśli po zalogowaniu do systemu możesz ponownie jakimiś  procedurami zainicjować poprawne działanie driverów to można utworzyć skrypt z w/w i umieścić go w autostart-cie ...
Ps. Co więcej jeśli masz dwa systemy a w tym Wndows 10 możesz po jakimś czasie znowu mieć spadek szybkości netu :-)
chyba jest to związane z tym że Winda coś przestawia ...pomaga wyłączenie szybkiego uruchamiania  :
Cytuj
fastboot (in Windows energy settings) solved the problem.
więcej:
https://unix.stackexchange.com/questions/305140/another-problem-with-realtek-8723be-module-not-loaded
https://askubuntu.com/questions/772180/wifi-not-working-on-realtek-rtl8723be-wifi-adapter

Jak sobie poradzisz to napisz co i jak pomogło ...na pewno innym się przyda ...lub nie dasz rady to może inni coś podpowiedzą
« Ostatnia zmiana: Listopad 10, 2018, 21:59:35 pm wysłana przez kris777 »

Offline ciastek1981

  • Globator Moderalny
  • Spamerzy
  • *******
  • Wiadomości: 1338
  • Punkty: 154
  • Płeć: Mężczyzna
Odp: Bardzo kiepski internet w Linux Mint
« Odpowiedź #14 dnia: Listopad 10, 2018, 22:37:29 pm »
@kris777

Po co tyle linków? Wystarczy tylko to (opis dla Minta 19 oraz Ubuntu 18.04, a różnica jest między domyślnym edytorem tekstu xed i gedit)

https://sites.google.com/site/easylinuxtipsproject/reserve-7

dodatkowo/ewentualnie jest to (ale tutaj są przekierowania do linku wyżej)

https://sites.google.com/site/easylinuxtipsproject/internet

Redaguje to gość, który udziela się na oficjalnym forum Minta i generalnie podpiera się wiedzą JeremyB (mod który głównie zajmuje się sieciami na oficjalnym forum Minta).

@bambaryla

Daj informację zwrotną czy dalej jest problem.
« Ostatnia zmiana: Listopad 11, 2018, 10:19:43 am wysłana przez ciastek1981 »