Autor Wątek: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych  (Przeczytany 1306 razy)

Offline Drib

  • Miętowe nasionko
  • *
  • Wiadomości: 21
  • Punkty: 0
Witam,

Mam problem, którego ani rusz nie mogę sam rozwiązać. Dotyczy Nemo oraz sieci lokalnej. Tak, wiem - w internecie jest mnóstwo informacji na ten temat, przetestowałem ich naprawdę sporo zanim zdecydowałem się napisać na tym forum. Ale albo ja nie jestem zbyt biegły w tych tematach, albo nie dotarłem do właściwej informacji.

Nemo często nie widzi komputerów oraz NAS'ów w mojej sieci lokalnej (SMB). Podkreślam - często, ale nie zawsze. A jeżeli "nie widzi" to tylko wówczas gdy próbuję rozwinąć ikonkę "sieć" z lewego panelu. Wpisanie adresu zasobu sieciowego z palca np. smb://xxx.xxx.xxx.xxx/folder jak najbardziej zawsze działa.
Dostęp do wszystkich komputerów z sieci poprzez SMBC - również.
Nie jestem zainteresowany montowaniem zasobów  sieciowych na stałe - jest ich sporo, użytkownicy mojej sieci domowej dołączają też co pewien czas - stąd dla mnie najlepszym rozwiązaniem jest dostęp właśnie z poziomu menadżera plików i "otoczenia sieciowego".

Zjawisko jest o tyle dziwne, że po instalacji systemu (LMDE 3 Cindy) przez kilka restartów wszystko chodziło bezproblemowo. Dopiero za którymś kolejnym uruchomieniem systemu, próba otwarcia zasobów sieciowych skończyła się długim oczekiwaniem i komunikatem - nie można wyświetlić "network:///".
Nie mam na LMDE serwera Samby (i nie widzę potrzeby go instalować). Z uwagi na to, że komputer wykorzystuję do pracy na zaledwie kilku programach, to działam na dość "gołej" instalacji. Czyli standardowy zestaw tego co daje instalator LMDE - komplet plików GVFS + pozostałe biblioteki pozwalające na odczyt różnych zasobów.

Próbowałem różnych rozwiązań, które znalazłem w sieci: modyfikacji plików fstab i smb.conf, w tym rozwiązania z tego forum - http://forum.linuxmint.pl/index.php/topic,8262.msg61873/topicseen.html#msg61873
I nic nie pomagało.

A teraz najciekawsze - wtedy kiedy nie mogę otworzyć połączenia sieciowego - pomaga (jednak nie zawsze) - całkowite odinstalowanie plików nemo-share i gvfs-backends.
Po ponownym ich zainstalowaniu wszystko - znowu czasami :) - wraca do normy.

A po kolejnym restarcie systemu - najczęściej ponownie nie widać zasobów sieci lokalnej spod Nemo.

Jeżeli z jakiś powodów nic nie robię z ww. plikami (wówczas jak nie mogę otworzyć sieci) to po kilkunastu minutach próba kliknięcia na ikonkę "sieć" w Nemo  wyświetla folder "Sieć Windows" bez żadnych zasobów, które są w tej sieci. Próba otworzenia tego folderu nic nie daje.
Nadmienię jeszcze, że w smb.conf mam ustawioną właściwą nazwę sieci domowej.

Wcześniej pracowałem na Ubuntu potem na Mincie 17 oraz 18 i wszystko było dobrze. Potem zainstalowałem Tarę i z uwagi na to, że na moim laptopie (Dell Latitude E6400) system ten chodził wyjątkowo wolno, przesiadłem się (po raz pierwszy) na edycję LMDE.  Generalnie ta wersja Minta bardzo mi pasuje, ale mam między innymi ten problem.

Próbowałem przywracać kopię z migawki systemu, przeinstalowywać całość - i zawsze na końcu problem z otwieraniem sieci lokalnej spod Nemo wracał.
Na laptopie mam na drugiej partycji Windowsa i tam dostęp do sieci działa bezproblemowo.
Nie jestem zbyt biegły w obsłudze Linuxa, ale ten system (w wydaniu LMDE) bardzo mi odpowiada do bieżącej pracy.

Może ktoś spotkał się z podobnym problemem, albo wie jak go rozwiązać. Będę wdzięczny za pomoc podaną w miarę prostych słowach.
aktualnie używam LMDE 3 Cindy na DELL Latitude E6400, 8GB RAM

Offline yahoob3

  • Grupa Trzymająca Władzę
  • Wielki miętus
  • *****
  • Wiadomości: 912
  • Punkty: 191
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #1 dnia: Listopad 14, 2018, 09:48:53 am »
Spróbuj (chwilowo, bo to "średniobezpiecze" rozwiązanie) dodać w configu samby, w sekcji [global] taką linijkę:
ntlm auth = yes
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

Offline Drib

  • Miętowe nasionko
  • *
  • Wiadomości: 21
  • Punkty: 0
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #2 dnia: Listopad 14, 2018, 12:09:21 pm »
Tego faktycznie nie dopisywałem.

Teraz jednak "jak na złość" dwukrotnie restartowałem system i za każdym razem Nemo bez problemów ma dostęp do zasobów sieci lokalnej.
Jak tylko wywinie mi znów numer i nie będzie chciał ich otworzyć to wyedytuję smb.conf, dopiszę to co radzisz.
Czy potem zrestartować system, czy też w inny sposób zrestartować tylko samą usługę - jeśli tak to w jaki sposób?

I jeszcze -
Cytuj
ntlm auth = yes
dlaczego jest średniobezpieczne?
aktualnie używam LMDE 3 Cindy na DELL Latitude E6400, 8GB RAM

Offline Drib

  • Miętowe nasionko
  • *
  • Wiadomości: 21
  • Punkty: 0
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #3 dnia: Listopad 14, 2018, 12:28:50 pm »
Długo nie musiałem czekać - kolejna próba restartu komputera i Nemo "odmówił" dostępu do sieci lokalnej.
Dopisałem sugerowaną linijkę - ponowny restart - i teraz Nemo "widzi" sieć.
Potestuję w normalnym użytkowaniu to potwierdzę czy to tylko jednorazowo, czy bardziej trwały trend...
aktualnie używam LMDE 3 Cindy na DELL Latitude E6400, 8GB RAM

Offline Drib

  • Miętowe nasionko
  • *
  • Wiadomości: 21
  • Punkty: 0
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #4 dnia: Listopad 14, 2018, 17:29:06 pm »
Niestety, radość przedwczesna.
Wpis nie działa, tzn. po kolejnym restarcie systemu, Nemo nie zamierza otworzyć zasobów sieci lokalnej. Jak zwykle w takiej sytuacji poczęstował mnie komunikatem - nie można wyświetlić "network:///".

Co, u licha, z tym można zrobić?
aktualnie używam LMDE 3 Cindy na DELL Latitude E6400, 8GB RAM

Offline kris777

  • Miętowy krzew
  • ****
  • Wiadomości: 367
  • Punkty: 55

Offline Drib

  • Miętowe nasionko
  • *
  • Wiadomości: 21
  • Punkty: 0
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #6 dnia: Listopad 14, 2018, 17:50:03 pm »
O ile pamiętam też dodawałem ten wpis - bez rezultatu.
aktualnie używam LMDE 3 Cindy na DELL Latitude E6400, 8GB RAM

Offline yahoob3

  • Grupa Trzymająca Władzę
  • Wielki miętus
  • *****
  • Wiadomości: 912
  • Punkty: 191
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #7 dnia: Listopad 14, 2018, 18:43:41 pm »
OK, to zacznijmy od początku tak, jak powinno być :)
Kolega Drib  otwiera terminal, wpisuje (kopiuje Ctrl+C i wkleja Ctrl+Shift+V) do terminala po kolei poniższe komendy i wkleja wyniki na forum pomiędzy znaczniki code:

iwconfig
ifconfig
smbtree

samba -V

Dobrze byłoby podać wyniki tych (poza ostatnią) komend w chwili gdy masz połączenie i widzisz otoczenie sieciowe i kiedy go nie masz.
Pokaż też zawartość pliku smb.conf (/etc/samba/smb.conf) lub wynik polecenia:
testparm -s
chociaż lepszy byłby cały config.



Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

Offline yahoob3

  • Grupa Trzymająca Władzę
  • Wielki miętus
  • *****
  • Wiadomości: 912
  • Punkty: 191
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #8 dnia: Listopad 14, 2018, 19:06:16 pm »
I jeszcze -
Cytuj
ntlm auth = yes
dlaczego jest średniobezpieczne?
Starsza wersja (NTLM własnie) uwierzytelniania od  NTLMv2. jest łatwiejsza do złamania.

SORRY za posta pod postem... "niechcęcy" wyszło! :)
« Ostatnia zmiana: Listopad 14, 2018, 19:09:35 pm wysłana przez yahoob3 »
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

Offline Drib

  • Miętowe nasionko
  • *
  • Wiadomości: 21
  • Punkty: 0
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #9 dnia: Listopad 14, 2018, 19:14:03 pm »
Polecenia smbtree i samba wymagają doinstalowania smbclient i samby. Czy doinstalować? Tak jak pisałem w pierwszym poście, w dotychczasowych distro i i instalacjach obywałem się bez serwera samby i wszystko działało w oparciu o biblioteki gvfs...
aktualnie używam LMDE 3 Cindy na DELL Latitude E6400, 8GB RAM

Offline yahoob3

  • Grupa Trzymająca Władzę
  • Wielki miętus
  • *****
  • Wiadomości: 912
  • Punkty: 191
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #10 dnia: Listopad 14, 2018, 19:26:32 pm »
Próbowałem różnych rozwiązań, które znalazłem w sieci: modyfikacji plików fstab i smb.conf, w tym rozwiązania z tego forum - http://forum.linuxmint.pl/index.php/topic,8262.msg61873/topicseen.html#msg61873
I nic nie pomagało.
Jak nie miałeś samby, to zdradź sekret jak TO zrobiłeś ;D
OK, jak chcesz. O Sambie pojęcie mgliste ale mam, jeśli chodzi o gvfs, to już niekoniecznie.
Mam w domu sieć na Sambie i większych problemów z nią nie mam.
Gdybyś zdecydował się na Sambę, to instalcja = apt install samba, ale ja ze swoje strony polecam jeszcze pakiet "system-config-samba". To taka nakładka graficzna na Sambę kilka rzeczy łatwiej w niej wyklikać, niż klepać config. ;)
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

Offline Drib

  • Miętowe nasionko
  • *
  • Wiadomości: 21
  • Punkty: 0
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #11 dnia: Listopad 14, 2018, 19:50:08 pm »
Z tego co zaobserwowałem to plik smb.conf był we wszystkich moich instalacjach różnych dystrybucji linuxa - bez serwera samby.
GVSF jest właśnie instalowany domyślnie po to by między innymi system obsługiwał protokół smb oraz inne. Przynajmniej tak mi się wydaje...

Tak więc tajemnica mojej możliwości edycji smb.conf - wyjaśniona  :)

Sambą (Samba4) kiedyś też się bawiłem - stawiałem serwer na Debianie wraz z udostępnianiem zasobów w sieci wraz z AD (win).
Teraz też - przy jednej z prób poradzenia sobie z aktualnym problemem - zainstalowałem sambę. Ponieważ nic to nie dało - finalnie jej się pozbyłem. Z pewnych względów zależy mi na jak najmniej dociążonej wersji LMDE.

Ale spróbuję znaleźć dzisiaj chwilę - doinstaluję Sambę i smbclient i zamieszczę efektu poleceń. Może za kilka minut
« Ostatnia zmiana: Listopad 14, 2018, 20:49:00 pm wysłana przez Drib »
aktualnie używam LMDE 3 Cindy na DELL Latitude E6400, 8GB RAM

Offline dedito

  • Urząd Porządkowy
  • Miętowy krzew
  • *******
  • Wiadomości: 435
  • Punkty: 181
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #12 dnia: Listopad 15, 2018, 07:32:24 am »
Uruchom sobie program w trybie debugowania, jako bieżący użytkownik (nie root):
gdb nemoJak się pojawi (gdb) wpisz run, nemo się uruchomi, a  w terminalu będą pojawiać się różne komunikaty, gdy wystąpi omawiany błąd
Cytuj
nie można wyświetlić "network:///"
skopiuj błędy które wyskoczą w terminalu i wklej je na forum.
Przykład:
gdb nemo
GNU gdb (Debian 7.12-6) 7.12.0.20161007-git
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from nemo...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/nemo
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffeccc9700 (LWP 17683)]
[New Thread 0x7fffec4c8700 (LWP 17684)]
[New Thread 0x7fffebcc7700 (LWP 17685)]
[New Thread 0x7fffeb2b9700 (LWP 17686)]

Potem jeszcze wyniki, już jako root:
fgrep gvfs /var/log/daemon.log /var/log/syslog
Co do wymagań dla samby, to w jakimś tam zakresie nemo z niej korzysta, podgląd zależności pokazuje, że wymaga klienta samby i jej podstawowych bibliotek.
« Ostatnia zmiana: Listopad 15, 2018, 07:53:56 am wysłana przez dedito »

Offline Drib

  • Miętowe nasionko
  • *
  • Wiadomości: 21
  • Punkty: 0
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #13 dnia: Listopad 15, 2018, 15:45:18 pm »
Jak na złość - dzisiejsze uruchomienia systemu nie dają opisywanych problemów z Nemo.
Jak tylko wystąpią - będę uruchamiał Nemo w trybie debugowania i zamieszczę wynikowe informacje.
Samby i smbclient jeszcze nie instalowałem - myślę, że faktycznie najpierw lepiej zdiagnozować Nemo i gvfs  :)
aktualnie używam LMDE 3 Cindy na DELL Latitude E6400, 8GB RAM

Offline dedito

  • Urząd Porządkowy
  • Miętowy krzew
  • *******
  • Wiadomości: 435
  • Punkty: 181
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #14 dnia: Listopad 15, 2018, 16:19:26 pm »
Same biblioteki smbclienta powinieneś mieć bo bez tego gvfsd-smb nie działa.
A pokaż przynajmniej te logi z gvfs, powinny być jakieś informacje z poprzednich błędów.

apt-cache depends gvfs-backends | grep -e smb -e samba
  Wymaga: libsmbclient
  Sugeruje: samba-common
« Ostatnia zmiana: Listopad 15, 2018, 16:32:49 pm wysłana przez dedito »