Autor Wątek: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych  (Przeczytany 1307 razy)

Offline Drib

  • Miętowe nasionko
  • *
  • Wiadomości: 21
  • Punkty: 0
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #15 dnia: Listopad 15, 2018, 16:42:06 pm »
wynik polecenia fgrep gvfs /var/log/daemon.log /var/log/syslog poniżej.

Trochę tego się nazbierało... musiałem skrócić bo wpis przekraczał wymaganą liczbę znaków.
jaroslaw@dell-latitude-e6400:~$ sudo su
[sudo] hasło użytkownika jaroslaw:
root@dell-latitude-e6400:/home/jaroslaw# fgrep gvfs /var/log/daemon.log /var/log/syslog
/var/log/daemon.log:Nov 14 18:16:42 dell-latitude-e6400 dbus-daemon[797]: Activating via systemd: service name='org.gtk.vfs.Daemon' unit='gvfs-daemon.service'
/var/log/daemon.log:Nov 14 18:28:34 dell-latitude-e6400 dbus-daemon[1021]: Activating via systemd: service name='org.gtk.vfs.Daemon' unit='gvfs-daemon.service'
/var/log/daemon.log:Nov 14 18:28:36 dell-latitude-e6400 dbus-daemon[1021]: Activating via systemd: service name='org.gtk.vfs.UDisks2VolumeMonitor' unit='gvfs-udisks2-volume-monitor.service'
/var/log/daemon.log:Nov 14 18:28:39 dell-latitude-e6400 dbus-daemon[1021]: Activating via systemd: service name='org.gtk.vfs.GoaVolumeMonitor' unit='gvfs-goa-volume-monitor.service'
/var/log/daemon.log:Nov 14 18:28:39 dell-latitude-e6400 dbus-daemon[1021]: Activating via systemd: service name='org.gtk.vfs.GPhoto2VolumeMonitor' unit='gvfs-gphoto2-volume-monitor.service'
/var/log/daemon.log:Nov 14 18:28:39 dell-latitude-e6400 dbus-daemon[1021]: Activating via systemd: service name='org.gtk.vfs.AfcVolumeMonitor' unit='gvfs-afc-volume-monitor.service'
/var/log/daemon.log:Nov 14 18:28:39 dell-latitude-e6400 gvfs-afc-volume-monitor[1409]: Volume monitor alive
/var/log/daemon.log:Nov 14 18:28:39 dell-latitude-e6400 dbus-daemon[1021]: Activating via systemd: service name='org.gtk.vfs.MTPVolumeMonitor' unit='gvfs-mtp-volume-monitor.service'
/var/log/daemon.log:Nov 14 18:28:39 dell-latitude-e6400 dbus-daemon[1021]: Activating via systemd: service name='org.gtk.vfs.Metadata' unit='gvfs-metadata.service'
/var/log/daemon.log:Nov 14 20:54:45 dell-latitude-e6400 dbus-daemon[812]: Activating via systemd: service name='org.gtk.vfs.Daemon' unit='gvfs-daemon.service'
/var/log/daemon.log:Nov 14 20:54:50 dell-latitude-e6400 dbus-daemon[1015]: Activating via systemd: service name='org.gtk.vfs.Daemon' unit='gvfs-daemon.service'
/var/log/daemon.log:Nov 14 20:54:52 dell-latitude-e6400 dbus-daemon[1015]: Activating via systemd: service name='org.gtk.vfs.UDisks2VolumeMonitor' unit='gvfs-udisks2-volume-monitor.service'
/var/log/daemon.log:Nov 14 20:54:52 dell-latitude-e6400 dbus-daemon[1015]: Activating via systemd: service name='org.gtk.vfs.GoaVolumeMonitor' unit='gvfs-goa-volume-monitor.service'
/var/log/daemon.log:Nov 14 20:54:52 dell-latitude-e6400 dbus-daemon[1015]: Activating via systemd: service name='org.gtk.vfs.GPhoto2VolumeMonitor' unit='gvfs-gphoto2-volume-monitor.service'
/var/log/daemon.log:Nov 14 20:54:52 dell-latitude-e6400 dbus-daemon[1015]: Activating via systemd: service name='org.gtk.vfs.AfcVolumeMonitor' unit='gvfs-afc-volume-monitor.service'
/var/log/daemon.log:Nov 14 20:54:53 dell-latitude-e6400 gvfs-afc-volume-monitor[1380]: Volume monitor alive
/var/log/daemon.log:Nov 14 20:54:53 dell-latitude-e6400 dbus-daemon[1015]: Activating via systemd: service name='org.gtk.vfs.MTPVolumeMonitor' unit='gvfs-mtp-volume-monitor.service'
/var/log/daemon.log:Nov 14 20:54:55 dell-latitude-e6400 dbus-daemon[1015]: Activating via systemd: service name='org.gtk.vfs.Metadata' unit='gvfs-metadata.service'
/var/log/daemon.log:Nov 14 20:59:52 dell-latitude-e6400 dbus-daemon[786]: Activating via systemd: service name='org.gtk.vfs.Daemon' unit='gvfs-daemon.service'
/var/log/daemon.log:Nov 14 21:00:03 dell-latitude-e6400 dbus-daemon[1005]: Activating via systemd: service name='org.gtk.vfs.Daemon' unit='gvfs-daemon.service'
/var/log/daemon.log:Nov 14 21:00:05 dell-latitude-e6400 dbus-daemon[1005]: Activating via systemd: service name='org.gtk.vfs.UDisks2VolumeMonitor' unit='gvfs-udisks2-volume-monitor.service'
/var/log/daemon.log:Nov 14 21:00:06 dell-latitude-e6400 dbus-daemon[1005]: Activating via systemd: service name='org.gtk.vfs.GoaVolumeMonitor' unit='gvfs-goa-volume-monitor.service'
/var/log/daemon.log:Nov 14 21:00:06 dell-latitude-e6400 dbus-daemon[1005]: Activating via systemd: service name='org.gtk.vfs.GPhoto2VolumeMonitor' unit='gvfs-gphoto2-volume-monitor.service'
/var/log/daemon.log:Nov 14 21:00:06 dell-latitude-e6400 dbus-daemon[1005]: Activating via systemd: service name='org.gtk.vfs.AfcVolumeMonitor' unit='gvfs-afc-volume-monitor.service'
/var/log/daemon.log:Nov 14 21:00:06 dell-latitude-e6400 gvfs-afc-volume-monitor[1355]: Volume monitor alive
/var/log/daemon.log:Nov 14 21:00:06 dell-latitude-e6400 dbus-daemon[1005]: Activating via systemd: service name='org.gtk.vfs.MTPVolumeMonitor' unit='gvfs-mtp-volume-monitor.service'
/var/log/daemon.log:Nov 14 21:00:08 dell-latitude-e6400 dbus-daemon[1005]: Activating via systemd: service name='org.gtk.vfs.Metadata' unit='gvfs-metadata.service'
/var/log/daemon.log:Nov 14 21:04:08 dell-latitude-e6400 gvfsd[789]: A connection to the bus can't be made

A co do bibliotek smbclient - tak one są instalowane domyślnie razem z systemem
aktualnie używam LMDE 3 Cindy na DELL Latitude E6400, 8GB RAM

Offline dedito

  • Urząd Porządkowy
  • Miętowy krzew
  • *******
  • Wiadomości: 435
  • Punkty: 181
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #16 dnia: Listopad 15, 2018, 17:06:35 pm »
Jak się nie mieści na forum to wtedy robisz np. tak
fgrep gvfs /var/log/daemon.log /var/log/syslog | pastebinit i tylko linka wklejasz na forum.

Offline Drib

  • Miętowe nasionko
  • *
  • Wiadomości: 21
  • Punkty: 0
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #17 dnia: Listopad 15, 2018, 17:31:17 pm »
Fakt, niegłupie :)

https://pastebin.com/juxNnpJw

Tu są logi z wczoraj i z dnia dzisiejszego.
aktualnie używam LMDE 3 Cindy na DELL Latitude E6400, 8GB RAM

Offline dedito

  • Urząd Porządkowy
  • Miętowy krzew
  • *******
  • Wiadomości: 435
  • Punkty: 181
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #18 dnia: Listopad 15, 2018, 17:49:35 pm »
To jeszcze zawęźmy do linijek z smb i/lub samba i powinno się zmieścić na forum
fgrep gvfs /var/log/daemon.log /var/log/syslog | grep -e smb -e samba
« Ostatnia zmiana: Listopad 15, 2018, 17:55:29 pm wysłana przez dedito »

Offline Drib

  • Miętowe nasionko
  • *
  • Wiadomości: 21
  • Punkty: 0
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #19 dnia: Listopad 15, 2018, 18:10:05 pm »
A i proszę:

jaroslaw@dell-latitude-e6400:~$ fgrep gvfs /var/log/daemon.log /var/log/syslog | grep -e smb -e samba
/var/log/syslog:Nov 15 08:21:53 dell-latitude-e6400 gvfsd-network[1676]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 08:23:23 dell-latitude-e6400 gvfsd-network[1707]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 08:51:13 dell-latitude-e6400 gvfsd-network[1592]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Działanie nieobsługiwane przez mechanizm przetwarzający
/var/log/syslog:Nov 15 09:01:37 dell-latitude-e6400 gvfsd-network[1973]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Działanie nieobsługiwane przez mechanizm przetwarzający
/var/log/syslog:Nov 15 09:39:47 dell-latitude-e6400 gvfsd-network[2842]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Działanie nieobsługiwane przez mechanizm przetwarzający
/var/log/syslog:Nov 15 09:41:05 dell-latitude-e6400 gvfsd-network[3043]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Działanie nieobsługiwane przez mechanizm przetwarzający
/var/log/syslog:Nov 15 09:51:04 dell-latitude-e6400 gvfsd-network[3262]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Działanie nieobsługiwane przez mechanizm przetwarzający
/var/log/syslog:Nov 15 09:51:11 dell-latitude-e6400 gvfsd-network[1546]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 09:51:50 dell-latitude-e6400 gvfsd-network[1593]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 09:57:44 dell-latitude-e6400 gvfsd-network[1818]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 09:58:56 dell-latitude-e6400 gvfsd-network[1840]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 09:58:56 dell-latitude-e6400 gvfsd-network[1838]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:00:38 dell-latitude-e6400 gvfsd-network[1945]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:02:32 dell-latitude-e6400 gvfsd-network[2351]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:02:45 dell-latitude-e6400 gvfsd-network[2385]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:02:53 dell-latitude-e6400 gvfsd-network[2391]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:02:53 dell-latitude-e6400 gvfsd-network[2397]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:04:38 dell-latitude-e6400 gvfsd-network[2423]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:04:38 dell-latitude-e6400 gvfsd-network[2425]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:05:37 dell-latitude-e6400 gvfsd-network[2510]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:05:52 dell-latitude-e6400 gvfsd-network[2549]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:06:19 dell-latitude-e6400 gvfsd-network[2586]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:07:12 dell-latitude-e6400 gvfsd-network[2608]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:10:37 dell-latitude-e6400 gvfsd-network[2910]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:20:43 dell-latitude-e6400 gvfsd-network[3130]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:20:54 dell-latitude-e6400 gvfsd-network[4538]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Działanie nieobsługiwane przez mechanizm przetwarzający
/var/log/syslog:Nov 15 10:24:58 dell-latitude-e6400 gvfsd-network[1500]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Działanie nieobsługiwane przez mechanizm przetwarzający
/var/log/syslog:Nov 15 10:26:03 dell-latitude-e6400 gvfsd-network[1752]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Działanie nieobsługiwane przez mechanizm przetwarzający
/var/log/syslog:Nov 15 15:08:56 dell-latitude-e6400 gvfsd-network[1574]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Działanie nieobsługiwane przez mechanizm przetwarzający
jaroslaw@dell-latitude-e6400:~$
aktualnie używam LMDE 3 Cindy na DELL Latitude E6400, 8GB RAM

Offline dedito

  • Urząd Porządkowy
  • Miętowy krzew
  • *******
  • Wiadomości: 435
  • Punkty: 181
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #20 dnia: Listopad 15, 2018, 18:36:35 pm »
A te czasy pokrywają się jakoś z czasami występowania błędu?
A i chyba zapomniałeś to uruchomić jako root.

Offline Drib

  • Miętowe nasionko
  • *
  • Wiadomości: 21
  • Punkty: 0
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #21 dnia: Listopad 15, 2018, 18:44:39 pm »
Sorki - co do braku root'a.
Poniżej już z root'em:

jaroslaw@dell-latitude-e6400:~$ sudo su
[sudo] hasło użytkownika jaroslaw:
root@dell-latitude-e6400:/home/jaroslaw# fgrep gvfs /var/log/daemon.log /var/log/syslog | grep -e smb -e samba
/var/log/syslog:Nov 15 08:21:53 dell-latitude-e6400 gvfsd-network[1676]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 08:23:23 dell-latitude-e6400 gvfsd-network[1707]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 08:51:13 dell-latitude-e6400 gvfsd-network[1592]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Działanie nieobsługiwane przez mechanizm przetwarzający
/var/log/syslog:Nov 15 09:01:37 dell-latitude-e6400 gvfsd-network[1973]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Działanie nieobsługiwane przez mechanizm przetwarzający
/var/log/syslog:Nov 15 09:39:47 dell-latitude-e6400 gvfsd-network[2842]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Działanie nieobsługiwane przez mechanizm przetwarzający
/var/log/syslog:Nov 15 09:41:05 dell-latitude-e6400 gvfsd-network[3043]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Działanie nieobsługiwane przez mechanizm przetwarzający
/var/log/syslog:Nov 15 09:51:04 dell-latitude-e6400 gvfsd-network[3262]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Działanie nieobsługiwane przez mechanizm przetwarzający
/var/log/syslog:Nov 15 09:51:11 dell-latitude-e6400 gvfsd-network[1546]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 09:51:50 dell-latitude-e6400 gvfsd-network[1593]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 09:57:44 dell-latitude-e6400 gvfsd-network[1818]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 09:58:56 dell-latitude-e6400 gvfsd-network[1840]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 09:58:56 dell-latitude-e6400 gvfsd-network[1838]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:00:38 dell-latitude-e6400 gvfsd-network[1945]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:02:32 dell-latitude-e6400 gvfsd-network[2351]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:02:45 dell-latitude-e6400 gvfsd-network[2385]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:02:53 dell-latitude-e6400 gvfsd-network[2391]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:02:53 dell-latitude-e6400 gvfsd-network[2397]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:04:38 dell-latitude-e6400 gvfsd-network[2423]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:04:38 dell-latitude-e6400 gvfsd-network[2425]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:05:37 dell-latitude-e6400 gvfsd-network[2510]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:05:52 dell-latitude-e6400 gvfsd-network[2549]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:06:19 dell-latitude-e6400 gvfsd-network[2586]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:07:12 dell-latitude-e6400 gvfsd-network[2608]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:10:37 dell-latitude-e6400 gvfsd-network[2910]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:20:43 dell-latitude-e6400 gvfsd-network[3130]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 15 10:20:54 dell-latitude-e6400 gvfsd-network[4538]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Działanie nieobsługiwane przez mechanizm przetwarzający
/var/log/syslog:Nov 15 10:24:58 dell-latitude-e6400 gvfsd-network[1500]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Działanie nieobsługiwane przez mechanizm przetwarzający
/var/log/syslog:Nov 15 10:26:03 dell-latitude-e6400 gvfsd-network[1752]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Działanie nieobsługiwane przez mechanizm przetwarzający
/var/log/syslog:Nov 15 15:08:56 dell-latitude-e6400 gvfsd-network[1574]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Działanie nieobsługiwane przez mechanizm przetwarzający
root@dell-latitude-e6400:/home/jaroslaw#


Co do pojawiania się błędu - dzisiaj dopołudnia mój syn odpalał Minta. Podpytałem go i faktycznie kilka razy sprawdzał i nie mógł się dostać do sieci spod Nemo - stąd może i część logów pokrywa się z tym błędem.
Ja odpaliłem kompa po 15 i wszystko śmiga.
aktualnie używam LMDE 3 Cindy na DELL Latitude E6400, 8GB RAM

Offline dedito

  • Urząd Porządkowy
  • Miętowy krzew
  • *******
  • Wiadomości: 435
  • Punkty: 181
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #22 dnia: Listopad 15, 2018, 19:04:19 pm »
Ok, to jest jakaś baza do dalszych poszukiwań.
W razie czego to podrzuć coś z debugera.

Offline Drib

  • Miętowe nasionko
  • *
  • Wiadomości: 21
  • Punkty: 0
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #23 dnia: Listopad 17, 2018, 07:34:49 am »
I dzisiaj z rana problem wystąpił.

Wynik gdb nemo do chwili wyświetlenia komunikatu "nie można wyświetlić network:///":
jaroslaw@dell-latitude-e6400:~$ gdb nemo
GNU gdb (Debian 7.12-6) 7.12.0.20161007-git
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from nemo...Reading symbols from /usr/lib/debug/.build-id/9f/c4ddb1650465a272252826a6e329bcf0d7d8bc.debug...done.
done.
(gdb) run
Starting program: /usr/bin/nemo
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffe95ef700 (LWP 2029)]
[New Thread 0x7fffe8dee700 (LWP 2030)]
[New Thread 0x7fffe3fff700 (LWP 2031)]
[New Thread 0x7fffe37fe700 (LWP 2032)]
[New Thread 0x7fffe092f700 (LWP 2034)]
[New Thread 0x7fffcffff700 (LWP 2035)]
[New Thread 0x7fffcf7fe700 (LWP 2036)]
[New Thread 0x7fffceffd700 (LWP 2037)]
[New Thread 0x7fffce7fc700 (LWP 2038)]
[New Thread 0x7fffcdffb700 (LWP 2039)]
[New Thread 0x7fffcd7fa700 (LWP 2040)]
[New Thread 0x7fffccff9700 (LWP 2041)]
[New Thread 0x7fffc7fff700 (LWP 2042)]
Nemo-Share-Message: Called "net usershare info" but it failed: "net usershare" zwrócił błąd 255: mkdir failed on directory /var/run/samba/msg.lock: Brak dostępu
net usershare: cannot open usershare directory /var/lib/samba/usershares. Error Brak dostępu
You do not have permission to create a usershare. Ask your administrator to grant you permissions to create a share.

[Thread 0x7fffceffd700 (LWP 2037) exited]
[Thread 0x7fffcdffb700 (LWP 2039) exited]
[Thread 0x7fffcf7fe700 (LWP 2036) exited]
[Thread 0x7fffcffff700 (LWP 2035) exited]
[Thread 0x7fffc7fff700 (LWP 2042) exited]
[Thread 0x7fffccff9700 (LWP 2041) exited]
[Thread 0x7fffce7fc700 (LWP 2038) exited]
[Thread 0x7fffe37fe700 (LWP 2032) exited]
[Thread 0x7fffcd7fa700 (LWP 2040) exited]
[Thread 0x7fffe092f700 (LWP 2034) exited]
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

I od razu również aktualne informacje po poleceniu fgrep gvfs /var/log/daemon.log /var/log/syslog (jak widać zawężenie do samby nic nie dało)

jaroslaw@dell-latitude-e6400:~$ sudo su
[sudo] hasło użytkownika jaroslaw:
root@dell-latitude-e6400:/home/jaroslaw# fgrep gvfs /var/log/daemon.log /var/log/syslog | grep -e smb -e samba
root@dell-latitude-e6400:/home/jaroslaw# fgrep gvfs /var/log/daemon.log /var/log/syslog
/var/log/daemon.log:Nov 17 07:12:12 dell-latitude-e6400 dbus-daemon[804]: Activating via systemd: service name='org.gtk.vfs.Daemon' unit='gvfs-daemon.service'
/var/log/daemon.log:Nov 17 07:12:18 dell-latitude-e6400 dbus-daemon[1075]: Activating via systemd: service name='org.gtk.vfs.Daemon' unit='gvfs-daemon.service'
/var/log/daemon.log:Nov 17 07:12:20 dell-latitude-e6400 dbus-daemon[1075]: Activating via systemd: service name='org.gtk.vfs.UDisks2VolumeMonitor' unit='gvfs-udisks2-volume-monitor.service'
/var/log/daemon.log:Nov 17 07:12:20 dell-latitude-e6400 dbus-daemon[1075]: Activating via systemd: service name='org.gtk.vfs.GoaVolumeMonitor' unit='gvfs-goa-volume-monitor.service'
/var/log/daemon.log:Nov 17 07:12:20 dell-latitude-e6400 dbus-daemon[1075]: Activating via systemd: service name='org.gtk.vfs.GPhoto2VolumeMonitor' unit='gvfs-gphoto2-volume-monitor.service'
/var/log/daemon.log:Nov 17 07:12:20 dell-latitude-e6400 dbus-daemon[1075]: Activating via systemd: service name='org.gtk.vfs.AfcVolumeMonitor' unit='gvfs-afc-volume-monitor.service'
/var/log/daemon.log:Nov 17 07:12:21 dell-latitude-e6400 gvfs-afc-volume-monitor[1451]: Volume monitor alive
/var/log/daemon.log:Nov 17 07:12:21 dell-latitude-e6400 dbus-daemon[1075]: Activating via systemd: service name='org.gtk.vfs.MTPVolumeMonitor' unit='gvfs-mtp-volume-monitor.service'
/var/log/daemon.log:Nov 17 07:12:23 dell-latitude-e6400 dbus-daemon[1075]: Activating via systemd: service name='org.gtk.vfs.Metadata' unit='gvfs-metadata.service'
root@dell-latitude-e6400:/home/jaroslaw#


Może to pomoże w "rozszyfrowaniu" problemu...
aktualnie używam LMDE 3 Cindy na DELL Latitude E6400, 8GB RAM

Offline dedito

  • Urząd Porządkowy
  • Miętowy krzew
  • *******
  • Wiadomości: 435
  • Punkty: 181
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #24 dnia: Listopad 17, 2018, 09:16:45 am »
U siebie jak uruchomię nemo jako root to mam podobnie.
Ale, jak na razie, nie mam pomysłu jak to rozwiązać.

Offline Drib

  • Miętowe nasionko
  • *
  • Wiadomości: 21
  • Punkty: 0
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #25 dnia: Listopad 17, 2018, 09:48:32 am »
A po dodatkowym czasie wynik wygląda tak:

jaroslaw@dell-latitude-e6400:~$ sudo su
[sudo] hasło użytkownika jaroslaw:
root@dell-latitude-e6400:/home/jaroslaw# fgrep gvfs /var/log/daemon.log /var/log/syslog
/var/log/daemon.log:Nov 17 07:12:12 dell-latitude-e6400 dbus-daemon[804]: Activating via systemd: service name='org.gtk.vfs.Daemon' unit='gvfs-daemon.service'
/var/log/daemon.log:Nov 17 07:12:18 dell-latitude-e6400 dbus-daemon[1075]: Activating via systemd: service name='org.gtk.vfs.Daemon' unit='gvfs-daemon.service'
/var/log/daemon.log:Nov 17 07:12:20 dell-latitude-e6400 dbus-daemon[1075]: Activating via systemd: service name='org.gtk.vfs.UDisks2VolumeMonitor' unit='gvfs-udisks2-volume-monitor.service'
/var/log/daemon.log:Nov 17 07:12:20 dell-latitude-e6400 dbus-daemon[1075]: Activating via systemd: service name='org.gtk.vfs.GoaVolumeMonitor' unit='gvfs-goa-volume-monitor.service'
/var/log/daemon.log:Nov 17 07:12:20 dell-latitude-e6400 dbus-daemon[1075]: Activating via systemd: service name='org.gtk.vfs.GPhoto2VolumeMonitor' unit='gvfs-gphoto2-volume-monitor.service'
/var/log/daemon.log:Nov 17 07:12:20 dell-latitude-e6400 dbus-daemon[1075]: Activating via systemd: service name='org.gtk.vfs.AfcVolumeMonitor' unit='gvfs-afc-volume-monitor.service'
/var/log/daemon.log:Nov 17 07:12:21 dell-latitude-e6400 gvfs-afc-volume-monitor[1451]: Volume monitor alive
/var/log/daemon.log:Nov 17 07:12:21 dell-latitude-e6400 dbus-daemon[1075]: Activating via systemd: service name='org.gtk.vfs.MTPVolumeMonitor' unit='gvfs-mtp-volume-monitor.service'
/var/log/daemon.log:Nov 17 07:12:23 dell-latitude-e6400 dbus-daemon[1075]: Activating via systemd: service name='org.gtk.vfs.Metadata' unit='gvfs-metadata.service'
/var/log/syslog:Nov 17 07:50:22 dell-latitude-e6400 gvfsd[1267]: dbus_mount_reply: Error from org.gtk.vfs.Mountable.mount(): Przekroczono czas oczekiwania
/var/log/syslog:Nov 17 07:50:22 dell-latitude-e6400 gvfsd[1267]: dbus_mount_reply: Error from org.gtk.vfs.Mountable.mount(): Przekroczono czas oczekiwania
/var/log/syslog:Nov 17 07:50:22 dell-latitude-e6400 gvfsd-network[1969]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 17 07:52:52 dell-latitude-e6400 gvfsd[1267]: dbus_mount_reply: Error from org.gtk.vfs.Mountable.mount(): Przekroczono czas oczekiwania
/var/log/syslog:Nov 17 07:52:52 dell-latitude-e6400 gvfsd[1267]: dbus_mount_reply: Error from org.gtk.vfs.Mountable.mount(): Przekroczono czas oczekiwania
/var/log/syslog:Nov 17 07:52:52 dell-latitude-e6400 gvfsd-network[2397]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
/var/log/syslog:Nov 17 08:06:03 dell-latitude-e6400 gvfsd[1267]: dbus_mount_reply: Error from org.gtk.vfs.Mountable.mount(): Przekroczono czas oczekiwania
/var/log/syslog:Nov 17 08:06:03 dell-latitude-e6400 gvfsd[1267]: dbus_mount_reply: Error from org.gtk.vfs.Mountable.mount(): Przekroczono czas oczekiwania
/var/log/syslog:Nov 17 08:06:03 dell-latitude-e6400 gvfsd-network[2619]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Podane położenie nie jest zamontowane
root@dell-latitude-e6400:/home/jaroslaw#


Tak jak pisałem wcześniej, teraz (po kilkunastu minutach) Nemo wyświetla już ikonę  "Sieć Windows", natomiast nie da wyświetlić zasobów tej sieci. Cały czas jest to ta sama sesja LMDE od samego rana.

Jak debuguję Nemo to wygląda to następująco:
jaroslaw@dell-latitude-e6400:~$ gdb nemo
GNU gdb (Debian 7.12-6) 7.12.0.20161007-git
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from nemo...Reading symbols from /usr/lib/debug/.build-id/9f/c4ddb1650465a272252826a6e329bcf0d7d8bc.debug...done.
done.
(gdb) run
Starting program: /usr/bin/nemo
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffe95ef700 (LWP 8920)]
[New Thread 0x7fffe8dee700 (LWP 8921)]
[New Thread 0x7fffe3fff700 (LWP 8922)]
[Thread 0x7fffe8dee700 (LWP 8921) exited]
[Thread 0x7ffff7f2ba80 (LWP 8916) exited]
[Thread 0x7fffe95ef700 (LWP 8920) exited]
[Inferior 1 (process 8916) exited normally]
(gdb)

Jak widać uruchamia Nemo i tyle.

Dla ciekawości spróbowałem gdb nemo z root'em.
Efekt jest taki:
jaroslaw@dell-latitude-e6400:~$ sudo su
[sudo] hasło użytkownika jaroslaw:
root@dell-latitude-e6400:/home/jaroslaw# gdb nemo
GNU gdb (Debian 7.12-6) 7.12.0.20161007-git
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from nemo...Reading symbols from /usr/lib/debug/.build-id/9f/c4ddb1650465a272252826a6e329bcf0d7d8bc.debug...done.
done.
(gdb) run
Starting program: /usr/bin/nemo
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffe95ef700 (LWP 9000)]
[New Thread 0x7fffe8dee700 (LWP 9001)]

(nemo:8995): GLib-GIO-CRITICAL **: g_dbus_proxy_get_name_owner: assertion 'G_IS_DBUS_PROXY (proxy)' failed

(nemo:8995): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: The name org.freedesktop.portal.Desktop is not owned
[New Thread 0x7fffe3fff700 (LWP 9034)]
[New Thread 0x7fffe37fe700 (LWP 9035)]
[New Thread 0x7fffe093a700 (LWP 9081)]
[New Thread 0x7fffcffff700 (LWP 9082)]
[New Thread 0x7fffcf7fe700 (LWP 9083)]
[Thread 0x7fffe093a700 (LWP 9081) exited]
[Thread 0x7fffe37fe700 (LWP 9035) exited]
[Thread 0x7fffcffff700 (LWP 9082) exited]
[New Thread 0x7fffcffff700 (LWP 9107)]
[New Thread 0x7fffe37fe700 (LWP 9108)]
[Thread 0x7fffe37fe700 (LWP 9108) exited]
[Thread 0x7fffcffff700 (LWP 9107) exited]
[Thread 0x7fffcf7fe700 (LWP 9083) exited]
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

I żeby było ciekawiej root nie może nawet wyświetlić ikony "Sieć Windows"
aktualnie używam LMDE 3 Cindy na DELL Latitude E6400, 8GB RAM

Offline kris777

  • Miętowy krzew
  • ****
  • Wiadomości: 367
  • Punkty: 55
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #26 dnia: Listopad 17, 2018, 10:07:50 am »
Tak mnie zastanawia ...bo temat dotyczy menedżera plików Nemo. Czy zatem na innych jest OK ? :-)
Czy np. Thumar / Caja  itd. wyświetlają poprawnie twoją sieć ....ja osobiście w to wątpię. Bo jeśli tak jak myślę NIE to problem jest nie w NEMO... a po prostu w sieci a dokładniej samba
« Ostatnia zmiana: Listopad 17, 2018, 10:10:17 am wysłana przez kris777 »

Offline Drib

  • Miętowe nasionko
  • *
  • Wiadomości: 21
  • Punkty: 0
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #27 dnia: Listopad 17, 2018, 10:15:08 am »
Jakiś czas temu próbowałem Caję - ona też jest forkiem Nautilusa - też ten sam problem. Jedynie bezproblemowo działa konsolowy SMBC. Z tych programów, które próbowałem tylko on poprawnie wyświetla wszystkie dyskowe zasoby sieciowe bez względu na zachowanie Nemo/ Caja.
aktualnie używam LMDE 3 Cindy na DELL Latitude E6400, 8GB RAM

Offline dedito

  • Urząd Porządkowy
  • Miętowy krzew
  • *******
  • Wiadomości: 435
  • Punkty: 181
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #28 dnia: Listopad 17, 2018, 10:19:53 am »
Obstawiałbym raczej rozszerzenie Nemo, które obsługuje udziały smb, gdyż jak sam autor zaznaczył:
Wpisanie adresu zasobu sieciowego z palca np. smb://xxx.xxx.xxx.xxx/folder jak najbardziej zawsze działa.
Dostęp do wszystkich komputerów z sieci poprzez SMBC - również.
Nie jestem zainteresowany montowaniem zasobów  sieciowych na stałe - jest ich sporo, użytkownicy mojej sieci domowej dołączają też co pewien czas - stąd dla mnie najlepszym rozwiązaniem jest dostęp właśnie z poziomu menadżera plików i "otoczenia sieciowego".
Trzeba raczej szukać rozwiązania w tym:
Wcześniej pracowałem na Ubuntu potem na Mincie 17 oraz 18 i wszystko było dobrze.

Dodatkowo Caja i Nautilus, prawdopodobnie też korzystają z tego samego rozszerzenia do obsługi smb (gvfs-backends)
« Ostatnia zmiana: Listopad 17, 2018, 10:23:18 am wysłana przez dedito »

Offline Drib

  • Miętowe nasionko
  • *
  • Wiadomości: 21
  • Punkty: 0
Odp: Nemo (z LMDE Cindy) i problem z dostępem do lokalnych zasobów sieciowych
« Odpowiedź #29 dnia: Listopad 17, 2018, 10:22:50 am »
Przypomniało mi się - chociaż pisałem o tym chyba w tym wątku - kiedy występuje problem z dostępem do zasobów sieci lokalnych (network:///) bez problemowo działa wywołanie sieciowego zasobu samby, np
smb://192.168.1.015/Public

Czyli biblioteki pozwalające czytać zasoby SMB działają. Wg. mnie problem gdzieś w Nautilusie (i forkach) lub na styku z SMB (w moim przypadku GVFS). Chociaż jak instalowałem Sambę - to problem nadal istniał.
I tak jak pisałem w pierwszym poście - znalezione w interencie modyfikacje pliku konfiguracyjnego samby nie pomagają. Zjawisko jest jakby losowe - przy jednej sesji problem jest, a przy kolejnej już wszystko działa jak należy.
aktualnie używam LMDE 3 Cindy na DELL Latitude E6400, 8GB RAM