Forum Linux Mint Polska

Autor Wątek: [SOLVED] Irytujący dźwięk  (Przeczytany 8898 razy)

Offline buri

  • Miętowy Kumpel
  • Dorodna miętowa sadzonka
  • *****
  • Wiadomości: 110
  • Punkty: 65
  • Płeć: Mężczyzna
[SOLVED] Irytujący dźwięk
« dnia: Grudzień 29, 2010, 21:25:16 pm »
Witam ponownie,
Bardzo irytujący jest dźwięk w trakcie włączania kompa oraz wyłączania, taki jak w starych kompach "bip" był gdy coś było nie tak z komputerem. Gdzie szukać przyczyny? Proszę o pomoc, gdyż on jest naprawdę głośny.
« Ostatnia zmiana: Styczeń 17, 2011, 17:24:15 pm wysłana przez buri »
Archbang x86

Offline mati75

  • Rodzina Linux Mint
  • Administrator
  • Spamerzy
  • *******
  • Wiadomości: 2381
  • Punkty: 25121
  • Płeć: Mężczyzna
    • >>>Click me!<<<
  • Wersja systemu: Inny
Odp: Irytujący dźwięk
« Odpowiedź #1 dnia: Grudzień 29, 2010, 21:26:58 pm »
Wyłącz z gdm, albo usuń sound-gdm czy jakoś tak z /usr/share/sounds/mint

υωαgα α∂мιи !!! вαиαмι иαριєя∂αℓα !!!

Offline buri

  • Miętowy Kumpel
  • Dorodna miętowa sadzonka
  • *****
  • Wiadomości: 110
  • Punkty: 65
  • Płeć: Mężczyzna
Odp: Irytujący dźwięk
« Odpowiedź #2 dnia: Grudzień 29, 2010, 21:42:10 pm »
Mati to nie ten, to jest właśnie dźwięk jak pod win coś było źle jak się bios włączał. Nie mam pojęcia jak to opisać. Słychać go jak pojawia się okienko zalogowania/wpisania hasła oraz na koniec przy zamykaniu przed pojawieniem się czarnego ekranu.
Archbang x86

Offline ilin

  • Siewca Mięty
  • Dorodny miętowy krzew
  • *****
  • Wiadomości: 673
  • Punkty: 250
  • Płeć: Mężczyzna
  • Palacz
  • Środowisko graficzne: Inne
  • Wersja systemu: Inny
Odp: Irytujący dźwięk
« Odpowiedź #3 dnia: Grudzień 29, 2010, 22:04:35 pm »
Nie wiem co to za dźwięk.
W mikserze nie da się tego wyciszyć ?
Polski portal Debiana


I tak przed terminalem nie uciekniesz :)

RA1D3N

  • Gość
Odp: Irytujący dźwięk
« Odpowiedź #4 dnia: Grudzień 29, 2010, 23:35:35 pm »
Penie chodzi ci o głośnik systemowy, aby go wyłączyć edytuj plik
sudo gedit /etc/modprobe.d/blacklist.confi dopisz na końcu
blacklist pcspkrPrzy ponownym uruchomieniu już nie będzie pikania :)

Offline buri

  • Miętowy Kumpel
  • Dorodna miętowa sadzonka
  • *****
  • Wiadomości: 110
  • Punkty: 65
  • Płeć: Mężczyzna
Odp: Irytujący dźwięk
« Odpowiedź #5 dnia: Grudzień 30, 2010, 00:26:45 am »
Też nie zadziałało :/

Gdzie mogę sprawdzić log z uruchamiania, może to pozwoli mi wychwycić co jest winne.

Edit:
Wydaje mi się, że to wina gdm3 tylko co może być przyczyną? Zauważyłem też dziwną rzecz - muszę hasłem np. uruchom ponownie komputer, zamknij.
« Ostatnia zmiana: Grudzień 30, 2010, 01:06:10 am wysłana przez buri »
Archbang x86

RA1D3N

  • Gość
Odp: Irytujący dźwięk
« Odpowiedź #6 dnia: Grudzień 30, 2010, 01:12:43 am »
Na pewno wszystko dobrze zrobiłeś? No chyba że rozmawiamy o 2ch różnych dźwiękach, to co podałem ci w poście wyżej, wyłącza pikanie które wydobywa się z głośniczka na płycie głównej komputera.

Offline buri

  • Miętowy Kumpel
  • Dorodna miętowa sadzonka
  • *****
  • Wiadomości: 110
  • Punkty: 65
  • Płeć: Mężczyzna
Odp: Irytujący dźwięk
« Odpowiedź #7 dnia: Grudzień 30, 2010, 01:15:08 am »
Robiłem już dziesiątki rzeczy więc spoko. Zrobiłem jak napisałeś, ale u mnie to widocznie coś innego :/
Archbang x86

Offline ilin

  • Siewca Mięty
  • Dorodny miętowy krzew
  • *****
  • Wiadomości: 673
  • Punkty: 250
  • Płeć: Mężczyzna
  • Palacz
  • Środowisko graficzne: Inne
  • Wersja systemu: Inny
Odp: Irytujący dźwięk
« Odpowiedź #8 dnia: Grudzień 30, 2010, 08:34:41 am »
Przecież pcspkr nie siedzi u niego w jądrze.
W innym watku pokazal lsmod.
Więc to nic nie da.
Polski portal Debiana


I tak przed terminalem nie uciekniesz :)

Offline buri

  • Miętowy Kumpel
  • Dorodna miętowa sadzonka
  • *****
  • Wiadomości: 110
  • Punkty: 65
  • Płeć: Mężczyzna
Odp: Irytujący dźwięk
« Odpowiedź #9 dnia: Grudzień 30, 2010, 08:49:07 am »
Próbowałem już w ustawieniach dźwięku przesunąć suwaki - nic nie dało.
Tego co proponował @RA1D3N oraz wyrzuciłem dźwięk gdm z lokalizacji co wskazał @Mati.

Znalazłem taki temat, odnosi się on do gdm może z gdm3 jest podobnie?
http://www.debuntu.org/how-disable-pulseaudio-and-sound-gdm
Nie udaje mi się stąd wykonać:
And the last thing to do is to grant access to this file to gdm user:

# chown gdm:gdm /var/lib/gdm/.pulse/client.conf
gdyż odnosi się ot do gdm a ja mam gdm3, próbowałem zmieniać ale error mi wyrzucało.

EDYTKA:
Dla pewności dźwięk  wydobywa się z głośnika, bądź jak podłącze słuchawki to przez nie.
« Ostatnia zmiana: Grudzień 30, 2010, 09:29:05 am wysłana przez buri »
Archbang x86

Offline ilin

  • Siewca Mięty
  • Dorodny miętowy krzew
  • *****
  • Wiadomości: 673
  • Punkty: 250
  • Płeć: Mężczyzna
  • Palacz
  • Środowisko graficzne: Inne
  • Wersja systemu: Inny
Odp: Irytujący dźwięk
« Odpowiedź #10 dnia: Grudzień 30, 2010, 10:02:35 am »
Pokaż
amixer scontrolsamixer scontents
Polski portal Debiana


I tak przed terminalem nie uciekniesz :)

Offline buri

  • Miętowy Kumpel
  • Dorodna miętowa sadzonka
  • *****
  • Wiadomości: 110
  • Punkty: 65
  • Płeć: Mężczyzna
Odp: Irytujący dźwięk
« Odpowiedź #11 dnia: Grudzień 30, 2010, 10:24:43 am »
buri@buri-laptop ~ $ amixer scontrols
Simple mixer control 'Master',0
Simple mixer control 'Capture',0

buri@buri-laptop ~ $ amixer scontents
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Mono:
  Front Left: Playback 18721 [29%] [on]
  Front Right: Playback 18721 [29%] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 65536
  Front Left: Capture 65536 [100%] [on]
  Front Right: Capture 65536 [100%] [on]

EDYTKA!

Powiem tak to są dwa inne dźwięki, teraz jakoś tak zauważyłem. Jeden pojawia się jak wyskakuje okienko logowania, drugi czasami gdy okienko wylogowywania (pojawia się na chwilkę w trakcie wyłączania, nie trza nic wpisywać ono tylko sobie mignie raz). Trzeci pojawia się przy zamykaniu systemu przed pojawieniem się czarnego okno z komunikatami (pierwszy ALSA shutdown).

Nie napisałem na samym początku Linux Mint LMDE x64 201012 (tak dla pewności).
« Ostatnia zmiana: Grudzień 30, 2010, 10:33:19 am wysłana przez buri »
Archbang x86

Offline ilin

  • Siewca Mięty
  • Dorodny miętowy krzew
  • *****
  • Wiadomości: 673
  • Punkty: 250
  • Płeć: Mężczyzna
  • Palacz
  • Środowisko graficzne: Inne
  • Wersja systemu: Inny
Odp: Irytujący dźwięk
« Odpowiedź #12 dnia: Grudzień 30, 2010, 10:28:05 am »
Jeszcze raz ale ciut inaczej.

Wykonaj najpierw
killall pulseaudio potem jeszcze raz podaj wyniki powyższych poleceń.
Polski portal Debiana


I tak przed terminalem nie uciekniesz :)

Offline buri

  • Miętowy Kumpel
  • Dorodna miętowa sadzonka
  • *****
  • Wiadomości: 110
  • Punkty: 65
  • Płeć: Mężczyzna
Odp: Irytujący dźwięk
« Odpowiedź #13 dnia: Grudzień 30, 2010, 10:35:36 am »
Moja EDYTKA wyżej (opisałem dokładniej te dźwięki bo są 3, 2 te same jeden inny - co już jest nieźle zakręcone).

wynik:
buri@buri-laptop ~ $ killall pulseaudio
buri@buri-laptop ~ $ amixer scontrols
Simple mixer control 'Master',0
Simple mixer control 'Capture',0
buri@buri-laptop ~ $ amixer scontents
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Mono:
  Front Left: Playback 18721 [29%] [on]
  Front Right: Playback 18721 [29%] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 65536
  Front Left: Capture 65536 [100%] [on]
  Front Right: Capture 65536 [100%] [on]
Archbang x86

Offline ilin

  • Siewca Mięty
  • Dorodny miętowy krzew
  • *****
  • Wiadomości: 673
  • Punkty: 250
  • Płeć: Mężczyzna
  • Palacz
  • Środowisko graficzne: Inne
  • Wersja systemu: Inny
Odp: Irytujący dźwięk
« Odpowiedź #14 dnia: Grudzień 30, 2010, 11:18:32 am »
Uruchom z menu

Centrum sterowania -> Programy startowe

Odznacz Gnome Login Sound.

Potem zrestartuj kompa.

Zobacz czy o to chodzi.
Polski portal Debiana


I tak przed terminalem nie uciekniesz :)