Forum Linux Mint Polska

Autor Wątek: Aktualizacja - błąd Resolve  (Przeczytany 3974 razy)

Mielczar

  • Gość
Aktualizacja - błąd Resolve
« dnia: Kwiecień 24, 2014, 18:21:05 pm »
Witam,
Próbowałem dzisiaj zaktualizować system według tej instrukcji http://forum.linuxmint.pl/index.php/topic,5704.0.html. Jednak po wspisaniu tego polecenia: sudo apt-get dist-upgrade otrzymuję taki błąd: mielczar@thinkpad /etc/apt/sources.list.d $ sudo apt-get -f dist-upgrade
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Obliczanie aktualizacji...Nie udało się
Następujące pakiety mają niespełnione zależności:
 modemmanager : Narusza zależności: network-manager (< 0.9.8.2-1) ale 0.9.8.0-5 ma zostać zainstalowany
E: Błąd, pkgProblemResolver::Resolve zwrócił błąd, może to być spowodowane zatrzymanymi pakietami.

Przekopałem internet, ale nic konkretnego nie znalazłem. Co mogę zrobić w tej sytuacji? Z góry dzieki.

Offline mati75

  • Rodzina Linux Mint
  • Administrator
  • Spamerzy
  • *******
  • Wiadomości: 2381
  • Punkty: 25121
  • Płeć: Mężczyzna
    • >>>Click me!<<<
  • Wersja systemu: Inny
Odp: Aktualizacja - błąd Resolve
« Odpowiedź #1 dnia: Kwiecień 24, 2014, 19:36:52 pm »
Wszystkie kroki wykonane?

υωαgα α∂мιи !!! вαиαмι иαριєя∂αℓα !!!

Mielczar

  • Gość
Odp: Aktualizacja - błąd Resolve
« Odpowiedź #2 dnia: Kwiecień 24, 2014, 22:53:48 pm »
Tak, wszystko zrobione(wg poleceń dla Cinnamone).


EDIT

Chyba problem udało się rozwiązać. Wygląda na to, że Aptitude poradził sobie z tym problemem. To polecenie:sudo aptitude dist-upgrade spowodowało, że aktualizacja ruszyła. Zapytało czy usunąć sprzeczne pakiety i zastąpić tymi z repo. Potwierdziłem i obecnie trwa aktualizacja. Po zakończeniu napiszę o jej skutkach.

EDIT 2

Niestety aktualizacja się nie udała. W pewnym momencie aptitude chciał pobrać jakieś dodatkowe pakiety(już w trakcie instalacji pobranych wcześniej) i pojawił się błąd, że sieć jest niedostępna. Cała aktualizacja zakończyła się z kodem błędu 998. Po restarcie wydaje się, że ciała wszystko poza siecią. Przy próbie uruchomienia menadżera sieci pojawia się informacja, że wersja menażera jest niezgodna z tą wymaganą przez system.
« Ostatnia zmiana: Kwiecień 25, 2014, 00:32:17 am wysłana przez Mielczar »

Offline mati75

  • Rodzina Linux Mint
  • Administrator
  • Spamerzy
  • *******
  • Wiadomości: 2381
  • Punkty: 25121
  • Płeć: Mężczyzna
    • >>>Click me!<<<
  • Wersja systemu: Inny
Odp: Aktualizacja - błąd Resolve
« Odpowiedź #3 dnia: Kwiecień 25, 2014, 14:00:22 pm »
sudo apt-get update
sudo apt-get install -f

υωαgα α∂мιи !!! вαиαмι иαριєя∂αℓα !!!

Mielczar

  • Gość
Odp: Aktualizacja - błąd Resolve
« Odpowiedź #4 dnia: Kwiecień 25, 2014, 15:10:41 pm »
To nic nie daje, ponieważ nie działa połączenie sieciowe w ogóle.

Działanie obu poleceń:
mielczar@thinkpad:~$ sudo apt-get update
[sudo] password for mielczar:
Błąd  http://extra.linuxmint.com debian InRelease
  
Błąd  http://http.debian.net testing InRelease
  
Błąd  http://security.debian.org testing/updates InRelease
  
Błąd  http://www.deb-multimedia.org testing InRelease
  
Błąd  http://repo.dug.net.pl debian InRelease
  
Błąd  http://packages.linuxmint.com debian InRelease
  
Błąd  http://extra.linuxmint.com debian Release.gpg
  Nie udało się przetłumaczyć nazwy "extra.linuxmint.com"
Błąd  http://http.debian.net testing Release.gpg
  Nie udało się przetłumaczyć nazwy "http.debian.net"
Błąd  http://security.debian.org testing/updates Release.gpg
  Nie udało się przetłumaczyć nazwy "security.debian.org"
Błąd  http://www.deb-multimedia.org testing Release.gpg
  Nie udało się przetłumaczyć nazwy "www.deb-multimedia.org"
Błąd  http://repo.dug.net.pl debian Release.gpg
  Nie udało się przetłumaczyć nazwy "repo.dug.net.pl"
Błąd  http://packages.linuxmint.com debian Release.gpg
  Nie udało się przetłumaczyć nazwy "packages.linuxmint.com"
Czytanie list pakietów... Gotowe
W: Nie udało się pobrać http://packages.linuxmint.com/dists/debian/InRelease  

W: Nie udało się pobrać http://extra.linuxmint.com/dists/debian/InRelease  

W: Nie udało się pobrać http://http.debian.net/debian/dists/testing/InRelease  

W: Nie udało się pobrać http://security.debian.org/dists/testing/updates/InRelease  

W: Nie udało się pobrać http://www.deb-multimedia.org/dists/testing/InRelease  

W: Nie udało się pobrać http://repo.dug.net.pl/mint/dists/debian/InRelease  

W: Nie udało się pobrać http://extra.linuxmint.com/dists/debian/Release.gpg  Nie udało się przetłumaczyć nazwy "extra.linuxmint.com"

W: Nie udało się pobrać http://http.debian.net/debian/dists/testing/Release.gpg  Nie udało się przetłumaczyć nazwy "http.debian.net"

W: Nie udało się pobrać http://security.debian.org/dists/testing/updates/Release.gpg  Nie udało się przetłumaczyć nazwy "security.debian.org"

W: Nie udało się pobrać http://www.deb-multimedia.org/dists/testing/Release.gpg  Nie udało się przetłumaczyć nazwy "www.deb-multimedia.org"

W: Nie udało się pobrać http://repo.dug.net.pl/mint/dists/debian/Release.gpg  Nie udało się przetłumaczyć nazwy "repo.dug.net.pl"

W: Nie udało się pobrać http://packages.linuxmint.com/dists/debian/Release.gpg  Nie udało się przetłumaczyć nazwy "packages.linuxmint.com"

W: Nie udało się pobrać niektórych plików indeksu, zostały one zignorowane lub użyto ich starszej wersji.
mielczar@thinkpad:~$ sudo apt-get install -f
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności      
Odczyt informacji o stanie... Gotowe
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 9 nieaktualizowanych.
mielczar@thinkpad:~$


Natomiast:
sudo apt-get dist-upgradenie może zacząć działania, ponieważ konieczne jest pobranie 59kB pakietów, ale sieć nie działa i tak w koło...

W dodatku nie ma NetworkManager'a, a konfiguracja ręczna też nie działa.
« Ostatnia zmiana: Kwiecień 25, 2014, 15:14:52 pm wysłana przez Mielczar »

Offline mati75

  • Rodzina Linux Mint
  • Administrator
  • Spamerzy
  • *******
  • Wiadomości: 2381
  • Punkty: 25121
  • Płeć: Mężczyzna
    • >>>Click me!<<<
  • Wersja systemu: Inny
Odp: Aktualizacja - błąd Resolve
« Odpowiedź #5 dnia: Kwiecień 25, 2014, 19:38:01 pm »
sudo apt-get update
sudo apt-get dist-upgrade

υωαgα α∂мιи !!! вαиαмι иαριєя∂αℓα !!!

Mielczar

  • Gość
Odp: Aktualizacja - błąd Resolve
« Odpowiedź #6 dnia: Kwiecień 26, 2014, 13:50:28 pm »
Zainstalowałem system od nowa i przy ponownej próbie aktualizacji z repo debian testing znowu pojawia się błąd.

mielczar@thinkpad:~$ sudo apt-get update
[sudo] password for mielczar:
Ign.  http://extra.linuxmint.com debian InRelease
Ign.  http://extra.linuxmint.com debian Release.gpg                           
Pobieranie:1 http://extra.linuxmint.com debian Release [2275 B]               
Ign.  http://extra.linuxmint.com debian/main amd64 Packages/DiffIndex         
Ign.  http://extra.linuxmint.com debian/main i386 Packages/DiffIndex           
Ign.  http://repo.dug.net.pl debian InRelease                                 
Stary http://www.deb-multimedia.org testing InRelease                         
Ign.  http://repo.dug.net.pl debian Release.gpg                               
Stary http://security.debian.org testing/updates InRelease                     
Stary http://repo.dug.net.pl debian Release                                   
Stary http://security.debian.org testing/updates/main amd64 Packages           
Stary http://www.deb-multimedia.org testing/main amd64 Packages               
Ign.  http://packages.linuxmint.com debian InRelease                           
Ign.  http://repo.dug.net.pl debian/main amd64 Packages/DiffIndex             
Stary http://security.debian.org testing/updates/contrib amd64 Packages       
Stary http://www.deb-multimedia.org testing/non-free amd64 Packages           
Ign.  http://repo.dug.net.pl debian/main i386 Packages/DiffIndex               
Stary http://security.debian.org testing/updates/non-free amd64 Packages       
Stary http://www.deb-multimedia.org testing/main i386 Packages                 
Pobieranie:2 http://packages.linuxmint.com debian Release.gpg [198 B]         
Pobieranie:3 http://extra.linuxmint.com debian/main amd64 Packages [20 B]     
Stary http://security.debian.org testing/updates/main i386 Packages           
Stary http://www.deb-multimedia.org testing/non-free i386 Packages             
Stary http://security.debian.org testing/updates/contrib i386 Packages         
Stary http://repo.dug.net.pl debian/main amd64 Packages                       
Stary http://security.debian.org testing/updates/non-free i386 Packages       
Pobieranie:4 http://packages.linuxmint.com debian Release [16,8 kB]           
Stary http://repo.dug.net.pl debian/main i386 Packages                         
Stary http://security.debian.org testing/updates/contrib Translation-en       
Stary http://security.debian.org testing/updates/main Translation-en           
Pobieranie:5 http://extra.linuxmint.com debian/main i386 Packages [20 B]       
Stary http://security.debian.org testing/updates/non-free Translation-en       
Pobieranie:6 http://packages.linuxmint.com debian/import amd64 Packages [53,6 kB]
Ign.  http://extra.linuxmint.com debian/main Translation-pl_PL                 
Ign.  http://repo.dug.net.pl debian/main Translation-pl_PL                     
Ign.  http://repo.dug.net.pl debian/main Translation-pl                       
Ign.  http://repo.dug.net.pl debian/main Translation-en                       
Ign.  http://extra.linuxmint.com debian/main Translation-pl                   
Ign.  http://extra.linuxmint.com debian/main Translation-en                   
Pobieranie:7 http://packages.linuxmint.com debian/main amd64 Packages [26,1 kB]
Ign.  http://www.deb-multimedia.org testing/main Translation-pl_PL             
Pobieranie:8 http://packages.linuxmint.com debian/upstream amd64 Packages [18,1 kB]
Ign.  http://www.deb-multimedia.org testing/main Translation-pl               
Ign.  http://www.deb-multimedia.org testing/main Translation-en               
Ign.  http://www.deb-multimedia.org testing/non-free Translation-pl_PL         
Ign.  http://www.deb-multimedia.org testing/non-free Translation-pl           
Ign.  http://www.deb-multimedia.org testing/non-free Translation-en           
Pobieranie:9 http://packages.linuxmint.com debian/backport amd64 Packages [20 B]
Pobieranie:10 http://packages.linuxmint.com debian/romeo amd64 Packages [5882 B]
Pobieranie:11 http://packages.linuxmint.com debian/import i386 Packages [53,6 kB]
Pobieranie:12 http://packages.linuxmint.com debian/main i386 Packages [26,1 kB]
Pobieranie:13 http://packages.linuxmint.com debian/upstream i386 Packages [18,1 kB]
Stary http://http.debian.net testing InRelease                                 
Stary http://http.debian.net testing/main amd64 Packages/DiffIndex             
Pobieranie:14 http://packages.linuxmint.com debian/backport i386 Packages [20 B]
Stary http://http.debian.net testing/contrib amd64 Packages/DiffIndex         
Stary http://http.debian.net testing/non-free amd64 Packages/DiffIndex         
Stary http://http.debian.net testing/main i386 Packages/DiffIndex             
Stary http://http.debian.net testing/contrib i386 Packages/DiffIndex           
Pobieranie:15 http://packages.linuxmint.com debian/romeo i386 Packages [5902 B]
Stary http://http.debian.net testing/non-free i386 Packages/DiffIndex         
Stary http://http.debian.net testing/contrib Translation-en/DiffIndex         
Stary http://http.debian.net testing/main Translation-pl/DiffIndex             
Stary http://http.debian.net testing/main Translation-en/DiffIndex             
Stary http://http.debian.net testing/non-free Translation-en/DiffIndex         
Ign.  http://packages.linuxmint.com debian/backport Translation-pl_PL         
Ign.  http://packages.linuxmint.com debian/backport Translation-pl
Ign.  http://packages.linuxmint.com debian/backport Translation-en
Ign.  http://packages.linuxmint.com debian/import Translation-pl_PL
Ign.  http://packages.linuxmint.com debian/import Translation-pl
Ign.  http://packages.linuxmint.com debian/import Translation-en
Ign.  http://packages.linuxmint.com debian/main Translation-pl_PL
Ign.  http://packages.linuxmint.com debian/main Translation-pl
Ign.  http://packages.linuxmint.com debian/main Translation-en
Ign.  http://packages.linuxmint.com debian/romeo Translation-pl_PL
Ign.  http://packages.linuxmint.com debian/romeo Translation-pl
Ign.  http://packages.linuxmint.com debian/romeo Translation-en
Ign.  http://packages.linuxmint.com debian/upstream Translation-pl_PL
Ign.  http://packages.linuxmint.com debian/upstream Translation-pl
Ign.  http://packages.linuxmint.com debian/upstream Translation-en
Pobrano 227 kB w 31s (7220 B/s)
Czytanie list pakietów... Gotowe
mielczar@thinkpad:~$ sudo apt-get dist-upgrade
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Obliczanie aktualizacji...Nie udało się
Następujące pakiety mają niespełnione zależności:
 modemmanager : Narusza zależności: network-manager (< 0.9.8.2-1) ale 0.9.8.0-5 ma zostać zainstalowany
E: Błąd, pkgProblemResolver::Resolve zwrócił błąd, może to być spowodowane zatrzymanymi pakietami.
E: Internal error, Upgrade broke stuff
mielczar@thinkpad:~$ sudo apt-get install -f
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 245 nieaktualizowanych.
mielczar@thinkpad:~$

Dochodzę do wniosku, że szybciej i prościej będzie zainstalować testing z netinstall i doinstalować ręcznie cinnamona.

Offline mati75

  • Rodzina Linux Mint
  • Administrator
  • Spamerzy
  • *******
  • Wiadomości: 2381
  • Punkty: 25121
  • Płeć: Mężczyzna
    • >>>Click me!<<<
  • Wersja systemu: Inny
Odp: Aktualizacja - błąd Resolve
« Odpowiedź #7 dnia: Kwiecień 26, 2014, 16:46:38 pm »
Usunąłbym network-manager i zainstalował wicd, potem kontynuował aktualizację.

υωαgα α∂мιи !!! вαиαмι иαριєя∂αℓα !!!

Mielczar

  • Gość
Odp: Aktualizacja - błąd Resolve
« Odpowiedź #8 dnia: Kwiecień 26, 2014, 18:01:51 pm »
Zrobiłem tak jak radziłeś(na wirtualnej maszynie tym razem, ale scenariusz aktualizacji wygląda tak jak na fizycznej). Teoretycznie udało się odinstalować network-manager'a i zainstalować pobranego wcześniej z zależnościami wicd'a. Jednak tuż po instalacji wicd nie uruchomił się. Po restarcie nie można zalogować się do systemu, zaraz po podaniu hasła, xsession zostaje zakończone i w terminalu przy xsession i wicd jest komunikat o błędzie. Próbuję zainstalować debiana i później dodać cinnamon'a.

Offline hsurim

  • Miętowa sadzonka
  • **
  • Wiadomości: 84
  • Punkty: 2
  • Płeć: Mężczyzna
  • Środowisko graficzne: Xfce
  • Wersja systemu: Inny
Odp: Aktualizacja - błąd Resolve
« Odpowiedź #9 dnia: Kwiecień 26, 2014, 23:36:46 pm »
(...)
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 245 nieaktualizowanych.
(...)
Robiłem to trzykrotnie na jednym z komputerów i mam podobnie.  ???

Offline mati75

  • Rodzina Linux Mint
  • Administrator
  • Spamerzy
  • *******
  • Wiadomości: 2381
  • Punkty: 25121
  • Płeć: Mężczyzna
    • >>>Click me!<<<
  • Wersja systemu: Inny
Odp: Aktualizacja - błąd Resolve
« Odpowiedź #10 dnia: Kwiecień 27, 2014, 09:43:30 am »
Dzisiaj naprawili network-manager w unstable, za dwa dni trafi aktualizacja do testing.

υωαgα α∂мιи !!! вαиαмι иαριєя∂αℓα !!!

Mielczar

  • Gość
Odp: Aktualizacja - błąd Resolve
« Odpowiedź #11 dnia: Kwiecień 27, 2014, 11:19:49 am »
Dobrze wiedzieć, poczekam i wtedy spróbuje aktualizacji. Póki co czyste LMDE ;)

Mielczar

  • Gość
Odp: Aktualizacja - błąd Resolve
« Odpowiedź #12 dnia: Kwiecień 30, 2014, 11:26:50 am »
Dzisiaj udało mi się zaktualizować LMDE w oparciu o repo Jessie. Problem z network-manager nie występował. Jedyne utrudnienie to takie, że podczas pobierania paczek wystąpił błąd w 4 pozycjach(nie można było ich pobrać). Problem ten rozwiązuje sudo apt-get update --fix-missings po tym wszystko przebiegło sprawnie.

Jednak jest jeszcze jeden problem. Po akutalizacji pojawiły się dziwne zaszarzenia na przyciskach, jakby tło pod napisami. Myślę, że zrzut wszystko wyjasnia.

« Ostatnia zmiana: Kwiecień 30, 2014, 14:19:13 pm wysłana przez Mielczar »

Offline mati75

  • Rodzina Linux Mint
  • Administrator
  • Spamerzy
  • *******
  • Wiadomości: 2381
  • Punkty: 25121
  • Płeć: Mężczyzna
    • >>>Click me!<<<
  • Wersja systemu: Inny
Odp: Aktualizacja - błąd Resolve
« Odpowiedź #13 dnia: Kwiecień 30, 2014, 14:48:56 pm »
Styl nie jest zgodny z nową wersją biblioteki gtk3. Można spróbować zainstalować pakiet ze stylami z minta 17, bądź poczekać na aktualizację.

υωαgα α∂мιи !!! вαиαмι иαριєя∂αℓα !!!

Mielczar

  • Gość
Odp: Aktualizacja - błąd Resolve
« Odpowiedź #14 dnia: Kwiecień 30, 2014, 18:12:04 pm »
Ok, problem rozwiązany. Pomogła instalacja pakietu z minta 17.

Dla zainteresowanych: Należy pobrać z tej storny: http://packages.linuxmint.com/list.php?release=Qiana pakiet mint-themes-gtk3 (w chwili pisania jest to wersja 3.10-2) i zainstalować poprzez manager oprogramowania. Przy okazji zamykamy ostrzeżenie o zbyt nowej wersji pakietu i klikamy instaluj. Po wszystkim reboot i buttony wyglądają jak św. iGNUcy przykazał :)
« Ostatnia zmiana: Kwiecień 30, 2014, 18:31:44 pm wysłana przez Mielczar »