Forum Linux Mint Polska

Autor Wątek: MOBILITY Radeon HD 3650  (Przeczytany 2663 razy)

FranekRopa

  • Gość
MOBILITY Radeon HD 3650
« dnia: Październik 04, 2014, 22:08:55 pm »
Witam!
Zainstalowałem niedawno LMDE na moim ThinkPadzie T500 z kartą jak w temacie. Problem jest taki, że kiedy po tzw. "wyszukiwaniu sterownika" na stronie amd wyskakuje driver dla wszystkich kart Radeon HD, po wklepaniu w terminalu sh ./amd*.run --buildpkg Debian/testing (bo tego jądra używa Mint Debian) wyskakuje:Created directory fglrx-install.tLCT1O
Verifying archive integrity... All good.
Uncompressing AMD Catalyst(TM) Proprietary Driver-8.97.100.7...
=====================================================================
 AMD Catalyst(TM) Proprietary Driver Installer/Packager
=====================================================================
Generating package: Debian/testing
cp: cannot stat '/home/grzegorz/Pobrane/fglrx-install.tLCT1O/x710_64a/*': No such file or directory
Package build failed!
Package build utility output:
dpkg-buildpackage: source package fglrx-installer
dpkg-buildpackage: source version 8.97.100.7-1
dpkg-buildpackage: source changed by AMD: Advanced Micro Devices. <http://ati.amd.com/support/driver.html>
 dpkg-source --before-build fglrx.dY7DPZ
dpkg-buildpackage: host architecture amd64
 debian/rules build
dh_testdir
# move licenses away from binary dir
if [ ! -d usr/share/doc/fglrx ]; then \
  mkdir -p usr/share/doc/fglrx; \
  mv usr/X11R6/bin/LICENSE.* usr/share/doc/fglrx; \
fi
# set executable on user apps
find usr/X11R6/bin -type f | xargs chmod a+x
# remove exec bit from files that don't deserve it
find usr/X11R6/include \
     usr/X11R6/lib \
     usr/X11R6/lib64 \
     usr/share usr/src     -type f | xargs chmod -x
find: `usr/X11R6/include': No such file or directory
find lib -not -name "*.sh" -type f | xargs chmod -x
find lib      -name "*.sh" -type f | xargs chmod +x
# set proper permissions on /etc files
if [ -d etc/ati ]; then \
chmod 755 etc/ati ; \
chmod 644 etc/ati/* ; \
chmod a+x etc/ati/*.sh ; \
fi
if [ -f debian/fglrx.default ]; then \
  mv -v debian/fglrx.default debian/fglrx; \
fi
'debian/fglrx.default' -> 'debian/fglrx'
# remove exec bit from 64-bit libs too
find usr/X11R6/lib64       -type f | xargs chmod -x
 debian/rules binary
dh_testdir
# move licenses away from binary dir
if [ ! -d usr/share/doc/fglrx ]; then \
  mkdir -p usr/share/doc/fglrx; \
  mv usr/X11R6/bin/LICENSE.* usr/share/doc/fglrx; \
fi
# set executable on user apps
find usr/X11R6/bin -type f | xargs chmod a+x
# remove exec bit from files that don't deserve it
find usr/X11R6/include \
     usr/X11R6/lib \
     usr/X11R6/lib64 \
     usr/share usr/src     -type f | xargs chmod -x
find: `usr/X11R6/include': No such file or directory
find lib -not -name "*.sh" -type f | xargs chmod -x
find lib      -name "*.sh" -type f | xargs chmod +x
# set proper permissions on /etc files
if [ -d etc/ati ]; then \
chmod 755 etc/ati ; \
chmod 644 etc/ati/* ; \
chmod a+x etc/ati/*.sh ; \
fi
if [ -f debian/fglrx.default ]; then \
  mv -v debian/fglrx.default debian/fglrx; \
fi
# remove exec bit from 64-bit libs too
find usr/X11R6/lib64       -type f | xargs chmod -x
dh_testdir
dh_testroot
dh_clean -k
dh_clean: dh_clean -k is deprecated; use dh_prep instead
dh_clean: Compatibility levels before 5 are deprecated (level 4 in use)
dh_installdirs
dh_installdirs: Compatibility levels before 5 are deprecated (level 4 in use)
# Create the directories to install into
dh_installdirs -pfglrx-driver \
usr \
usr/lib/xorg \
usr/lib/xorg/modules \
usr/lib/dri \
usr/bin \
usr/sbin \
etc/acpi \
etc/acpi/events \
etc/default \
etc/X11/Xsession.d
dh_installdirs: Compatibility levels before 5 are deprecated (level 4 in use)
# the amd64 package includes 32bit compatibility libraries
dh_installdirs -pfglrx-driver \
emul/ia32-linux/usr/lib \
emul/ia32-linux/usr/lib/xorg \
emul/ia32-linux/usr/lib/xorg/modules \
emul/ia32-linux/usr/lib/dri
dh_installdirs: Compatibility levels before 5 are deprecated (level 4 in use)
dh_installdirs -pfglrx-driver-dev \
usr \
usr/include \
usr/lib
dh_installdirs: Compatibility levels before 5 are deprecated (level 4 in use)
dh_installdirs -pfglrx-kernel-src \
usr/src/modules/fglrx \
usr/src/modules/fglrx/debian
dh_installdirs: Compatibility levels before 5 are deprecated (level 4 in use)
dh_installdirs -A -pfglrx-amdcccle \
usr \
usr/bin \
usr/share \
usr/share/applnk \
usr/share/applications \
usr/share/icons \
usr/share/pixmaps
dh_installdirs: Compatibility levels before 5 are deprecated (level 4 in use)
dh_installdirs -p \
usr/src
dh_installdirs: Compatibility levels before 5 are deprecated (level 4 in use)
dh_install
dh_install: Compatibility levels before 5 are deprecated (level 4 in use)
ldconfig -n usr/X11R6/lib/
dh_install -pfglrx-driver "usr/X11R6/bin/fgl*"      "usr/bin"
dh_install: Compatibility levels before 5 are deprecated (level 4 in use)
dh_install -pfglrx-driver "usr/X11R6/bin/aticonfig" "usr/bin"
dh_install: Compatibility levels before 5 are deprecated (level 4 in use)
dh_install -pfglrx-driver "usr/sbin/atieventsd"     "usr/sbin"
dh_install: Compatibility levels before 5 are deprecated (level 4 in use)
dh_installman -pfglrx-driver "usr/share/man/man8/atieventsd.8"
dh_installman: Compatibility levels before 5 are deprecated (level 4 in use)
# amd64 needs some library redirection
dh_install -pfglrx-driver "usr/X11R6/lib64/*.so*"           "usr/lib"
dh_install: Compatibility levels before 5 are deprecated (level 4 in use)
dh_install -pfglrx-driver "usr/X11R6/lib64/modules/dri"     "usr/lib"
dh_install: Compatibility levels before 5 are deprecated (level 4 in use)
dh_install -pfglrx-driver "usr/X11R6/lib64/modules/linux"   "usr/lib/xorg/modules"
dh_install: Compatibility levels before 5 are deprecated (level 4 in use)
cp: cannot stat './usr/X11R6/lib64/modules/linux': No such file or directory
dh_install: cp -a ./usr/X11R6/lib64/modules/linux debian/fglrx-driver/usr/lib/xorg/modules/ returned exit code 1
make: *** [binary] Error 2
dpkg-buildpackage: error: debian/rules binary gave error exit status 2
Removing temporary directory: fglrx-install.tLCT1O
dokładnie to. Co w takiej sytuacji zrobić/jak to poprawnie zainstalować? (jakby co byłem zalogowany na roocie)
Dzięki za odpowiedź,
Pozdrawiam.
Grzegorz

Offline saygon

  • Miętowe nasionko
  • *
  • Wiadomości: 20
  • Punkty: 1
  • Płeć: Mężczyzna
    • T3chn0l0gii - O IT i nie tylko
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: Linux Mint 17
Odp: MOBILITY Radeon HD 3650
« Odpowiedź #1 dnia: Październik 04, 2014, 23:04:54 pm »
Spróbuj tego:
sudo apt-get purge fglrx fglrx-amdcccle
Następnie usuń foldery sterowników wydając polecenia:
sudo rm -R /usr/lib/fglrx
sudo rm -R /usr/share/ati

Uruchom ponownie komputer i wydaj polecenie:
sudo apt-get install fglrx && sudo aticonfig --initial -f

Jeśli nadal będziesz miał problem zainstaluj sterowniki za pomocą menadżera sterowników.

FranekRopa

  • Gość
Odp: MOBILITY Radeon HD 3650
« Odpowiedź #2 dnia: Październik 05, 2014, 11:14:02 am »
W pierwszym kroku niewypał:
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Package 'fglrx' is not installed, so not removed
E: Nie udało się odnaleźć pakietu fglrx-amdcccle
Spróbuje jeszcze z menadżerem.

Offline saygon

  • Miętowe nasionko
  • *
  • Wiadomości: 20
  • Punkty: 1
  • Płeć: Mężczyzna
    • T3chn0l0gii - O IT i nie tylko
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: Linux Mint 17
Odp: MOBILITY Radeon HD 3650
« Odpowiedź #3 dnia: Październik 05, 2014, 14:36:41 pm »
Instalację sterownika odpalałeś za uprawnieniami roota?

FranekRopa

  • Gość
Odp: MOBILITY Radeon HD 3650
« Odpowiedź #4 dnia: Październik 05, 2014, 15:13:33 pm »
Oczywiście, że tak.
Poszukałem po internecie i podobno fglrx w wersji >8.53 nie obsługuje tegoż radeonka, znalazłem jakiegoś linka do 8.4, z tym że nie działa (https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/ati-driver-installer-8.42.3-x86.x86_64.run), wyświetla się bodajże "Brak dostępu", a w przeglądarce "Error 403: Forbidden." Jakbyś gdzieś widział linka do pobrania to byłbym bardzo wdzięczny, sam pogoogluje do godziny jak będzie taka potrzeba.

Offline saygon

  • Miętowe nasionko
  • *
  • Wiadomości: 20
  • Punkty: 1
  • Płeć: Mężczyzna
    • T3chn0l0gii - O IT i nie tylko
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: Linux Mint 17
Odp: MOBILITY Radeon HD 3650
« Odpowiedź #5 dnia: Październik 05, 2014, 15:57:05 pm »
Znalazłem, pobierz ten sterownik po przez wget
wget http://ftp.isu.edu.tw/pub/Linux/Gentoo/distfiles/ati-driver-installer-8.42.3-x86.x86_64.run

FranekRopa

  • Gość
Odp: MOBILITY Radeon HD 3650
« Odpowiedź #6 dnia: Październik 05, 2014, 16:36:52 pm »
Niestety, po zrobieniuati*.run --buildpkg Debian/testing dalej zwraca error code 2.

Offline saygon

  • Miętowe nasionko
  • *
  • Wiadomości: 20
  • Punkty: 1
  • Płeć: Mężczyzna
    • T3chn0l0gii - O IT i nie tylko
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: Linux Mint 17
Odp: MOBILITY Radeon HD 3650
« Odpowiedź #7 dnia: Październik 05, 2014, 17:03:41 pm »

FranekRopa

  • Gość
Odp: MOBILITY Radeon HD 3650
« Odpowiedź #8 dnia: Październik 05, 2014, 21:18:42 pm »
No próbowałem, nie działa...
Spróbuję napisać do AMD, ale pewnie w ogóle nie odpowiedzą, albo odpiszą w skrócie "Przepraszamy, ale blablabla i nie jesteśmy w stanie Ci pomóc. Dziękujemy za kontakt.". Poszperam w googlach, może się znajdzie sposób.

Offline Ulvhedin

  • Globator Moderalny
  • Spamerzy
  • *******
  • Wiadomości: 1628
  • Punkty: 1118
  • Płeć: Mężczyzna
  • Środowisko graficzne: Mate
  • Wersja systemu: 18
Odp: MOBILITY Radeon HD 3650
« Odpowiedź #9 dnia: Październik 06, 2014, 12:46:26 pm »
Link FAQ w mojej stopce. Instalacja driverów dla ATI opisana.

FranekRopa

  • Gość
Odp: MOBILITY Radeon HD 3650
« Odpowiedź #10 dnia: Październik 06, 2014, 20:44:48 pm »
W logu instalacji sterownika bylo napisane, ze fglrx potrzebuje kernel headers. Zainstalowalem i musialem przywrocic pliki o ktorych backup mnie poprosil i mam problem; mianowicie po uruchomieniu monitor pokazuje komunikat "OUT OF RANGE". Gdzie zmienic rozdzielczosc, tak zeby byla  mniejsza i monitor sobie radzil (chodzi o configa)? Przepraszam za brak polskich znakow diakrytycznych, ale jestem na live i nie dzialaja.
« Ostatnia zmiana: Październik 06, 2014, 20:48:32 pm wysłana przez FranekRopa »

FranekRopa

  • Gość
Odp: MOBILITY Radeon HD 3650
« Odpowiedź #11 dnia: Październik 13, 2014, 21:51:28 pm »
Dobra, działa już. Powód-brak DKMS. Dzięki za wsparcie.