Forum Linux Mint Polska

Autor Wątek: Podkręcanie procesora  (Przeczytany 808 razy)

Offline aras

  • Siewca Mięty
  • Miętowy krzew
  • *****
  • Wiadomości: 357
  • Punkty: 756
  • Płeć: Mężczyzna
  • linux to linux
    • http://cojesturokiem.blogspot.com
Podkręcanie procesora
« dnia: Styczeń 24, 2016, 22:17:10 pm »


Siema, jako że wgrałem sobie modowanego biosa do mojego starego laptopa z odblokowanym dual ida, to chciałem żeby działało to również na linuxie, bo n windowsie działa.

Co zrobić, żeby CPU-Z na linuxie widził te same parametry Multiplier, bo chciałbym, żeby to było 10 x 199,5 i żeby cpupower frequency-info pokazywał wartość 1995 Mhz, bo listing w dalszym ciągu jest taki:

cpupower frequency-info
analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.0 us.
  hardware limits: 800 MHz - 1.80 GHz
  available frequency steps: 1.80 GHz, 1.80 GHz, 1.20 GHz, 800 MHz
  available cpufreq governors: ondemand, performance
  current policy: frequency should be within 800 MHz and 1.80 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency is 1.20 GHz.
  boost state support:
    Supported: no
    Active: no

bo to:

/etc/modprobe.d/ignore_ppc.conf

# If the frequency of your machine gets wrongly limited by BIOS, this should help
options processor ignore_ppc=1

i to również nie pomaga:

[igor@bystry cpufreq]$ sudo cpupower frequency-set -u 1995 mhz
Setting cpu: 0
Error setting new values. Common errors:
- Do you have proper administration rights? (super-user?)
- Is the governor you requested available and modprobed?
- Trying to set an invalid policy?
- Trying to set a specific frequency, but userspace governor is not available,
   for example because of hardware which cannot be set to a specific frequency
   or because the userspace governor isn't loaded?
[igor@bystry cpufreq]$

i nwet jakby miało pomóc to tylko w zakresie 800-1800 Mhz, a chodzi o 1995 Mhz

a jeśli chodzi o msr, też mi to nic nie mówi:

[igor@bystry ~]$ sudo rdmsr 0x198
[sudo] hasło użytkownika igor:
617092506320925

Ogólnie buszuję po: /sys/devices/system/cpu/

ale nic mi nie przychodzi na myśl, oprócz zmiany wartości w kilku plikach na 1955000:

[igor@bystry cpu]$ cd /sys/devices/system/cpu/cpu0/cpufreq
[igor@bystry cpufreq]$ ls
affected_cpus               freqdomain_cpus                scaling_governor
bios_limit                  related_cpus                   scaling_max_freq
cpuinfo_cur_freq            scaling_available_frequencies  scaling_min_freq
cpuinfo_max_freq            scaling_available_governors    scaling_setspeed
cpuinfo_min_freq            scaling_cur_freq
cpuinfo_transition_latency  scaling_driver

chociaż i tak nie mogę wymusić zapisu pliku, pewnie na innym levelu, ale czy to wogóle ma jakiś sens i jezeli nawet coś by dało radę, to jak zapisać ustawienia, żeby przy ponownym uruchomieniu nie musieć bawić się od nowa.

Także cóż tu zrobić ?

Pozdro




« Ostatnia zmiana: Styczeń 24, 2016, 22:28:57 pm wysłana przez aras »
z linuxem jak z kobietą, musisz zaakceptować wady i zalety, jak chcesz sobie poużywać ;)