Forum Linux Mint Polska

Autor Wątek: Po instalacji Linux Mint 18 nie uruchamia sie samoczynnie z HDD [SOLVED]  (Przeczytany 502 razy)

Offline puro

  • Miętowe nasionko
  • *
  • Wiadomości: 8
  • Punkty: 0
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Witam.

Minta zainstalowalem na lapku Acer Aspire V 15 Nitro. (tylko Mint, bez Windowsa) Po instalacji nie ururuchamia sie z dysku. Przy wlaczeniu lapka wyskakuje "no bootable disk". Jestem nowym uzytkownikiem linuxa, jednak mialem juz doczynienia z instalacja roznych wersji linuxa na serverach. Pierwszy raz instaluje Linuxa na lapku dla wlasnego uzytku. Szukam rozwiazania problemu na roznych forach, rowniez na tym przeczytalem sporo watkow.

- W BIOS ustawilem security boot na disabled.
- Po wlaczeniu lapka, wybierajac opcje bootowania dyskow klawiszem [f12] nie wykrywa zadnego dysku.
- probowalem sudo grub-install /dev/sda ,niestety bez efektow
- zmiana opcji w BIOS z UEFI na legacy nic nie dala. probowalem tez zainstalowac ponownie minta z opcja ustawiona na legacy, jednak nie chce sie zbootowac z usb

W BIOS znalazlem opcje recovery acer disc - enabled (uzywajac klawisza [alt + f10])
Linux uruchamia sie z dysku tylko wtedy gdy podczas uruchomienia kompa naciskam [alt + f10]

Czy ktos ma jakis pomysl jak zrobic by linux uruchamial sie z dysku?

Czy to moze byc wina HDD, lub BIOS jest nie kompatybilny?
« Ostatnia zmiana: Grudzień 20, 2016, 14:10:39 pm wysłana przez puro »

Offline kruger84

  • Miętowy liść
  • *
  • Wiadomości: 30
  • Punkty: -16
Odp: Po instalacji Linux Mint 18 nie uruchamia sie samoczynnie z HDD
« Odpowiedź #1 dnia: Grudzień 15, 2016, 16:55:13 pm »
Jakie masz partycje na dysku ? Ja instalowałem system na sda2 ale gruba na sda1. Kiedy wrzucałem gruba na sda, komp mi nie startował. Tyle, że ja miałem kilka systemów na jednym dysku. Inna sprawa to program rozruchowy biosu. U mnie w biosie np. niekiedy muszę dodać opcję rozruchową pod dany system operacyjny.

Offline puro

  • Miętowe nasionko
  • *
  • Wiadomości: 8
  • Punkty: 0
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Odp: Po instalacji Linux Mint 18 nie uruchamia sie samoczynnie z HDD
« Odpowiedź #2 dnia: Grudzień 15, 2016, 19:05:45 pm »
ustawilem 3 partycje

sda1 - efi - sustemowa
sda2 - swap
sda3 - /

teraz zainstalowalem Minta od nowa na partycjach

sda1 - grubbios 100 mb (jak instalowalem OS-y na serverach to dawalo sie 2mb (ale dysk musial miec minimum 2T, ja mam 1T ale chcialem sprobowac) czy jakos podobnie, ale przy instalacji byly bledy z instalacja grub stad zwiekszylem do 100 mb
sda2 - efi
sda3 - swap
sda4 - /

w biosie ustawilem "network boot" na enabled
teraz przy bootowaniu jest czarny ekran z napisem checking media

potem informacja ze niewlasciwy dysk bootowania, zeby wlozyc recovery boot media i nacisnac dowolny klawisz. Po wlozeniu usb z instalka, OS sie uruchamia. Jak tego nie zrobie to wyskakuje opcja bootowania z dysku, IPv4 i IPv6.
Dysk jest oznaczony jako unknown device i to mnie zastanawia. Czy jest mozliwe ze BIOS nie rozpoznaje partycji linuxowych i przez to w boot manager nie widac dysku?
Moze update BIOS zalatwil by sprawe? ale z drugiej strony mam calkiem nowego lapka.

Mam jeszcze pomysl by przy instalacji zrobic partycje /boot (tak jak sie to robilo na serverach i tam ustawic program rozruchowy). Nie wydaje mi sie zeby to pomoglo, ale z braku pomyslow na pewno sprobuje

Dziekuje za odpowiedz, zawsze daje to nowe spojrzenie na problem. Niby teraz przy bootowaniu nie musze naciskac [alt + f10], ale nie rozwiazalo to problemu.

Jakies sugestie? jestem wdzieczny za kazda odpowiedz :)

Offline kruger84

  • Miętowy liść
  • *
  • Wiadomości: 30
  • Punkty: -16
Odp: Po instalacji Linux Mint 18 nie uruchamia sie samoczynnie z HDD
« Odpowiedź #3 dnia: Grudzień 15, 2016, 20:09:21 pm »
Gdzie umieściłeś bootloadera ?

 

teraz zainstalowalem Minta od nowa na partycjach

sda1 - grubbios 100 mb (jak instalowalem OS-y na serverach to dawalo sie 2mb (ale dysk musial miec minimum 2T, ja mam 1T ale chcialem sprobowac) czy jakos podobnie, ale przy instalacji byly bledy z instalacja grub stad zwiekszylem do 100 mb
sda2 - efi
sda3 - swap
sda4 - /


Zastanawiam się nad sda1. Partycje sda2/3/4 zostaw, ale sda1 spróbowałbym usunąć. Przeinstaluj minta na nowo, przy czym bootloadera daj na partycję EFI, czyli najprawdopodobniej sda2. Chyba, że wprowadzisz jeszcze jakieś zmiany po swojemu.


w biosie ustawilem "network boot" na enabled
teraz przy bootowaniu jest czarny ekran z napisem checking media

Network boot pozostaw na disable

Offline puro

  • Miętowe nasionko
  • *
  • Wiadomości: 8
  • Punkty: 0
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Odp: Po instalacji Linux Mint 18 nie uruchamia sie samoczynnie z HDD
« Odpowiedź #4 dnia: Grudzień 17, 2016, 18:38:50 pm »
Witam, dziekuje za odpowiedz.

Zrobilem zgodnie z rada. przeinstalowalem OS-a, grub na partycji EFI. Networkboot wrocil na disable.
Nic sie nie zmienilo, zreszta za pierwszym razem tak instalowalem Minta.

Instalujac linuxa na serverach, musiala byc partycja /boot. Probowalem to i tutaj. Grub instalujac na /boot. bez efektu

Probowalem tez kolejnej instalacji z partycja /grubbios (przy instalacji jest wybor partycji rozruchowej... chyba przekrecilem nazwe tej partycji) i /boot. tez bez efektu.

Dzwonilem do znajomych z IT. Przez telefon jedynie uslyszalem ze wszystko powinno dzialac. zebym sprobowal zmienic w BIOS z UEFI na legacy i wtedy zainstalowac minta jeszcze raz. Po zminie na legacy, nie chce sie bootowac instalka z usb. W wolnym czasie chyba sie przejade do znajomych by sami spojrzeli na lapka. Nie mam juz pomyslow jak rozwiazac ten problem. Po rozruchu lapka wciskajac [alt + f10] uruchamiam OS. Boje sie troche ze to moze jakos uszkodzic kompa, lub HDD

Moze majac windowsa obok Minta przy uruchomieniu bedzie mozna wybrac co ma sie bootowac. Tylko ze nie chce miec windowsa :P.

Jedyne co przychodzi mi do glowy ze to problem z BIOS-em, lub z dyskiem. Moze jakies zabezpieczenie w BIOS? Moze sformatowac dysk na lapku najpierw? Ale chyba przy instalacji jest to robione... Sprawdze jeszcze czy moge aktualizowac BIOS, to nie powinno zaszkodzic.

Jak znajde sposob na rozwiazanie problemu to napisze.

Offline kruger84

  • Miętowy liść
  • *
  • Wiadomości: 30
  • Punkty: -16
Odp: Po instalacji Linux Mint 18 nie uruchamia sie samoczynnie z HDD
« Odpowiedź #5 dnia: Grudzień 17, 2016, 19:14:11 pm »
W takim przypadku trzeba byłoby przyjrzeć się ustawieniom biosu. Jak możesz zrób zdjęcia swojego biosu, a konkretniej poszczególnych zakładek. Znam z doświadczenia sytuacje kiedy komp z zakupionym Windowsem 8, dopuszczał instalacje Windowsa 10, ale Windowsa 7 nie dało rady odpalić już nawet instalatora. Dopiero zmiana ustawień biosu - w tym wyłączenie "secure boot" dopuszczała możliwość instalowania czegoś innego spoza win 8/10.

W niektórych biosach jest możliwość dodawania opcji rozruchowych pod dany system operacyjny. Na ogół instalatory same dokonują tych wpisów. Być może masz w swoim biosie taka opcję ale, musisz ręcznie zrobić wpis. Poza tym, instalka usb przestała się ładować bo zmieniłeś EUFI na legacy. Musiałbyś jeszcze zmienić w opcjach usb na legacy. Wykonaj fotki biosu i wtedy może coś wymyślimy.
« Ostatnia zmiana: Grudzień 17, 2016, 19:31:57 pm wysłana przez kruger84 »

Offline puro

  • Miętowe nasionko
  • *
  • Wiadomości: 8
  • Punkty: 0
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Odp: Po instalacji Linux Mint 18 nie uruchamia sie samoczynnie z HDD
« Odpowiedź #6 dnia: Grudzień 17, 2016, 20:15:36 pm »
Wlaczylem w BIOS security boot na enabled.
W opcjach seciurity boot jest opcja zeby wybrac zaufany program rozruchowy UEFI.
Nie wiem tylko ktora opcje wybrac i co wpisac w boot description.

Nie umiem wstawic zdjecia, napisze co jest do wyboru :

fwupx64.efi
grubx64.efi
shimx64.efi
MokManager.efi

po wybraniu jednej z opcji wyskakuje okno czy chce dodac ten plik do bazy danych i trzeba wpisac boot desciption.
jak przepisuje nazwe pliku, to pisze ze ta nazwa istnieje. jak wpisywalem cos innego, to dalo sie potwierdzic, ale bootowanie bez zmian.

Jeszcze nie sprawdzilem wszystkich plikow. Probowalem tylko z grubem

Offline kruger84

  • Miętowy liść
  • *
  • Wiadomości: 30
  • Punkty: -16
Odp: Po instalacji Linux Mint 18 nie uruchamia sie samoczynnie z HDD
« Odpowiedź #7 dnia: Grudzień 17, 2016, 20:23:04 pm »
Najprawdopodobniej będzie to grubx64 Przy boot desciption wpisz cokolwiek np linux. Pokombinuj z innymi wpisami jeśli nie wyjdzie z grubx64

Offline puro

  • Miętowe nasionko
  • *
  • Wiadomości: 8
  • Punkty: 0
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Odp: Po instalacji Linux Mint 18 nie uruchamia sie samoczynnie z HDD
« Odpowiedź #8 dnia: Grudzień 17, 2016, 20:43:27 pm »
bez zmian. a jak wpisuje w desciption grubx64 to pisze ze plik juz istnieje

Offline puro

  • Miętowe nasionko
  • *
  • Wiadomości: 8
  • Punkty: 0
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Odp: Po instalacji Linux Mint 18 nie uruchamia sie samoczynnie z HDD
« Odpowiedź #9 dnia: Grudzień 17, 2016, 20:52:37 pm »
udalo sie :).
plik grubx64.

Dzieki wielkie. Problem rozwiazny.
Miales racje za pierwszym razem jak pisales ze w BIOS trzeba dodac opcje rozruchowa :)
« Ostatnia zmiana: Grudzień 18, 2016, 18:10:34 pm wysłana przez puro »

Offline kruger84

  • Miętowy liść
  • *
  • Wiadomości: 30
  • Punkty: -16
Odp: Po instalacji Linux Mint 18 nie uruchamia sie samoczynnie z HDD
« Odpowiedź #10 dnia: Grudzień 17, 2016, 20:58:30 pm »
Szczerze mówiąc nie wiem dlaczego nie chce ci system zabotować. Miałem niekiedy problem z uruchomieniem systemu, ale za każdym razem powodem były ustawienia biosu. Może inne osoby niech się wypowiedzą, bo pomimo szczerych chęci nie umiem Ci pomóc.

Offline puro

  • Miętowe nasionko
  • *
  • Wiadomości: 8
  • Punkty: 0
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Odp: Po instalacji Linux Mint 18 nie uruchamia sie samoczynnie z HDD
« Odpowiedź #11 dnia: Grudzień 17, 2016, 21:30:12 pm »
Problem rozwiazany. Juz OS sie bootuje normalnie.

zaufany program UEFI - grubx64.efi

Dzieki wielkie :)
« Ostatnia zmiana: Grudzień 18, 2016, 18:10:51 pm wysłana przez puro »