Forum Linux Mint Polska

Autor Wątek: Brak polskich znaków w edytorze tekstu  (Przeczytany 898 razy)

Offline omkar

  • Miętowy liść
  • *
  • Wiadomości: 29
  • Punkty: 0
  • Płeć: Mężczyzna
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Brak polskich znaków w edytorze tekstu
« dnia: Luty 02, 2017, 20:42:43 pm »
Witajcie!

Nie mogę rozwiązać problemu związanego z prawidłowym odczytem polskich znaków w edytorze tekstu, w plikach utworzonych w notatniku w systemach Windows (Linux Mint 18.1). Poza tym, przy każdym ich otwarciu wywala komunikat "uruchomić plik, wyświetlić jego zawartość?".
W tym temacie jest napisane o co chodzi i jak to rozwązać: http://www.ubuntu-pomoc.org/gedit-brak-polskich-znakow-kodowanie-windows-1250/

Rozwiązanie tam proponowane niestety odpada, ponieważ  w edytorze konfiguracji - editor Minta 18, nie ma w folderze: apps/gedit-2/preferences, opcji encodings.
Jedyne co mogę na razie zrobić, to otwierać te pliki w  notatniku z Wine.
Znacie rozwiązanie tego problemu?
« Ostatnia zmiana: Kwiecień 25, 2017, 22:19:55 pm wysłana przez omkar »

Offline Mintek

  • Dorodna miętowa sadzonka
  • ***
  • Wiadomości: 122
  • Punkty: 6
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Używam Mint 18.1 Cinnamon z kernelem 4.10.5

Offline omkar

  • Miętowy liść
  • *
  • Wiadomości: 29
  • Punkty: 0
  • Płeć: Mężczyzna
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Odp: Brak polskich znaków w edytorze tekstu
« Odpowiedź #2 dnia: Luty 03, 2017, 21:28:54 pm »
Niestety w encodings nie ma opcji auto-detected. Jest  candidate-encodings [''] i na dole, domyślne: [''].
Próbowałem wkleić  UTF-8', 'CURRENT', 'WINDOWS-1250', 'ISO-8859-2, ale to nic nie dało.

Offline ciastek1981

  • Linux User #621498
  • Pole mięty
  • ******
  • Wiadomości: 714
  • Punkty: 102
  • Płeć: Mężczyzna
  • Deepin && Voyager 16.04.X LTS (Xubuntu)
  • Środowisko graficzne: Inne
  • Wersja systemu: Inny
Odp: Brak polskich znaków w edytorze tekstu
« Odpowiedź #3 dnia: Luty 03, 2017, 22:18:48 pm »
http://forum.linuxmint.pl/index.php?topic=9065.msg61865

Chciaż teraz to chyba hunspell-pl za to odpowiada.

Offline omkar

  • Miętowy liść
  • *
  • Wiadomości: 29
  • Punkty: 0
  • Płeć: Mężczyzna
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Odp: Brak polskich znaków w edytorze tekstu
« Odpowiedź #4 dnia: Luty 04, 2017, 08:52:47 am »
Myspell-pl już był zainstalowany i język wybrany prawidłowo.
Instalacja hunspell-pl też nic nie dała.

Offline Dyna

  • Miętowa sadzonka
  • **
  • Wiadomości: 50
  • Punkty: 0
  • Płeć: Mężczyzna
  • Środowisko graficzne: Mate
  • Wersja systemu: 18
Odp: Brak polskich znaków w edytorze tekstu
« Odpowiedź #5 dnia: Luty 04, 2017, 15:49:49 pm »
Używam LM 17.3 Mate, w domyślnym edytorze "PLUMA" miałem ten sam problem.
Zainstalowałem "Gedit", czyta polskie znaki poprawnie, a nadto umożliwia zapis z innym kodowaniem znaków,
co pozwala na późniejszą edycję np. w LibreOffice Writer.

Offline ciastek1981

  • Linux User #621498
  • Pole mięty
  • ******
  • Wiadomości: 714
  • Punkty: 102
  • Płeć: Mężczyzna
  • Deepin && Voyager 16.04.X LTS (Xubuntu)
  • Środowisko graficzne: Inne
  • Wersja systemu: Inny
Odp: Brak polskich znaków w edytorze tekstu
« Odpowiedź #6 dnia: Luty 04, 2017, 17:42:24 pm »
Jest kilka możliwości, przeinstalować xed'a lub np. pakiet językowy

sudo apt-get install language-pack-pl
sudo dpkg-reconfigure locales

albo np. tak

sudo update-locale LC_ALL=pl_PL.UTF-8 LANG=pl_PL.UTF-8
sudo dpkg-reconfigure locales

Pobawić się poleceniami locale, loadkeys czy setxkbmap

Offline omkar

  • Miętowy liść
  • *
  • Wiadomości: 29
  • Punkty: 0
  • Płeć: Mężczyzna
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Odp: Brak polskich znaków w edytorze tekstu
« Odpowiedź #7 dnia: Luty 05, 2017, 10:55:04 am »
Dziękuje za pomoc, ale żadna z w/w wskazówek nie załatwia sprawy.

Chyba się nie rozumiemy. Problem nie dotyczy odczytu polskich znaków w systemie Linux Mint, ponieważ są one prawidłowo wyświetlane. Nie można ich prawidłowo wyświetlić jedynie w przypadku, gdy plik tekstowy został utworzony w notatniku w systemie Windows.
Z tego co zobaczyłem na forach, to w wersji 17 Minta  można było w edytorze konfiguracji ustawić kodowanie na Windows-1250. W osiemnastce nie ma opcji edcodings.
Również w edytorze dconf nie ma opcji auto-detected i nie można zmienić kodowania.
W edytorze tekstu są krzaczki, a w Gedit również pojawiają się błędy. Jedynie notatnik z Wine wszystko odczytuje prawidłowo, ale przy otwarciu plików (podobnie jak w przypadku innych edytorów) pojawia się zawsze komunikat: uruchomić plik, wyświetlić jego zawartość?

Offline magnus

  • Miętowy liść
  • *
  • Wiadomości: 27
  • Punkty: 0
  • Środowisko graficzne: Mate
  • Wersja systemu: 18
Odp: Brak polskich znaków w edytorze tekstu
« Odpowiedź #8 dnia: Luty 05, 2017, 13:21:57 pm »
Ta opcja jest dostępna w xed:
dconf editor > org > x > editor > auto-detected-encodings

Offline omkar

  • Miętowy liść
  • *
  • Wiadomości: 29
  • Punkty: 0
  • Płeć: Mężczyzna
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Odp: Brak polskich znaków w edytorze tekstu
« Odpowiedź #9 dnia: Luty 05, 2017, 20:00:12 pm »
Dziękuję Magnus!
Udało się, choć komunikat nadal się pojawia, ale chyba już tak musi być.

Żeby wkleić nową wartość: 'UTF-8', 'CURRENT', 'WINDOWS-1250', 'ISO-8859-2' zaznaczyłem auto-ident. Uaktywniła się opcja "ustaw na wartość domyślną", którą zatwierdziłem.

Pozdrawiam :)
« Ostatnia zmiana: Luty 05, 2017, 20:38:42 pm wysłana przez omkar »

Offline magnus

  • Miętowy liść
  • *
  • Wiadomości: 27
  • Punkty: 0
  • Środowisko graficzne: Mate
  • Wersja systemu: 18
Odp: Brak polskich znaków w edytorze tekstu
« Odpowiedź #10 dnia: Luty 06, 2017, 11:47:45 am »
Można pozbyć się tego komunikatu:
Menedżer Plików > Edycja > Preferencje > Zachowanie > Wykonywalne pliki tekstowe >  Wyświetlanie plików tekstowych po kliknięciu

Offline omkar

  • Miętowy liść
  • *
  • Wiadomości: 29
  • Punkty: 0
  • Płeć: Mężczyzna
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Odp: Brak polskich znaków w edytorze tekstu
« Odpowiedź #11 dnia: Luty 06, 2017, 14:19:03 pm »
Dzięki!
Szkoda, że to wszystko nie działa domyślnie. Ale przynajmniej możemy się czegoś przy okazji nauczyć :)

Offline ciastek1981

  • Linux User #621498
  • Pole mięty
  • ******
  • Wiadomości: 714
  • Punkty: 102
  • Płeć: Mężczyzna
  • Deepin && Voyager 16.04.X LTS (Xubuntu)
  • Środowisko graficzne: Inne
  • Wersja systemu: Inny
Odp: Brak polskich znaków w edytorze tekstu
« Odpowiedź #12 dnia: Luty 06, 2017, 16:27:35 pm »
Ja z Cinnamon'a nie korzystam więc nie wiem czy to jest wina środowiska, instalacji czy czegoś innego.

W Mate jedynie muszę pamiętać żeby koniec wiersza ustawić na Windows bo inaczej wszystko się zlewa, chociaż jak się puści plik do druku to drukuje tak jak zostało stworzone  8)

Poza tym na swoim sprzęcie zauważyłem taką prawidłowość, że należy instalować system z obsługą sieci kiedy komputer podpięty jest bezpośrednio kablem do routera, a po zainstalowaniu konfigurować wifi.

Offline omkar

  • Miętowy liść
  • *
  • Wiadomości: 29
  • Punkty: 0
  • Płeć: Mężczyzna
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Odp: Brak polskich znaków w edytorze tekstu
« Odpowiedź #13 dnia: Sierpień 21, 2017, 10:12:49 am »
W Mincie 18.2 jest trochę inaczej. Trzeba w edytorze dconf: org > x > editor > preferences > encodings - auto-detected, zamiast 'UTF-8', 'CURRENT', 'ISO-8859-15', 'UTF-16' wkleić: 'UTF-8', 'CURRENT', 'WINDOWS-1250', 'ISO-8859-2'.
Edytor najlepiej zainstalować stąd: ttps://community.linuxmint.com/software/view/dconf-editor
Instalacja z terminala, przynajmniej u mnie nie działa prawidłowo.

Offline christo

  • Dorodny miętowy krzew
  • *****
  • Wiadomości: 596
  • Punkty: 30
  • Płeć: Mężczyzna
  • Środowisko graficzne: KDE
  • Wersja systemu: Linux Mint 17.3
Odp: Brak polskich znaków w edytorze tekstu
« Odpowiedź #14 dnia: Sierpień 21, 2017, 10:58:37 am »
Na zakończenie, bo rozumiem że rozwiązane , ożywam DC zarówno do obsługi plików jak i do edycji plików txt oraz do podgladu i nie miałem żadnych tego typu problemów cóż przyda się na przyszłość.Podziękował.
Only Jesus saves.