Forum Linux Mint Polska

Autor Wątek: Jak zainstalować wtyczkę e-deklaracje na linux mint 17.3  (Przeczytany 1741 razy)

Offline yahoob3

  • Miętowy krzew
  • ****
  • Wiadomości: 319
  • Punkty: 3
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Odp: Jak zainstalować wtyczkę e-deklaracje na linux mint 17.3
« Odpowiedź #15 dnia: Marzec 12, 2017, 18:35:12 pm »
Jeśli na komputerze jest już Adobe Air, to na stronie MF (http://www.finanse.mf.gov.pl/documents/766655/1196444/e-DeklaracjeDesktop.air) jest instalator pod Linuksa. Otwierasz AA i wskazujesz pobrany plik *.air. Może instalowałeś wersję dla Windows, dlatego w Wine?
e-Pity nie wymaga Adobe Readera, działa na systemowej przeglądarce dokumentów (pdf). e-Deklaracje są może o tyle lepsze, że z tego co widzę jest więcej formularzy i "mały LEX podatkowy".
Obydwa programy umożliwiają wysyłkę z e-podpisem, w e-Pitach można wysłać bez e-podpisu (trzeba tylko "zweryfikować się" za pomocą przychodu z roku poprzedniego. Nie wiem czy Deklaracje to umożliwiają. W zeszłym roku, jeśli dobrze pamiętam program sam ciągnął dane do PITu z serwera MF - trzeba było tylko je zweryfikować... i wysłać jeszcze raz. :)

Skrypt, o którym pisałem kilka postów wyżej mocno pomaga załatwić sprawę instalacji e-Pitów. W tutkach (zwłaszcza tym z PDFa) trzeba uważać, bo zwykłe kopiuj/wklej nie zadziała bo wkradają się niepotrzebne "entery".
Każda sroczka swój ogonek chwali, to i ja :) e-Pitów używam od 2013 r. i jest OK... cała rodzina mi d. zawraca :)
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; Intel+GeForce 720M;
Ubuntu 14.04.1 Unity/GnFallb.; kern. 3.19; 32-bit na: GA-VM900M z CPU Pent. 2.66 GHz*2; 2.5 GB RAM; GeForce 7300LE. LU#586742

Offline kris777

  • Dorodna miętowa sadzonka
  • ***
  • Wiadomości: 116
  • Punkty: 10
  • Środowisko graficzne: Mate
  • Wersja systemu: 18
Odp: Jak zainstalować wtyczkę e-deklaracje na linux mint 17.3
« Odpowiedź #16 dnia: Marzec 12, 2017, 20:14:03 pm »
Z tego co zauważylem e-pity to chyba program sponsorowany ? niby darmowy ale ma pewne ograniczenia..... trzeba przy wyborze  1% podatku a cele chrytatywne  zaznaczyć ich wybór / opcję  ! lub nie wybrać nic :-) .... dlatego wolę e-deklarację  chcę mieć swobodę w decydowaniu ..i tyle.

Ps. E-deklaracje również ma w/w opcję wysyłki wypełnionego PIT-a ........." (trzeba tylko "zweryfikować się" za pomocą przychodu z roku poprzedniego".... ale pamiętajmy od przybytku głowa nie boli więc im więcem nożliwości na Linuxa tym lepiej !

Ostatnio tak dla sportu instalowałem e-Deklaracje ... mogę podać co i jak :

Instalacja e-Deklaracje 2017r sprawdzone na Linux Mint Mate / Lubuntu
Uwaga ! tworzenie katalogów i kopiowanie plików dokonujemy jako zwykły użytkownik a nie root bo inaczej
pliki zostaną zapisane w katalogu /root ...a nie w ścieżce /home/nazwa użytkownika/ ...
instalowanie pakietów już jako root ( sudo su / hasło to = ROOT .... exit = powrót do zwykłego użytkownika :-)
Można także w całej konfiguracji zastąpić wpis $HOME na : /home/nazwa użytkownika/

a) instalacja wget’a oraz adobe reader’a która o dziwo sprawiła najwięcej kłopotu jako ROOT :-)
sudo apt-get install wget
wget http://ardownload.adobe.com/pub/adobe/reader/unix/9.x/9.5.1/enu/AdbeRdr9.5.1-1_i486linux_enu.bin
chmod +x ./AdbeRdr9.5.1-1_i486linux_enu.bin
sudo ./AdbeRdr9.5.1-1_i486linux_enu.bin
jeśli się adobe nie uruchomi a raczej tak będzie to musimy zainstalować dodatkowe pakiety z komendą :
apt-get -f install
sudo apt-get install libxml2:i386 libstdc++6:i386
możemy sprawdzić uruchomienie AdobeReader-a w terminalu jako zwykły user komenda : acroread
b) Kolejny krok to instalacja bibliotek oraz utworzenie dwóch linków ( ROOT ):
sudo apt-get install libgtk2.0-0:i386 libstdc++6:i386 libxml2:i386 libxslt1.1:i386 libcanberra-gtk-module:i386 gtk2-engines-murrine:i386 libqt4-qt3support:i386 libgnome-keyring0:i386 libnss-mdns:i386 libnss3:i386

sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0
c) instalujemy i rozpakowujemy adobe-air-sdk , umieszczamy go np. w katalogu : /home/nazwa użytkownika/adobe-air-sdk ( NO ROOT ! )
wget http://airdownload.adobe.com/air/lin/download/2.6/AdobeAIRSDK.tbz2
mkdir $HOME/adobe-air-sdk
tar jxf AdobeAIRSDK.tbz2 -C $HOME/adobe-air-sdk


wget https://aur.archlinux.org/cgit/aur.git/snapshot/adobe-air.tar.gz
tar xvf adobe-air.tar.gz -C $HOME/adobe-air-sdk

sed -i -e 's/\/opt/$HOME/g' $HOME/adobe-air-sdk/adobe-air/adobe-air
chmod +x $HOME/adobe-air-sdk/adobe-air/adobe-air
e) Jeszcze raz pobieramy e-deklaracje, kopiujemy do katalogu w adobe-air-sdk. dla wydobycia ikony ( NO ROOT ! )
mkdir $HOME/adobe-air-sdk/e-deklaracje
wget http://www.finanse.mf.gov.pl/documents/766655/1196444/e-DeklaracjeDesktop.air
cp e-DeklaracjeDesktop.air $HOME/adobe-air-sdk/e-deklaracje/
cp e-DeklaracjeDesktop.air /tmp/

cd /tmp/

unzip /tmp/e-DeklaracjeDesktop.air
cp /tmp/assets/icons/icon128.png  $HOME/adobe-air-sdk/e-deklaracje/e-deklaracje.png
f) Ostatni krok utworzenie launchera ( będzie on w menu : Biuro ) - NO ROOT !
cat <<__CONF__ | tee $HOME/.local/share/applications/e-deklaracje.desktop
[Desktop Entry]
Type=Application
Terminal=false
Categories=Office
Exec=$HOME/adobe-air-sdk/adobe-air/adobe-air $HOME/adobe-air-sdk/e-deklaracje/e-DeklaracjeDesktop.air
Icon=$HOME/adobe-air-sdk/e-deklaracje/e-deklaracje.png
Name=e-Deklaracje
__CONF__

klik enter

Program e-deklaracje będzie w menu : Biuro
Aktualizacja programu niestety ręczna :
wget http://www.finanse.mf.gov.pl/documents/766655/1196444/e-DeklaracjeDesktop.air
sudo cp e-DeklaracjeDesktop.air $HOME/adobe-air-sdk/e-deklaracje/
« Ostatnia zmiana: Styczeń 06, 2018, 12:05:58 pm wysłana przez kris777 »

Offline sewziem

  • Miętowe nasionko
  • *
  • Wiadomości: 6
  • Punkty: 0
  • Środowisko graficzne: Mate
  • Wersja systemu: 18
Odp: Jak zainstalować wtyczkę e-deklaracje na linux mint 17.3
« Odpowiedź #17 dnia: Styczeń 17, 2018, 13:13:08 pm »
Witam,
Dzięki za instrukcję instalacji. Bardzo pomocna.

A może znałby ktoś sposób na zainstalowanie programu JPK_KLIENT_2 ? Bo instrukcja zapodana przez ministerstwo finansów w ogóle nie działa.

Swoją drogą - organizacja i rozwiązania informatyczne proponowane przez MF to w ogóle masakra...