Forum Linux Mint Polska

Autor Wątek: [SOLVED] Stary dziadek & Mint & WIFI ;) nie działa...  (Przeczytany 1572 razy)

Offline Orpheo

  • Miętowe nasionko
  • *
  • Wiadomości: 8
  • Punkty: 0
  • Środowisko graficzne: Xfce
  • Wersja systemu: Linux Mint 17.2
[SOLVED] Stary dziadek & Mint & WIFI ;) nie działa...
« dnia: Marzec 22, 2017, 16:40:18 pm »
Kłaniam się wszystkim !
    Przedwczoraj postawiony system [Mint] na laptopie w towarzystwie Windows 10. Z MBR poradziłem sobie, wszak pamiętam czasy Corel Linuxa ;) [takoż i innych Red Hatów, Mandraków itp.]
    Ale napotkałem problem z połączeniem wifi. Laptop spoczywa w kanciapie, na parterze domu, router piętro wyżej. Jak włączę Windows - dostęp do sieci jest i wszystko działa, jednakowoż jak odpalę Mint - nawet nie wykrywa takiej sieci. Zrobiłem wysoce zaawansowany test [jak na mój wiek] i z telefonu zrobiłem hotspot - z miejsca znalazł, połączył się i śmiga. Polazłem więc z laptopem na klatkę schodową - cisza, poszedłem na górny korytarz - cisza, dopiero około 2-3 metrów od routera znalazł sieć wifi, pięknie się połączył i śmigał.
Zlazłem na dół spowrotem - nie ma szans na połączenie, nie widzi sieci, nie połączy się...
    Smutne to, gdyż wiedzion słabością do linuxa myślałem, że będzie działał bez zarzutu.
    Proszę o jakieś wskazówki, sugestie, pomoc albo chociaż informację, że problem jest nie do zwalczenia. Powtarzam - w tym samym miejscu [na dole domu] na Windows 10 - działa bez zarzutu.
Pozdrawiam
« Ostatnia zmiana: Marzec 25, 2017, 08:44:36 am wysłana przez Orpheo »

Offline viperkris78

  • Miętowe nasionko
  • *
  • Wiadomości: 2
  • Punkty: 0
  • Płeć: Mężczyzna
  • Środowisko graficzne: Xfce
  • Wersja systemu: Linux Mint 17.2
Odp: Stary dziadek & Mint & WIFI ;) nie działa...
« Odpowiedź #1 dnia: Marzec 22, 2017, 19:34:50 pm »
Witam wszystkich.
To mój pierwszy post, więc chciałem się przywitać. Mintka używam od ok roku, na bardzo starym lapku hp omnibook 6100. W związku z tematem, myślę że może Linux włączył kartę wifi w jakimś trybie oszczędzania energii lub po prostu karta ma nie ten sterownik jaki powinna mieć. Próbowałeś po tym jak zadziałał hotspot z telefonu, odsunąć od niego komputer więcej niż 3-4 metry i sprawdzić działanie, może bardziej obeznani w temacie pomogą.

Online yahoob3

  • Miętowy krzew
  • ****
  • Wiadomości: 401
  • Punkty: 25
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Odp: Stary dziadek & Mint & WIFI ;) nie działa...
« Odpowiedź #2 dnia: Marzec 22, 2017, 21:51:58 pm »
A mógłbyś napisać co to za laptop? I ważniejsze: jaka karta sieciowa?
lspciPodobny problem mam na Lenovo B570e z jakimś tanim, "e"konomicznym Atherosem, z jednym gniazdem antenowym. Sprawę rozwiązała karta wifi na USB.
Pod Windows jest OK, bo są spec-sterowniki.
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; Intel+GeForce 720M;
Ubuntu 14.04.1 Unity/GnFallb.; kern. 3.19; 32-bit na: GA-VM900M z CPU Pent. 2.66 GHz*2; 2.5 GB RAM; GeForce 7300LE. LU#586742

Offline Orpheo

  • Miętowe nasionko
  • *
  • Wiadomości: 8
  • Punkty: 0
  • Środowisko graficzne: Xfce
  • Wersja systemu: Linux Mint 17.2
Odp: Stary dziadek & Mint & WIFI ;) nie działa...
« Odpowiedź #3 dnia: Marzec 23, 2017, 14:31:32 pm »
Zamieszczam poniżej zrzut z lspci:

00:00.0 Host bridge: Intel Corporation Broadwell-U Host Bridge -OPI (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)
00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)
00:04.0 Signal processing controller: Intel Corporation Broadwell-U Camarillo Device (rev 09)
00:14.0 USB controller: Intel Corporation Wildcat Point-LP USB xHCI Controller (rev 03)
00:16.0 Communication controller: Intel Corporation Wildcat Point-LP MEI Controller #1 (rev 03)
00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #1 (rev e3)
00:1c.2 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #3 (rev e3)
00:1c.4 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #5 (rev e3)
00:1c.5 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #6 (rev e3)
00:1f.0 ISA bridge: Intel Corporation Wildcat Point-LP LPC Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation Wildcat Point-LP SATA Controller [AHCI Mode] (rev 03)
00:1f.3 SMBus: Intel Corporation Wildcat Point-LP SMBus Controller (rev 03)
00:1f.6 Signal processing controller: Intel Corporation Wildcat Point-LP Thermal Management Controller (rev 03)
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller (rev 07)
0d:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330] (rev ff)
13:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter

Intel(R) Core(TM) i3-5005U CPU @ 2.00GHz
4 GB RAM

Na dzień dzisiejszy bez zmian - pisząc tego posta korzystam z łącza via telefon komórkowy.

« Ostatnia zmiana: Sierpień 10, 2017, 18:01:11 pm wysłana przez szymon1978 »

Online yahoob3

  • Miętowy krzew
  • ****
  • Wiadomości: 401
  • Punkty: 25
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Odp: Stary dziadek & Mint & WIFI ;) nie działa...
« Odpowiedź #4 dnia: Marzec 23, 2017, 15:49:07 pm »
Spróbuj tego rozwiązania:
https://forums.linuxmint.com/viewtopic.php?t=219125

Z tego, co widać w guglu, karta jest "problematyczna"... Realteki tak mają... niektóre ;)
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; Intel+GeForce 720M;
Ubuntu 14.04.1 Unity/GnFallb.; kern. 3.19; 32-bit na: GA-VM900M z CPU Pent. 2.66 GHz*2; 2.5 GB RAM; GeForce 7300LE. LU#586742

Offline Orpheo

  • Miętowe nasionko
  • *
  • Wiadomości: 8
  • Punkty: 0
  • Środowisko graficzne: Xfce
  • Wersja systemu: Linux Mint 17.2
Odp: Stary dziadek & Mint & WIFI ;) nie działa...
« Odpowiedź #5 dnia: Marzec 23, 2017, 17:31:35 pm »
    Dziękuję za poświęcenie czasu tematowi. Zastanawia mnie sam początek wątku wskazanego przez Ciebie:
"....My router is visible but 90 % of the time ..."
    Niestety u mnie, w miejscu [w sensie lokalizacji] na którym najbardziej mi zależy - router jest całkowicie niewidoczny. Sądzisz, że warto spróbować tego rozwiązania ?

    Tak czy owak zastanawiające jest inne stwierdzenie we wspomnianym wątku:
"... worked with the people at realtek to code for the antenna select parameter. ..."
Jeśli podane tam rozwiązanie programowo ma wpływ na jakiekolwiek parametry anteny czy też sterownika i mogłoby pomóc - zdecydowanie spróbuję. Niestety mam zbyt skromną wiedzę co do komend i towarzyszących im argumentów by przeanalizować jakie właściwie zmiany mogą one wprowadzić i czy mogę spróbować pod Mint. Proszę o jakieś podpowiedzi ale i opinie. Kłaniam się.

Offline viperkris78

  • Miętowe nasionko
  • *
  • Wiadomości: 2
  • Punkty: 0
  • Płeć: Mężczyzna
  • Środowisko graficzne: Xfce
  • Wersja systemu: Linux Mint 17.2
Odp: Stary dziadek & Mint & WIFI ;) nie działa...
« Odpowiedź #6 dnia: Marzec 23, 2017, 19:17:02 pm »
Spróbuj może zmienić program do obsługi wifi, u mnie np. standardowo obecny po instalacji manager kiepsko działał, dopiero zmiana na inny (wicd, chyba tak się nazywa bo nie mam przed sobą lapka) pomogło i normalnie się łączy.

Online yahoob3

  • Miętowy krzew
  • ****
  • Wiadomości: 401
  • Punkty: 25
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Odp: Stary dziadek & Mint & WIFI ;) nie działa...
« Odpowiedź #7 dnia: Marzec 23, 2017, 20:15:59 pm »
Hmmm... może spróbuj krok po kroku. Jeśli wicd nie zadziała.
Zacznijmy od aktualizacji:
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
Powinieneś mieć po tym wersję 17.3 (jakiś backup danych tak na wszelki wypadek by się przydał).
Następnie zbliż się do routera, żeby komputer się połączył i klepnij w terminalu:
iwconfigzobaczymy co się pokaże.
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; Intel+GeForce 720M;
Ubuntu 14.04.1 Unity/GnFallb.; kern. 3.19; 32-bit na: GA-VM900M z CPU Pent. 2.66 GHz*2; 2.5 GB RAM; GeForce 7300LE. LU#586742

Offline Orpheo

  • Miętowe nasionko
  • *
  • Wiadomości: 8
  • Punkty: 0
  • Środowisko graficzne: Xfce
  • Wersja systemu: Linux Mint 17.2
Odp: Stary dziadek & Mint & WIFI ;) nie działa...
« Odpowiedź #8 dnia: Marzec 24, 2017, 15:20:22 pm »
Dzień Dobry,

Zrobiłem aktualizację wg Twoich wskazówek. Polazłem z laptopem do routera, połączył się i działał.
Zrzut z wyniku "iwconfig" - poniżej:
orpheo@Orpheo ~ $ sudo apt-get dist-upgrade
sudo: unable to resolve host Orpheo
[sudo] password for orpheo:
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Obliczanie aktualizacji... Gotowe
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.
orpheo@Orpheo ~ $ iwconfig
enp7s0    no wireless extensions.

lo        no wireless extensions.

wlp19s0   IEEE 802.11bgn  ESSID:"HyperNet_Dom_477" 
          Mode:Managed  Frequency:2.427 GHz  Access Point: F4:F2:6D:A4:25:C4   
          Bit Rate=150 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=42/70  Signal level=-68 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:1   Missed beacon:0

orpheo@Orpheo ~ $
Dziękuję za te wstępne wskazówki. Zaraz restartuję komputer i zobaczę czy i co ewentualnie się zmieniło. Przepraszam, że dopiero teraz to robiłem, ale niedawno wróciłem z pracy. Pozdrawiam i dzięki raz jeszcze.

« Ostatnia zmiana: Sierpień 10, 2017, 18:01:57 pm wysłana przez szymon1978 »

Offline Orpheo

  • Miętowe nasionko
  • *
  • Wiadomości: 8
  • Punkty: 0
  • Środowisko graficzne: Xfce
  • Wersja systemu: Linux Mint 17.2
Odp: Stary dziadek & Mint & WIFI ;) nie działa...
« Odpowiedź #9 dnia: Marzec 24, 2017, 17:24:24 pm »
    Wracam po restarcie i aktualizacjach - niestety bez zmian.
    Postawiłem Fedorę z racji sentymentu - również brak sieci. Problem pewnie jest stricte w oprogramowaniu, ponieważ na W10 zasuwa jak wściekłe. Te pierony od hardware'u pewnie nigdy nie zdradzą w czym rzecz. Ale to nie mój problem - szkoda, bo kiedyś linuxa uważało się za system przede wszystkim sieciowy. Pozostanę na windzie, przy czym proszę o zostawienie tego wątku otwartym - może znajdzie się jakieś rozwiązanie.

Online yahoob3

  • Miętowy krzew
  • ****
  • Wiadomości: 401
  • Punkty: 25
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Odp: Stary dziadek & Mint & WIFI ;) nie działa...
« Odpowiedź #10 dnia: Marzec 24, 2017, 17:57:32 pm »
To był dopiero pierwszy krok :)
Wykonaj teraz:
sudo apt-get install git dkms build-essential linux-headers-generic
git clone https://github.com/lwfinger/rtlwifi_new.git
tu terminal może krzyknąć, że nie ma "git', więc:
sudo apt-get install git
i jeszcze raz komendę git...., potem:
sudo dkms add ./rtlwifi_new
sudo dkms build rtlwifi-new/0.6
sudo dkms install rtlwifi-new/0.6
zrestartuj komputer,  i podaj wynik:
iwlist scan | egrep -i 'ssid|quality'
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; Intel+GeForce 720M;
Ubuntu 14.04.1 Unity/GnFallb.; kern. 3.19; 32-bit na: GA-VM900M z CPU Pent. 2.66 GHz*2; 2.5 GB RAM; GeForce 7300LE. LU#586742

Offline Orpheo

  • Miętowe nasionko
  • *
  • Wiadomości: 8
  • Punkty: 0
  • Środowisko graficzne: Xfce
  • Wersja systemu: Linux Mint 17.2
Odp: Stary dziadek & Mint & WIFI ;) nie działa...
« Odpowiedź #11 dnia: Marzec 24, 2017, 18:39:49 pm »
Służę uprzejmie - taki mam komunikat:

orpheo@Orpheo ~ $ iwlist scan | egrep -i 'ssid|quality'
enp7s0    Interface doesn't support scanning.

lo        Interface doesn't support scanning.

                    Quality=52/70  Signal level=-58 dBm 
                    ESSID:"iPhone"
orpheo@Orpheo ~ $
« Ostatnia zmiana: Sierpień 10, 2017, 18:03:23 pm wysłana przez szymon1978 »

Online yahoob3

  • Miętowy krzew
  • ****
  • Wiadomości: 401
  • Punkty: 25
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Odp: Stary dziadek & Mint & WIFI ;) nie działa...
« Odpowiedź #12 dnia: Marzec 24, 2017, 20:16:42 pm »
No to teraz wykonaj:
sudo modprobe -r rtl8723be
sudo modprobe rtl8723be ant_sel=1
i pokaż jeszcze raz:
iwlist scan | egrep -i 'ssid|quality'jeśli sygnał nadal odbierany z iPhona będzie taki sam jak tu:
Cytuj
Quality=52/70  Signal level=-58 dBm

spróbuj takiej sekwencji:
sudo modprobe -r rtl8723be
sudo modprobe rtl8723be ant_sel=2

i zobacz czy będzie lepiej:
iwlist scan | egrep -i 'ssid|quality'
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; Intel+GeForce 720M;
Ubuntu 14.04.1 Unity/GnFallb.; kern. 3.19; 32-bit na: GA-VM900M z CPU Pent. 2.66 GHz*2; 2.5 GB RAM; GeForce 7300LE. LU#586742

Online yahoob3

  • Miętowy krzew
  • ****
  • Wiadomości: 401
  • Punkty: 25
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Odp: Stary dziadek & Mint & WIFI ;) nie działa...
« Odpowiedź #13 dnia: Marzec 24, 2017, 20:27:20 pm »
Jak to wyżej nie pomoże to polecam:
[reklama]TP-LINK TL-WN722N z "Atheros Communications, Inc. AR9271 802.11n"[/reklama]
Hula jak złoto.
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; Intel+GeForce 720M;
Ubuntu 14.04.1 Unity/GnFallb.; kern. 3.19; 32-bit na: GA-VM900M z CPU Pent. 2.66 GHz*2; 2.5 GB RAM; GeForce 7300LE. LU#586742

Offline Orpheo

  • Miętowe nasionko
  • *
  • Wiadomości: 8
  • Punkty: 0
  • Środowisko graficzne: Xfce
  • Wersja systemu: Linux Mint 17.2
Odp: Stary dziadek & Mint & WIFI ;) nie działa...
« Odpowiedź #14 dnia: Marzec 25, 2017, 06:43:43 am »
Witajcie z rana !

      Wykonałem komendy od Ciebie i w pewnym momencie pojawiła się na liście widoczna sieć domowa [!] z siłą 3 kresek w skali do 4-ech.
Przełączyłem się na nią, jednak po połączeniu nie mam internetu. Zrestartowałem system i piszę teraz w oparciu o hotspot z telefonu. Skoro sieć była widoczna [po restarcie jej nie ma] to być może została jakaś kosmetyka do zrobienia, ale to zbyt zaawansowane dla mnie. Czy mogę prosić o dalszą pomoc ?
[i tak jestem w szoku, że nagle zobaczył tę sieć]

EDIT:
Po ustawieniu "ant-sel=1" miałem najlepszy zasięg sieci. Podpatrzyłem więc komendę:

echo "options rtl8723be ant_sel=1" | sudo tee -a /etc/modprobe.d/rtl8723be.conf
która wg mojej interpretacji zapisuje to ustawienie w plikach konfiguracyjnych. Mimo, że nie miałem internetu to po restarcie komputera działa wyśmienicie !

Serdecznie dziękuję za pomoc - może to rozwiązanie przyda się komuś jeszcze, kłaniam się i pozdrawiam !!!
« Ostatnia zmiana: Sierpień 10, 2017, 18:05:01 pm wysłana przez szymon1978 »