Forum Linux Mint Polska

Autor Wątek: Automatyczne montowanie dysków - fstab  (Przeczytany 443 razy)

Offline majkel1989

  • Miętowe nasionko
  • *
  • Wiadomości: 3
  • Punkty: 0
  • Środowisko graficzne: KDE
  • Wersja systemu: 18
Automatyczne montowanie dysków - fstab
« dnia: Maj 03, 2017, 21:10:36 pm »
Mam na komputerze 2 systemy: windows 10 i linux mint. chcę by dyski ntfs były automatycznie montowane w linux.
mój plik fstab wygląda aktualnie tak:
# / was on /dev/sda6 during installation
UUID=5184ee86-ce5d-483a-8c3f-e9295f9aefb7 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=a074d76b-bb9c-4a07-8c49-08a0c600f2b7 none            swap    sw              0       0

okno zarządzania partycjami:



Do pliku próbowałem dopisywać kod:

/dev/sda2    /mnt/windows10    ntfs    defaults    0 0
lub

UUID=E8B45D3BB45D0E06    /mnt/windows10    ntfs    defaults    0 0
Gdy uruchamiałem ponownie komputer to system nie chciał wystartować. Musiałem wrócić do poprzedniej wersji pliku fstab. Jaki robię błąd w kodzie?

Błąd podczas uruchamiania:


Offline christo

  • Dorodny miętowy krzew
  • *****
  • Wiadomości: 571
  • Punkty: 30
  • Płeć: Mężczyzna
  • Środowisko graficzne: KDE
  • Wersja systemu: Linux Mint 17.3
Odp: Automatyczne montowanie dysków - fstab
« Odpowiedź #1 dnia: Maj 05, 2017, 23:02:08 pm »
Dodajesz we fstab coś takiego UUID=1234567890     /media/user/DYSK_C  ntfs-3g     defaults   0    0na przykład , wstawiasz swój UUID i swoja nazwę DYSK_C , oczywiście folder  /media/user/DYSK_C musi istnieć.
Sprawdzasz montowanie poprzez sudo mount -a , nie musisz się po edycji fstab przebootowywac.
Acha i chyba w windzie trzeba wyłączyć fastboota.
« Ostatnia zmiana: Maj 05, 2017, 23:03:54 pm wysłana przez christo »
Only Jesus saves.

Offline majkel1989

  • Miętowe nasionko
  • *
  • Wiadomości: 3
  • Punkty: 0
  • Środowisko graficzne: KDE
  • Wersja systemu: 18
Odp: Automatyczne montowanie dysków - fstab
« Odpowiedź #2 dnia: Maj 10, 2017, 00:41:16 am »
Dziękuję, wszystko działa jako powinno:)
Moim błędem była ścieżka montowania i format plików.
Dziękuję.
Temat zamknięty

Offline majkel1989

  • Miętowe nasionko
  • *
  • Wiadomości: 3
  • Punkty: 0
  • Środowisko graficzne: KDE
  • Wersja systemu: 18
Odp: Automatyczne montowanie dysków - fstab
« Odpowiedź #3 dnia: Maj 14, 2017, 11:24:04 am »
PS. Jeśli ktoś ma analogiczną sytuację i wyskakuje błąd montowania dysków, tzn. że Windows korzysta z partycji (nie wyłączył się w pełni). Aby rozwiązać problem należy odznaczyć w Windows>Opcje zasilania funkcję FAST STARTUP (źródło:
http://windowsable.com/how-to-enable-or-disable-fast-startup-in-windows-10/
Temat zamknięty