Forum Linux Mint Polska

Autor Wątek: Drganie ekranu na monitorze UHD (Radeon R9)  (Przeczytany 882 razy)

Offline TeK

  • Miętowe nasionko
  • *
  • Wiadomości: 10
  • Punkty: 0
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Drganie ekranu na monitorze UHD (Radeon R9)
« dnia: Lipiec 08, 2017, 19:04:44 pm »
Cześć,

Pisałem już w tej sprawie na oficjalnym forum Minta ale chyba mnie zlali albo nie rozszyfrowali mojego "angielskiego"

Postanowiłem definitywnie porzucić Windowsa na rzecz Linux'a i mimo usilnych prób i uporu problemy które mnie spotykają uniemożliwiają mi nawet rozpoczęcie przygody z tym systemem.
Po kilku próbnych intalacjach różnych dytrybucji na maszynie wirtualnej zdecydowałem że Linux Mint to jest to i nic innego mnie nie intresuje.

Problemy zaczęły się kiedy zainstalowałem Mina na mojej maszynie fizycznej.
Pierwszy dotyczył mojej nietypowej karty dzwiękowej (Auzentech x-fi forte), już wiem że nic z tym nie zrobie ale z tym da się życ (od biedy jest jeszcze wbudowana w płytę).

Gorsza sprawa dotyczy monitora (albo karty graficznej), w takich warunkach nie da sie korzystać z komputera, prędzej czy później grozi to chorobą morska i bólem głowy.
Sprawdzałem też czy takie zjawisko występuje na ubuntu i tam też coś podobnego się dzieje, tyle że tylko w wersji 16.04, na 17.04 wszystko jest ok, więc jest nadzieja że można to jakoś ustawić także na Mint'cie.

Jako że cięzko opisać słowami o co chodzi wrzuciłem na youtuba filmik nagrany telefonem co się dzieje:

https://youtu.be/9mYcIiLrNtg
https://youtu.be/S7kJy_hd4nY

Mój sprzęt to stary Radeon R9 290 + monitor LG 27 UHD (podłaczony przez DisplayPort) + stary monitor BenQ FHD (DVI).
Z tego drugiego jestem nawet gotów zrezygnować byle by ten główny też tak nie falował.

Bardzo proszę o pomoc, jestem kompletnie zielony w linuxie (jedyne co do tej pory zrobiłem to zainstalowałem nową MESA 17), jak trzeba wkleić wynik jakiejś komendy to zaraz to uczynię.

Z góry dziękuję.


Offline ciastek1981

  • Linux User #621498
  • Pole mięty
  • ******
  • Wiadomości: 719
  • Punkty: 102
  • Płeć: Mężczyzna
  • Deepin && Voyager 16.04.X LTS (Xubuntu)
  • Środowisko graficzne: Inne
  • Wersja systemu: Inny

Offline TeK

  • Miętowe nasionko
  • *
  • Wiadomości: 10
  • Punkty: 0
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Odp: Drganie ekranu na monitorze UHD (Radeon R9)
« Odpowiedź #2 dnia: Lipiec 09, 2017, 23:07:53 pm »
Monitor obsługuje freesync,sterownik AMD nie wiem (nie widze tu żadnego panelu kontrolnego  tym wbudowanym), jak zainstalowałem tego ze strony AMDGPU-PRO to Cinnamon zaczął się wysypywać.
Zresztą freesync dotyczy raczej tylko gier i to pełnoekranowych a nie pulpitu.

Za to w drugiej możliwośi jest kilka linijek do wpisania w plikach konfiguracyjnych których jeszcze nie stosowałem.
Przetestuję i dam znać czy coś pomogło.

W każdym razie dzięki za pomoc.

pozdrawiam
TeK

Offline ciastek1981

  • Linux User #621498
  • Pole mięty
  • ******
  • Wiadomości: 719
  • Punkty: 102
  • Płeć: Mężczyzna
  • Deepin && Voyager 16.04.X LTS (Xubuntu)
  • Środowisko graficzne: Inne
  • Wersja systemu: Inny
Odp: Drganie ekranu na monitorze UHD (Radeon R9)
« Odpowiedź #3 dnia: Lipiec 10, 2017, 00:02:18 am »
Ja ci za wiele nie pomogę jeżeli chodzi o AMD (jestem do tej firmy definitywnie uprzedzony)

Warto jeszcze poszperać tutaj - jak tu nie znają odpowiedzi to będzie problem

https://www.phoronix.com/forums/forum/linux-graphics-x-org-drivers

Ubuntu 17.04 ZZ ma kernel 4.10, a Mint 18.2 4.8.0-53. Poza tym sterownik od AMD nie będzie wspierał jądra nowszego niż 4.8.xx.

Offline TeK

  • Miętowe nasionko
  • *
  • Wiadomości: 10
  • Punkty: 0
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Odp: Drganie ekranu na monitorze UHD (Radeon R9)
« Odpowiedź #4 dnia: Lipiec 11, 2017, 20:32:20 pm »
Wgrałem kernela i 4.8 i 4.12 a później sterowniki ze strony AMD, z kernelem 4.12 w ogóle sie system nie włączał a z 4.8 wysypywał się cinnamon.
Dobrze że łatwo to można było odinstalować.
Już powoli wymiękam :( Chyba nie pozostaje nic jak ten Ubuntu 17.04 z tym fatalnym dla mnie UI:(.

Offline ciastek1981

  • Linux User #621498
  • Pole mięty
  • ******
  • Wiadomości: 719
  • Punkty: 102
  • Płeć: Mężczyzna
  • Deepin && Voyager 16.04.X LTS (Xubuntu)
  • Środowisko graficzne: Inne
  • Wersja systemu: Inny
Odp: Drganie ekranu na monitorze UHD (Radeon R9)
« Odpowiedź #5 dnia: Lipiec 11, 2017, 21:51:09 pm »
Przecież napisałem

Cytuj
Poza tym sterownik od AMD nie będzie wspierał jądra nowszego niż 4.8.xx.

Chociaż gdzieś widziałem, że ktoś się chwalił, że ruszył na kernelu 4.9

Zamiast Cinnamona masz jeszcze Mate i Xfce. Zamknięty sterownik pozwoli na generowanie większej ilości klatek.

---

Czy ta metoda nie zadziałała?

https://cubethethird.wordpress.com/2016/06/14/eliminate-screen-tearing-with-amd-gpu-on-ubuntu/

Zobacz sobie folder co po ścieżce

nazwa_menadżera_plików /usr/share/X11/xorg.conf.d/
Sprawdź czy masz pliki 10-amdgpu.conf, 20-amdgpu.conf lub 10-amdgpu-pro.conf  (dla zamkniętego)

lub bezpośrednio

sudo xed /usr/share/X11/xorg.conf.d/10-amdgpu.conf
lub

sudo xed /usr/share/X11/xorg.conf.d/20-amdgpu.conf
lub

sudo xed /usr/share/X11/xorg.conf.d/10-amdgpu-pro.conf
i dopisanie

Cytuj
Option "DRI" "3"
Option "AccelMethod" "glamor"

Nie wiem jak wygląda u ciebie ten plik w środku.

Ostatecznie powinno wyglądać to mniej więcej tak

Section "Device"
    Identifier "Hawaii" lub "AMDgpu"
    Driver "amdgpu"
    Option "TearFree" "on" lub "true"
    Option "DRI" "3"
    Option "AccelMethod" "glamor"
EndSection

---

Jeżeli jesteś nastawiony na Zesty Zapus to obok Unity masz przecież Mate i Xfce jak chcesz pasek na dole to możesz przełączyć na pasek Redmond w Mate Tweak czy Xfce Tweak (takich bajerów w Mincie nie ma)

https://ubuntu-mate.org/blog/ubuntu-mate-zesty-final-release/

https://xubuntu.org/news/xubuntu-17-04-release/

Sam kernel 4.10 wniósł jakieś poprawki do architektury Fiji, a 290 to poprzednia generacja. Chociaż kto ich tam wie.

---

Edyta Generalnie w zeszłym roku był problem z kartami z rodzin "Southern islands" i "Sea Islands" i otwartym sterownikiem amdgpu. Wyjaśnia to dlaczego amdgpu u ciebie działa na Ubuntu 17.04.

Offline TeK

  • Miętowe nasionko
  • *
  • Wiadomości: 10
  • Punkty: 0
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Odp: Drganie ekranu na monitorze UHD (Radeon R9)
« Odpowiedź #6 dnia: Lipiec 13, 2017, 20:27:23 pm »
U mnie plik 10-amdgpuconf wygląda tak:

Section "OutputClass"
Identifier "AMDgpu"
MatchDriver "amdgpu"
Driver "amdgpu"
EndSection

Stworzyłem plik 20-radeon.conf z takimi wpisami:

Section "Device"
    Identifier "Radeon"
    Driver "radeon"
    Option "TearFree" "on"
    Option "DRI" "3"
    Option "AccelMethod" "glamor"
EndSection

Ale to nic nie zmieniło, tyle że pewnie źle nazwałem ten plik :(
« Ostatnia zmiana: Lipiec 14, 2017, 22:37:35 pm wysłana przez szymon1978 »

Offline ciastek1981

  • Linux User #621498
  • Pole mięty
  • ******
  • Wiadomości: 719
  • Punkty: 102
  • Płeć: Mężczyzna
  • Deepin && Voyager 16.04.X LTS (Xubuntu)
  • Środowisko graficzne: Inne
  • Wersja systemu: Inny
Odp: Drganie ekranu na monitorze UHD (Radeon R9)
« Odpowiedź #7 dnia: Lipiec 13, 2017, 21:13:45 pm »
Za bardzo kombinujesz  ??? Chociaż z tymi kartami Sea Island (HAWAII) to dziwna sprawa powinien je obsługiwać amdgpu, a tu piszą o Radeonie

Trzeba było w tym co masz spróbować dopisać (zrób najpierw amdgpu)

/usr/share/X11/xorg.conf.d/10-amdgpu.conf
Powinno to wyglądać tak

Section "Device"
    Identifier "AMDgpu"
    Driver "amdgpu"
    Option "TearFree" "on"
    Option "DRI" "3"
    Option "AccelMethod" "glamor"
EndSection

Jeżeli będzie problem to wróć wtedy do starego ustawienia w 10-amdgpu.conf
i wpisz to co powyżej do nowo utworzonego 20-amdgpu.conf

Dla amdgpu koniecznie w

/etc/modprobe.d/blacklist.conf
musisz dopisać

blacklist radeon potem restart

Jak nie zadziała to w10-amdgpu.conf wpisz to swoje

Section "Device"
    Identifier "Radeon"
    Driver "radeon"
    Option "TearFree" "on"
    Option "DRI" "3"
    Option "AccelMethod" "glamor"
EndSection

I usuń wpis w blacklist.conf o blacklist radeon.

Przy Option - opcje włączasz  "on", "true", "yes" i "1", a wyłączasz "off", "false", "no" i "0".

Poza tym w poprzednim poście pisałem o co biega z amdgpu. Ja nie sprawdzałem skąd się to bierze, wiem tylko, że np. w Debianie w backportach dla kernela 4.8 był ten sterownik od listopada zeszłego roku. Dlaczego nie ma tego w Mincie nie wiem.

Jak jest jakiś posiadacz karty z rodziny "Southern islands" lub "Sea Islands" to niech pochwali się co mu zrobiło dobrze na otwartych sterownikach.
Na sucho (bez karty AMD) ciężko mi pomóc, bo nie mam jak sprawdzić.


Edyta Jakby był problem ze sterownikiem Radeon to sprawdź czy oprócz w blacklist.conf nie masz w

xed /etc/default/grub
takiego wpisu

Cytuj
GRUB_CMDLINE_LINUX="radeon.blacklist=yes"

W teorii twoja karta powinna śmigać i na nowszym amdgpu (warunek w kernelu dla Sea Island musi być CONFIG_DRM_AMDGPU_CIK=Y) i starszym radeon. Kwestia po prostu działania samego sterownika.

Offline TeK

  • Miętowe nasionko
  • *
  • Wiadomości: 10
  • Punkty: 0
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Odp: Drganie ekranu na monitorze UHD (Radeon R9)
« Odpowiedź #8 dnia: Lipiec 17, 2017, 23:53:27 pm »
Doszedłem do punktu:

blacklist radeon

potem restart

no i juz mnie tylko twardy reset ratował, wcześniej zrobiłem kopię pliku 10-amggpu.conf_ORG ale nie wiem dlaczego nie mogłem tego oryginalnego ani usunąc ani zmienić (plik readonly i nic nie pomaga, a już go kiedys popsułem i udało mi się za pomocą nano go poprawić), wieć jutro chyba czeka mnie reinstalka systmu na nowo.

W międzyczasie dostałem info od MInta że zgłosili mok problem jako BUGxxx (https://bugs.kde.org/show_bug.cgi?id=382025) tylko że proszą o sprawdzenie czegoś a nie bardzo wiem o co chodzi i jak im odpowiedzieć:

"Could you check if this behavior also occurs if you use the xrandr tool to set
up your screens?"

Offline ciastek1981

  • Linux User #621498
  • Pole mięty
  • ******
  • Wiadomości: 719
  • Punkty: 102
  • Płeć: Mężczyzna
  • Deepin && Voyager 16.04.X LTS (Xubuntu)
  • Środowisko graficzne: Inne
  • Wersja systemu: Inny
Odp: Drganie ekranu na monitorze UHD (Radeon R9)
« Odpowiedź #9 dnia: Lipiec 18, 2017, 00:59:06 am »
Tam ci nikt nie pomógł?

https://forums.linuxmint.com/viewtopic.php?f=59&t=249127

To teraz KDE zamiast Cinnamona używasz -> Bug?

Cytuj
... jak zainstalowałem tego ze strony AMDGPU-PRO to Cinnamon zaczął się wysypywać.

Co do xrandr

https://wiki.archlinux.org/index.php/xrandr

https://dug.net.pl/tekst/210/ustawienia_parametrow_pracy_monitorow_za_pomoca_xrandr/

PS Zamiast nano używaj xed ułatw sobie życie, pamiętaj że pliki w systemie plików może zmieniać i przenosić tylko użytkownik z odpowiednimi uprawnieniami - pamiętaj o sudo

Do przenoszenia plików możesz użyć cp lub mv - przeniesie plik do miejsca docelowego i nadpisze istniejący.

Ja jak coś popsuje w configu i nie mogę odpalić, a chcę wrócić do poprzedniej konfiguracji to do pomocy przy naprawie używam Knoppix'a.

Offline TeK

  • Miętowe nasionko
  • *
  • Wiadomości: 10
  • Punkty: 0
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Odp: Drganie ekranu na monitorze UHD (Radeon R9)
« Odpowiedź #10 dnia: Lipiec 18, 2017, 17:48:04 pm »
Niestety nikt mi tam nie pomógł.
Dzieki za pomysł z Knopixx'em, udało sie odratować system (w konsoli używałem sudo ale też nie chciał tych plików podmienic/skasowac)

wywłałem xandra -q

Screen 0: minimum 320 x 200, current 3840 x 2160, maximum 16384 x 16384
DisplayPort-0 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 600mm x 340mm
   3840x2160     60.00*+  30.00 
   1920x1080     60.00    59.94 
   1600x900      60.00 
   1280x1024     60.02 
   1152x864      59.96 
   1280x720      60.00    59.94 
   1024x768      60.00 
   800x600       60.32 
   720x480       60.00    59.94 
   640x480       60.00    59.94 
HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-0 connected (normal left inverted right x axis y axis)
   1920x1080     60.00 +
   1680x1050     59.88 
   1600x900      60.00 
   1280x1024     75.02    60.02 
   1280x960      60.00 
   1152x864      75.00 
   1280x720      60.00 
   1152x720      59.97 
   1024x768      75.03    60.00 
   832x624       74.55 
   800x600       75.00    60.32 
   640x480       75.00    59.94 
   720x400       70.08 


jak zmieniam rozdzielczość za jego pomocą to wszystko zachowuje się identycznie. Faktycznie wygląda to troche jakby był problem z synchronizacją ale boje się tu czegokolwiek (oprócz odświeżania) zmieniać bo tak chyba można popsuć monitor.

pozdr
tk

Offline TeK

  • Miętowe nasionko
  • *
  • Wiadomości: 10
  • Punkty: 0
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Odp: Drganie ekranu na monitorze UHD (Radeon R9)
« Odpowiedź #11 dnia: Lipiec 18, 2017, 17:49:20 pm »
A i KDE zaistalowałem tylko raz żeby sprawdzić czy coś bedzie lepeiej, ale nie było i wróciłem do Cinamonna, nie wiem dlaczego podpieli to pod KDO.

Offline ciastek1981

  • Linux User #621498
  • Pole mięty
  • ******
  • Wiadomości: 719
  • Punkty: 102
  • Płeć: Mężczyzna
  • Deepin && Voyager 16.04.X LTS (Xubuntu)
  • Środowisko graficzne: Inne
  • Wersja systemu: Inny
Odp: Drganie ekranu na monitorze UHD (Radeon R9)
« Odpowiedź #12 dnia: Lipiec 18, 2017, 19:23:47 pm »
Napisz jaki dokładnie masz ten monitor. Coś mi się kojarzy, że niektóre monitory miały natywnie 4096x2160.

Możesz pokombinować z gtf i cvt Z taką uwagą, że te polecenia mogą pokazywać inne niż są rzeczywiste parametry przy modeline (Jest opisany taki przypadek dla monitora 31mu97) Wtedy warto poszukać w necie po modelu i porównać.

Zobacz co ci zwróci w terminalu

gtf 3840 2160 60
oraz

gtf 3840 2160 30
Wtedy można próbować ustawić na nowo dla 60 i 30 Hz.

xrandr --newmode to_co_się_wyświetliło_po_modeline
np.

xrandr --newmode "3840x2160_60" 556.730  4096 4104 4136 4176  2160 2208 2216 2222 +hsync +vsync
Potem tak samo dla obu częstotliwości

xrandr --addmode DisplayPort-0 rozdz_poziom(x)rozdz_pion_częstotliwość
np.

xrandr --addmode DisplayPort-0 3840x2160_60
Jak w sznurkach powyżej.

Poza tym kombinuj z tymi opcjami dla sterownika Radeon - "TearFree" "on", Option "DRI" "3" i Option "AccelMethod" "glamor" w pliku 10-amdgpu.conf.

Offline TeK

  • Miętowe nasionko
  • *
  • Wiadomości: 10
  • Punkty: 0
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Odp: Drganie ekranu na monitorze UHD (Radeon R9)
« Odpowiedź #13 dnia: Lipiec 18, 2017, 23:15:57 pm »
To jest juz troche wiekowa, dawno nie produkowana, konstrukcja LG 27MU67.
http://www.lg.com/us/monitors/lg-27MU67-B-4k-uhd-led-monitor

Gtf zwraca:

gtf 3840 2160 60

  # 3840x2160 @ 60.00 Hz (GTF) hsync: 134.10 kHz; pclk: 712.34 MHz
  Modeline "3840x2160_60.00"  712.34  3840 4152 4576 5312  2160 2161 2164 2235  -HSync +Vsync


gtf 3840 2160 30

  # 3840x2160 @ 30.00 Hz (GTF) hsync: 65.91 kHz; pclk: 339.57 MHz
  Modeline "3840x2160_30.00"  339.57  3840 4080 4496 5152  2160 2161 2164 2197  -HSync +Vsync


Bedę kombinował dalej, dzięki

pozdr
tk

Offline TeK

  • Miętowe nasionko
  • *
  • Wiadomości: 10
  • Punkty: 0
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: 18
Odp: Drganie ekranu na monitorze UHD (Radeon R9)
« Odpowiedź #14 dnia: Lipiec 18, 2017, 23:37:09 pm »
A ten xrandr to trzeba jakoś przeładować, bo nie widze żeby się coś zmieniło po dodaniu "newmode", nawet ekranem nie mignie.

A co do tych "TearFree" "on", Option "DRI" "3" i Option "AccelMethod" "glamor" to je mam wpisane ale w pliku 20-radeon.conf,
bo jak wpisze cokolwiek z tych opcji do pliku 10-amdgpu.conf to się tryb graficzny w ogole nie uruchamia i musze w konsoli kasować te wpisy (xed nie chce mi sie w konsoli tekstowej odpalac tylko nano działa).

pozdr
tk