Forum Linux Mint Polska

Autor Wątek: Screen tearing na Gigabyte Brix :(  (Przeczytany 186 razy)

Offline shin

  • Miętowe nasionko
  • *
  • Wiadomości: 2
  • Punkty: 0
  • Środowisko graficzne: Xfce
  • Wersja systemu: 18
Screen tearing na Gigabyte Brix :(
« dnia: Lipiec 24, 2017, 10:06:08 am »
Witam serdecznie.
Ostatnio stałem sie szczęśliwym (no prawie) posiadaczem mini pc Gigabyte Brix z Celkiem n3150 i grafiką Intela.  Sprzęcik podpięty do TV i używany do oglądanie filmów, YouTube i Netflx. Niestety mam problem z rozjeżdzaniem się obrazu, czyli tzw. screen tearing.  Używam także Minta 18.2 na moim leciwym T400 i ten problem jest marginalny. Znalazłem jakieś sposoby na zagranicznych stronach ale albo coś robie nie tak, albo źle soś zrozumialem. Może ktoś zna ten problem i móglby mi łopatologicznie wytlumaczyć jak go rozwiązać.
Z gory dziękuję !

Online ciastek1981

  • Linux User #621498
  • Dorodny miętowy krzew
  • *****
  • Wiadomości: 625
  • Punkty: 102
  • Płeć: Mężczyzna
  • Voyager (Xubuntu) & Arch
  • Środowisko graficzne: Xfce
  • Wersja systemu: Inny
Odp: Screen tearing na Gigabyte Brix :(
« Odpowiedź #1 dnia: Lipiec 24, 2017, 13:26:56 pm »
Podaj wyniki poleceń opatrzone znacznikiem # - [c o d e][/c o d e]
 
echo $XDG_CURRENT_DESKTOP
inxi -CGM
oraz

grep EE /var/log/Xorg.0.log

Offline shin

  • Miętowe nasionko
  • *
  • Wiadomości: 2
  • Punkty: 0
  • Środowisko graficzne: Xfce
  • Wersja systemu: 18
Odp: Screen tearing na Gigabyte Brix :(
« Odpowiedź #2 dnia: Lipiec 25, 2017, 07:33:00 am »
shin@shin-GB-BACE-3150 ~ $ echo $XDG_CURRENT_DESKTOP
XFCE
shin@shin-GB-BACE-3150 ~ $ inxi -CGM
Machine:   Mobo: GIGABYTE model: MZBSWBP-00 v: 1.x
           Bios: American Megatrends v: F4 date: 12/23/2016
CPU:       Quad core Intel Celeron N3150 (-MCP-) cache: 1024 KB
           clock speeds: max: 2080 MHz 1: 740 MHz 2: 868 MHz 3: 2053 MHz
           4: 1668 MHz
Graphics:  Card: Intel Device 22b1
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1360x768@60.02hz
           GLX Renderer: Mesa DRI Intel HD Graphics 400 (Braswell)
           GLX Version: 3.0 Mesa 12.0.6
shin@shin-GB-BACE-3150 ~ $ grep EE /var/log/Xorg.0.log
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.



Offline euklides

  • Siewca Mięty
  • Miętowy krzew
  • *****
  • Wiadomości: 337
  • Punkty: 70
  • Płeć: Mężczyzna
  • Środowisko graficzne: Mate
  • Wersja systemu: Inny
Chromium OS  54.0.2840.92 (Build) (64-bitowa) https://www.neverware.com/#introtext-3

Linux MInt 17.3 Cinnamon Edition Rose  3.19.0-32-generic

Point Linux http://pointlinux.org/ Debian 3.16.43-2+deb8u2 i686 GNU/Linux

Online ciastek1981

  • Linux User #621498
  • Dorodny miętowy krzew
  • *****
  • Wiadomości: 625
  • Punkty: 102
  • Płeć: Mężczyzna
  • Voyager (Xubuntu) & Arch
  • Środowisko graficzne: Xfce
  • Wersja systemu: Inny
Odp: Screen tearing na Gigabyte Brix :(
« Odpowiedź #4 dnia: Lipiec 25, 2017, 10:17:56 am »
Przypuszczam, że ciebie dotknął znany problem z kompozytorem XFCE.Teraz nie pamiętam czy w 18 (jak na obrazku) są te ustawienia i czy zmiana coś daje



Druga metoda to sposób znany z Xubuntu, dla wygody zamiast nano lepiej użyć Xed.

https://askubuntu.com/a/891782

Jak ci nazwy angielskie przeszkadzają to odznaczasz włączenie


 

Potem w terminalu

sudo apt-get update
sudo apt-get install compton
Potem w ukrytym katalogu .config tworzysz plik compton.conf

cd ~/.config
xed compton.conf
Wklejasz to co poniżej do notatnika który ci się otworzył, a następnie zapisujesz

Cytuj
backend = "glx";
glx-no-stencil = true;
glx-copy-from-front = false;
glx-swap-method = "undefined";
shadow = true;
no-dnd-shadow = true;
no-dock-shadow = true;
clear-shadow = true;
shadow-radius = 5;
shadow-offset-x = -5;
shadow-offset-y = -5;
shadow-opacity = 0.5;
shadow-exclude = [
    "! name~=''",
    "name = 'Notification'",
    "name = 'Plank'",
    "name = 'Docky'",
    "name = 'Kupfer'",
    "name = 'xfce4-notifyd'",
    "name *= 'VLC'",
    "name *= 'compton'",
    "name *= 'Chromium'",
    "name *= 'Chrome'",
    "name *= 'Firefox'",
    "class_g = 'Conky'",
    "class_g = 'Kupfer'",
    "class_g = 'Synapse'",
    "class_g ?= 'Notify-osd'",
    "class_g ?= 'Cairo-dock'",
    "class_g ?= 'Xfce4-notifyd'",
    "class_g ?= 'Xfce4-power-manager'"
];
shadow-ignore-shaped = false;
menu-opacity = 1;
inactive-opacity = 1;
active-opacity = 1;
frame-opacity = 1;
inactive-opacity-override = false;
alpha-step = 0.06;
blur-background-fixed = false;
blur-background-exclude = [
    "window_type = 'dock'",
    "window_type = 'desktop'"
];
fading = true;
fade-delta = 4;
fade-in-step = 0.03;
fade-out-step = 0.03;
fade-exclude = [ ];
mark-wmwin-focused = true;
mark-ovredir-focused = true;
use-ewmh-active-win = true;
detect-rounded-corners = true;
detect-client-opacity = true;
refresh-rate = 0;
vsync = "opengl-swc";
dbe = false;
paint-on-overlay = true;
sw-opti = false;
unredir-if-possible = true;
focus-exclude = [ ];
detect-transient = true;
detect-client-leader = true;
wintypes:
{
    tooltip =
    {
        fade = true;
        shadow = false;
        opacity = 0.85;
        focus = true;
    };
};

Żeby uruchomić wpisujesz w terminalu

compton
Na końcu trzeba dodać autostart. W pola wpisujesz

Cytuj
Nazwa: Compton
Opis: Compositor for X11
Polecenie: compton

Przy regule musi być zaznaczony checkbox, żeby startowało za każdy razem


 



 


Edyta: Jakby był jakiś problem z tym comptonem (ja u siebie na buntu widzę jakiś błędy z wyświetlaniem ramek np. w centrum oprogrmowania) to po prostu odznacz w autostarcie i zaznacz Włączenie w kompozycjach (czyli odwróć modyfikację), a następnie zrestartuj komputer.

Możliwe, że jeżeli problem dotyczy tylko pseudoprzeglądarki Firefox to wystarczy wpisać w pasku przeglądarki

about:config
W polu szukaj wpisać (co poniżej) i false zmienić na true, a następnie zrestartować przeglądarkę.

gfx.xrender.enabled
---

PS Z tego co widzę, to wszystko jest wyjaśnione tutaj

https://forums.linuxmint.com/viewtopic.php?t=241389&start=40#p1339875
« Ostatnia zmiana: Lipiec 31, 2017, 09:18:18 am wysłana przez ciastek1981 »