Forum Linux Mint Polska

Autor Wątek: nagios3 - nie da się poprawnie zainstalować  (Przeczytany 366 razy)

Offline matiej

  • Miętowe nasionko
  • *
  • Wiadomości: 3
  • Punkty: 0
  • Środowisko graficzne: Xfce
  • Wersja systemu: Linux Mint 17.2
nagios3 - nie da się poprawnie zainstalować
« dnia: Sierpień 10, 2017, 22:47:14 pm »
Witam
NiIestety coś mnie podkusiło na spróbowanie minta. Wszystko się rozwala przez próbę niemożności skonfigurowania nagios3-common. Usługa nie wstaje. NIe wiadomo w czym leży błąd. MInt to świeża instalka. Uzywam minta 18.2 +xfce
Przy próbie instalacji nagios3 wszystko idzie do punktu w którym dostaje oto taki komunikat:

host@host$ sudo apt install nagios3

After modifying main.cf, be sure to run '/etc/init.d/postfix reload'.

Running newaliases
Setting up bsd-mailx (8.1.2-0.20160123cvs-2) ...
update-alternatives: using /usr/bin/bsd-mailx to provide /usr/bin/mailx (mailx) in auto mode
Setting up nagios3-common (3.5.1.dfsg-2.1ubuntu1.3) ...
Job for nagios3.service[b] failed because the control process exited with error code[/b]. See "systemctl status nagios3.service" and "journalctl -xe" for details.
invoke-rc.d: initscript nagios3, action "start" failed.
● nagios3.service - LSB: nagios host/service/network monitoring and management system
   Loaded: loaded (/etc/init.d/nagios3; bad; vendor preset: enabled)
   Active: failed (Result: exit-code) since Thu 2017-08-10 22:35:22 CEST; 35ms ago
     Docs: man:systemd-sysv-generator(8)
  Process: 16880 ExecStart=/etc/init.d/nagios3 start (code=exited, status=1/FAILURE)

Aug 10 22:35:22 duneb nagios3[16880]: Processing object config file '/etc/nagios3/conf.d/generic-service_nagios2.cfg'...
Aug 10 22:35:22 duneb nagios3[16880]: Processing object config file '/etc/nagios3/conf.d/hostgroups_nagios2.cfg'...
Aug 10 22:35:22 duneb nagios3[16880]:    Read object config files okay...
Aug 10 22:35:22 duneb nagios3[16880]: Running pre-flight check on configuration data...
Aug 10 22:35:22 duneb nagios3[16880]: Checking services...
Aug 10 22:35:22 duneb nagios3[16880]: Error: Service check command 'check_load' specified in service 'Current Load' ...where!
Aug 10 22:35:22 duneb nagios3[16880]: Error: Service check command 'check_users' specified in service 'Current Users...where!
Aug 10 22:35:22 duneb nagios3[16880]: Error: Service check command 'check_all_disks' specified in service 'Disk Spac...where!
Aug 10 22:35:22 duneb nagios3[16880]: Error: Service check command 'check_http' specified in service 'HTTP' for host...where!
Aug 10 22:35:22 duneb nagios3[16880]: Error: Service check command 'check_ssh' specified in service 'SSH' for host '...where!
Aug 10 22:35:22 duneb nagios3[16880]: Error: Service check command 'check_procs' specified in service 'Total Process...where!
Hint: Some lines were ellipsized, use -l to show in full.
[b]dpkg: error processing package nagios3-common[/b] (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of nagios3-cgi:
 nagios3-cgi depends on nagios3-common (= 3.5.1.dfsg-2.1ubuntu1.3); however:
  Package nagios3-common is not configured yet.

[b]dpkg: error processing package nagios3-cgi (--configure):
 dependency problems - leaving unconfigured[/b]
dpkg: dependency problems prevent configuration of nagios3-core:
 nagios3-core depends on nagios3-common (= 3.5.1.dfsg-2.1ubuntu1.3); however:
  Package nagios3-common is not configured yet.

dpkg: error processing package nagios3-core (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nagios3:
 nagios3 depends on nagios3-cgi (= 3.5.1.dfsg-2.1ubuntu1.3); however:
  Package nagios3-cgi is not configured yet.
 nagios3 depends on nagios3-core (= 3.5.1.dfsg-2.1ubuntu1.3); however:
  Package nagios3-core is not configured yet.

dpkg: error processing package nagios3 (--configure):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.23-0ubuntu9) ...
Processing triggers for systemd (229-4ubuntu19) ...
Processing triggers for ureadahead (0.100.0-19) ...
Errors were encountered while processing:
 nagios3-common
 nagios3-cgi
 nagios3-core
 nagios3
E: Sub-process /usr/bin/dpkg returned an error code (1)

Jak ktoś może pomóc to świetnie - jak nie bede musiał się pozengnać z mintem. Straciłem już na to ponad 2 godziny szukania na necie i bez rezultaltu.

Jakby było mało tylko dystrybucja mint ma taki problem u mnie że net działa z prędkością 7-60kb/s ! - dziwne distro naprawdę.

ps. rejestracja konta tutaj i zabezpieczenie na antybot to jakieś szaleństwo - z 15 prób.
« Ostatnia zmiana: Sierpień 10, 2017, 23:00:21 pm wysłana przez matiej »

Offline ciastek1981

  • Linux User #621498
  • Pole mięty
  • ******
  • Wiadomości: 714
  • Punkty: 102
  • Płeć: Mężczyzna
  • Deepin && Voyager 16.04.X LTS (Xubuntu)
  • Środowisko graficzne: Inne
  • Wersja systemu: Inny
Odp: nagios3 - nie da się poprawnie zainstalować
« Odpowiedź #1 dnia: Sierpień 12, 2017, 12:47:38 pm »
Coś nacudowałeś. Sprawdzałem na Mincie 18.2 z Xfce instaluje się bez zająknięcia.

sudo rm -rf /etc/nagios3
sudo apt-get --purge remove nagios3-common
Potem jeszcze raz spróbuj zainstalować

sudo apt-get install nagios3

Offline matiej

  • Miętowe nasionko
  • *
  • Wiadomości: 3
  • Punkty: 0
  • Środowisko graficzne: Xfce
  • Wersja systemu: Linux Mint 17.2
Odp: nagios3 - nie da się poprawnie zainstalować
« Odpowiedź #2 dnia: Sierpień 14, 2017, 10:27:06 am »
Ale co ja mogłem nacudować - swieża instalka. Myślisz że nie próbowałem purga i rfa ?  i to kilkakrotnie takze purgiem apache, postfixa itp. Zero efektu. W międzyczasie pokusiłem się o instalkę z źródeł nagiosa 4 i to działa bez zarzutu.

Tak więc uratował się mint - przyznam że mi zależało bo to jedyne distro którego deweloperzy użyli mózgu w sensie zgrania wszystkiego graficznie i z szablonami.




Offline Ulvhedin

  • Globator Moderalny
  • Spamerzy
  • *******
  • Wiadomości: 1565
  • Punkty: 1118
  • Płeć: Mężczyzna
  • Środowisko graficzne: Xfce
  • Wersja systemu: Inny
Odp: nagios3 - nie da się poprawnie zainstalować
« Odpowiedź #3 dnia: Sierpień 14, 2017, 13:03:08 pm »
matiej: ze swojej strony polecam mimo wszystko izolowanie takich dodatków.
Na swojej maszynie domowej jak i roznej masci serwerach uzywam do tego dockera z predefiniowanymi apkami.

Zyskujesz to ze apka działa sobie w swoim srodowisku odizolowana od systemu, ma spełnione systemowe zaleznosci i łatwo o ewentualny upgrejd.
Dodatowo bardzo czesto twórcy dbaja o przygotowanie dockerowego image'a dla swojej aplikacji wiec mam pewnosc ze to po prostu ma działac.

Zasadniczo polecam bo w ten sposob kontrolujesz to co masz na kompie. :)

Offline ciastek1981

  • Linux User #621498
  • Pole mięty
  • ******
  • Wiadomości: 714
  • Punkty: 102
  • Płeć: Mężczyzna
  • Deepin && Voyager 16.04.X LTS (Xubuntu)
  • Środowisko graficzne: Inne
  • Wersja systemu: Inny
Odp: nagios3 - nie da się poprawnie zainstalować
« Odpowiedź #4 dnia: Sierpień 14, 2017, 17:04:49 pm »
@matiej

Jakaś tam podpowiedź się pojawiała
See "systemctl status nagios3.service" and "journalctl -xe" for details.
Ja po prostu wrzuciłem Minta Xfce na VMWare Player'a i sprawdziłem czy się instaluje, nie generowało żadnych błędów więc tak napisałem. Może przy usuwaniu/odinstalowywaniu trzeba było dać jeszcze nagios3-cgi, nagios3-core, nagios3

Offline matiej

  • Miętowe nasionko
  • *
  • Wiadomości: 3
  • Punkty: 0
  • Środowisko graficzne: Xfce
  • Wersja systemu: Linux Mint 17.2
Odp: nagios3 - nie da się poprawnie zainstalować
« Odpowiedź #5 dnia: Sierpień 14, 2017, 21:09:28 pm »
Jakaś tam podpowiedź się pojawiała
See "systemctl status nagios3.service" and "journalctl -xe" for details.

No przecież status nagiosa masz w pierwszym poście,  a journal takze niczego konkretnego nie pokazywał.
Jak umiesz odczytać z statusu coś więcej oprócz tego że nagios-common sie wywala to chętnie się dowiem, ale już ponownie tego mi się zwyczajnie nie chce instalować. jeszcze rozpieprzy mi 4kę. No i także kasowałem nagios* - wiec to nie to...Temat jest już bez sensu bo nie chcę replikować problemu, a 4ka mi działa-  amoże to tylko dziwny wypadek przy pracy - jest to typowe dla linuxa.

ps. z dockerem mozesz mi zapodać jakieś info-linki ? dowiedziałbym się coś więcej w tym temacie.


ps.2 czy wy tez macie tak że przy wysyłaniu za kazdym razem postu jest komunikat "błąd bazy danych - Spróbuj ponownie. Jeśli powrócisz do tego komunikatu, zgłoś błąd administratorowi." - po czym sie okazuje że post jednak został wysłany..
« Ostatnia zmiana: Sierpień 14, 2017, 21:11:20 pm wysłana przez matiej »