Forum Linux Mint Polska

Autor Wątek: Mint 18.2 Uśpienie i hibernacja nie działają.  (Przeczytany 361 razy)

Offline Błażej

  • Miętowe nasionko
  • *
  • Wiadomości: 8
  • Punkty: 0
  • Płeć: Mężczyzna
  • Środowisko graficzne: KDE
  • Wersja systemu: 18
Mint 18.2 Uśpienie i hibernacja nie działają.
« dnia: Wrzesień 29, 2017, 23:04:40 pm »
Witam,
Na wstępie chciałbym zaznaczyć, że jestem tutaj nowy, więc z góry przepraszam za wszystkie głupie błędy, które pewnie popełnię i proszę o wyrozumiałość.  ;)

Do rzeczy:
Mam problem z trybem uśpienia, jak i hibernacją.
Laptop w stan uśpienia/hibernacji przechodzi, jednak nie wybudza się z niego (ekran zapala się, widać kursor na czarnym tle, jednak komputer nie reaguje. Działa tylko twardy reset).

System: Linux Mint 18.2 "Sonya"
Kernel: 4.11.0-14-generic
Laptop: Acer Aspire E1-570G
Linux jest zainstalowany obok Windowsa 10 (jeśli ma to jakieś znaczenie).

Co powoduje, że uśpienie/hibernacja nie działa, jak to naprawić?
Z góry dziękuję za pomoc i pozdrawiam.

Online ciastek1981

  • Linux User #621498
  • Dorodny miętowy krzew
  • *****
  • Wiadomości: 625
  • Punkty: 102
  • Płeć: Mężczyzna
  • Voyager (Xubuntu) & Arch
  • Środowisko graficzne: Xfce
  • Wersja systemu: Inny
Odp: Mint 18.2 Uśpienie i hibernacja nie działają.
« Odpowiedź #1 dnia: Wrzesień 30, 2017, 10:57:44 am »

Kernel: 4.11.0-14-generic


Po co w tej wersji? Używaj zalecanego kernela. Potem są różne szopki, a to nie można zainstalować TLP z menadżera oprogramowania, a to usługi którymi zarządza systemd w nowszym kerenlu są zwalone np. 1 i 2. Dodaj do tego "chorą" filozofię aktualizacji Minta i problem gwarantowany.

Spój tak:
1. Wróć do zalecanego kernela
2. Zainstaluj TLP
sudo apt-get install tlp tlp-rdw 3. Zrestartuj lub w termianlu
sudo tlp start4. Sprawdź czy działa
« Ostatnia zmiana: Wrzesień 30, 2017, 11:01:55 am wysłana przez ciastek1981 »

Offline Błażej

  • Miętowe nasionko
  • *
  • Wiadomości: 8
  • Punkty: 0
  • Płeć: Mężczyzna
  • Środowisko graficzne: KDE
  • Wersja systemu: 18
Odp: Mint 18.2 Uśpienie i hibernacja nie działają.
« Odpowiedź #2 dnia: Wrzesień 30, 2017, 14:15:24 pm »
Używaj zalecanego kernela.

Dzięki za pomoc, ale czy mógłbyś mi podać zalecaną wersję, lub powiedzieć gdzie znaleźć takie informacje, jestem nowy, nie wiem gdzie to znaleźć.
Myślałem, że najnowsza wersja kernela będzie najlepsza.

Jeszcze raz dzięki za pomoc, pozdrawiam.

Online ciastek1981

  • Linux User #621498
  • Dorodny miętowy krzew
  • *****
  • Wiadomości: 625
  • Punkty: 102
  • Płeć: Mężczyzna
  • Voyager (Xubuntu) & Arch
  • Środowisko graficzne: Xfce
  • Wersja systemu: Inny
Odp: Mint 18.2 Uśpienie i hibernacja nie działają.
« Odpowiedź #3 dnia: Wrzesień 30, 2017, 15:47:08 pm »
Zajrzyj do Menadżera aktualizacji. Ja Minta nie używam i ścieżki nie pamiętam.

Offline Błażej

  • Miętowe nasionko
  • *
  • Wiadomości: 8
  • Punkty: 0
  • Płeć: Mężczyzna
  • Środowisko graficzne: KDE
  • Wersja systemu: 18
Odp: Mint 18.2 Uśpienie i hibernacja nie działają.
« Odpowiedź #4 dnia: Wrzesień 30, 2017, 18:01:17 pm »
Zainstalowałem Kernel 4.8.0-53 generic. (nie wiem czy dobry).
Zainstalowałem TLP.
Po uruchomieniu TLP terminal odpowiedział:
"TLP started in AC mode."
Jednak próba przejścia w tryb uśpienia powoduje ten sam problem. Komputer usypia się, jednak po wybudzeniu ekran zapala się widać nieruchomy kursor na ciemnym tle i nic się nie dzieje. Pomaga tylko twardy reset. System później odpala się normalnie.


Online ciastek1981

  • Linux User #621498
  • Dorodny miętowy krzew
  • *****
  • Wiadomości: 625
  • Punkty: 102
  • Płeć: Mężczyzna
  • Voyager (Xubuntu) & Arch
  • Środowisko graficzne: Xfce
  • Wersja systemu: Inny
Odp: Mint 18.2 Uśpienie i hibernacja nie działają.
« Odpowiedź #5 dnia: Wrzesień 30, 2017, 19:03:48 pm »
Najszybciej to ciśnij tym sprzętem w sprzedawcę  8)

W Menadżerze sterowników poprzełączaj na sterowniki zamknięte (jeżeli masz zamknięte to sprawdź w drugą stronę). Zaktualizuj BIOS.

Przydały by się logi i informacje

1. O sprzęcie

inxi -CGM -xx
sudo lspci -vnn | grep -A12 VGA
2. Przyda się informacja o SWAP i RAM

lsblk
free -m

3. Logi zgodnie z wymaganiami (przeczytaj) http://forum.linuxmint.pl/index.php?topic=6937.0 Jak ktoś kumaty w końcu tu zajrzy  ;D

cat /var/log/pm-suspend.log|pastebinitcat /var/log/Xorg.0.log|pastebinitdmesg|pastebinit cat /var/log/syslog|pastebinitcat /proc/cmdline|pastebinit
Edyta: Jeżeli będzie problem z wygenerowaniem logu

cat /var/log/pm-suspend.log|pastebinit
to spróbuj zapodać terminalu

sudo PM_DEBUG=true pm-suspend
Jak uśpi system, to spróbuj go wybudzić, wciskając np. klawisz funkcyjny i potem spróbuj jeszcze raz wygenerować

cat /var/log/pm-suspend.log|pastebinit

PS. Jak ci się będzie dłużyło oczekiwane na odpowiedź to poczytaj

https://sites.google.com/site/easylinuxtipsproject/bugs#TOC-Hibernate-and-suspend-don-t-always-work-well:-they-make-some-computers-malfunction-or-even-enter-a-coma
« Ostatnia zmiana: Październik 01, 2017, 13:15:42 pm wysłana przez ciastek1981 »

Offline Błażej

  • Miętowe nasionko
  • *
  • Wiadomości: 8
  • Punkty: 0
  • Płeć: Mężczyzna
  • Środowisko graficzne: KDE
  • Wersja systemu: 18
Odp: Mint 18.2 Uśpienie i hibernacja nie działają.
« Odpowiedź #6 dnia: Październik 01, 2017, 17:34:20 pm »
Dzięki za pomoc.  :D

Sprawdziłem i BIOS jest aktualny.
Zmieniłem sterowniki, zobaczymy, czy to coś da.

1.Pierwsze polecenie zwraca:
Machine:   Mobo: Acer model: EA50_CX v: V2.06
           Bios: Insyde v: V2.06 date: 10/08/2013
CPU:       Dual core Intel Core i5-3337U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 7183
           clock speeds: min/max: 800/2700 MHz 1: 899 MHz 2: 896 MHz
           3: 914 MHz 4: 802 MHz
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller
           bus-ID: 00:02.0 chip-ID: 8086:0166
           Card-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M]
           bus-ID: 01:00.0 chip-ID: 10de:1140
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) FAILED: nouveau
           Resolution: 1366x768@60.01hz
           GLX Renderer: N/A GLX Version: N/A Direct Rendering: N/A

Drugie:

00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
        Subsystem: Acer Incorporated [ALI] 3rd Gen Core processor Graphics Controller [1025:0835]
        Flags: bus master, fast devsel, latency 0, IRQ 30
        Memory at b3000000 (64-bit, non-prefetchable) [size=4M]
        Memory at c0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 3000 [size=64]
        [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
        Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 2
        Capabilities: [a4] PCI Advanced Features
        Kernel driver in use: i915
        Kernel modules: i915

2. Pierwsze:

NAME    MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sr0      11:0    1  1024M  0 rom 
sda       8:0    0 465,8G  0 disk
├─sda4    8:4    0    75G  0 part
├─sda2    8:2    0   300M  0 part /boot/efi
├─sda9    8:9    0   1,9G  0 part [SWAP]
├─sda7    8:7    0   190M  0 part
├─sda10   8:10   0    42G  0 part /home
├─sda5    8:5    0    70G  0 part
├─sda3    8:3    0   128M  0 part
├─sda1    8:1    0   400M  0 part
├─sda8    8:8    0  23,3G  0 part /
├─sda11   8:11   0  16,8G  0 part
└─sda6    8:6    0 235,9G  0 part

Drugie:

             razem       użyte       wolne    dzielone   buf/cache    dostępne
Pamięć:        3840        1139         688         116        2012        2299
Wymiana:        1906           0        1906

Punkt 3 wrzucę jak wrócę do domu. Dodam jako edycja.

Online ciastek1981

  • Linux User #621498
  • Dorodny miętowy krzew
  • *****
  • Wiadomości: 625
  • Punkty: 102
  • Płeć: Mężczyzna
  • Voyager (Xubuntu) & Arch
  • Środowisko graficzne: Xfce
  • Wersja systemu: Inny
Odp: Mint 18.2 Uśpienie i hibernacja nie działają.
« Odpowiedź #7 dnia: Październik 01, 2017, 19:48:23 pm »
Póki co to wydaje mi się, że Swap jest za mały. Przy 4 GB RAM i hibernacji zaleca się Swap 6-8 GB.

https://help.ubuntu.com/community/SwapFaq#How_much_swap_do_I_need.3F

Zobaczymy co logi pokażą.

Offline Błażej

  • Miętowe nasionko
  • *
  • Wiadomości: 8
  • Punkty: 0
  • Płeć: Mężczyzna
  • Środowisko graficzne: KDE
  • Wersja systemu: 18
Odp: Mint 18.2 Uśpienie i hibernacja nie działają.
« Odpowiedź #8 dnia: Październik 01, 2017, 20:24:20 pm »
No właśnie chyba przez przypadek w międzyczasie system spieprzyłem. :(

Zmieniłem sterowniki w menu na te od nVidii i chciałem zrestartować komputer. Przy próbie restartu wyskoczył błąd. Spróbowałem opcji wyłącz, wyskoczył ten sam błąd, raz jeszcze i ten sam efekt. Trochę zdziwiony i lekko wystraszony zrobiłem hard reset (miałem nadzieję, że system wstanie). Przy próbie uruchomienia na początku wszystko idzie normalnie. GRUB się uruchamia, po wybraniu Linux Mint-a ładnie pokazuje się logo Minta i w momencie, w którym normalnie powinien otworzyć się ekran logowania mam czarny ekran. Nic się nie wyświetla, ani nie dzieje. Czytałem gdzieś, że może to problem ze sterownikami grafiki, ale wtedy chyba wyświetliłby się jakiś błąd?

Mam "obok" Windowsa 10, który startuje normalnie.

Czy to faktycznie wina sterowników, czy może zepsułem co innego?
Jak to ewentualnie naprawić? Czy od razu postawić system od nowa? (Na szczęście mam osobną partycję /home, więc przy stawianiu systemu ważnych plików nie stracę).

Za mały SWAP, faktycznie, jak odratuję/postawię na nowo system dam większy SWAP.

Wielkie dzięki za pomoc, pozdrawiam.  :)

Online ciastek1981

  • Linux User #621498
  • Dorodny miętowy krzew
  • *****
  • Wiadomości: 625
  • Punkty: 102
  • Płeć: Mężczyzna
  • Voyager (Xubuntu) & Arch
  • Środowisko graficzne: Xfce
  • Wersja systemu: Inny
Odp: Mint 18.2 Uśpienie i hibernacja nie działają.
« Odpowiedź #9 dnia: Październik 01, 2017, 23:31:36 pm »
Jak czarny ekran się pojawia to spróbuj wcisnąć F2 i się zalogować. Jeżeli pójdzie to trzeba spróbować przeinstalować menadżer logowania:

sudo apt-get install --reinstall lightdm lightdm-settings
« Ostatnia zmiana: Październik 01, 2017, 23:43:41 pm wysłana przez ciastek1981 »

Offline kris777

  • Miętowa sadzonka
  • **
  • Wiadomości: 73
  • Punkty: 10
  • Środowisko graficzne: Mate
  • Wersja systemu: 18
Odp: Mint 18.2 Uśpienie i hibernacja nie działają.
« Odpowiedź #10 dnia: Październik 02, 2017, 14:53:39 pm »
A dokładnie jaką wersję Minta wgrywasz ?. ... ja tak mam z moim lapkiem na Linux Mint Xfce .... suspend / uśmienie po zamknięciu klapki i ponownym otwarciu i włączeniu power mam tylko czarny ekran :-) ...i tylko hard reset pomagał . Stało się tak za każdem razem jak zmieniłem drivery z otwartych na zamknięte nvidii ... momo że spowrotem powróciłem do otwartych suspend już nie działał :-) ... ale na Linux Mint / Mate i Cnnamon jest wszystko OK ...mimo zmiany driverów .

Offline Błażej

  • Miętowe nasionko
  • *
  • Wiadomości: 8
  • Punkty: 0
  • Płeć: Mężczyzna
  • Środowisko graficzne: KDE
  • Wersja systemu: 18
Odp: Mint 18.2 Uśpienie i hibernacja nie działają.
« Odpowiedź #11 dnia: Październik 02, 2017, 16:07:11 pm »
kris777
Mam Linux Mint 18.2 KDE z kernelem 4.8.0-53 generic
Do tej pory nie zmieniałem sterowników. Były domyślnie włączone otwarte.

ciastek1981

Naciskam F2 i nie pomaga  :(
Jest jakiś sposób, żeby wykonać te komendę, którą napisałeś?
Może w Recovery Mode jest jakaś opcja do tego?

Czy robić od razu reinstal systemu i nie kombinować?
Jeśli tak, to czy jest jakaś opcja, żeby zapisać gdzieś konfigurację KDE (pasek zadań, pulpit, itd.), jaką teraz mam, a później wczytać na postawionym od nowa systemie?

Dzięki za pomoc, pozdrawiam.

Offline kris777

  • Miętowa sadzonka
  • **
  • Wiadomości: 73
  • Punkty: 10
  • Środowisko graficzne: Mate
  • Wersja systemu: 18
Odp: Mint 18.2 Uśpienie i hibernacja nie działają.
« Odpowiedź #12 dnia: Październik 02, 2017, 17:32:37 pm »
Tu jest jakiś temat odnośnie tego problemu jednak po angielsku i lekko skomplikowane to : KLIK
Tu chyba potwierdzili iż zmiana kernela pomogła ? ... KLIK ... dużo jest różnych porad ale ? .... KLIK  KLIK  KLIK
« Ostatnia zmiana: Październik 02, 2017, 17:54:35 pm wysłana przez kris777 »

Online ciastek1981

  • Linux User #621498
  • Dorodny miętowy krzew
  • *****
  • Wiadomości: 625
  • Punkty: 102
  • Płeć: Mężczyzna
  • Voyager (Xubuntu) & Arch
  • Środowisko graficzne: Xfce
  • Wersja systemu: Inny
Odp: Mint 18.2 Uśpienie i hibernacja nie działają.
« Odpowiedź #13 dnia: Październik 02, 2017, 17:44:53 pm »
Spróbuj w kombinacji z Ctrl+Alt+F2 (można kombinować of F1 do F8). Tylko nie pamiętam co do czego jest teraz. F7-F8 to powinny być od X-ów. F1-F6 tryb tekstowy.

Edyta:
Jak miga sam kursor i nie ma żadnych komunikatów to Ctrl+Alt+F2 daje tryb tekstowy, a Ctrl+Alt+F7 włącza X'y.

Swoją drogą dlaczego nikt nie zwróci uwagi na to, że głupoty piszę  8) Samo F2 nie działa.
« Ostatnia zmiana: Październik 02, 2017, 18:04:01 pm wysłana przez ciastek1981 »

Offline Błażej

  • Miętowe nasionko
  • *
  • Wiadomości: 8
  • Punkty: 0
  • Płeć: Mężczyzna
  • Środowisko graficzne: KDE
  • Wersja systemu: 18
Odp: Mint 18.2 Uśpienie i hibernacja nie działają.
« Odpowiedź #14 dnia: Październik 02, 2017, 18:36:09 pm »
kris777

Dzięki za linki, w wolnej chwili poczytam.  :)

ciastek1981

Po wciśnięciu Ctrl + Alt + F2 system sam wstał i nie było potrzeby wpisywania żadnych komend.

Na pasku zadań wyświetla mi się teraz ikonka nVidii, więc jak rozumiem działa na zamkniętych sterownikach.

Mogę dokończyć podawanie logów.

3. Pierwsze:
Wyskakuje błąd, tak jak przewidziałeś, dodam do posta później jako edycja.

EDYCJA:

http://paste.ubuntu.com/25661727/

Po uspaniu spróbowałem wybudzić system przyciskiem zasilania, jednak wystąpiła ta sama sytuacja co zwykle (czarny ekran, nieruchomy kursor myszy), zrobiłem hard reset, po którym odpaliłem minta normalnie i znowu pojawił się problem z niepokazującym ekranem logowania. Jeszcze raz hard reset i włączam znowu, tym razem od razu na logu minta wciska CTRL + ALT + F2 i ekran logowania otwiera się normalnie. Spróbuję przełączyć na otwarte sterowniki i obejrzeć, czy problem z ekranem logowania na nich występuje.

Druga edycja:

Po zmianie sterownika z zamkniętego nVidii na otwarty problem z ekranem logowania nie występuje.

(koniec edycji)

Drugie:

http://paste.ubuntu.com/25661647/

Trzecie:

http://paste.ubuntu.com/25661651/

Czwarte:

http://paste.ubuntu.com/25661669/

Piąte:

http://paste.ubuntu.com/25661674/

Dzięki, log z którym był błąd będzie w edycji.
« Ostatnia zmiana: Październik 02, 2017, 19:02:38 pm wysłana przez Błażej »