Forum Linux Mint Polska

Autor Wątek: Błąd z pakietami Sparky podczas aktualizacji  (Przeczytany 120 razy)

Offline Dawid

  • Miętowe nasionko
  • *
  • Wiadomości: 5
  • Punkty: 0
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: Linux Mint 17.3
Błąd z pakietami Sparky podczas aktualizacji
« dnia: Listopad 10, 2017, 18:43:52 pm »
Mam 4 pakiety Sparky do aktualizacji, ale gdy próbuję to zrobić to wyświetlają mi się dwa okna z informacją o błędzie. W pierwszym oknie takie coś:
E: /var/cache/apt/archives/sparky-apt_5~20171103_all.deb: podproces dpkg-deb --control zwrócił kod błędu 2
E: /var/cache/apt/archives/sparky-desktop_20171103_all.deb: podproces dpkg-deb --control zwrócił kod błędu 2
E: /var/cache/apt/archives/sparky-office_0.1.15_all.deb: podproces dpkg-deb --control zwrócił kod błędu 2
E: /var/cache/apt/archives/sparky-aptus_0.3.13_all.deb: podproces dpkg-deb --control zwrócił kod błędu 2

A w drugim to:
(synaptic:14917): GLib-CRITICAL **: g_child_watch_add_full: assertion 'pid > 0' failed
dpkg-deb: błąd: archiwum "/var/cache/apt/archives/sparky-apt_5~20171103_all.deb" zawiera przedwczesny człon "control.tar.xz" przed "control.tar.gz", przerywanie
dpkg: błąd przetwarzania archiwum /var/cache/apt/archives/sparky-apt_5~20171103_all.deb (--unpack):
 podproces dpkg-deb --control zwrócił kod błędu 2
dpkg-deb: błąd: archiwum "/var/cache/apt/archives/sparky-desktop_20171103_all.deb" zawiera przedwczesny człon "control.tar.xz" przed "control.tar.gz", przerywanie
dpkg: błąd przetwarzania archiwum /var/cache/apt/archives/sparky-desktop_20171103_all.deb (--unpack):
 podproces dpkg-deb --control zwrócił kod błędu 2
dpkg-deb: błąd: archiwum "/var/cache/apt/archives/sparky-office_0.1.15_all.deb" zawiera przedwczesny człon "control.tar.xz" przed "control.tar.gz", przerywanie
dpkg: błąd przetwarzania archiwum /var/cache/apt/archives/sparky-office_0.1.15_all.deb (--unpack):
 podproces dpkg-deb --control zwrócił kod błędu 2
dpkg-deb: błąd: archiwum "/var/cache/apt/archives/sparky-aptus_0.3.13_all.deb" zawiera przedwczesny człon "control.tar.xz" przed "control.tar.gz", przerywanie
dpkg: błąd przetwarzania archiwum /var/cache/apt/archives/sparky-aptus_0.3.13_all.deb (--unpack):
 podproces dpkg-deb --control zwrócił kod błędu 2
Wystąpiły błędy podczas przetwarzania:
 /var/cache/apt/archives/sparky-apt_5~20171103_all.deb
 /var/cache/apt/archives/sparky-desktop_20171103_all.deb
 /var/cache/apt/archives/sparky-office_0.1.15_all.deb
 /var/cache/apt/archives/sparky-aptus_0.3.13_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Nie udało się zainstalować pakietu. Próba powrócenia do poprzedniego stanu:

Co na to poradzić?

Offline Jarook

  • Miętowe nasionko
  • *
  • Wiadomości: 4
  • Punkty: 0
  • Środowisko graficzne: KDE
  • Wersja systemu: Linux Mint 17.2
Odp: Błąd z pakietami Sparky podczas aktualizacji
« Odpowiedź #1 dnia: Grudzień 05, 2017, 10:54:39 am »
spróbuj wykorzystac inną paczke, moze ta jest uszkodzona

Offline rrico

  • Miętowy liść
  • *
  • Wiadomości: 34
  • Punkty: 0
  • Płeć: Mężczyzna
  • Środowisko graficzne: Mate
  • Wersja systemu: Inny
Odp: Błąd z pakietami Sparky podczas aktualizacji
« Odpowiedź #2 dnia: Grudzień 05, 2017, 13:49:33 pm »
Mi to wygląda, że system potrzebuje paczek *.tar.gz nie *.tar.xz do ukończenia tej instalki. Inaczej pakowane.
----------------------
Linux Mint 18.2 Mate/Cinnamon x64 | lap Toshiba satellite A350
Ubuntu Mate 16.04.2 x64 | klocek składak (offline)