Autor Wątek: [SOLVED] Kłopot z uruchomieniem skanera Canon LiDe 220  (Przeczytany 4909 razy)

Offline ciastek1981

  • Globator Moderalny
  • Spamerzy
  • *******
  • Wiadomości: 1257
  • Punkty: 153
  • Płeć: Mężczyzna
Odp: Kłopot z uruchomieniem skanera Canon LiDe 220
« Odpowiedź #60 dnia: Luty 15, 2018, 21:45:33 pm »
Uroki Debiana Stable (LMDE 2 to obecnie Debian Old Stable) i klonów na nim bazujących - "naprawimy przy następnym wydaniu". Ja się teraz przymierzam bo podmiany repo na Testing w moim V9, ale przez to, że po projekt jednego autora obawiam się, że system wykrzaczy. Muszę najpierw przetestować na wirtualce.

Offline oktet

  • Miętowa sadzonka
  • **
  • Wiadomości: 72
  • Punkty: 14
Odp: Kłopot z uruchomieniem skanera Canon LiDe 220
« Odpowiedź #61 dnia: Luty 24, 2018, 22:24:39 pm »
OK udało mi się po raz drugi zainstalować skaner Canon LiDE 220 na virtualbox-ie / LMDE 2... nie wiem czy pomogę na 100% bo z tym systemem jest coś nie tak. Moje postępowanie :
 instalacja systemu LMDE2 Mate 64bit
update / upgrade do : Linux 3.16.0-5-amd64 #1 SMP Debian 3.16.51-3+deb8u1 (2018-01-08) x86_64 GNU/Linux
instalacja paczek:
apt-get install gocr libusb-dev libsane-dev libsane-extras xsane-common xsanemodyfikacja plików:
nano /etc/sane.d/genesys.confdodanie wpisów:
# Canon LiDE 220
usb 0x04a9 0x190f
ctrl x ... t ..... enter
nano /lib/udev/rules.d/60-libsane.rulesdodanie wpisu:
# Canon CanoScan LiDE 220
ATTRS{idVendor}=="04a9", ATTRS{idProduct}=="190f", ENV{libsane_matched}="yes"
reboot systemu
ściągnięcie i kompilacja paczki sane-backends:
wget http://http.debian.net/debian/pool/main/s/sane-backends/sane-backends_1.0.25.orig.tar.gz
tar -xvzf sane-backends_1.0.25.orig.tar.gz
chmod +x sane-backends-1.0.25
cd sane-backends-1.0.25
./configure
make
make install
następnie:
apt-get purge libsane
apt-get autoremove libsane
apt-get install xsane
Po tym skaner Cannon-a uruchomił się poprawnie z programem xsane.
Można także dodać wpis w terminalu:
sudo usermod -a -G scanner nazwa użytkownika
i sprawdzić w terminalu czy  program xsane nie uruchamia się tylko jako root ( sudo su ).... jeśli tak to nadać odpowiednie uprawnienia:
chmod a+w /dev/bus/usb/001/003w moim przypadku jeśli skaner jest wykrywany jako:
lsusb:
Bus 001 Device 003: ID 04a9:190f Canon, Inc.

Dzisiaj przysiadłem, zrobiłem na osobnym dysku świerzutką instalację LMDE 2 i przeleciałem całą procedurę którą poleciłeś i którą dla jasności przytoczyłem powyżej.
Następnie podłączyłem skaner, uruchomiłem Xsane i ku mojej radości - skaner natychmiast ruszył.
Można zatem powiedzieć że ten twój kompletny opis jest trafiony i chyba wyczerpuje temat instalacji skanera Canon LiDe 220 na Mint-Debian.
Bardzo dziękuję wszystkim za pomoc i z radością dopisuję solved.   :)
« Ostatnia zmiana: Luty 24, 2018, 22:47:08 pm wysłana przez oktet »
Niektórzy twierdzą że "Linuksy" są zawodne i źle zabezpieczone i dlatego serwery Microsoft pracują na... Debianie.   ??? ... :o