Autor Wątek: [ Rozwiazano ]AppImage przestał działać  (Przeczytany 425 razy)

Offline wogabun

  • Dorodna miętowa sadzonka
  • ***
  • Wiadomości: 244
  • Punkty: 2
  • Płeć: Mężczyzna
[ Rozwiazano ]AppImage przestał działać
« dnia: Październik 06, 2018, 16:45:59 pm »
Grzebałem w ustawieniach programu RepetierHost a usiłowałem dodać mu ścieżkę do zewnętrznego slicera program sie wysypał i przestał działać . Program zpisuje ustawienia w /local/share/RepetirHost ale usuniecie tego katalogu nic nie daje wiec pomyślałem ze gdzie jeszcze coś zapisał tzn.jakieś błędne ustawienia pobrałem nową paczkę i to samo. Jak go uruchomić ?
« Ostatnia zmiana: Październik 08, 2018, 18:27:59 pm wysłana przez wogabun »
Wiem że nic nie wiem .. ale inni nawet tego nie wiedzą
Linux tajemny jest albowiem poczekać cierpliwie trzeba i zaczyna działać , aczkolwiek nie zawsze ..... Król Julian

Offline yahoob3

  • Grupa Trzymająca Władzę
  • Wielki miętus
  • *****
  • Wiadomości: 892
  • Punkty: 191
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: AppImage przestał działać
« Odpowiedź #1 dnia: Październik 06, 2018, 17:39:50 pm »
Spróbuj poszukać na komputerze miejsc, gdzie RH może się jeszcze "ukrywać":
locate *repetirHost*
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

Offline wogabun

  • Dorodna miętowa sadzonka
  • ***
  • Wiadomości: 244
  • Punkty: 2
  • Płeć: Mężczyzna
Odp: AppImage przestał działać
« Odpowiedź #2 dnia: Październik 06, 2018, 17:49:02 pm »
Nic nie znajduje właśnie albo to ma zaszyte w pliku albo zle pytam, szukałem po dysku a nie wiem jak się do niego dobrać żeby coś zobaczyć
Wiem że nic nie wiem .. ale inni nawet tego nie wiedzą
Linux tajemny jest albowiem poczekać cierpliwie trzeba i zaczyna działać , aczkolwiek nie zawsze ..... Król Julian

Offline yahoob3

  • Grupa Trzymająca Władzę
  • Wielki miętus
  • *****
  • Wiadomości: 892
  • Punkty: 191
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: AppImage przestał działać
« Odpowiedź #3 dnia: Październik 06, 2018, 17:53:05 pm »
A:
locate *epetir*Powinno znaleźć chociaż tę paczkę, którą ściągnąłeś.
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

Offline wogabun

  • Dorodna miętowa sadzonka
  • ***
  • Wiadomości: 244
  • Punkty: 2
  • Płeć: Mężczyzna
Odp: AppImage przestał działać
« Odpowiedź #4 dnia: Październik 06, 2018, 17:58:17 pm »
paczke tak ,locate *Repetier*
/home/marek/Repetier-Host-x86_64-2.1.3.AppImage
Wiem że nic nie wiem .. ale inni nawet tego nie wiedzą
Linux tajemny jest albowiem poczekać cierpliwie trzeba i zaczyna działać , aczkolwiek nie zawsze ..... Król Julian

Offline yahoob3

  • Grupa Trzymająca Władzę
  • Wielki miętus
  • *****
  • Wiadomości: 892
  • Punkty: 191
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: AppImage przestał działać
« Odpowiedź #5 dnia: Październik 06, 2018, 18:05:01 pm »
Cytuj
I had a similar looking problem in Mint 18 today and Repetier-host would not start after install.

I had previous installed mono using Software manager. This seems to be a problem.

My solution was to use Synaptic Package manager to install "mono-compete." and to install "build-essential" as recommended above.

Repetier now starts.


(note I had also installed "mono-reference-assembliers-4.0" before, I don't know if it has any effect here, but if above doesn't work that might be worth a shot.)
Takie remedium proponują na:
https://forum.repetier.com/categories/repetier-host-linux w  tym wątku: https://forum.repetier.com/discussion/2848/install-on-linux-mint-18-i-leave-nothing
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

Offline wogabun

  • Dorodna miętowa sadzonka
  • ***
  • Wiadomości: 244
  • Punkty: 2
  • Płeć: Mężczyzna
Odp: AppImage przestał działać
« Odpowiedź #6 dnia: Październik 06, 2018, 18:51:41 pm »
Dziwne nie było tych pakietów ale jakieś 4 godziny temu działał i chciałem poprawić  :D no i poprawiłem  :( tak ze nadal nie działa
Wiem że nic nie wiem .. ale inni nawet tego nie wiedzą
Linux tajemny jest albowiem poczekać cierpliwie trzeba i zaczyna działać , aczkolwiek nie zawsze ..... Król Julian

Offline yahoob3

  • Grupa Trzymająca Władzę
  • Wielki miętus
  • *****
  • Wiadomości: 892
  • Punkty: 191
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: AppImage przestał działać
« Odpowiedź #7 dnia: Październik 06, 2018, 19:04:35 pm »
Stara prawda... jak działa, to nie grzeb ;D
A tak serio, jak TO instalowałeś wcześniej?

EDIT:
Wg tego?
https://www.repetier.com/documentation/repetier-host/rh-installation-and-configuration/
« Ostatnia zmiana: Październik 06, 2018, 19:07:47 pm wysłana przez yahoob3 »
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

Offline wogabun

  • Dorodna miętowa sadzonka
  • ***
  • Wiadomości: 244
  • Punkty: 2
  • Płeć: Mężczyzna
Odp: AppImage przestał działać
« Odpowiedź #8 dnia: Październik 06, 2018, 19:12:38 pm »
Nijak, pobrałem i dwuklik i działa, drukarka, port usb i było z 3 tygodnie ok i działał idealnie tak ze nie rozumiem, teraz widać ze startuje, tworzy część tylko folderów w .local/share /rephost i zamyka sie, jest tam log ale pusty i bądź tu mądry. Podejrzewam ze zle wpisałem sciezki i on leci do nieprawidłowej lokalizacji ale czy na pewno to nie wiem, a jezeli tak to gdzies jeszcze zapisuje ale gdzie ? Przy zmianie lokalizacji to samo nie działa
Jezeli wiesz jak to podejrzeć to moze tam jest jakiś config
« Ostatnia zmiana: Październik 06, 2018, 19:33:43 pm wysłana przez wogabun »
Wiem że nic nie wiem .. ale inni nawet tego nie wiedzą
Linux tajemny jest albowiem poczekać cierpliwie trzeba i zaczyna działać , aczkolwiek nie zawsze ..... Król Julian

Offline yahoob3

  • Grupa Trzymająca Władzę
  • Wielki miętus
  • *****
  • Wiadomości: 892
  • Punkty: 191
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: AppImage przestał działać
« Odpowiedź #9 dnia: Październik 06, 2018, 20:17:57 pm »
Widziałeś to?
https://www.youtube.com/watch?v=9onjKL0KK2I
zwłaszcza to co, gościu klepie w terminalu...

Sorrki, linki mi się pomerdały  :)

EDIT:
Cytuj
The Repetier-Host software has the following requirements:

A recent Linux version
Mono 2.6
Graphic card with OpenGL driver.
Optional: Skeinforge for slicing STL files.
Looks like Mono only supports ANSI baudrates, so don't use 250000 baud.
Installation instuctions
Go to the directory, where you want to install the software. After unpacking you have a new directory in that folder.
Get the latest linux tarball
Unpack: tar -xzf repetierHostLinux.tgz (Name may differ)
Go into directory: cd RepetierHost
Run configuration: sh configureFirst.sh
Make sure your user has permission to access the serial port. On Debian like Linux distributions, this requires membership in group dialout. You can add your user with usermod -a -G dialout yourUserName
Make sure mono and all required libraries are installed. On Debian you can call: apt-get install monodevelop which installs all needed programs and libraries.
Now everyone can start the Host by entering repetierHost (in /usr/bin is a link pointing to your installation).

Za:
https://github.com/repetier/Repetier-Host/wiki/Installation
« Ostatnia zmiana: Październik 06, 2018, 20:22:57 pm wysłana przez yahoob3 »
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

Offline wogabun

  • Dorodna miętowa sadzonka
  • ***
  • Wiadomości: 244
  • Punkty: 2
  • Płeć: Mężczyzna
Odp: AppImage przestał działać
« Odpowiedź #10 dnia: Październik 06, 2018, 22:50:27 pm »
Nic nie pomogło bo przedtem były nadane prawa wykonywania jako programu a ttyUSB dodane do localhost jak pisałem chodził ale cos sie pomieszało i teraz na chwilek pokazuje sie cień okna i znika . Niestety jestem za słaby na to
Wiem że nic nie wiem .. ale inni nawet tego nie wiedzą
Linux tajemny jest albowiem poczekać cierpliwie trzeba i zaczyna działać , aczkolwiek nie zawsze ..... Król Julian

Offline wogabun

  • Dorodna miętowa sadzonka
  • ***
  • Wiadomości: 244
  • Punkty: 2
  • Płeć: Mężczyzna
Odp: [ Rozwiazano ]AppImage przestał działać
« Odpowiedź #11 dnia: Październik 08, 2018, 18:30:45 pm »
Po uruchomieniu programu w konsoli program wypluł błędy i wystarczyło skasować katalog , problem taki jak tu
https://forum.repetier.com/discussion/3813/repetier-stoped-working-open-xbuntu-16-04
Wiem że nic nie wiem .. ale inni nawet tego nie wiedzą
Linux tajemny jest albowiem poczekać cierpliwie trzeba i zaczyna działać , aczkolwiek nie zawsze ..... Król Julian