Forum Linux Mint Polska

Pełna wersja: Jak zainstalować KADU w Mint 20?
Aktualnie przeglądasz uproszczoną wersję forum. Kliknij tutaj, by zobaczyć wersję z pełnym formatowaniem.
Stron: 1 2
Instalujemy następujące paczki (po kliknięciu rozpocznie się ściąganie plików - system pyta czy otworzyć przy pomocy instalatora paczek GDebi - wybieramy tak):
http://ftp.debian.org/debian/pool/main/k....1_all.deb
http://ftp.debian.org/debian/pool/main/k..._amd64.deb
http://ftp.debian.org/debian/pool/main/k..._amd64.deb

U mnie zadziałało:
[Obrazek: HA46X7Il.png]
wszystko dobrze do momentu instalacji ostatniego pakietu pojawia się komunikat
 Błąd: Zależność nie może być spełniona: kadu-common (=4.4-1)
Dziwne, w jakiej kolejności instalowałeś te trzy pakiety?
W miarę świeży Mint 20 i po instalacji w kolejności:
kadu-common
libkadu
kadu
pięknie się zainstalował. Wywala co prawda błąd importu bazy (pewnie kontaktów), ale moje stuletnie kontakty zaimportował, są nawet moje dane, które też gdzieś pod koniec ubiegłego wieku podawałem na GG Smile
Coś więcej powie wynik z
Kod:
apt policy kadu*
(02-07-2020, 17:28)yahoob3 napisał(a): [ -> ]Dziwne, w jakiej kolejności instalowałeś te trzy pakiety?
W miarę świeży Mint 20 i po instalacji w kolejności:
kadu-common
libkadu
kadu
pięknie się zainstalował. Wywala co prawda błąd importu bazy (pewnie kontaktów), ale moje stuletnie kontakty zaimportował, są nawet moje dane, które też gdzieś pod koniec ubiegłego wieku podawałem na GG Smile
w takiej jakiej podawałeś pakiety po kolei. Dziwi mnie że taki program jakim jest Kadu jest zwijany w Mint 20 w Mint 19 instaluje bez problemu poleceniem sudo apt install kadu i po ptokach.
Pokaż wynik apt policy kadu*, jak prosił @dedito i dorzuć jeszcze wynik inxi -r.
Zobaczymy czy mam jakieś inne repozytoria niż Ty.
(03-07-2020, 16:00)yahoob3 napisał(a): [ -> ]Pokaż wynik apt policy kadu*, jak prosił @dedito i dorzuć jeszcze wynik inxi -r.
Zobaczymy czy mam jakieś inne repozytoria niż Ty.
Kod:
[email protected]:~$ apt policy kadu*
kadu-external-modules:
  Zainstalowana: (brak)
  Kandydująca:  (brak)
  Tabela wersji:
kadu-dev:
  Zainstalowana: 4.1-1
  Kandydująca:  4.1-1
  Tabela wersji:
*** 4.1-1 100
        100 /var/lib/dpkg/status
kadu-common:
  Zainstalowana: 4.1-1.1

Kod:
[email protected]:~$ inxi -r
Repos:
  No active apt repos in: /etc/apt/sources.list
  Active apt repos in: /etc/apt/sources.list.d/google-chrome.list
  1: deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
  Active apt repos in: /etc/apt/sources.list.d/google-earth-pro.list
  1: deb [arch=amd64] http://dl.google.com/linux/earth/deb/ stable main
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
  1: deb http://ftp.icm.edu.pl/pub/Linux/dist/linuxmint/packages ulyana main upstream import backport
  2: deb http://archive.ubuntu.com/ubuntu focal main restricted universe multiverse
  3: deb http://archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
  4: deb http://archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ focal partner
  Kandydująca:  4.1-1.1
  Tabela wersji:
*** 4.1-1.1 100
        100 /var/lib/dpkg/status
Pobrałem sobie te kadu i sprawdziłem zależności wewnątrz pliku control:
Cytat:Depends: kadu-common (= 4.1-1)
i tą paczkę masz zainstalowaną, więc chyba coś źle przepisałeś z tym (=4.4-1).
Spróbuj jeszcze raz zainstalować.
(04-07-2020, 12:25)dedito napisał(a): [ -> ]Pobrałem sobie te kadu i sprawdziłem zależności wewnątrz pliku control:
Cytat:Depends: kadu-common (= 4.1-1)
i tą paczkę masz zainstalowaną, więc chyba coś źle przepisałeś z tym (=4.4-1).
Spróbuj jeszcze raz zainstalować.
Kod:
Package: kadu
Version: 4.1-1
Architecture: amd64
Maintainer: Patryk Cisek <[email protected]>
Installed-Size: 5358
Depends: kadu-common (= 4.1-1), libkadu (= 4.1-1), libqca-qt5-2-plugins, libqt5sql5-sqlite, libqt5svg5, libc6 (>= 2.14), libenchant1c2a (>= 1.6.0), libgadu3 (>= 1:1.12.0~pre+r1278), libgcc1 (>= 1:3.0), libgcrypt20 (>= 1.7.0), libidn11 (>= 1.13), libinjeqt1, libmpdclient2 (>= 2.1), libotr5 (>= 4.0.0), libqt5concurrent5 (>= 5.0.2), libqt5core5a (>= 5.7.0), libqt5dbus5 (>= 5.0.2), libqt5gui5 (>= 5.2.0), libqt5multimedia5 (>= 5.6.0~beta), libqt5network5 (>= 5.0.2), libqt5qml5 (>= 5.0.2), libqt5quick5 (>= 5.0.2), libqt5quickwidgets5 (>= 5.3.0), libqt5script5 (>= 5.6.0~beta), libqt5sql5 (>= 5.3.0), libqt5webkit5 (>= 5.6.0~rc), libqt5widgets5 (>= 5.4.0), libqt5x11extras5 (>= 5.6.0), libqt5xml5 (>= 5.0.2), libqt5xmlpatterns5 (>= 5.0.2), libqxmpp0, libstdc++6 (>= 5), libx11-6, libxext6, libxss1, zlib1g (>= 1:1.1.4)
Suggests: kadu-themes
Breaks: kadu-external-modules (<< 1.0)
Replaces: kadu-external-modules (<< 1.0)
Section: net
Priority: optional
Homepage: http://kadu.net
Description: Gadu-Gadu/XMPP client for X11
Gadu-Gadu is a Windows instant messenger, very popular in Poland.
Kadu is a Qt5 client of Gadu-Gadu and XMPP for *nix systems.
.
This package provides Kadu along with plugins developed by Kadu developers.

Dodano po pewnym czasie:
Instalowałem dziś na nowo i bez zmian coś ten Mint 20 mnie nie lubi

Dodano po pewnym czasie:
Nie ten pakiet mi pan podał poszukałem dziś na spokojnie w kadu.deb i znalazłem opodobny ale inna nazwa kadu_4.1-1.1+b1_amd64 i działa i wielkie dzięki
(04-07-2020, 12:59)mac73 warden napisał(a): [ -> ]Nie ten pakiet mi pan podał poszukałem dziś na spokojnie w kadu.deb i znalazłem opodobny ale inna nazwa kadu_4.1-1.1+b1_amd64 i działa i wielkie dzięki
Który konkretnie pakiet był błędnie podany?
Chodzi o ten? http://ftp.debian.org/debian/pool/main/k..._amd64.deb
Stron: 1 2