Forum Linux Mint Polska

Pełna wersja: Problem z instalacją windows 10 w dualboot
Aktualnie przeglądasz uproszczoną wersję forum. Kliknij tutaj, by zobaczyć wersję z pełnym formatowaniem.
Stron: 1 2 3
Witam
Mam taki nie typowy problem z instalacją najnowszego Minta.
Otóż posiadam laptop HP Probook 6460b z zainstalowanym Windowsem 10 w trybie UEFI.
Tylko że mój laptop posiada emulowany tryb UEFI (tak mi sie wydaje bo nie mam Secure Boot)
Pendrive stworzyłem za pomocą Rufusa. Ale gdy bootuje pendrive normalnie czyli wybieram go z listy to nie wykrywa Windowsa 10.
Ale jak wybiorę opcje Boot from EFI files to wtedy widzi Windowsa ale czasami wywala błąd:
Uruchomienie 'grub install /dev/sda1/ nie powiodło się. Błąd Krytyczny po czym instalator się crashuje i system sie nie uruchamia.
Czasami też Mint zainstaluje się bez problemu ale GRUB się nie pojawia.
Już próbowałem różnych sposobów typu install-grub albo upgrade-grub ale to nie działa.
Nawet próbowałem sam partycjonować dyski ale to nic nie dawało.
Proszę na mnie nie krzyczeć że coś po pierniczyłem bo w środowisku Linuxów jestem nowy.
Cześć, uruchom pendrive z Mintem, w terminalu wykonaj te polecenia i pokaż wyniki:

inxi -Fxz

sudo fdisk -l

[ -d /sys/firmware/efi ] && echo UEFI || echo BIOS

Co to znaczy "nie mam Secure Boot"? Nie ma takiej opcji w ustawieniach BIOS?
@magnus
Kod:
[email protected]:~$ inxi -fx2
CPU:
  Topology: Dual Core model: Intel Core i5-2410M bits: 64 type: MT MCP
  arch: Sandy Bridge rev: 7 L2 cache: 3072 KiB bogomips: 18360
  Speed: 798 MHz min/max: 800/2900 MHz Core speeds (MHz): 1: 798 2: 798
  3: 798 4: 798
  Flags: acpi aes aperfmperf apic arat arch_perfmon avx bts clflush cmov
  constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept est
  flexpriority flush_l1d fpu fxsr ht ibpb ibrs ida lahf_lm lm mca mce
  md_clear mmx monitor msr mtrr nonstop_tsc nopl nx pae pat pbe pcid
  pclmulqdq pdcm pebs pge pln pni popcnt pse pse36 pti pts rdtscp rep_good
  sep ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc
  tsc_deadline_timer vme vmx vnmi vpid x2apic xsave xsaveopt xtopology xtpr
Kod:
[email protected]:~$ sudo fdisk -l
Disk /dev/loop0: 1.75 GiB, 1863593984 bytes, 3639832 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/sda: 298.9 GiB, 320072933376 bytes, 625142448 sectors
Disk model: Hitachi HTS72323
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 153D795E-3262-40E2-AF06-F7133C0133B9

Device        Start      End  Sectors  Size Type
/dev/sda1      2048    206847    204800  100M EFI System
/dev/sda2    206848    239615    32768    16M Microsoft reserved
/dev/sda3    239616 517567892 517328277 246.7G Microsoft basic data
/dev/sda4  624099328 625139711  1040384  508M Windows recovery environment
/dev/sda5  517568512 624099327 106530816  50.8G Linux filesystem

Partition table entries are not in disk order.




Disk /dev/sdb: 7.48 GiB, 8022654976 bytes, 15669248 sectors
Disk model: USB Flash Disk 
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x4089a39b

Device    Boot  Start      End  Sectors  Size Id Type
/dev/sdb1  *          0  3876543  3876544  1.9G  0 Empty
/dev/sdb2          648    8583    7936  3.9M ef EFI (FAT-12/16/32)
/dev/sdb3      3878912 15669247 11790336  5.6G 83 Linux
Kod:
[email protected]:~$ [ -d /sys/firmware/efi ] && echo UEFI || echo BIOS
UEFI
Po prostu nie mam takiej opcji pisalem ze mam UEFI chyba emulowane (sorry za brak polskich znakow ale mint live ich nie posiada)

dedito: proszę stosować znaczniki kodu

Dodano po pewnym czasie:
Odpaliłem jeszcze boot-repair ale nic nie naprawił.

załączam log

Pierwszy z pliku boot-repair.log:
http://hastebin.cf/fomifugava.coffeescript
Drugi z pliku RESULTS.txt:


http://hastebin.cf/ojipitinow.bash
W przypadku potrzeby wyłączenia secureboot opis jest na stronie producenta https://support.hp.com/us-en/document/c04784866

Cytat:Secure Boot settings for consumer notebook computers
To enable or disable Secure Boot on an HP notebook computer, first confirm if Legacy Support is available and enabled.
  1. Turn off the computer.
  2. Press the power button to turn on the computer, and then immediately press the Esc key repeatedly until the Startup Menu opens.
    [Obrazek: c03536641.jpg]
  3. Press F10 to open BIOS Setup.
  4. Use the right arrow key to select System Configuration, use the down arrow key to select Boot Options, and then press Enter.
    [Obrazek: c04849960.jpg]
  5. Check for Legacy Support in the list.
    [Obrazek: c05869568.jpg]
    • If Legacy Support is not listed, continue to the next step.
    • If Legacy Support is listed and you are enabling Secure Boot, use the down arrow to select Legacy Support, press Enter, select Disabled, press Enter, and then continue to the next step.
    • If Legacy Support is listed and you are disabling Secure Boot, continue to the next step.
  6. Use the down arrow key to select Secure Boot, and then press Enter.
  7. Use the down arrow key to select Enabled or Disabled depending on your requirements.
    [Obrazek: c03980379.jpg]
  8. Press Enter to save the change.
    • If you enabled Secure Boot, depending on your notebook, press F10 to save the changes and reboot, or use the left arrow key to select the File menu, use the down arrow key to select Save Changes and Exit, and then press Enter to select Yes to confirm the change.
    • If you disabled Secure Boot, continue to the next step.
  9. Use the arrow keys to select Legacy Support, press Enter to change the setting to Enable, press Enter, select Yes in the confirmation window, and then press Enter.
    [Obrazek: c04849964.jpg]
  10. Use the down arrow key to select a device in the Legacy Boot Order menu, and press F5 and F6 to move the device down or up.
    [Obrazek: c04849965.jpg]
  11. Press F10 to accept the changes, use the left arrow key to select Yes, and then press Enter to Exit Saving Changes to restart the computer.
  12. If an Operating System Boot Mode Change message displays, type the code shown, and then press Enter to start Windows.

  13. note:
    Make sure you type the code correctly. There is no text field to see what you are typing. This is expected behavior.

  14. [Obrazek: c04682591.jpg]
  15. Turn off the computer, wait a few seconds, turn on the computer, and then immediately press Esc repeatedly until the Startup menu opens.
  16. When the Startup Menu displays, press F9 to open the Boot Device Options.
    [Obrazek: c04849966.jpg]
  17. When the Boot Manager Window opens, use the down arrow key to select a boot device, and then press Enter to start the computer from the selected device.
    [Obrazek: c04682593.jpg]

Pokaż jeszcze wynik lspci, bo nie jestem pewien w jakim trybie pracuje dysk.
Jeśli w RAID to trzeba będzie go przestawić na IDE.
@dedito ale ja mam taki bios/uefi https://www.youtube.com/watch?v=f_aYkQmOKvE
PRZEŁOM jednak GRUB jest tylko w formie plików jak wymusiłem przez Boot from EFI files żeby zbutował do grub to system Mint się uruchomił.
i normalnie działał tylko jak to ustawić żeby było przed windowsem. Zastosowałem komende:

Kod:
bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi
Ale ona nie zadziałała

Dodano po pewnym czasie:
O to wpisy z bcedit:
Kod:
Windows Boot Manager
--------------------
identifier              {bootmgr}
device                  partition=E:
path                    \EFI\ubuntu\shimx64.efi
description             Windows Boot Manager
locale                  pl-PL
inherit                 {globalsettings}
default                 {current}
resumeobject            {3d38a63d-37e1-11eb-91f8-e44a3d31a06d}
displayorder            {current}
toolsdisplayorder       {memdiag}
timeout                 30

Windows Boot Loader
-------------------
identifier              {current}
device                  partition=C:
path                    \Windows\system32\winload.efi
description             Windows 10
locale                  pl-PL
inherit                 {bootloadersettings}
recoverysequence        {3d38a63f-37e1-11eb-91f8-e44a3d31a06d}
displaymessageoverride  Recovery
recoveryenabled         Yes
isolatedcontext         Yes
allowedinmemorysettings 0x15000075
osdevice                partition=C:
systemroot              \Windows
resumeobject            {3d38a63d-37e1-11eb-91f8-e44a3d31a06d}
nx                      OptIn
bootmenupolicy          Standard
hypervisorlaunchtype    Auto

Dodano po pewnym czasie:
Komende źle zastosowałem bo miałem efi zamontowane i tak to nie działa
Kod:
Windows Boot Manager
--------------------
identifier              {bootmgr}
device                  partition=\Device\HarddiskVolume1
path                    \EFI\ubuntu\shimx64.efi
description             Windows Boot Manager
locale                  pl-PL
inherit                 {globalsettings}
default                 {current}
resumeobject            {3d38a63d-37e1-11eb-91f8-e44a3d31a06d}
displayorder            {current}
toolsdisplayorder       {memdiag}
timeout                 30

Windows Boot Loader
-------------------
identifier              {current}
device                  partition=C:
path                    \Windows\system32\winload.efi
description             Windows 10
locale                  pl-PL
inherit                 {bootloadersettings}
recoverysequence        {3d38a63f-37e1-11eb-91f8-e44a3d31a06d}
displaymessageoverride  Recovery
recoveryenabled         Yes
isolatedcontext         Yes
allowedinmemorysettings 0x15000075
osdevice                partition=C:
systemroot              \Windows
resumeobject            {3d38a63d-37e1-11eb-91f8-e44a3d31a06d}
nx                      OptIn
bootmenupolicy          Standard
hypervisorlaunchtype    Auto
Próbowałeś w ustawieniach BIOS (OS Boot Manager) przesunąć "ubuntu" na pierwszą pozycję na liście i zapisać zmiany?
@magnus nie mam takiej sekcji żeby to przezstawić jeszcze zobacze ale obejrzyj sobie film który wysłałem w poprzednim pościa
Każdy BIOS ma dział z listą urządzeń/systemów do rozruchu (Boot Sequence).

Spróbuj także >> Problemy podczas instalacji systemu w dziale "Brak wyboru systemu przy rozruchu".
(25-12-2020, 14:20)magnus napisał(a): [ -> ]Próbowałeś w ustawieniach BIOS (OS Boot Manager) przesunąć "ubuntu" na pierwszą pozycję na liście i zapisać zmiany?

(25-12-2020, 15:36)Zaptyp napisał(a): [ -> ]@magnus nie mam takiej sekcji żeby to przezstawić jeszcze zobacze ale obejrzyj sobie film który wysłałem w poprzednim pościa

W 1:17 filmu widać, że jest tam UEFI BOOT ORDER i poniżej OS BOOT MANAGER, czyli dokładnie to o czym pisał @magnus.
https://youtu.be/f_aYkQmOKvE?t=77
@dedito jak by można było to bym zmienił o to dowód że nie można https://youtu.be/DTF04cH5q8I
Stron: 1 2 3