Forum Linux Mint Polska

Pełna wersja: Czytnik kart pamięci nie montuje automatycznie karty SD.
Aktualnie przeglądasz uproszczoną wersję forum. Kliknij tutaj, by zobaczyć wersję z pełnym formatowaniem.
Kernel: 4.15.0-140-generic x86_64 (64 bit) Desktop: WindowMaker 0.95.7  Distro: Linux Mint 18.3 Sylvia.Laptop MSI. Nie działa czytnik kart SD. Problem rozwiązuję w następujący sposób:

Kod:
rmmod rtsx_usb_sdmmc
modprobe rtsx_usb_sdmmc

Muszę tak robić za każdym razem, jako ROOT, gdy tylko chcą podmontować kartę. Jeśli włączam laptopa z włożoną kartą, jest ona również dostępna po zalogowaniu, jednakże po jej wyjęciu historia się powtarza. Jak zrobić, aby podmontowywała się automatycznie po umieszczeniu w czytniku, może ktoś coś?
Wyniki polecenia
Kod:
lsusb
z widocznym czytnikiem i niewidocznym byłyby pomocne.
Kod:
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 046d:c019 Logitech, Inc. Optical Tilt Wheel Mouse
Bus 001 Device 004: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 003: ID 8087:0a2a Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


to samo zarówno przy działającym, jak również niedziałającym.

Dedito: używaj znaczników kodu
Spróbuj tego rozwiązania:
Cytat:That said, you can give this a try if you're interested:

Open terminal
Create a file with: xed admin:///etc/modprobe.d/sdcard.conf
Paste this into the file: options sdhci debug_quirks2=0x2
Save the file
Once this is done, we'll need to remove and probe some modules:

sudo rmmod sdhci_acpi sdhci_pci sdhci
sudo modprobe sdhci; sudo modprobe sdhci_acpi; sudo modprobe sdhci_pci
Then, to save the config and make it active:

sudo update-initramfs -u

Za https://askubuntu.com/questions/1298103/...ad-sd-card
Dzięki, próbowałem, ale nie dało rady, pozdrawiam.
Odmontowujesz kartę przed wyjęciem?
Co pokazuje dmesg | tail po wyjęciu i włożeniu karty?