Forum Linux Mint Polska

Pełna wersja: Problem dzwięku - sluchawki Marshall Major 3
Aktualnie przeglądasz uproszczoną wersję forum. Kliknij tutaj, by zobaczyć wersję z pełnym formatowaniem.
Cześć Wszystkim!

Ostatnio zakupiłem słuchawki na kablu Marshall Major 3 - nie piszę po to, aby się pochwalić, ale po to aby móc w pełni cieszyć się z nich korzystania podczas używania Linux Mint.

Otóż na laptopie mam dual boota i na 'windzie' wszystko działa ok - dźwięk jest czysty i dobry.
Na Linux Mint niestety tak nie jest - dźwięk jest mocno zniekształcony, nie potrafię tego dokładnie opisać - jakby odwrócony - główne tony, czy słowa są mocno w tle, natomiast dźwięki z tła są głównymi.

Na wbudowanych głośnikach dźwięk też jest ok.

[Obrazek: xpm8ePEl.png]
Grzebałem się w opcjach dźwięku - niestety przy wszystkich kombinacjach efekt dalej jest taki sam.

Problem na zwyczajnych słuchawkach 'pchełkach' nie istnieje.

Proszę o pomoc.
Z góry dziękuję .

VL

Dodano po pewnym czasie:
UPDATE:

Na windzie efekt jest ten sam do czasu aż po podłączeniu nie wybiorę, że są to słuchawki:
[Obrazek: xlvJGuil.png]

Po tym zabiegu wszyto jest już ok
Proszę podać informacje o konfiguracji sprzętowej/programowej w postaci wyniku polecenia inxi -Fxz (więcej szczegółów uzyskasz klikając w link)

Podając wyniki komend bądź logi proszę używać znaczników - CODE (więcej szczegółów uzyskasz klikając w link)

Więcej zasad, które należy stosować znajdziesz w Zasadach forum

Stosując zasady pomagasz Sobie i Nam bo:
- My nie musimy zajmować się redagowaniem postów, przypominaniem o przestrzeganiu zasad, zbieraniem wystarczającej ilości informacji do udzielenia merytorycznej pomocy.
- Ty masz większe szanse na szybkie otrzymanie merytorycznej odpowiedzi.
Hola hola Smile
Headset to nie to samo co headphones.


EDIT:
Mieliśmy podobny wątek i nawet zaczęło działać, ale... ustawienie właśnie headset "tragizuje" dźwięk.
Z resztą, sam poczytaj Smile
https://forum.linuxmint.pl/showthread.php?tid=1765
Proszę wybaczyć nie stosowania się zasad, obiecuje się z nimi zapoznać i je stosować.




Wynik inxi -Fxz:



Kod:
System:
  Kernel: 5.4.0-91-generic x86_64 bits: 64 compiler: gcc v: 9.3.0
  Desktop: MATE 1.24.0 Distro: Linux Mint 20.2 Uma base: Ubuntu 20.04 focal
Machine:
  Type: Laptop System: Acer product: Aspire ES1-311 v: V1.08
  serial: <filter>
  Mobo: Acer model: Aspire ES1-311 v: V1.08 serial: <filter> UEFI: Insyde
  v: 1.08 date: 09/11/2014
Battery:
  ID-1: BAT0 charge: 44.4 Wh condition: 50.8/48.9 Wh (104%)
  model: LGC AC14B8K status: Discharging
CPU:
  Topology: Quad Core model: Intel Pentium N3540 bits: 64 type: MCP
  arch: Silvermont rev: 8 L2 cache: 1024 KiB
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 17333
  Speed: 500 MHz min/max: 500/2666 MHz Core speeds (MHz): 1: 500 2: 500
  3: 520 4: 634
Graphics:
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
  vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0
  Display: server: X.Org 1.20.11 driver: modesetting unloaded: fbdev,vesa
  resolution: 1366x768~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics (BYT) v: 4.2 Mesa 21.0.3
  direct render: Yes
Audio:
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel
  bus ID: 00:1b.0
  Sound Server: ALSA v: k5.4.0-91-generic
Network:
  Device-1: Broadcom and subsidiaries BCM43142 802.11b/g/n vendor: Lite-On
  driver: wl v: kernel port: 2000 bus ID: 02:00.0
  IF: wls2 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 1000
  bus ID: 03:00.1
  IF: ens3f1 state: down mac: <filter>
Drives:
  Local Storage: total: 953.87 GiB used: 304.03 GiB (31.9%)
  ID-1: /dev/sda model: SSDPR-CX400-01T size: 953.87 GiB temp: 33 C
Partition:
  ID-1: / size: 91.17 GiB used: 20.32 GiB (22.3%) fs: ext4 dev: /dev/sda2
  ID-2: /home size: 368.99 GiB used: 283.68 GiB (76.9%) fs: ext4
  dev: /dev/sda3
  ID-3: swap-1 size: 7.45 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda4
Sensors:
  System Temperatures: cpu: 40.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 240 Uptime: 2m Memory: 3.73 GiB used: 1.91 GiB (51.3%)
  Init: systemd runlevel: 5 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.17
  inxi: 3.0.38




(11-12-2021, 20:54)yahoob3 napisał(a): [ -> ]Hola hola Smile
Headset to nie to samo co headphones.


EDIT:
Mieliśmy podobny wątek i nawet zaczęło działać, ale... ustawienie właśnie headset "tragizuje" dźwięk.
Z resztą, sam poczytaj [Obrazek: smile.png]
https://forum.linuxmint.pl/showthread.php?tid=1765
Tak, nasz rację, jednak z racji tego, że w kablu jest mikrofon, to wybór pada na headset Wink
Właśnie ustawienie headset na windzie działa idealnie.

Niestety nie mogę tego ogarnąć na linuxie.

Dodano po pewnym czasie:
EDIT:

Moje słuchawki są kablowe - nie lubię BT - prywatna preferencja.
a mam problem z dźwiękiem, wątek który podałeś jest o mikrofonie.
Nigdy nie miałem z tym problemu... ale...
Pożyczę jakieś i sprawdzę u siebie. Podłączasz słuchawki kablem USB czy normalnym (4 pinowym) jackiem?

EDIT:
Zasadniczo powinieneś wybrać w OUTPUT - słuchawki, a w INPUT - mikrofon; ten który się pojawi, nie laptopowy. Odezwę się późniejszym wieczorem.

EDIT2:
Zasadniczo, to nie mam nic do dodania do "wybrać w OUTPUT - słuchawki, a w INPUT - mikrofon; ten który się pojawi"
Nie wiem tylko skąd w Mincie bierzesz ustawienie headset... bo go nie ma (jeśli mówimy o zwykłym jacku czteropinowym). Chyba, że bawisz się serwerm dźwięku o nazwie "pipewire"... to rozumiem. Ale to niepotrzebne, poza tym jakość dźwięku tego serwera pozostawia wiele do życzenia. Nie mam niestety do testowania słuchawek USB tylko zwykłe od telefonu z 4pin jackiem i nie mam żadnych problemów - wyjście = słuchawki (headphones); mikrofon - wejście - wybieram ten podłączony. W sumie sam się ustawia - nic nie trzeba kombinować.

Ha, jak się okazuje mam podobny zestaw: słuchawki BT z kablem 4pin, tylko chińskie - HAMA.
Po podłączeniu działa wszystko super. No może poza jakością dźwięku z mikrofonu. Ale... wydaje mi się, że takie słuchawki zostały stworzone (wiem Marshall... ale nawet oni potrafią robić "badziew") do słuchania muzyki z telefonu (BT) plus opcja odebrania telefonu.
Jeszcze jedno "ale". Czy mi się wydaje, czy Twoje słuchawki mają dwa wejścia jack - zarówno w lewej, jak i w prawej słuchawce?

Mam Cinnamon, więc okno wygląda nieco inaczej - słuchawki:

  [Obrazek: topdpQV.png]


mikrofon:

  [Obrazek: 7KE9bG9.png]


Problem z dźwiękiem może wynikać z ustawienia "PulseEffect". Jeśli masz zainstalowany "pavucontrol" i używasz efektów - wyłącz je.


PS Teraz zwróciłem uwagę... przenoszę temat - nie dotyczy LMDE, tylko zwykłego Minta.
Bump/Up
Hej,
Wybaczcie brak odpowiedzi.
Słuchawki miałem w serwisie, temu nie pisałem.
Po update mint na 20.3 problem nie występuje.
Dziękuję za pomoc, można zamykać Smile.