Forum Linux Mint Polska

Pełna wersja: Czarny ekran po wybudzeniu
Aktualnie przeglądasz uproszczoną wersję forum. Kliknij tutaj, by zobaczyć wersję z pełnym formatowaniem.
Stron: 1 2 3
Po ostatniej walce z grub, pojawił sie kolejny problem po wybudzeniu mam czarny ekran muszę ponownie uruchamiać laptopa. Może coś się stało po użyciu boot-repair. Przywróciłem timeshiftem starszą wersję systemu i ten sam problem
Kod:
System:
  Kernel: 5.4.0-96-generic x86_64 bits: 64 compiler: gcc v: 9.3.0
  Desktop: Cinnamon 5.2.7 Distro: Linux Mint 20.3 Una
  base: Ubuntu 20.04 focal
Machine:
  Type: Laptop System: Hewlett-Packard product: HP Compaq 8710p v: F.0E
  serial: <filter>
  Mobo: Hewlett-Packard model: 30C3 v: KBC Version 73.31 serial: <filter>
  BIOS: Hewlett-Packard v: 68MAD Ver. F.0E date: 08/19/2008
Battery:
  ID-1: C1FD charge: 21.7 Wh condition: 0.0/0.0 Wh (100%)
  model: Hewlett-Packard Primary status: Unknown
CPU:
  Topology: Dual Core model: Intel Core2 Duo T7500 bits: 64 type: MCP
  arch: Core Merom rev: B L2 cache: 4096 KiB
  flags: lm nx pae sse sse2 sse3 ssse3 vmx bogomips: 8777
  Speed: 798 MHz min/max: 800/2201 MHz Core speeds (MHz): 1: 798 2: 798
Graphics:
  Device-1: NVIDIA G84GLM [Quadro NVS 320M] vendor: Hewlett-Packard
  driver: nvidia v: 340.108 bus ID: 01:00.0
  Display: x11 server: X.Org 1.20.13 driver: nvidia
  unloaded: fbdev,modesetting,nouveau,vesa resolution: 1680x1050~60Hz
  OpenGL: renderer: Quadro NVS 320M/PCIe/SSE2 v: 3.3.0 NVIDIA 340.108
  direct render: Yes
Audio:
  Device-1: Intel 82801H HD Audio vendor: Hewlett-Packard
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0
  Sound Server: ALSA v: k5.4.0-96-generic
Network:
  Device-1: Intel 82566MM Gigabit Network vendor: Hewlett-Packard
  driver: e1000e v: 3.2.6-k port: 5040 bus ID: 00:19.0
  IF: enp0s25 state: down mac: <filter>
  Device-2: Intel PRO/Wireless 4965 AG or AGN [Kedron] Network
  driver: iwl4965 v: in-tree: port: 4000 bus ID: 10:00.0
  IF: wlp16s0 state: up mac: <filter>
Drives:
  Local Storage: total: 238.47 GiB used: 121.41 GiB (50.9%)
  ID-1: /dev/sda model: SSDPR-CX400-256 size: 238.47 GiB
Partition:
  ID-1: / size: 57.71 GiB used: 44.82 GiB (77.7%) fs: ext4 dev: /dev/sda6
  ID-2: swap-1 size: 3.79 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda8
Sensors:
  System Temperatures: cpu: 51.0 C mobo: 34.0 C gpu: nvidia temp: 51 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 216 Uptime: 4m Memory: 3.78 GiB used: 2.07 GiB (54.7%)
  Init: systemd runlevel: 5 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.17
  inxi: 3.0.38
Nieco stary sterownik masz do GPU. Do starszych kart lepszy byłby chyba 390.
U mnie 340 powodował problemy z Cinnamonem.
Może po ponownej instalacji gruba, trzeba ponownie zainstalować sterownik karty graficznej. Kojarzę że w gruba powinien być odpowiedni zapis przy karcie NVIDIA. Niestety dla tej starej karty sterownik 390 juz nie działa
Faktycznie Smile
Na tej stronce jest o dodaniu nouveau do czarnej listy - to akurat może pomóc:
https://linuxdicasesuporte.blogspot.com/...uster.html
Może po ponownej instalacji gruba, trzeba ponownie zainstalować sterownik karty graficznej. Kojarzę że w gruba powinien być odpowiedni zapis przy karcie NVIDIA. Niestety dla tej starej karty sterownik 390 juz nie działa
Po ponownej instalacji GRUB, nie trzeba ponownie instalować sterownika karty graficznej.
Sprawdź czy uda się przełączyć na konsolę CTRL+ALT+F1

Przydałyby się też logi z plików var/log/dmesgszczególnie te zawierające fragmenty związane z usypianiem i wybudzaniem, u mnie akurat tak się to zgłaszaPM: suspend entry (deep) i PM: suspend exit.
(24-01-2022, 20:29)dedito napisał(a): [ -> ]Po ponownej instalacji GRUB, nie trzeba ponownie instalować sterownika karty graficznej.
Sprawdź czy uda się przełączyć na konsolę CTRL+ALT+F1

Przydałyby się też logi z plików var/log/dmesgszczególnie te zawierające fragmenty związane z usypianiem i wybudzaniem, u mnie akurat tak się to zgłaszaPM: suspend entry (deep) i PM: suspend exit.

Niestety w pliku nie ma tych fragmentów i nie mogę zamieścic zawartosci pliku za duzo znaków
To na pastebina wrzuć.
Niektórym w tej sytuacji pomogło umieszczenie exit 0 na początku pliku /usr/bin/nvidia-sleep.sh. To polecenie powoduje że skrypt nie jest wykonywany.
Po dodaniu exit 0 początek pliku wygląda tak:

Kod:
#!/bin/bash

exit 0

if [ ! -f /proc/driver/nvidia/suspend ]; then
    exit 0
fi

RUN_DIR="/var/run/nvidia-sleep"
XORG_VT_FILE="${RUN_DIR}"/Xorg.vt_number
Przy okazji, wyskoczył mi komunikat w raportach systemowych: wykonaj konwersję usrmerge, czy jest to niezbędne?
Stron: 1 2 3