Forum Linux Mint Polska

Pełna wersja: Po instalacji Mint-a 19.1 komp nie wyłącza się .
Aktualnie przeglądasz uproszczoną wersję forum. Kliknij tutaj, by zobaczyć wersję z pełnym formatowaniem.
Stron: 1 2
Witam wszystkich bardziej doświadczonych .
Od razu mówię , że wykorzystałem opcję ,, szukaj "

Miałem już kilka linux-ów ponieważ Windows przestał mnie bawić i najbardziej podoba mi się mint . Zainstalowałem na komputerze żony Minta 19.1 , śmiga super .
Po przejściach u siebie zainstalowałem również ( walczyłem z biosem ) i powstał kłopot po 1-e nie mógł się zaktualizować bo wywalał mi jakiś błąd ( nie wiem jaki bo na na tych logach się nie znam ) , ale pogmerałem i udało mi się go rozwiązać .
Pewnie kolejne przeinstalowanie systemu pomogło bo instalowałem najpierw 19kę potem 19.1 Xfce następnie Kde i Mate i Cinnamon , który jest najfajniejszy .
Otóż za może 3cim razem jak zainstalowałem zaczął mi się aktualizować , ale nadal nie chciał się wyłączać systemowo ( start - zamknij system ) ja dodatkowo ustawiam sobie zawsze , aby wyłączał mi się po naciśnięciu przycisku start .
Raz np naciskam wyłącznik około 21.30 , ikony znikają , brak reakcji myszy , na dotyk itp po prostu blokuje się tak jakby miał się wyłączyć . Wstałem do łazienki 00.25 to jeszcze komp był włączony ( świecił się pulpit i klawiatura ) , przytrzymałem przycisk i się wyłączył .
Zdarzają się sytuacje , że po naciśnięciu wyłącznika , lapek wyłączy się po 5 - 10 - 15 minutach nie ma reguły .

I teraz moje pytanko : czy istnieje sposób , aby wpisując odpowiednią komendę ( której ja oczywiście nie znam ) w terminalu , uzyskać odpowiedź co jest przyczyną wadliwego wyłączania się i jak usterkę usunąć ?

Z góry dzięx za pomoc .
Podaj nam trochę informacji o sprzęcie: https://forum.linuxmint.pl/showthread.php?tid=304
wg pkt. 5 w sposób opisany w pkt. 4 Smile
Przepraszam i już dodaje :

Kod:
CPU: Quad Core Intel Core i5-7300HQ (-MCP-) speed/min/max: 800/800/3500 MHz
Kernel: 4.15.0-55-generic x86_64 Up: 2h 37m Mem: 1053.9/7858.4 MiB (13.4%)
Storage: 1.14 TiB (51.0% used) Procs: 205 Shell: bash 4.4.20 inxi: 3.0.27
Przydał by się raczej wynik inxi -Fxz tak na początek.
Podaje i może przyśpieszmy  Wink , co ( jakie komendy ) mam wykonać to je zastosuje Big Grin no chyba , że każda komenda jest zależna od poprzedniej Dodgy


System:
Kod:
Host: gawel-X580VD Kernel: 4.15.0-55-generic x86_64 bits: 64 compiler: gcc
  v: 7.4.0 Desktop: Cinnamon 4.0.10 Distro: Linux Mint 19.1 Tessa
  base: Ubuntu 18.04 bionic
Machine:
  Type: Laptop System: ASUSTeK product: X580VD v: 1.0 serial: <filter>
  Mobo: ASUSTeK model: X580VD v: 1.0 serial: <filter>
  UEFI: American Megatrends v: X580VD.308 date: 10/20/2017
Battery:
  ID-1: BAT0 charge: 39.8 Wh condition: 40.0/48.1 Wh (83%)
  model: ASUSTeK ASUS Battery status: Not charging
CPU:
  Topology: Quad Core model: Intel Core i5-7300HQ bits: 64 type: MCP
  arch: Kaby Lake rev: 9 L2 cache: 6144 KiB
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19968
  Speed: 800 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 800 2: 800
  3: 800 4: 800
Graphics:
  Device-1: Intel vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: ASUSTeK
  driver: nouveau v: kernel bus ID: 01:00.0
  Display: x11 server: X.Org 1.19.6 driver: modesetting,nouveau
  unloaded: fbdev,vesa resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2)
  v: 4.5 Mesa 19.0.2 direct render: Yes
Audio:
  Device-1: Intel CM238 HD Audio vendor: ASUSTeK driver: snd_hda_intel
  v: kernel bus ID: 00:1f.3
  Sound Server: ALSA v: k4.15.0-55-generic
Network:
  Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: e000
  bus ID: 03:00.0
  IF: wlp3s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: ASUSTeK driver: r8169 v: 2.3LK-NAPI port: d000 bus ID: 04:00.0
  IF: enp4s0 state: down mac: <filter>
Drives:
  Local Storage: total: 1.14 TiB used: 596.55 GiB (51.0%)
  ID-1: /dev/sda vendor: A-Data model: SP900NS38 size: 238.47 GiB
  ID-2: /dev/sdb vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
  v: 3.0 bus ID: 00:17.0
Partition:
  ID-1: / size: 233.24 GiB used: 10.55 GiB (4.5%) fs: ext4 dev: /dev/sda2
Sensors:
  System Temperatures: cpu: 49.5 C mobo: N/A gpu: nouveau temp: 511 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 205 Uptime: 7h 00m Memory: 7.67 GiB used: 1.05 GiB (13.6%)
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20
  inxi: 3.0.27
Pokaż jeszcze zawartość pliku /etc/default/grub

Komenda xed /etc/default/grub wyświetli jego zwartość - skopiuj i wklej tu na forum.

Zanim to zrobisz, spróbuj uruchomić komputer na oryginalnym jądrze.
Podczas startu komputera przytrzymujesz Shift (wciskasz go zaraz po wciśnięciu klawisza power) do momentu, gdy pojawi się menu GRUB. Następnie wybierasz opcje zaawansowane i wybierasz uruchomienie komputera na starszym jądrze.

EDIT:
Pomóc może jeszcze instalacja nowszego jądra - 4.18 zaraz kończy się wsparcie, więc może warto spróbować 5.x.
Zrobiłem tak jak napisałeś , po wciśnięciu włącznika , nacisnąłem Shift i trzymałem , aż do ...... ekranu powitalnego czyli logowania się do systemu ( hasło ) . Nie pojawiła się opcja GRUB więc się normalnie zalogowałem do kompa .

Piszesz o instalacji nowego jądra , hmm raczej nigdy nie musiałem tego robić , więc nie wiem jak się do tego zabrać .

Podaję co wyskoczyło po komendzie xed /etc/default/grub



Tadam :

Kod:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#  info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
Jak to mówią ,, więcej grzechów nie pamiętam ''

Poczytaj regulamin Smile Kolor zielony jest zarezerwowany.
Jako, że masz dysk SSD, Shift musisz chyba nacisnąć prawie równocześnie z power Smile

Instalację nowszego jądra możesz przeprowadzić z poziomu menedżera aktualizacji - widok - jądra. Zainstaluj na razie najnowsze dostępne.
Postaram odezwać się wieczorem.
Jeśli przytrzymanie klawisza Shift nie działa to spróbuj pojedynczego naciśnięcia klawisza Esc po zniknięciu logo BIOS.
Zainstalowałem najnowsze jądro 5 , ale lapek nadal wyłącza się wolno bo ostatnio po 10 minutach ( około bo dokładnie nie widziałem kiedy klawiatura się wyłączyła ) .
Stron: 1 2