Forum Linux Mint Polska

Pełna wersja: Brak wifi linux mint 19.2 Cinnamon
Aktualnie przeglądasz uproszczoną wersję forum. Kliknij tutaj, by zobaczyć wersję z pełnym formatowaniem.
Stron: 1 2 3
Kod:
[email protected]:~$ sudo apt install libelf-dev libelf-devel
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności     
Odczyt informacji o stanie... Gotowe
E: Nie udało się odnaleźć pakietu libelf-devel

Dodano po pewnym czasie:
Co to znaczy?
Pakiet zaginął gdzieś w czeluściach internetu Smile

Spróbuj zatem:
Kod:
sudo apt install elfutils-libelf-devel


EDIT:
Pewnie nic z tego nie wyjdzie.
WTF?!
Kod:
[email protected]:~$ sudo apt install elfutils-libelf-devel
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności     
Odczyt informacji o stanie... Gotowe
E: Nie udało się odnaleźć pakietu elfutils-libelf-devel

Dodano po pewnym czasie:
Jak? Co? Chyba poprostu wrócę do Windows'a...
Heh, zacznijmy od początku.
Co robiłeś po instalacji systemu?
Najpierw miałem zainstalowane ubuntu, potem zmieniłem na mint’a i... mam go na partycji obok windows’a

Dodano po pewnym czasie:
Więc może to przez to?

Dodano po pewnym czasie:
Something like „dualboot”
Dualboot nie ma tu nic do rzeczy.

Spróbujmy jeszcze czegoś - zainstaluj program UKUU wg tej strony: https://linuxhint.com/upgrade_kernel_linux_mint/
i przy jego pomocy wgraj ostatnie jądro 4.18. Po restarcie komputera podaj wynik polecenia inxi -Fxz.
Zaczęło się pobierac jądro 4.18

Dodano po pewnym czasie:
Kod:
[email protected]:~$ inxi -Fxz
System:
  Host: AngelSagiri Kernel: 4.18.0-041800-generic x86_64 bits: 64 compiler: gcc
  v: 8.2.0 Desktop: Cinnamon 4.2.3 Distro: Linux Mint 19.2 Tina
  base: Ubuntu 18.04 bionic
Machine:
  Type: Laptop System: ASUSTeK product: X555LJ v: 1.0 serial: <filter>
  Mobo: ASUSTeK model: X555LJ v: 1.0 serial: <filter> UEFI: American Megatrends
  v: X555LJ.602 date: 05/06/2016
Battery:
  ID-1: BAT0 charge: 21.8 Wh condition: 23.7/37.3 Wh (63%)
  model: ASUSTeK ASUS Battery status: Charging
CPU:
  Topology: Dual Core model: Intel Core i3-5005U bits: 64 type: MT MCP
  arch: Broadwell rev: 4 L2 cache: 3072 KiB
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 15978
  Speed: 999 MHz min/max: 500/1900 MHz Core speeds (MHz): 1: 999 2: 1000 3: 999
  4: 999
Graphics:
  Device-1: Intel HD Graphics 5500 vendor: ASUSTeK driver: i915 v: kernel
  bus ID: 00:02.0
  Device-2: NVIDIA GK208BM [GeForce 920M] vendor: ASUSTeK driver: nouveau
  v: kernel bus ID: 04:00.0
  Display: x11 server: X.Org 1.19.6 driver: modesetting,nouveau
  unloaded: fbdev,vesa resolution: 1366x768~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2)
  v: 4.5 Mesa 19.0.2 direct render: Yes
Audio:
  Device-1: Intel Broadwell-U Audio vendor: ASUSTeK driver: snd_hda_intel
  v: kernel bus ID: 00:03.0
  Device-2: Intel Wildcat Point-LP High Definition Audio vendor: ASUSTeK
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0
  Sound Server: ALSA v: k4.18.0-041800-generic
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: ASUSTeK driver: r8169 v: 2.3LK-NAPI port: 4000 bus ID: 02:00.0
  IF: enp2s0 state: down mac: <filter>
  Device-2: MEDIATEK MT7630e 802.11bgn Wireless Network Adapter vendor: Foxconn
  driver: N/A port: 4000 bus ID: 03:00.0
  IF-ID-1: enp0s20u3 state: unknown speed: N/A duplex: N/A mac: <filter>
Drives:
  Local Storage: total: 931.51 GiB used: 13.82 GiB (1.5%)
  ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS541010A9E680 size: 931.51 GiB
Partition:
  ID-1: / size: 47.81 GiB used: 13.79 GiB (28.8%) fs: ext4 dev: /dev/sda6
Sensors:
  System Temperatures: cpu: 42.0 C mobo: N/A gpu: nouveau temp: 39 C
  Fan Speeds (RPM): cpu: 2500
Info:
  Processes: 205 Uptime: 2m Memory: 5.73 GiB used: 917.8 MiB (15.7%)
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.19
  inxi: 3.0.32

Dodano po pewnym czasie:
Zrobione

Dodano po pewnym czasie:
I co teraz?
OK, wykonaj jeszcze raz po kolei komendy z tego posta: https://forum.linuxmint.pl/showthread.ph...40#pid3340

Terminal otwórz przez Ctrl+Alt+T
To mi się wyświetliło:
Kod:
[email protected]:~$ sudo apt-get install linux-headers-generic build-essential git
[sudo] password for angelsagiri:       
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności     
Odczyt informacji o stanie... Gotowe
The following additional packages will be installed:
  g++ g++-7 git-man libc-dev-bin libc6-dev libstdc++-7-dev linux-headers-4.15.0-62 linux-headers-4.15.0-62-generic
Sugerowane pakiety:
  g++-multilib g++-7-multilib gcc-7-doc libstdc++6-7-dbg git-daemon-run | git-daemon-sysvinit git-doc git-el git-email git-gui gitk gitweb git-cvs git-mediawiki
  git-svn glibc-doc libstdc++-7-doc
Zostaną zainstalowane następujące NOWE pakiety:
  build-essential g++ g++-7 libc-dev-bin libc6-dev libstdc++-7-dev linux-headers-4.15.0-62 linux-headers-4.15.0-62-generic linux-headers-generic
Następujące pakiety zostaną zaktualizowane:
  git git-man
2 aktualizowanych, 9 nowo instalowanych, 0 usuwanych i 246 nieaktualizowanych.
Konieczne pobranie 28,7 MB archiwów.
Po tej operacji zostanie dodatkowo użyte 149 MB miejsca na dysku.
Kontynuować? [T/n] T
Pobieranie:1 http://archive.ubuntu.com/ubuntu bionic/main amd64 libc-dev-bin amd64 2.27-3ubuntu1 [71,8 kB]
Pobieranie:2 http://archive.ubuntu.com/ubuntu bionic/main amd64 libc6-dev amd64 2.27-3ubuntu1 [2 587 kB]
Pobieranie:3 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 libstdc++-7-dev amd64 7.4.0-1ubuntu1~18.04.1 [1 468 kB]
Pobieranie:4 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 g++-7 amd64 7.4.0-1ubuntu1~18.04.1 [7 574 kB]
Pobieranie:5 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 g++ amd64 4:7.4.0-1ubuntu2.3 [1 568 B]                                                         
Pobieranie:6 http://archive.ubuntu.com/ubuntu bionic/main amd64 build-essential amd64 12.4ubuntu1 [4 758 B]                                                           
Pobieranie:7 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 git amd64 1:2.17.1-1ubuntu0.4 [3 907 kB]                                                       
56% [Pracuje]                                                                                                                                              940 kB/s 13slPobieranie:8 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 git-man all 1:2.17.1-1ubuntu0.4 [803 kB]                                                       
Pobieranie:9 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 linux-headers-4.15.0-62 all 4.15.0-62.69 [11,1 MB]                                             
Pobieranie:10 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 linux-headers-4.15.0-62-generic amd64 4.15.0-62.69 [1 230 kB]                                  e
Pobieranie:11 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 linux-headers-generic amd64 4.15.0.62.64 [2 352 B]                                           
Pobrano 28,7 MB w 24s (1 186 kB/s)                                                                                                                                     
.comWybieranie wcześniej niewybranego pakietu libc-dev-bin.
(Odczytywanie bazy danych ... 286503 pliki i katalogi obecnie zainstalowane.)
Przygotowywanie do rozpakowania pakietu .../00-libc-dev-bin_2.27-3ubuntu1_amd64.deb ...
bRozpakowywanie pakietu libc-dev-bin (2.27-3ubuntu1) ...
enWybieranie wcześniej niewybranego pakietu libc6-dev:amd64.
Przygotowywanie do rozpakowania pakietu .../01-libc6-dev_2.27-3ubuntu1_amd64.deb ...
Rozpakowywanie pakietu libc6-dev:amd64 (2.27-3ubuntu1) ...
jarWybieranie wcześniej niewybranego pakietu libstdc++-7-dev:amd64.
Przygotowywanie do rozpakowania pakietu .../02-libstdc++-7-dev_7.4.0-1ubuntu1~18.04.1_amd64.deb ...
Rozpakowywanie pakietu libstdc++-7-dev:amd64 (7.4.0-1ubuntu1~18.04.1) ...
obinWybieranie wcześniej niewybranego pakietu g++-7.
Przygotowywanie do rozpakowania pakietu .../03-g++-7_7.4.0-1ubuntu1~18.04.1_amd64.deb ...
Rozpakowywanie pakietu g++-7 (7.4.0-1ubuntu1~18.04.1) ...
Wybieranie wcześniej niewybranego pakietu g++.
Przygotowywanie do rozpakowania pakietu .../04-g++_4%3a7.4.0-1ubuntu2.3_amd64.deb ...
Rozpakowywanie pakietu g++ (4:7.4.0-1ubuntu2.3) ...
Wybieranie wcześniej niewybranego pakietu build-essential.
Przygotowywanie do rozpakowania pakietu .../05-build-essential_12.4ubuntu1_amd64.deb ...
Rozpakowywanie pakietu build-essential (12.4ubuntu1) ...
/Przygotowywanie do rozpakowania pakietu .../06-git_1%3a2.17.1-1ubuntu0.4_amd64.deb ...
MRozpakowywanie pakietu git (1:2.17.1-1ubuntu0.4) nad (1:2.17.0-1ubuntu1) ...
TPrzygotowywanie do rozpakowania pakietu .../07-git-man_1%3a2.17.1-1ubuntu0.4_all.deb ...
Rozpakowywanie pakietu git-man (1:2.17.1-1ubuntu0.4) nad (1:2.17.0-1ubuntu1) ...
76Wybieranie wcześniej niewybranego pakietu linux-headers-4.15.0-62.
Przygotowywanie do rozpakowania pakietu .../08-linux-headers-4.15.0-62_4.15.0-62.69_all.deb ...
Rozpakowywanie pakietu linux-headers-4.15.0-62 (4.15.0-62.69) ...
30E.gitWybieranie wcześniej niewybranego pakietu linux-headers-4.15.0-62-generic.
Przygotowywanie do rozpakowania pakietu .../09-linux-headers-4.15.0-62-generic_4.15.0-62.69_amd64.deb ...
Rozpakowywanie pakietu linux-headers-4.15.0-62-generic (4.15.0-62.69) ...
Wybieranie wcześniej niewybranego pakietu linux-headers-generic.
Przygotowywanie do rozpakowania pakietu .../10-linux-headers-generic_4.15.0.62.64_amd64.deb ...
Rozpakowywanie pakietu linux-headers-generic (4.15.0.62.64) ...
Konfigurowanie pakietu git-man (1:2.17.1-1ubuntu0.4) ...
Konfigurowanie pakietu linux-headers-4.15.0-62 (4.15.0-62.69) ...
Przetwarzanie wyzwalaczy pakietu man-db (2.8.3-2ubuntu0.1)...
Konfigurowanie pakietu libc-dev-bin (2.27-3ubuntu1) ...
Konfigurowanie pakietu libc6-dev:amd64 (2.27-3ubuntu1) ...
Konfigurowanie pakietu git (1:2.17.1-1ubuntu0.4) ...
Konfigurowanie pakietu linux-headers-4.15.0-62-generic (4.15.0-62.69) ...
/etc/kernel/header_postinst.d/dkms:
* dkms: running auto installation service for kernel 4.15.0-62-generic
  ...done.
Konfigurowanie pakietu libstdc++-7-dev:amd64 (7.4.0-1ubuntu1~18.04.1) ...
Konfigurowanie pakietu linux-headers-generic (4.15.0.62.64) ...
Konfigurowanie pakietu g++-7 (7.4.0-1ubuntu1~18.04.1) ...
Konfigurowanie pakietu g++ (4:7.4.0-1ubuntu2.3) ...
update-alternatives: użycie /usr/bin/g++ jako dostarczającego /usr/bin/c++ (c++) w trybie automatycznym
Konfigurowanie pakietu build-essential (12.4ubuntu1) ...
[email protected]:~$ git clone https://github.com/benjarobin/MT7630E.git
fatal: destination path 'MT7630E' already exists and is not an empty directory.
[email protected]:~$ cd MT7630E/rt2x00
[email protected]:~/MT7630E/rt2x00$ make
make -C /lib/modules/4.18.0-041800-generic/build M=/home/angelsagiri/MT7630E/rt2x00 modules
make[1]: Entering directory '/usr/src/linux-headers-4.18.0-041800-generic'
Makefile:938: "Cannot use CONFIG_STACK_VALIDATION=y, please install libelf-dev, libelf-devel or elfutils-libelf-devel"
  CC [M]  /home/angelsagiri/MT7630E/rt2x00/rt2x00dev.o
/home/angelsagiri/MT7630E/rt2x00/rt2x00dev.c: In function ‘rt2x00lib_rxdone’:
/home/angelsagiri/MT7630E/rt2x00/rt2x00dev.c:792:19: error: ‘RX_FLAG_HT’ undeclared (first use in this function); did you mean ‘RX_ENC_HT’?
  rxdesc.flags |= RX_FLAG_HT;
                  ^~~~~~~~~~
                  RX_ENC_HT
/home/angelsagiri/MT7630E/rt2x00/rt2x00dev.c:792:19: note: each undeclared identifier is reported only once for each function it appears in
scripts/Makefile.build:317: recipe for target '/home/angelsagiri/MT7630E/rt2x00/rt2x00dev.o' failed
make[2]: *** [/home/angelsagiri/MT7630E/rt2x00/rt2x00dev.o] Error 1
Makefile:1500: recipe for target '_module_/home/angelsagiri/MT7630E/rt2x00' failed
make[1]: *** [_module_/home/angelsagiri/MT7630E/rt2x00] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-4.18.0-041800-generic'
Makefile:22: recipe for target 'all' failed
make: *** [all] Error 2
[email protected]:~/MT7630E/rt2x00$ sudo make install
make: *** No rule to make target 'install'.  Stop.
[email protected]:~/MT7630E/rt2x00$ sudo modprobe mt7630
modprobe: FATAL: Module mt7630 not found in directory /lib/modules/4.18.0-041800-generic
[email protected]:~/MT7630E/rt2x00$

Dodano po pewnym czasie:
I co macie jakieś pomysły?
Coś masz powalone już w systemie... zamiast zainstalować się headersy do 4.18... poleciało znów 4.15.

Wykonaj tak:
Kod:
sudo apt-get install linux-headers-generic build-essential

EDIT:
Wróć!
Ta komenda zainstalowała 4,15... wykonaj tak:
Kod:
sudo apt-get install --reinstall linux-headers-$(uname -r) build-essential dkms
Stron: 1 2 3