Brak dżwięku w systemie.

  • 26 replies
  • 13627 views
*

mario-mario

Brak dżwięku w systemie.
« dnia: Kwiecień 01, 2012, 16:39:37 pm »
Witam. Po zainstalowaniu na swoim pc zinstalowałem naszego minta na komputerze siostrzeńca. Zrobiełem tak ja sir lucjan polecił mi wcześniej, zamieniłem repozytoria mint debian na debian testing i zaktualizowałem cały system. Wszystko udało się dobrze, najnowsze jądro 3.2 i system bardzo sprawnie działa. Jadnak mam poważny probelm, nie mam dzwięku. Znalazłem niby rozwiązanie problmu, czyli w /usr/share/alsa/pulse-alsa.conf usunąłem ostatnich dwadzieścia linijek i nic z tego. Co gorsze pc ma dwie karty dzwiękowe intela i dodatkową yamaha, na której zainstalowany windows działa,  Nie wiem jak sobie z tym poradzić. Bradzo proszę o pomoc, gdyż z tą yamahą to naprawdę wielki problem, trzeba zaistalować chyba takie pakiety  snd_ymfpci: yamaha/ds1e_ctrl.fw, yamaha/ds1_ctrl.fw, yamaha/ds1_dsp.fw, z tym że nie ma ich w repozytorich.
« Ostatnia zmiana: Kwiecień 01, 2012, 17:50:32 pm wysłana przez mario-mario »

*

Offline bossot

  • ***
  • 100
  • 0
Odp: Brak dżwięku w systemie.
« Odpowiedź #1 dnia: Kwiecień 01, 2012, 18:59:53 pm »
prawoklik na głośniczek/wybierz główny kanał i sprawdź co tam jest ustawione

*

mario-mario

Odp: Brak dżwięku w systemie.
« Odpowiedź #2 dnia: Kwiecień 01, 2012, 19:07:06 pm »
Widać tylko tyle:
karta dżwiękowa Intel 82801BA-ICH2  (Alsa mixer)
Kanał Główny
Najgorsze jest to, że nie widać karty Yamaha
lspci
00:00.0 Host bridge: Intel Corporation 82845 845 [Brookdale] Chipset Host Bridge (rev 04)
00:01.0 PCI bridge: Intel Corporation 82845 845 [Brookdale] Chipset AGP Bridge (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 05)
00:1f.0 ISA bridge: Intel Corporation 82801BA ISA Bridge (LPC) (rev 05)
00:1f.1 IDE interface: Intel Corporation 82801BA IDE U100 Controller (rev 05)
00:1f.2 USB controller: Intel Corporation 82801BA/BAM USB Controller #1 (rev 05)
00:1f.3 SMBus: Intel Corporation 82801BA/BAM SMBus Controller (rev 05)
00:1f.4 USB controller: Intel Corporation 82801BA/BAM USB Controller #1 (rev 05)
00:1f.5 Multimedia audio controller: Intel Corporation 82801BA/BAM AC'97 Audio Controller (rev 05)
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)
02:00.0 Multimedia audio controller: Yamaha Corporation YMF-724F [DS-1 Audio Controller] (rev 03)
02:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:03.0 USB controller: ALi Corporation USB 1.1 Controller (rev 03)
02:03.1 USB controller: ALi Corporation USB 1.1 Controller (rev 03)
02:03.2 USB controller: ALi Corporation USB 1.1 Controller (rev 03)
02:03.3 USB controller: ALi Corporation USB 2.0 Controller (rev 01)
A jak w terminalu otwieram alsamixer to w opisie Cards widzę wpis PulseAudio

*

Offline euklides

  • *****
  • 343
  • 72
  • Płeć: Mężczyzna
Odp: Brak dżwięku w systemie.
« Odpowiedź #3 dnia: Kwiecień 01, 2012, 19:39:49 pm »
A ja widze dwie karty audio tak więc w pulseaudio wybierz jedna z nich i powinno działać , Jak chcesz z Yamaha korzystać to wskaż w input i w output tą kartę .

00:1f.5 Multimedia audio controller: Intel Corporation 82801BA/BAM AC'97 Audio Controller (rev 05)
02:00.0 Multimedia audio controller: Yamaha Corporation YMF-724F [DS-1 Audio Controller] (rev 03)
OS: Ubuntu Bionic Beaver (development branch) x86_64
Kernel: 4.13.0-32-generic
DE: Unity7

*

mario-mario

Odp: Brak dżwięku w systemie.
« Odpowiedź #4 dnia: Kwiecień 01, 2012, 19:45:23 pm »
System widzi tylko, że mam jedną kartę zainstalowaną
sudo cat /proc/asound/cards
 0 [I82801BAICH2   ]: ICH - Intel 82801BA-ICH2
                      Intel 82801BA-ICH2 with ALC650F at irq 17

Dodany: [time]Kwiecień 01, 2012, 07:51:34 [/time]
euklides możesz mi opisać jak przestawić, ąby Yamaha działała. Będę bardzo wdzięczny, ponieważ to moje trudne początki i nie wiem jak dokładnie to zrobić, Zależy mi tyko, żeby odpalić dźwięk na karcie yamaha
Dodany: Kwiecień 01, 2012, 22:36:25 pm
Udało mi się zainstalować kartę yamaha. ale nadal nie ma dżwięku.
sudo cat /proc/asound/cards
[sudo] password for patryk:
 0 [I82801BAICH2   ]: ICH - Intel 82801BA-ICH2
                      Intel 82801BA-ICH2 with ALC650F at irq 17
 1 [YMF724F        ]: YMF724F - Yamaha DS-1 (YMF724F)
                      Yamaha DS-1 (YMF724F) at 0xe2000000, irq 17
Co dalej trzeba zrobić? Jak uruchamiam alsamixer to widać taką informację.
 Card: PulseAudio                                    F1:  Help             
│ Chip: PulseAudio                                    F2:  System information
│ View: F3:[Playback] F4: Capture  F5: All            F6:  Select sound card
│ Item: Master 
Czy tak powinno być, czy nie powinienem widzieć wpis  Card: Yamaha DS-1 (YMF724F)?
« Ostatnia zmiana: Kwiecień 01, 2012, 22:36:25 pm wysłana przez mario-mario »

*

Offline bossot

  • ***
  • 100
  • 0
Odp: Brak dżwięku w systemie.
« Odpowiedź #5 dnia: Kwiecień 02, 2012, 07:55:41 am »
Zamiast bawić się alsamixerem lepiej zainstaluj pakiet pavucontrol. W multimediach pojawi ci się kontrola głośności pulse audio, a tam w ostatniej zakładce będziesz mógł wyłączyć "integrę". Zabawa z alsamixerem może trochę potrwać, miałem podobny problem tyle że u mnie dźwięk domyślnie szedł do "karty dźwiękowej" HDMI (na karcie graficznej).

*

mario-mario

Odp: Brak dżwięku w systemie.
« Odpowiedź #6 dnia: Kwiecień 02, 2012, 16:05:32 pm »
Panowie nic nie działa. Boje się, że coraz bardziej zbliżam się do przepaści, ciągle coś zmieniam, a tu nic. marcin 82 tak robię, F6 przechodzę na kartę yamaha i nic. Odpalam ponownie alsamixer i ten sam widok,  Card: PulseAudio. bossot jak otwieram pavucontrol z terminala to od razu widać, że coś nie tak
pavucontrol
** (pavucontrol:3059): DEBUG: Failed to initialize device manager extension: Nie ma takiego rozszerzenia
Ratujcie proszę, bo tracę nadzieję i warę, że linux jest fajnym systemem.
Mam jeszcze prośbę. Tak pokombinowałem ze zmianami w etc/modprobe.d/, że nie wiem czy nie zabardzo, i teraz nie wiem jak pownna być zawartość tego katalogu. Może podesłalibyście jakie tam macie pliki?
patryk@patryk ~ $ ls /etc/modprobe.d
alsa-base-blacklist.conf  dkms.conf                    oss-compat.conf
alsa-base.conf            fbdev-blacklist.conf         radeon-kms.conf
alsa.conf                 i915-kms.conf
alsa.conf.dpkg-bak        linux-sound-base_noOSS.conf

*

mario-mario

Odp: Brak dżwięku w systemie.
« Odpowiedź #7 dnia: Kwiecień 02, 2012, 16:51:03 pm »
Jak sam zauważyłeś nie mam takiego pliku, Zrobiłem jedynie taką operację: do pliku /etc/modprobe.d/alsa-base.conf dopisałem
options snd-emu10k1 index=0
options snd-hda-intel index=1
Po tym słyszalny jest jakiś szum z głośników, czego przedtem nie było.
To mam stworzyć plik sound i tam umieścić ten wpis?

*

mario-mario

Odp: Brak dżwięku w systemie.
« Odpowiedź #8 dnia: Kwiecień 02, 2012, 17:20:38 pm »
patryk@patryk ~ $ lspci -k
00:00.0 Host bridge: Intel Corporation 82845 845 [Brookdale] Chipset Host Bridge (rev 04)
Subsystem: EPoX Computer Co., Ltd. Device 4001
Kernel driver in use: agpgart-intel
00:01.0 PCI bridge: Intel Corporation 82845 845 [Brookdale] Chipset AGP Bridge (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 05)
00:1f.0 ISA bridge: Intel Corporation 82801BA ISA Bridge (LPC) (rev 05)
00:1f.1 IDE interface: Intel Corporation 82801BA IDE U100 Controller (rev 05)
Subsystem: EPoX Computer Co., Ltd. Device 4001
Kernel driver in use: ata_piix
00:1f.2 USB controller: Intel Corporation 82801BA/BAM USB Controller #1 (rev 05)
Subsystem: EPoX Computer Co., Ltd. Device 4001
Kernel driver in use: uhci_hcd
00:1f.3 SMBus: Intel Corporation 82801BA/BAM SMBus Controller (rev 05)
Subsystem: EPoX Computer Co., Ltd. Device 4001
Kernel driver in use: i801_smbus
00:1f.4 USB controller: Intel Corporation 82801BA/BAM USB Controller #1 (rev 05)
Subsystem: EPoX Computer Co., Ltd. Device 4001
Kernel driver in use: uhci_hcd
00:1f.5 Multimedia audio controller: Intel Corporation 82801BA/BAM AC'97 Audio Controller (rev 05)
Subsystem: EPoX Computer Co., Ltd. Device 4001
Kernel driver in use: snd_intel8x0
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)
Kernel driver in use: nouveau
02:00.0 Multimedia audio controller: Yamaha Corporation YMF-724F [DS-1 Audio Controller] (rev 03)
Subsystem: Yamaha Corporation DS-XG PCI Audio CODEC
Kernel driver in use: snd_ymfpci
02:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
Subsystem: Compex FN22-3(A) LinxPRO Ethernet Adapter
Kernel driver in use: 8139too
02:03.0 USB controller: ALi Corporation USB 1.1 Controller (rev 03)
Subsystem: ALi Corporation ASRock 939Dual-SATA2 Motherboard
Kernel driver in use: ohci_hcd
02:03.1 USB controller: ALi Corporation USB 1.1 Controller (rev 03)
Subsystem: ALi Corporation ASRock 939Dual-SATA2 Motherboard
Kernel driver in use: ohci_hcd
02:03.2 USB controller: ALi Corporation USB 1.1 Controller (rev 03)
Subsystem: ALi Corporation ASRock 939Dual-SATA2 Motherboard
Kernel driver in use: ohci_hcd
02:03.3 USB controller: ALi Corporation USB 2.0 Controller (rev 01)
Subsystem: ALi Corporation ASRock 939Dual-SATA2 Motherboard
Kernel driver in use: ehci_hcd
Wiem, że trudny jestem, ale nie wiem do którego pliku dopisać i gdzie, Czy do alsa-base.conf?

*

mario-mario

Odp: Brak dżwięku w systemie.
« Odpowiedź #9 dnia: Kwiecień 02, 2012, 17:42:39 pm »
Niestety nadal cisza. Przerasta mnie i to bardzo. Trzeci dzień walczę i nic :(

*

mario-mario

Odp: Brak dżwięku w systemie.
« Odpowiedź #10 dnia: Kwiecień 02, 2012, 17:46:31 pm »
A dlaczego jak urachamiam alsamixer to zawsze widzę to:
Card: PulseAudio                                                 F1:  Help             
│ Chip: PulseAudio                                              F2:  System information
│ View: F3:[Playback] F4: Capture  F5: All          F6:  Select sound card
│ Item: Master   
 a nie katrę yamahy?
Jak to przestawić? F6 przechodzę na yamaha, enter i nic,
Dodany: Kwiecień 02, 2012, 17:48:02 pm
patryk@patryk ~ $ sudo dpkg -l | grep pulse
[sudo] password for patryk:
ii  gstreamer0.10-pulseaudio:i386                 0.10.31-1                       GStreamer plugin for PulseAudio
rc  libpulse-browse0                              0.9.21-4                        PulseAudio client libraries (zeroconf support)
ii  libpulse-mainloop-glib0:i386                  1.1-3                           PulseAudio client libraries (glib support)
ii  libpulse0:i386                                1.1-3                           PulseAudio client libraries
ii  pulseaudio                                    1.1-3                           PulseAudio sound server
ii  pulseaudio-esound-compat                      1.1-3                           PulseAudio ESD compatibility layer
ii  pulseaudio-module-gconf                       1.1-3                           GConf module for PulseAudio sound server
ii  pulseaudio-module-zeroconf                    1.1-3                           Zeroconf module for PulseAudio sound server
ii  pulseaudio-utils                              1.1-3                           Command line tools for the PulseAudio sound server
ii  vlc-plugin-pulse                              1:2.0.1-0.0                     PulseAudio plugin for VLC
« Ostatnia zmiana: Kwiecień 02, 2012, 17:48:02 pm wysłana przez mario-mario »

*

mario-mario

Odp: Brak dżwięku w systemie.
« Odpowiedź #11 dnia: Kwiecień 02, 2012, 18:10:42 pm »
Nadal nic. Po tamtym wpisie do alsa-base.conf po restarcie komputera ja się już system załaduje to widać ja nagle zostaje całkiem wyciszony, krzyzk nagle pojawia się na głośniku, i szum z głośników wtedy znika. W alsamixer jak wciskam F6 to widzię, że zmieniła się klejność kart
│0  Yamaha DS-1 (YMF724F)
1  Intel 82801BA-ICH2   
Przedtem było na odwrót  Jednak nadal to jest jak się włączy alsę.
 Card: PulseAudio                           
│ Chip: PulseAudio                                 
│ View: F3:[Playback] F4: Capture  F5: All         
│ Item: Master     

*

mario-mario

Odp: Brak dżwięku w systemie.
« Odpowiedź #12 dnia: Kwiecień 02, 2012, 18:24:10 pm »
Trochę mi głupio, ale nie rozumiem tego polecenia.

*

mario-mario

Odp: Brak dżwięku w systemie.
« Odpowiedź #13 dnia: Kwiecień 02, 2012, 18:31:15 pm »
patryk@patryk ~ $ sudo apt-get -s --purge remove pulseaudio
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Następujące pakiety zostaną USUNIĘTE:
  paprefs* pulseaudio* pulseaudio-esound-compat* pulseaudio-module-gconf*
  pulseaudio-module-zeroconf*
0 aktualizowanych, 0 nowo instalowanych, 5 usuwanych i 0 nieaktualizowanych.
Purg paprefs [0.9.9-2]
Purg pulseaudio-module-zeroconf [1.1-3]
Purg pulseaudio-module-gconf [1.1-3]
Purg pulseaudio-esound-compat [1.1-3]
Purg pulseaudio [1.1-3]

*

mario-mario

Odp: Brak dżwięku w systemie.
« Odpowiedź #14 dnia: Kwiecień 02, 2012, 18:49:06 pm »
Działa, wreszcie działa. Bardzo dziękuję za kolejną pomoc,