Autor Wątek: xUbuntu 12.10 "Przecinanie" obrazu wideo na pełnym ekranie.  (Przeczytany 7162 razy)

Offline stiff

  • Miętowy Kumpel
  • Dorodna miętowa sadzonka
  • *****
  • Wiadomości: 128
  • Punkty: 60
  • Płeć: Mężczyzna
    • Free Software Linkownia
xUbuntu 12.10 "Przecinanie" obrazu wideo na pełnym ekranie.
« dnia: Listopad 03, 2012, 13:48:27 pm »
Witam.

Zauważyłem problem w xUbuntu 12.10. "Przecinanie" obrazu wideo na pełnym ekranie. Z tego co doczytałem nazywa się to tearing. Jak mam włączone kompozycje (te wszystkie cienie i przezroczystości) to "przecina" obraz video podczas oglądania na pełnym ekranie.

Doczytałem, że to problem braku opcji synchronizaji czegoś tam w menedżerze okien.
http://www.webupd8.org/2012/10/xfce-sync-to-vblank-support-for-xfwm.html
Jest w linku jakieś rozwiązanie, ale nie działa z kartami nvidia. A ja taką właśnie posiadam (taką przynajmniej mam podłączoną).

Czy jest sposób na to, żeby móc właczyć kompozycje (cieniowanie, przezroczystości) i oglądać bez problemu wideo?

Offline aras

  • Miętowy Kumpel
  • Miętowy krzew
  • *****
  • Wiadomości: 358
  • Punkty: 756
  • Płeć: Mężczyzna
  • linux to linux
    • http://cojesturokiem.blogspot.com
Odp: xUbuntu 12.10 "Przecinanie" obrazu wideo na pełnym ekranie.
« Odpowiedź #1 dnia: Listopad 03, 2012, 16:48:57 pm »
z linuxem jak z kobietą, musisz zaakceptować wady i zalety, jak chcesz sobie poużywać ;)

Offline stiff

  • Miętowy Kumpel
  • Dorodna miętowa sadzonka
  • *****
  • Wiadomości: 128
  • Punkty: 60
  • Płeć: Mężczyzna
    • Free Software Linkownia
Odp: xUbuntu 12.10 "Przecinanie" obrazu wideo na pełnym ekranie.
« Odpowiedź #2 dnia: Listopad 03, 2012, 18:48:53 pm »
Podaj wynik:
lspci -k | grep -A2 VGAglxinfo | grep renderingJeśli nie znaleziono drugiego polecenia to zainstaluj pakiet mesa-utils.

lspci -k | grep -A2 VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 440] (rev a1)
Kernel driver in use: nvidia
Kernel modules: nvidia_current, nouveau, nvidiafb

glxinfo | grep rendering
direct rendering: Yes
    GL_NV_parameter_buffer_object2, GL_NV_path_rendering,

Dodany: Listopad 03, 2012, 18:55:25 pm
może to CI pomoże http://en.wikipedia.org/wiki/VDPAU

Kiepsko u mnie z angielskim. Ale może chodzi o to żeby ustawić sterownik wyjściowy na VDPAU? Jak tak to jak ustawię to zmienia się sposób "psucia" ekranu. Z jednej linii przecinającej w dolnej części ekranu na takie cętkowanie w różnych miejscach ekranu.

Offline stiff

  • Miętowy Kumpel
  • Dorodna miętowa sadzonka
  • *****
  • Wiadomości: 128
  • Punkty: 60
  • Płeć: Mężczyzna
    • Free Software Linkownia
Odp: xUbuntu 12.10 "Przecinanie" obrazu wideo na pełnym ekranie.
« Odpowiedź #3 dnia: Listopad 12, 2012, 09:33:28 am »
Nikt nie zna rozwiązania? Bo z tego co czytam to dosyć powszechny problem i dziwi mnie to trochę, że nie robią nic z tym. A z tego co sam zaobserwowałem to problem nie występuje tylko w jednej dystrybucji. Instalując różne wersje ubuntu, mint (12.04, 12.10) to na każdej z nich był ten problem.

Offline mati75

  • Rodzina Linux Mint
  • Administrator
  • Spamerzy
  • *******
  • Wiadomości: 2399
  • Punkty: 25121
  • Płeć: Mężczyzna
    • >>>Click me!<<<
Odp: xUbuntu 12.10 "Przecinanie" obrazu wideo na pełnym ekranie.
« Odpowiedź #4 dnia: Listopad 12, 2012, 11:07:56 am »
U mnie działa normalnie.

υωαgα α∂мιи !!! вαиαмι иαριєя∂αℓα !!!

Offline yossarian

  • Siewca Mięty
  • Dorodna miętowa sadzonka
  • *****
  • Wiadomości: 156
  • Punkty: 211
Odp: xUbuntu 12.10 "Przecinanie" obrazu wideo na pełnym ekranie.
« Odpowiedź #5 dnia: Listopad 12, 2012, 11:57:12 am »
xfwm4 już tak ma.
Jakość zamkniętych sterów wbrew pozorom jest żałosna. Stery AMD jak i Nvidii to syf, który się wykłada przy KMS i kompozycjach.
Poszukaj w ustawieniach Nvidii czegoś co się nazywa Sync to VBlank.
Można jeszcze dodać do xorg.conf, w sekcji Device:
Option "TearFree" "true"
Szanse raczej małe.
Wyłącz kompozycje na czas oglądania filmów.

Offline stiff

  • Miętowy Kumpel
  • Dorodna miętowa sadzonka
  • *****
  • Wiadomości: 128
  • Punkty: 60
  • Płeć: Mężczyzna
    • Free Software Linkownia
Odp: xUbuntu 12.10 "Przecinanie" obrazu wideo na pełnym ekranie.
« Odpowiedź #6 dnia: Listopad 12, 2012, 12:06:16 pm »
No ale to nie tylko właśnie xfwm4. W sterowniku od karty mam pozaznaczane te opcje. Mam cały czas wyłączone kompozycje, tylko drażni mnie że opcja jest, a nie mogę z niej korzystać.

Spróbuję jeszcze z tą opcją... jak będę potrafił :)

Mam jeszcze zintegrowaną Intela, ale nie chcę z niej korzystać, bo nieraz gram, a tam wydajność kiepska w porównaniu do GF.

Offline yossarian

  • Siewca Mięty
  • Dorodna miętowa sadzonka
  • *****
  • Wiadomości: 156
  • Punkty: 211
Odp: xUbuntu 12.10 "Przecinanie" obrazu wideo na pełnym ekranie.
« Odpowiedź #7 dnia: Listopad 12, 2012, 12:19:26 pm »
No ale to nie tylko właśnie xfwm4.
Ale inne menedżery okien trochę lepiej sobie z tym radzą.

Offline stiff

  • Miętowy Kumpel
  • Dorodna miętowa sadzonka
  • *****
  • Wiadomości: 128
  • Punkty: 60
  • Płeć: Mężczyzna
    • Free Software Linkownia
Odp: xUbuntu 12.10 "Przecinanie" obrazu wideo na pełnym ekranie.
« Odpowiedź #8 dnia: Listopad 12, 2012, 12:23:57 pm »
Jednak dodanie tej linii w xorg.conf nic nie daje :(
Dodany: [time]Listopad 12, 2012, 12:26:15 [/time]
No ale to nie tylko właśnie xfwm4.
Ale inne menedżery okien trochę lepiej sobie z tym radzą.
To fakt... W Mint Mate 13 przecinanie pojawia się nieraz. często jak się minimalizuje obraz, póżniej znowu daje pełny ekran. Ale problem i tak występuje.
W xfce (ubuntu 12.04, 12.10, mint 13) problem jest widoczny cały czas.

Offline yossarian

  • Siewca Mięty
  • Dorodna miętowa sadzonka
  • *****
  • Wiadomości: 156
  • Punkty: 211
Odp: xUbuntu 12.10 "Przecinanie" obrazu wideo na pełnym ekranie.
« Odpowiedź #9 dnia: Listopad 12, 2012, 12:34:55 pm »
Sprawdź czy w ogóle działa synchronizacja:
glxgears

Offline stiff

  • Miętowy Kumpel
  • Dorodna miętowa sadzonka
  • *****
  • Wiadomości: 128
  • Punkty: 60
  • Płeć: Mężczyzna
    • Free Software Linkownia
Odp: xUbuntu 12.10 "Przecinanie" obrazu wideo na pełnym ekranie.
« Odpowiedź #10 dnia: Listopad 12, 2012, 12:38:25 pm »
Cytuj
glxgears
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
302 frames in 5.0 seconds = 60.282 FPS
301 frames in 5.0 seconds = 60.023 FPS
301 frames in 5.0 seconds = 60.022 FPS
301 frames in 5.0 seconds = 60.021 FPS
301 frames in 5.0 seconds = 60.022 FPS
301 frames in 5.0 seconds = 60.022 FPS
300 frames in 5.0 seconds = 59.979 FPS
301 frames in 5.0 seconds = 60.062 FPS
301 frames in 5.0 seconds = 60.021 FPS
W terminalu Wyświetla się to tak.
Animacja, która się włączyła wygląda raczej ok.

Offline yossarian

  • Siewca Mięty
  • Dorodna miętowa sadzonka
  • *****
  • Wiadomości: 156
  • Punkty: 211
Odp: xUbuntu 12.10 "Przecinanie" obrazu wideo na pełnym ekranie.
« Odpowiedź #11 dnia: Listopad 12, 2012, 12:45:50 pm »
Spróbuj z innymi wersjami sterowników.

Możesz zamiast xfwm4 używać innego menadżera okien z Xfce.
« Ostatnia zmiana: Listopad 12, 2012, 12:48:41 pm wysłana przez yossarian »

Offline Ulvhedin

  • Administrator
  • Spamerzy
  • *******
  • Wiadomości: 1733
  • Punkty: 1199
  • Płeć: Mężczyzna
Odp: xUbuntu 12.10 "Przecinanie" obrazu wideo na pełnym ekranie.
« Odpowiedź #12 dnia: Listopad 12, 2012, 13:13:52 pm »
stiff: nie osiagniesz wyzszego wyniku bo masz napewno wlaczone vertical sync.
glxgears o niczym nie swiadczy.

Offline yossarian

  • Siewca Mięty
  • Dorodna miętowa sadzonka
  • *****
  • Wiadomości: 156
  • Punkty: 211
Odp: xUbuntu 12.10 "Przecinanie" obrazu wideo na pełnym ekranie.
« Odpowiedź #13 dnia: Listopad 12, 2012, 13:22:37 pm »
stiff: nie osiagniesz wyzszego wyniku bo masz napewno wlaczone vertical sync.
glxgears o niczym nie swiadczy.
Przecież właśnie po to uruchamiał glxgears.

Offline Ulvhedin

  • Administrator
  • Spamerzy
  • *******
  • Wiadomości: 1733
  • Punkty: 1199
  • Płeć: Mężczyzna
Odp: xUbuntu 12.10 "Przecinanie" obrazu wideo na pełnym ekranie.
« Odpowiedź #14 dnia: Listopad 12, 2012, 13:28:55 pm »
sorki... nie zauwazylem postu :D
administracja: usuncie prosze moje posty z tego watku