Problem z wyłączaniem - 15, MATE [ROZWIĄZANY]

  • 6 replies
  • 2447 views
*

Offline sim

  • *
  • 35
  • 1
  • Płeć: Mężczyzna
Problem z wyłączaniem - 15, MATE [ROZWIĄZANY]
« dnia: Sierpień 31, 2013, 14:51:52 pm »
Witam. Używam Linuxa 15 z pulpitem MATE, na laptopie Lenovo B580.

Ok. 1 na 5 razy, przy wyłączaniu, komputer się nie wyłącza - system zamiast zgasić sprzęt zawiesza się na ekranie z logiem Minta. Jedyne rozwiązanie to wyjęcie baterii lub przytrzymanie 8 sek. klawisza reset.

Jak to naprawić?
« Ostatnia zmiana: Sierpień 31, 2013, 18:52:32 pm wysłana przez sim »
Nihil satis, nisi optimum.

*

Offline mati75

  • Rodzina Linux Mint
  • *******
  • 2394
  • 25121
  • Płeć: Mężczyzna
    • >>>Click me!<<<
Odp: Problem z wyłączaniem - 15, MATE
« Odpowiedź #1 dnia: Sierpień 31, 2013, 16:24:07 pm »
Zaktualizować system.

υωαgα α∂мιи !!! вαиαмι иαριєя∂αℓα !!!

*

Offline sim

  • *
  • 35
  • 1
  • Płeć: Mężczyzna
Odp: Problem z wyłączaniem - 15, MATE
« Odpowiedź #2 dnia: Sierpień 31, 2013, 16:36:06 pm »
Robię to codziennie przecież...
Nihil satis, nisi optimum.

*

Offline mati75

  • Rodzina Linux Mint
  • *******
  • 2394
  • 25121
  • Płeć: Mężczyzna
    • >>>Click me!<<<
Odp: Problem z wyłączaniem - 15, MATE
« Odpowiedź #3 dnia: Sierpień 31, 2013, 16:50:03 pm »
To spróbujemy inaczej.
sudo add-apt-repository "deb http://packages.mate-desktop.org/repo/ubuntu raring main"
sudo rm /etc/apt/preferences
sudo su
echo "Package: *
Pin: release o=linuxmint
Pin-Priority: 700
 
Package: *
Pin: origin packages.linuxmint.com
Pin-Priority: 700
 
Package: *
Pin: release o=Ubuntu
Pin-Priority: 500
 
Package: *
Pin: origin repo.mate-desktop.org
Pin-Priority: 700" >> /etc/apt/sources.list
sudo apt-get update
sudo apt-get --yes --quiet --allow-unauthenticated install mate-archive-keyring
sudo apt-get update
sudo apt-get dist-upgrade

υωαgα α∂мιи !!! вαиαмι иαριєя∂αℓα !!!

*

Offline sim

  • *
  • 35
  • 1
  • Płeć: Mężczyzna
Odp: Problem z wyłączaniem - 15, MATE
« Odpowiedź #4 dnia: Sierpień 31, 2013, 18:03:26 pm »
Oj, zrobiła się jakaś kaszana. Wszystko to przekleiłem krok po kroku, ale po pierwszej z 4 ostatnich linijek sudo wyświetlił:

E: Typ "Package:" jest nieznany w linii 1 listy źródeł /etc/apt/sources.list
E: Nie udało się odczytać list źródeł.

Menedżer aktualizacji też wyświetla błąd:

ERROR###ERROR###ERROR###ERROR###ERROR###ERROR###ERROR
E:Type 'Package:' is not known on line 1 in source list /etc/apt/sources.list

Jak to posprzątać?

update: sorry, umknęły mi dwie pierwsze linijki.... spróbuję raz jeszcze

update2: po pierwszej linii wyświetla mi Nie można dodać prywatnego archiwum pakietów: „No JSON object could be decoded”
« Ostatnia zmiana: Sierpień 31, 2013, 18:08:35 pm wysłana przez sim »
Nihil satis, nisi optimum.

*

Offline mati75

  • Rodzina Linux Mint
  • *******
  • 2394
  • 25121
  • Płeć: Mężczyzna
    • >>>Click me!<<<
Odp: Problem z wyłączaniem - 15, MATE
« Odpowiedź #5 dnia: Sierpień 31, 2013, 18:17:51 pm »
Widzę, że ja błąd zrobiłem. Poprawka:
sudo rm /etc/apt/sources.list
sudo su
echo "Package: *
Pin: release o=linuxmint
Pin-Priority: 700
 
Package: *
Pin: origin packages.linuxmint.com
Pin-Priority: 700
 
Package: *
Pin: release o=Ubuntu
Pin-Priority: 500
 
Package: *
Pin: origin repo.mate-desktop.org
Pin-Priority: 700" >> /etc/apt/preferences

υωαgα α∂мιи !!! вαиαмι иαριєя∂αℓα !!!

*

Offline sim

  • *
  • 35
  • 1
  • Płeć: Mężczyzna
Odp: Problem z wyłączaniem - 15, MATE
« Odpowiedź #6 dnia: Sierpień 31, 2013, 18:52:14 pm »
Chyba zaskoczyło, dzięki.
Nihil satis, nisi optimum.