Problemy z instalacją programów

  • 4 replies
  • 3139 views
*

piko17

Problemy z instalacją programów
« dnia: Marzec 18, 2014, 19:21:19 pm »
Witam.
Jestem początkującym użytkownikiem linuxa i mam pewoen problem przy instalacji jakiejkolwiek aplikacji. Problem prawie identyczny jak w tym temacie http://forum.linuxmint.pl/index.php?topic=4461.0 lecz z innym plikiem i nie mogę sobie z tym poradzic. Oto log:
Cytuj
pi@raspberrypi ~ $ sudo apt-get install -f
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności      
Odczyt informacji o stanie... Gotowe
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 1 nieaktualizowanych.
11 nie w pełni zainstalowanych lub usuniętych.
Po tej operacji zostanie dodatkowo użyte 0 B miejsca na dysku.
Konfigurowanie pakietu cups (1.5.3-5+deb7u1) ...
insserv: warning: script 'mathkernel' missing LSB tags and overrides
insserv: There is a loop between service watchdog and mathkernel if stopped
insserv:  loop involving service mathkernel at depth 2
insserv:  loop involving service watchdog at depth 1
insserv: Stopping mathkernel depends on watchdog and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: błąd przetwarzania cups (--configure):
 podproces zainstalowany skrypt post-installation zwrócił kod błędu 1
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu printer-driver-hpcups:
 printer-driver-hpcups zależy od cups; jednakże:
  Pakiet cups nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania printer-driver-hpcups (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu hplip:
 hplip zależy od printer-driver-hpcups (= 3.12.6-3.1+deb7u1); jednakże:
  Pakiet printer-driver-hpcups nie jest jeszcze skonfigurowany.
 hplip zależy od cups (>= 1.1.20); jednakże:
  Pakiet cups nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania hplip (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu printer-driver-postscript-hp:
 printer-driver-postscript-hp zależy od hplip (>= 3.12.6-3.1+deb7u1); jednakże:
  Pakiet hplip nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania printer-driver-postscript-hp (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
Konfigurowanie pakietu samba (2:3.6.6-6+deb7u2) ...
insserv: warning: script 'mathkernel' missing LSB tags and overrides
insserv: There is a loop between service watchdog and mathkernel if stopped
insserv:  loop involving service mathkernel at depth 2
insserv:  loop involving service watchdog at depth 1
insserv: Stopping mathkernel depends on watchdog and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: błąd przetwarzania samba (--configure):
 podproces zainstalowany skrypt post-installation zwrócił kod błędu 1
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu cups-pdf:
 cups-pdf zależy od cups; jednakże:
  Pakiet cups nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania cups-pdf (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu printer-driver-gutenprint:
 printer-driver-gutenprint zależy od cups (>= 1.3.0); jednakże:
  Pakiet cups nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania printer-driver-gutenprint (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu printer-driver-splix:
 printer-driver-splix zależy od cups (>= 1.5.0-3~); jednakże:
  Pakiet cups nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania printer-driver-splix (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
Konfigurowanie pakietu sane-utils (1.0.22-7.4) ...
insserv: warning: script 'mathkernel' missing LSB tags and overrides
insserv: There is a loop between service watchdog and mathkernel if stopped
insserv:  loop involving service mathkernel at depth 2
insserv:  loop involving service watchdog at depth 1
insserv: Stopping mathkernel depends on watchdog and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: błąd przetwarzania sane-utils (--configure):
 podproces zainstalowany skrypt post-installation zwrócił kod błędu 1
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu cups-driver-gutenprint:
 cups-driver-gutenprint zależy od printer-driver-gutenprint; jednakże:
  Pakiet printer-driver-gutenprint nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania cups-driver-gutenprint (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
Konfigurowanie pakietu watchdog (5.12-1) ...
/run/udev or .udevdb or .udev presence implies active udev.  Aborting MAKEDEV invocation.
insserv: warning: script 'mathkernel' missing LSB tags and overrides
insserv: There is a loop between service watchdog and mathkernel if stopped
insserv:  loop involving service mathkernel at depth 2
insserv:  loop involving service watchdog at depth 1
insserv: Stopping mathkernel depends on watchdog and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: błąd przetwarzania watchdog (--configure):
 podproces zainstalowany skrypt post-installation zwrócił kod błędu 1
Wystąpiły błędy podczas przetwarzania:
 cups
 printer-driver-hpcups
 hplip
 printer-driver-postscript-hp
 samba
 cups-pdf
 printer-driver-gutenprint
 printer-driver-splix
 sane-utils
 cups-driver-gutenprint
 watchdog
E: Sub-process /usr/bin/dpkg returned an error code (1)
Proszę o pomoc.
 |Pozdrawiam
« Ostatnia zmiana: Marzec 18, 2014, 20:08:50 pm wysłana przez piko17 »

*

Offline moarcode

  • Siewca hejtu
  • *******
  • 1799
  • 993
  • Płeć: Mężczyzna
  • 1, 2,3 próba klawiatury.
Odp: Problemy z instalacją programów
« Odpowiedź #1 dnia: Marzec 18, 2014, 19:28:13 pm »
#otworz przegladarke --z-parametrami-dotyczacymi-bledu

Look closer, fall deeper.

*

piko17

Odp: Problemy z instalacją programów
« Odpowiedź #2 dnia: Marzec 18, 2014, 20:07:51 pm »
Link naprawiony.
« Ostatnia zmiana: Marzec 18, 2014, 20:09:22 pm wysłana przez piko17 »

*

Offline mati75

  • Rodzina Linux Mint
  • *******
  • 2393
  • 25121
  • Płeć: Mężczyzna
    • >>>Click me!<<<
Odp: Problemy z instalacją programów
« Odpowiedź #3 dnia: Marzec 18, 2014, 21:34:03 pm »
sudo rm /etc/init.d/mathkernel
sudo apt-get install -f

υωαgα α∂мιи !!! вαиαмι иαριєя∂αℓα !!!

*

piko17

Odp: Problemy z instalacją programów
« Odpowiedź #4 dnia: Marzec 21, 2014, 23:04:19 pm »
Wielkie dzięki. Pomogło.