Jak zainstalować wtyczkę e-deklaracje na linux mint 17.3

  • 18 replies
  • 3189 views
*

Offline dexter

  • *
  • 32
  • 0
Jak zainstalować wtyczkę e-deklaracje na linux mint 17.3
« dnia: Marzec 01, 2017, 22:15:07 pm »
Witam
Chciałbym zainstalować wtyczkę e-deklaracje do wysłania pit-a za ubiegły rok. Znalazłem poradniki sprzed kilku lat, ale mam wątpliwości i chciałbym zapytać, czy ktoś już to robił. Wątpliwości to informacje nt adobe air, który jest do tego potrzebny, ale już nie wspierany. Trochę boję się o bezpieczeństwo w takim wypadku

Dzięki za podpowiedzi

*

Offline Mintek

  • ***
  • 122
  • 6
Używam Mint 18.1 Cinnamon z kernelem 4.10.5

*

Offline christo

  • *****
  • 626
  • 30
  • Płeć: Mężczyzna
Odp: Jak zainstalować wtyczkę e-deklaracje na linux mint 17.3
« Odpowiedź #2 dnia: Marzec 01, 2017, 22:38:55 pm »
A tutaj patrzyłeś ?
http://www.finanse.mf.gov.pl/systemy-informatyczne/e-deklaracje
Only Jesus saves.

*

Offline wolare

  • *
  • 43
  • 0
Odp: Jak zainstalować wtyczkę e-deklaracje na linux mint 17.3
« Odpowiedź #3 dnia: Marzec 02, 2017, 00:13:51 am »
nie wiem czy coś się nie zmieniło
ale próbowałem to robic rok temu i lipa
MF  to ściema totalna ....  ta instalka wymaga środowiska Adobe AIR - które nie jest aktualizowane przez Adobe od 3 lat dla linuxa
więc konsekwentnie formularze aktywne deklaracji stworzone na stronach MF nie dadzą się wczytać - nawet jak uda wam się instalka starego adobe

*

Offline dexter

  • *
  • 32
  • 0
Odp: Jak zainstalować wtyczkę e-deklaracje na linux mint 17.3
« Odpowiedź #4 dnia: Marzec 02, 2017, 08:01:03 am »
Kilkakrotnie wysyłałem pity z windowsa, to jest dla mnie jasne, ale na linuksie nie wiem jak zainstalować tę wtyczkę, stąd to pytanie. Jeśli się nie da, to trudno mam jeszcze możliwość wysłania poprzez windowsa

*

Offline yahoob3

  • *****
  • 636
  • 109
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Jak zainstalować wtyczkę e-deklaracje na linux mint 17.3
« Odpowiedź #5 dnia: Marzec 02, 2017, 08:07:21 am »
Jeśli interesują Cię/Was e-pity (do rozliczenia rocznych PITów - super) to wieczorem mogę gdzieś wystawić skrypt instalacyjny, który ładnie działa, a napisał go jeden z członków forum Ubuntu.
Skrypt pobiera i instaluje Adobe Air, a potem same e-pity. Na 17.3 działa, na 18.1 też z wysyłaniem pitów do MF włącznie.
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

*

Offline dexter

  • *
  • 32
  • 0
Odp: Jak zainstalować wtyczkę e-deklaracje na linux mint 17.3
« Odpowiedź #6 dnia: Marzec 02, 2017, 15:12:17 pm »
Jeśli to nie problem to poproszę, przyda się
Dzięki :)

*

Offline yahoob3

  • *****
  • 636
  • 109
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Jak zainstalować wtyczkę e-deklaracje na linux mint 17.3
« Odpowiedź #7 dnia: Marzec 02, 2017, 17:51:51 pm »
http://www.venco.com.pl/~yahoob3/priv/tajne/pity.sh
Proszę, to skrypt użytkownika Nolt. Dane dotyczące licencji w początkowej sekcji skryptu.
Aby go uruchomić należy PPM ustawić we: właściwości -> uprawnienia ->zaznaczyć wykonanie (po naszemu chmod +x) i
... np. przeciągnąć plik na otwarte okno terminala, przestawić kursor na początek linii poleceń i wpisać "sudo", enter, podać hasło i postępować zgodnie z wyświetlającymi się poleceniami.
I już.

PS. A z tym przeciąganiem na terminal, to żeby udowodnić, że nie taki Linuch straszny jak go wszędy opisują :-D
« Ostatnia zmiana: Marzec 02, 2017, 18:16:10 pm wysłana przez yahoob3 »
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

*

Offline wolare

  • *
  • 43
  • 0
Odp: Jak zainstalować wtyczkę e-deklaracje na linux mint 17.3
« Odpowiedź #8 dnia: Marzec 02, 2017, 19:10:00 pm »
dzięki #yahoob3
wiedziałem, że temat rozwiązać można tylko w społeczności .....  urzędasy są inteligentni inaczej :)
choć nadal mam wątpliwości czy wersja adobe air nie jest za stara dla nowych formularzy - sprawdzę

*

Offline dexter

  • *
  • 32
  • 0
Odp: Jak zainstalować wtyczkę e-deklaracje na linux mint 17.3
« Odpowiedź #9 dnia: Marzec 03, 2017, 08:29:04 am »
dzięki yahoob3
Mój linux teraz będzie pełnowartościowy, skorzystam
Dziękuję wszystkim za podpowiedzi

*

Offline toto-56

  • *
  • 45
  • 10
  • Płeć: Mężczyzna
Odp: Jak zainstalować wtyczkę e-deklaracje na linux mint 17.3
« Odpowiedź #10 dnia: Marzec 04, 2017, 17:31:19 pm »
Do wszystkich zainteresowanych tematem e-Deklaracje.
---------------------------------------------------------------
Informuję, że program MF działa bez zarzutu pod LinuxMint 18.1 jak i w starszych wersjach.
Tak, wymaga instalacji Adobe AIR i nie ma tu znaczenia że nie jest rozwijany przez Adobe.
E-Deklaracje działają na starej jego wersji 1:2.6.0.19170.
Przedwczoraj wypełniłem i wysłałem z e-Deklaracji PIT-36 do MF bez najmniejszych problemów.

Instalka Adobe Air: wget http://airdownload.adobe.com/air/lin/download/2.6/AdobeAIRInstaller.binWięcej na ten temat tu: http://ubuntuhandbook.org/index.php/2013/07/install-adobe-air-linux-mint-32-64-bit/



Pozdrawiam
t.
« Ostatnia zmiana: Marzec 04, 2017, 17:47:31 pm wysłana przez toto-56 »

*

Offline kris777

  • ***
  • 157
  • 33
Odp: Jak zainstalować wtyczkę e-deklaracje na linux mint 17.3
« Odpowiedź #11 dnia: Marzec 05, 2017, 13:51:37 pm »
A czy program e-pity to to samo co e-deklaracje  ? ... bo w temacie jest e-deklaracje ...

*

Offline yahoob3

  • *****
  • 636
  • 109
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Jak zainstalować wtyczkę e-deklaracje na linux mint 17.3
« Odpowiedź #12 dnia: Marzec 11, 2017, 17:32:03 pm »
Jeden jest zielony, a drugi niebieski  ;D
Poza tym, e-Pity to program do typowych rozliczeń podatku od osób fizycznych. (głównie PIT-x)
E-Deklaracje to bardziej rozbudowane narzędzie do rozliczania podatków (i nie tylko) zarówno os-fiz jak i przedsiębiorstw (PIT-x i VAT-x).
IMO do "domowego użytku" wystarczą e-Pity.
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

*

Offline kris777

  • ***
  • 157
  • 33
Odp: Jak zainstalować wtyczkę e-deklaracje na linux mint 17.3
« Odpowiedź #13 dnia: Marzec 12, 2017, 17:52:27 pm »
W sumie to zainstalowałem według tutka e-pity ... a potem e-deklaracje z tej strony : http://www.finanse.mf.gov.pl/web/wp/pp/e-deklaracje/do-pobrania/-/asset_publisher/rG2P/content/aplikacja-e-deklaracje-desktop-umozliwiajaca-osobom-fizycznym-zlozenie-formularzy-elektronicznych-bez-kwalifikowanego-podpisu-elektronicznego
ale program zainstalował się w sekcji wine ..więc nie wiem czy jest on konieczny do obsługi ? ... trzeba też doinstalować program Adobe Reader u mnie w wersji 64 bit ... wszystko działa OK ...PIT poleciał w kosmos ..czytaj w czarną dziurę budżetu :-)

*

Offline yahoob3

  • *****
  • 636
  • 109
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Jak zainstalować wtyczkę e-deklaracje na linux mint 17.3
« Odpowiedź #14 dnia: Marzec 12, 2017, 18:35:12 pm »
Jeśli na komputerze jest już Adobe Air, to na stronie MF (http://www.finanse.mf.gov.pl/documents/766655/1196444/e-DeklaracjeDesktop.air) jest instalator pod Linuksa. Otwierasz AA i wskazujesz pobrany plik *.air. Może instalowałeś wersję dla Windows, dlatego w Wine?
e-Pity nie wymaga Adobe Readera, działa na systemowej przeglądarce dokumentów (pdf). e-Deklaracje są może o tyle lepsze, że z tego co widzę jest więcej formularzy i "mały LEX podatkowy".
Obydwa programy umożliwiają wysyłkę z e-podpisem, w e-Pitach można wysłać bez e-podpisu (trzeba tylko "zweryfikować się" za pomocą przychodu z roku poprzedniego. Nie wiem czy Deklaracje to umożliwiają. W zeszłym roku, jeśli dobrze pamiętam program sam ciągnął dane do PITu z serwera MF - trzeba było tylko je zweryfikować... i wysłać jeszcze raz. :)

Skrypt, o którym pisałem kilka postów wyżej mocno pomaga załatwić sprawę instalacji e-Pitów. W tutkach (zwłaszcza tym z PDFa) trzeba uważać, bo zwykłe kopiuj/wklej nie zadziała bo wkradają się niepotrzebne "entery".
Każda sroczka swój ogonek chwali, to i ja :) e-Pitów używam od 2013 r. i jest OK... cała rodzina mi d. zawraca :)
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742