Python3.6.1 w linux mint 18.1

  • 3 replies
  • 899 views
*

Offline td

  • *
  • 25
  • 0
Python3.6.1 w linux mint 18.1
« dnia: Maj 01, 2017, 17:34:00 pm »
Zainstalowałem w linux mint 18.1 Python w wersji najnowszej 3.6.1, ponieważ wtyczka do programu kodi "goldvodtv" nie instalowała się bo wymagała takiego programu. Mimo tego że program python3.6.1 zainstalował się poprawnie i jest w systemie to jednak działa w dalszym ciągu poprzednia wersja i wtyczka do "kodi" w dalszym ciągu nie instaluje się. Co zrobić aby w systemie zadziałał nowo zainstalowany program "python"?
Jeśli ktoś jest z tym zapoznany, to prosiłbym o pomoc.

Tadeusz

*

Offline euklides

  • *****
  • 343
  • 72
  • Płeć: Mężczyzna
Odp: Python3.6.1 w linux mint 18.1
« Odpowiedź #1 dnia: Maj 02, 2017, 12:35:25 pm »
Python musi być w programie kodi jako zależność dodatku , co oznacza że jeśli programiści kodi go nie dodadzą  to nie ma możliwości abyś go sam dodał .

Jaka wersję kodi posiadasz , może trzeba zaktualizować kodiego i po sprawie .
OS: Ubuntu Bionic Beaver (development branch) x86_64
Kernel: 4.13.0-32-generic
DE: Unity7

*

Offline td

  • *
  • 25
  • 0
Odp: Python3.6.1 w linux mint 18.1
« Odpowiedź #2 dnia: Maj 02, 2017, 14:38:39 pm »
Jeśli chodzi o kodi to posiadam najnowszą stabilną wersję 17.1, pozostałe wersje są już niestabilne. Nie bardzo rozumiem, bo skoro program kodi nie wspiera programu python3, to dlaczego "goldvod" wydaje wtyczkę która jest oparta na phyton3 i nie instaluje się w programie podczas gdy poprzednie wtyczki tego typu instalowały się bez problemu.

td

*

Offline euklides

  • *****
  • 343
  • 72
  • Płeć: Mężczyzna
Odp: Python3.6.1 w linux mint 18.1
« Odpowiedź #3 dnia: Maj 02, 2017, 16:33:12 pm »
dodatek który jest odpowiedzialny za taki stan rzeczy to xbmc.python tylko on jest napisany do wersji 2.7 .

napisz do twórców tego cuda aby ci dosłali działająca zależnośćw wersji 3,  albo niech obniżą wersję pythona 
OS: Ubuntu Bionic Beaver (development branch) x86_64
Kernel: 4.13.0-32-generic
DE: Unity7