Linux Mint 17.2 i Geany oraz Code::Block. Problem.

  • 3 replies
  • 333 views
Linux Mint 17.2 i Geany oraz Code::Block. Problem.
« dnia: Styczeń 12, 2018, 15:59:49 pm »
Witam!
Od razu przechodzę do sedna. Zainstalowałem niedawno Linux Mint 17.2 i chcę się pouczyć programowania w C++. Zainstalowałem g++ oraz Geany jak lekkie środowisko do kodowania. Używałem Geany w Windows i tu pojwaia się problem.
Tworzę plik z kodem źródłowym, kompiluję i wszysko jest ok. Ale jak próbuję go uruchomić to dostaję taki komunikat:

./geany_run_script.sh: 5: ./geany_run_script.sh: ./p1: Permission denied
------------------
(program exited with code: 126)
Press return to continue

I szczerze powiedziawszy nie mam pojęcia co z tym zrobić?

*

Offline napaony

  • *
  • 23
  • 0
Odp: Linux Mint 17.2 i Geany oraz Code::Block. Problem.
« Odpowiedź #1 dnia: Styczeń 12, 2018, 16:33:26 pm »
Musisz dać zezwolenie w pliku /ustawienia/zezwolenie wykonywanie jako programu

Odp: Linux Mint 17.2 i Geany oraz Code::Block. Problem.
« Odpowiedź #2 dnia: Styczeń 12, 2018, 16:56:47 pm »
Ok. Ale w Geany czy trzeba edytować jakiś plik?
Poprawka. Znalazłem to i mam tą opcję zaznaczoną a dalej jest to samo. Nie wiem co dalej...
« Ostatnia zmiana: Styczeń 12, 2018, 18:25:35 pm wysłana przez Grzegorz_beginner »

*

Offline napaony

  • *
  • 23
  • 0
Odp: Linux Mint 17.2 i Geany oraz Code::Block. Problem.
« Odpowiedź #3 dnia: Styczeń 13, 2018, 09:21:04 am »
https://askubuntu.com/questions/409025/permission-denied-when-running-sh-scripts
ctrl+h i zobacz czy nie masz ukrytego pliku który stworzyłeś też daj zezwolenie