Kalwiatura Bluetooth zasypia

  • 6 replies
  • 560 views
Kalwiatura Bluetooth zasypia
« dnia: Marzec 05, 2018, 16:25:12 pm »
Kupiłem sobie klawiaturę  RT-MWK02+ (made in china) i wszystko było by dobrze gdyby klawiatura po kilku minutach bezczynności nie "zasypiała". Czasem da się ją "obudzić" , ale rzadko kiedy się udaje. Przez  cały dzień właśnie z tego powodu muszę 20 razy, a może więcej - restartować komputer. Według mnie oprogramowanie do bluetooth Mint'a 18.1 64 bit jest do kitu. Może wystarczyło by napisać jakiś skrypt który wykonywał by scheduler co jakieś 2 minuty ? Nie wiem jak znaleźć to urządzenie w sieci bo jak wpiszę ifconfig to klawiatury nie widzę w tym co on wyświetla. A może jakiś inny sposób na pobudzanie klawiatury ?

*

Offline ciastek1981

  • *******
  • 1134
  • 150
  • Płeć: Mężczyzna
  • Sprzątam forum, usuwam reklamy oraz daję bany ;)
Odp: Kalwiatura Bluetooth zasypia
« Odpowiedź #1 dnia: Marzec 06, 2018, 01:40:37 am »
Na społeczność zawsze można liczyć  :-\ Nie używam co prawda bluetooth, ale jakbym miał patrzeć to sprawdziłbym configi w

/etc/bluetooth/main.conf/etc/bluetooth/input.conf
#- przed oznacza, że opcja traktowana jest jak zwykły tekst i nie jest wykonywana

Reszty informacji należy szukać np. tutaj

https://wiki.debian.org/BluetoothUser
https://wiki.archlinux.org/index.php/Bluetooth_keyboard


« Ostatnia zmiana: Marzec 06, 2018, 01:45:06 am wysłana przez ciastek1981 »

*

Offline yahoob3

  • *****
  • 683
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Kalwiatura Bluetooth zasypia
« Odpowiedź #2 dnia: Marzec 06, 2018, 07:26:55 am »
Możesz jeszcze sprawdzić, czy masz łączone oszczędzanie energii na USB. Jeśli nie masz, zainstaluj pakiet powertop:
sudo apt install powertopUruchomić powertop w terminlu:
sudo powertopPrzejść Tabem do zakładki "Tunables" i zobaczyć czy przy porcie USB jak np. poniżej. Logitech to u mnie właśnie klawatura BT.
   Bad           Autosuspend for USB device 2.4G Mouse [3-2]
>> Bad           Autosuspend for USB device USB Receiver [Logitech]                                                     
zamiast Bad jest Good. Jeśli jest na Good, spróbuj zmienić Enterem na Bad. Wyjdź z programu Esc i zrestartuj komputer.

W plikach, o których pisał ciastek1981 mam wszystko za##### :)

I jeszcze jedno. Czemu 18.1 a nie 18.3?
« Ostatnia zmiana: Marzec 06, 2018, 07:31:10 am wysłana przez yahoob3 »
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

*

Offline ciastek1981

  • *******
  • 1134
  • 150
  • Płeć: Mężczyzna
  • Sprzątam forum, usuwam reklamy oraz daję bany ;)
Odp: Kalwiatura Bluetooth zasypia
« Odpowiedź #3 dnia: Marzec 06, 2018, 08:43:49 am »
18.1 bo su zablokowali  i trzeba było wpisywać sudo su albo sudo -s albo .... 8) Było na forum.

Kiedyś jak używałem taniej myszki Nateca to nie chciała działać jak miała słabe baterie i wznawiała połączenie po wyjęciu dongla i przełączeniu pstryka pod spodem.

Opłotkowane wszystko? No wiem, że tak jest, ale w głowie sobie zakodowałem ten wpis https://unix.stackexchange.com/questions/177998/bluetooth-mouse-disconnects



« Ostatnia zmiana: Marzec 06, 2018, 09:03:42 am wysłana przez ciastek1981 »

*

Offline yahoob3

  • *****
  • 683
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Kalwiatura Bluetooth zasypia
« Odpowiedź #4 dnia: Marzec 06, 2018, 10:11:54 am »
18.1 bo su zablokowali  i trzeba było wpisywać sudo su albo sudo -s albo .... 8) Było na forum.

A to jakiś wielki problem? ;)

Cytuj
Kiedyś jak używałem taniej myszki Nateca to nie chciała działać jak miała słabe baterie i wznawiała połączenie po wyjęciu dongla i przełączeniu pstryka pod spodem.

Ja używam Manty - droga nie była ;) I działa jak ta lala.

Cytuj
Opłotkowane wszystko? No wiem, że tak jest, ale w głowie sobie zakodowałem ten wpis https://unix.stackexchange.com/questions/177998/bluetooth-mouse-disconnects

Za dużo chyba na DUGu siedzisz ;)
Terminal w fazie drugiej, w pierwszej, co da się wyklikać, to klikać. Pamiętaj, że na początku terminal zniechęca :)
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

Odp: Kalwiatura Bluetooth zasypia
« Odpowiedź #5 dnia: Marzec 06, 2018, 21:57:14 pm »
Dziękuję za odpowiedzi - fajne te linki do BT pod Debianem. Ale do rzeczy : odwiedziłem te pliki typu .conf  w katalogu /etc/bluetooth/ i wszystko jest zahashowane oprócz jednej linijki w pliku : proximity.conf  a że on krótki to, wklejam jego  całą zawartość :
/etc/bluetooth/proximity.conf====================================================
# Configuration file for the proximity service

# This section contains options which are not specific to any
# particular interface
[General]

# Configuration to allow disabling Proximity services
# Allowed values: LinkLoss,PathLoss,FindMe
Disable=PathLoss
====================================================

Z 4-ch plików  - tylko ta linijka jest bez #.

Zainstalowałem powertop i dobrze że w linii bt dongle jest Bad:

Bad  Autosuspend for USB device Wireless Receiver [Telink]

bo nie umiem tej linii edytować. Więc na razie bez zmian.

Brak znaczników CODE #
« Ostatnia zmiana: Marzec 07, 2018, 21:11:01 pm wysłana przez ciastek1981 »

*

Offline ciastek1981

  • *******
  • 1134
  • 150
  • Płeć: Mężczyzna
  • Sprzątam forum, usuwam reklamy oraz daję bany ;)
Odp: Kalwiatura Bluetooth zasypia
« Odpowiedź #6 dnia: Marzec 07, 2018, 20:49:01 pm »
Bad znaczy tylko tyle, że nie jest aktywna funkcja oszczędzania energii. Intel zrobił nawet całą broszurę o swoim wynalazku

https://01.org/sites/default/files/page/powertop_users_guide_201412.pdf

W linku w którym wcześniej podawałem padła propozycja ustawienia w

/etc/bluetooth/input.conf
czasu bezczynności

IdleTimeout=0
« Ostatnia zmiana: Marzec 07, 2018, 20:59:56 pm wysłana przez ciastek1981 »