[SOLVED]Xfce - jasność ekranu

  • 19 replies
  • 743 views
[SOLVED]Xfce - jasność ekranu
« dnia: Maj 09, 2018, 20:29:26 pm »
Witam,
zainstalowałem na starym laptopie system Mint 18.3 64bit z Xfce, komputer ma służyć tylko do internetu + zdjęcia i filmy.
Laptop to Lenovo B570e. Mam kilka problemów z którymi nie mogę sobie poradzić a na windowsie nie występowały:
1) Najważniejszy. Nie mogę zmienić jasności ekranu. Pojawia się suwak na ekranie przy naciśnięciu Fn+"jasn. w dół" ale ekran się nie ściemnia.
2) Jak całkowicie wyłączyć ekran logowania po wyjściu ze stanu wstrzymania. Chcę aby po otwarciu pokrywy od razu pojawiał się pulpit.
3) Czy da się usunąć pasek tytułu z firefoxa, tak aby karty były przy samej krawędzi ekranu
4) Jak ustawić szybsze przewijanie kółkiem myszy, więcej wierszy na jeden obrót.
« Ostatnia zmiana: Maj 13, 2018, 22:55:35 pm wysłana przez niktwazny »

*

Offline yahoob3

  • *****
  • 723
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Xfce - jasność ekranu
« Odpowiedź #1 dnia: Maj 09, 2018, 20:56:10 pm »
W zasadzie do każdego problemu powinieneś założyć osobny wątek, bo dotyczą całkowicie innych rzeczy.
Przy okazji, na tym lapku bardzo ładnie sprawuje się Cinnamon. :) I nie ma większości problemów jak pod XFCE. 4 GB RAM wystarczy.

Na razie:
Ad 4)
http://forum.linuxmint.pl/index.php?topic=9716.msg65154#msg65154

Ad 3)
https://addons.mozilla.org/pl/firefox/addon/hide-title-bar/
UWAGA! - znikają razem z paskiem tytułu przyciski sterujące: minimalizuj, max.. i zamknij. Był kiedyś jeszcze taki plugin do FF, ale zabij, nie pamiętam nazwy.
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

*

Offline jury

  • ***
  • 173
  • 31
Odp: Xfce - jasność ekranu
« Odpowiedź #2 dnia: Maj 10, 2018, 11:13:50 am »
Ad 2) W "Managerze Zasilania" w zakładce "Ogólne" masz taką opcję "Działanie zamknięcia pokrywy laptopa". Czy przy "Zasilanie akumulatorowe" nie masz wybranego "Zablokowanie ekranu"?

Odp: Xfce - jasność ekranu
« Odpowiedź #3 dnia: Maj 10, 2018, 16:14:17 pm »
Testowałem Cinnamon z pendrive i panel tytułu w firefox nadal jest a regulacja jasności też nie działa.
"Działanie zamknięcia pokrywy laptopa" jest ustawione "Wstrzymanie" zarówno dla zasilania sieciowego jak i akumulatorowego.

Odp: Xfce - jasność ekranu
« Odpowiedź #4 dnia: Maj 10, 2018, 16:15:16 pm »
Testowałem Cinnamon z pendrive i panel tytułu w firefox nadal jest a regulacja jasności też nie działa.
"Działanie zamknięcia pokrywy laptopa" jest ustawione "Wstrzymanie" zarówno dla zasilania sieciowego jak i akumulatorowego.

*

Offline yahoob3

  • *****
  • 723
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Xfce - jasność ekranu
« Odpowiedź #5 dnia: Maj 10, 2018, 19:43:24 pm »
Specjalnie dla Ciebie zainstalowałem XFCE na VM ;)
Ad 1)
Pytania pomocnicze:
- jaką masz kartę graficzną? Nie AMD przypadkiem?
- Sprawa druga możesz pokazać ustawienia gruba:
xed /etc/default/grubMoże temu "komputeru" trzeba powiedzieć, że ma Linuksa na pokładzie :)
Wklej całą zawartość pliku pomiędzy znaczniki code: http://forum.linuxmint.pl/index.php?topic=6937.msg64458#msg64458

Ad 2)
Menu, Ustawienia Light Locker - Blokowanie/włączenie na zero, oraz w menedżerze zasilania, w zakładce "Bezpieczeństwo" - Automatically lock the sesion wybierz "Nigdy". Zadziała po restarcie komputera.
« Ostatnia zmiana: Maj 10, 2018, 20:22:57 pm wysłana przez yahoob3 »
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

*

Offline yahoob3

  • *****
  • 723
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Xfce - jasność ekranu
« Odpowiedź #6 dnia: Maj 10, 2018, 20:15:27 pm »
Ad 3) errata ;)
sudo apt install wmctrlTeraz dodatek powinien zadziałać.
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

Odp: Xfce - jasność ekranu
« Odpowiedź #7 dnia: Maj 10, 2018, 21:09:20 pm »
wynik polecenia hwinfo --gfxcard 12: PCI 02.0: 0300 VGA compatible controller (VGA)             
  [Created at pci.366]
  Unique ID: _Znp.Ku0GSm9Y5mC
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Model: "Intel 2nd Generation Core Processor Family Integrated Graphics Controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x0106 "2nd Generation Core Processor Family Integrated Graphics Controller"
  SubVendor: pci 0x17aa "Lenovo"
  SubDevice: pci 0x3975
  Revision: 0x09
  Driver: "i915"
  Driver Modules: "i915"
  Memory Range: 0xd0000000-0xd03fffff (rw,non-prefetchable)
  Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable)
  I/O Ports: 0x3000-0x303f (rw)
  Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
  IRQ: 26 (509 events)
  Module Alias: "pci:v00008086d00000106sv000017AAsd00003975bc03sc00i00"
  Driver Info #0:
    Driver Status: i915 is active
    Driver Activation Cmd: "modprobe i915"
  Config Status: cfg=new, avail=yes, need=no, active=unknown

Primary display adapter: #12





Ustawienia gruba
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Cytuj
Ad 3) errata ;)

sudo apt install wmctrl

Teraz dodatek powinien zadziałać.

rozumiem że wtedy znikną przyciski minimalizuj, maksymalizuj, wyłącz?
« Ostatnia zmiana: Maj 11, 2018, 12:29:10 pm wysłana przez szymon1978 »

*

Offline yahoob3

  • *****
  • 723
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Xfce - jasność ekranu
« Odpowiedź #8 dnia: Maj 10, 2018, 21:22:29 pm »
Cytuj
rozumiem że wtedy znikną przyciski minimalizuj, maksymalizuj, wyłącz?
Teoretycznie tak, ale z tego co czytam, jest problem z tym dodatkiem w xfce.
Podobno działa w FF Nightly.

Edytuj grub:
sudo xed /etc/default/grub i linię "GRUB_CMDLINE_LINUX_DEFAULT="quiet splash""
popraw (kopiuj/wklej) tak, żeby wyglądała tak:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux video.use_native_backlight=1"zapisz i zamknij plik, następnie wykonaj:
sudo update-grub i zrestartuj komputer.
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

Odp: Xfce - jasność ekranu
« Odpowiedź #9 dnia: Maj 10, 2018, 21:50:25 pm »
Niestety teraz po naciśnięciu Fn + "zw. jasnosc"/"zmn. jasność" nie pojawia się suwak ani ekran nie ciemnieje.

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux video.use_native_backlight=1"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

*

Offline yahoob3

  • *****
  • 723
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Xfce - jasność ekranu
« Odpowiedź #10 dnia: Maj 10, 2018, 21:54:00 pm »
OK, to jeszcze inaczej:
Linia GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" - tak jak była wcześniej a w następnej "GRUB_CMDLINE_LINUX=""" wklej: GRUB_CMDLINE_LINUX="acpi_backlight=vendor", zapisz... update-grub i restart.
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

Odp: Xfce - jasność ekranu
« Odpowiedź #11 dnia: Maj 10, 2018, 22:12:35 pm »
teraz Fn + "zmn. jasność" pojawia się suwak ale mogę na nim sterować jasnością w 2 stanach max i max - 1, jasność ekranu się wtedy nie zmienia, po naciśnięciu symbolu baterii w trayu można dowolnie przesuwać suwakiem ale jasność się nadal nie zmienia.

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="acpi_backlight=vendor"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

*

Offline yahoob3

  • *****
  • 723
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Xfce - jasność ekranu
« Odpowiedź #12 dnia: Maj 10, 2018, 22:35:50 pm »
Heh, trochę permutacji jest ;/
Jeśli dobrze pamiętam, to klawisze to Fn+ strzałki prawo/lewo? Czy góra/dół?


Zainstaluj:
sudo apt install xbacklightSpróbuj też takiego ustawienia w grub:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux video.use_native_backlight=0"
GRUB_CMDLINE_LINUX=""

Zobacz, czy ten link pomoże - przedostatni post.
https://forums.linuxmint.com/viewtopic.php?t=159418
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

Odp: Xfce - jasność ekranu
« Odpowiedź #13 dnia: Maj 10, 2018, 23:26:31 pm »
Cytuj
Zobacz, czy ten link pomoże - przedostatni post.
https://forums.linuxmint.com/viewtopic.php?t=159418

pomogło, czyli

tworzę plik /usr/share/X11/xorg.conf.d/80-backlight.conf

z zawartością
Section "Device"
Identifier "Intel Graphics"
Driver "intel"
Option "AccelMethod" "sna"
Option "Backlight" "intel_backlight" # use your backlight that works here
BusID "PCI:0:2:0"
EndSection


Cytuj
Menu, Ustawienia Light Locker - Blokowanie/włączenie na zero, oraz w menedżerze zasilania, w zakładce "Bezpieczeństwo" - Automatically lock the sesion wybierz "Nigdy". Zadziała po restarcie komputera.

Rozwiązało problem z ekranem logowania.

Pasek tytułu z firefoxa rozwiązałem przez zainstalowanie Chromium :) i chyba nawet jest lepsza(mapy google lepiej działają np)

Wyszła jeszcze taka jedna sprawa, korzystając z myszy Tracer Vortex nano RF samoczynnie po chwili po ustawieniu zmienia się DPI, na myszy SteelSeries Rival 100 jest ok, trzyma cały czas DPI. Nie jest to aż tak ważne bo ta mysz Tracer i tak jest nieudana i trzeba ją będzie wymienić, chyba że rozwiązanie tego było by znane, bez zagłebiania się w temat.

oraz

jak w Chromium ustawić język polski?


dzięki za porady i zainteresowanie

*

Offline yahoob3

  • *****
  • 723
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Xfce - jasność ekranu
« Odpowiedź #14 dnia: Maj 10, 2018, 23:30:01 pm »
Super, mi wywaliło xorga :)
Co do myszy... załóż nowy wątek, bo za ten Moderacja powiesi nas za klejnoty...
A tu dodaj [SOLVED]...


Chromium:
sudo apt-get install chromium-browser-l10n
« Ostatnia zmiana: Maj 11, 2018, 09:14:13 am wysłana przez yahoob3 »
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742