Lnux Mint 18 - starszy sprzęt - ATI niska responsywność

  • 35 replies
  • 1433 views
Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« dnia: Maj 25, 2018, 12:08:49 pm »
Dzień dobry.
Posiadam starszy sprzęt, który postanowiłem reanimować (e5200, 6GB ramu oraz radeon x1350). Mint w najnowszej wersji zaktualizowany tj. 18.3 x64. Chodzi to mocno średnio, kursor jakby laguje okna przy przeciąganiu tak samo. Jest coś co można zrobić żeby poprawić responsywność?
wpc@WPC ~ $ inxi -Fxz
System:    Host: WPC Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: ASUSTeK model: P5K SE v: Rev 1.xx
           Bios: American Megatrends v: 1402 date: 06/25/2009
CPU:       Dual core Pentium E5200 (-MCP-) cache: 2048 KB
           flags: (lm nx sse sse2 sse3 ssse3) bmips: 10029
           clock speeds: max: 2500 MHz 1: 1600 MHz 2: 2500 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RV515 [Radeon X1300/X1550]
           bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1400x1050@60.10hz
           GLX Renderer: Gallium 0.4 on ATI RV515
           GLX Version: 2.1 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card Intel 82801I (ICH9 Family) HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network:   Card-1: Qualcomm Atheros Attansic L1 Gigabit Ethernet
           driver: atl1 v: 2.1.3 bus-ID: 02:00.0
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: 3Com Device ced7 port: ec00 bus-ID: 05:00.0
           IF: N/A state: N/A speed: N/A duplex: N/A mac: N/A
           Card-3: Ralink Wireless PCI Adapter RT2400 / RT2460
           driver: rt2400pci v: 2.3.0 bus-ID: 05:01.0
           IF: wlp5s1 state: down mac: <filter>
Drives:    HDD Total Size: 320.1GB (4.2% used)
           ID-1: /dev/sda model: ST320LT007 size: 320.1GB
Partition: ID-1: / size: 288G used: 6.9G (3%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 6.44GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 41.0C mobo: 37.0C
           Fan Speeds (in rpm): cpu: 937 psu: 0 sys-1: 0
Info:      Processes: 189 Uptime: 3:45 Memory: 2176.5/5965.2MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35
« Ostatnia zmiana: Maj 25, 2018, 15:58:09 pm wysłana przez rafall93123 »

*

Offline yahoob3

  • *****
  • 799
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« Odpowiedź #1 dnia: Maj 25, 2018, 19:48:32 pm »
Witamy Nowego :)

Próbowałeś zamiast Cinnamona, MATE lub jeszcze lepiej XFCE? Te dwa środowiska lepiej sprawują się na starszym sprzęcie.
Właśnie jestem po instalacji XFCE na Compaq'u nc 8230 z 2 GB RAM i jest przyzwoicie :)
Z tą grafiką nie pomogę, bo może to ona coś bruździ - nie mam żadnego AMD pod ręką.
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

*

Offline ciastek1981

  • *******
  • 1219
  • 153
  • Płeć: Mężczyzna
Odp: Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« Odpowiedź #2 dnia: Maj 25, 2018, 21:27:21 pm »
Gawędziarzu, a może byś poprosił o to

dmesg|pastebinithttp://forum.linuxmint.pl/index.php?topic=6937.0

*

Offline yahoob3

  • *****
  • 799
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« Odpowiedź #3 dnia: Maj 25, 2018, 21:36:25 pm »
Fakt, mogłem o tym pomyśleć, że ktoś potrafi to czytać, w przeciwieństwie do mnie. Poprawie się.
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

*

Offline ciastek1981

  • *******
  • 1219
  • 153
  • Płeć: Mężczyzna
Odp: Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« Odpowiedź #4 dnia: Maj 25, 2018, 21:42:25 pm »
E5200 to ma zegar 2,5Ghz. Reszta to wróżenie z fusów. Najpierw pytamy co go boli  8)
« Ostatnia zmiana: Maj 25, 2018, 21:45:40 pm wysłana przez ciastek1981 »


*

Offline ciastek1981

  • *******
  • 1219
  • 153
  • Płeć: Mężczyzna
Odp: Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« Odpowiedź #6 dnia: Maj 27, 2018, 00:04:56 am »
Jeszcze muszę się wczytać, ale jakoś dziwnie to wygląda ??? (albo ślepnę)

[    0.000000] PM: Registered nosave memory: [mem 0x00000000-0x00000fff]
[    0.000000] PM: Registered nosave memory: [mem 0x0009d000-0x0009dfff]
[    0.000000] PM: Registered nosave memory: [mem 0x0009e000-0x0009ffff]
[    0.000000] PM: Registered nosave memory: [mem 0x000a0000-0x000e3fff]
...

Co tam zwróci np.

sudo  dmidecode -t 17 | grep -i size

cat /proc/meminfo

To też jest ciekawe

[    0.000000] Calgary: detecting Calgary via BIOS EBDA area
[    0.000000] Calgary: Unable to locate Rio Grande table in EBDA - bailing!

yahoob3, poradzisz sobie?

Przydałby się jeszcze wynik polecenia np.
 
journalctl -k | grep -i bios
albo

journalctl -k | grep -i error
... no i x-y

cat /var/log/Xorg.0.log | grep -i error
« Ostatnia zmiana: Maj 27, 2018, 09:36:23 am wysłana przez ciastek1981 »

*

Offline yahoob3

  • *****
  • 799
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« Odpowiedź #7 dnia: Maj 27, 2018, 10:38:54 am »
Co postaram się wymyślić, ale dopiero wieczorem, bo zaraz zmykam na komunistyczną impre.
Co do miasta w Kanadzie ;D to, chodzi o zarządzanie pamięcią. Można to spróbować naprawić. Muszę się temu przyjrzeć bliżej. Na szybko nie będę wymyślał.
Być może same zmiany w GRUBie pomogą.


EDIT:OK, z tego, co wyczytałem w guglu i u siebie w kompie, Calgary raczej nie ma wpływu na to, co dzieje się z tym komputerem.Przez moje Lenovo też nie przepływa Rio Grande, a sprzęt chodzi dobrze przy podobnych parametrach CPU i tej samej ilości RAM i IMHO to jest główny podejrzany w sprawie problemów.Pytanie za 100 pkt.:Kości RAM masz identyczne, czy kombinowane?Podaj wyniki poleceń, o których pisał Ciastek1981, to raz.
Dwa - najprostszy test: wyjmij jedną z kości RAM, uruchom komputer najpierw na jednej kości, a potem na drugiej i zobacz jak się komputer zachowuje.

« Ostatnia zmiana: Maj 27, 2018, 20:48:50 pm wysłana przez yahoob3 »
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

Odp: Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« Odpowiedź #8 dnia: Maj 28, 2018, 17:15:46 pm »
Wyniki podanych poleceń. https://pastebin.com/EPWEQpF7
Odpaliłem Fedorę na live no niestety coś z grafiką było nie tak, bo ekran logowania się nie wyświetlał poprawnie. Kolejna próba to Antergos z Cinnamonem to samo co na Mincie.

*

Offline yahoob3

  • *****
  • 799
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« Odpowiedź #9 dnia: Maj 29, 2018, 08:31:31 am »
Spróbuj uruchomić komputer w trybie Live z opcją "compatibility" lub "nomodeset"
http://linuxmint-installation-guide.readthedocs.io/en/latest/boot_options.html
Jest szansa, że zadziała:
https://forums.linuxmint.com/viewtopic.php?t=165498
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

*

Offline ciastek1981

  • *******
  • 1219
  • 153
  • Płeć: Mężczyzna
Odp: Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« Odpowiedź #10 dnia: Maj 30, 2018, 11:38:04 am »
To w którą stronę idziemy? Przydałoby się jeszcze, żeby wypisało wszystko z "failed"

cat /var/log/Xorg.0.log | grep -i ee
Jakiś spec od Radków by się przydał bo ostatni raz kartę ATI/AMD miałem i w komputerze widziałem coś około 2003 roku.

Odp: Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« Odpowiedź #11 dnia: Maj 30, 2018, 11:48:37 am »
W ustawieniach widnieje 1400x1050 https://pastebin.com/

*

Offline ciastek1981

  • *******
  • 1219
  • 153
  • Płeć: Mężczyzna
Odp: Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« Odpowiedź #12 dnia: Maj 30, 2018, 11:55:34 am »
Popraw link.

Odp: Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« Odpowiedź #13 dnia: Maj 30, 2018, 12:34:02 pm »
Coś nie klikło, poprawione:) https://pastebin.com/R1ac1asN

*

Offline ciastek1981

  • *******
  • 1219
  • 153
  • Płeć: Mężczyzna
Odp: Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« Odpowiedź #14 dnia: Maj 30, 2018, 14:37:14 pm »
Na razie spróbuj na Mincie (o ile jest zainstalowany) zrobić tak (najpierw przeczytaj od dołu)

sudo xed /usr/share/X11/xorg.conf.d/20-radeon.conf
...wklej to co poniżej do dokumentu (jeżeli jest pusty), zapisz i uruchom ponownie.
Section "Device"
    Identifier "Radeon"
    Driver "radeon"
    Option "TearFree" "on"
    Option "DRI" "3"
EndSection

Ewentualnie, jeżeli jest plik 10-radeon.conf to, przed EndSection należy dopisać/edytować

sudo xed /usr/share/X11/xorg.conf.d/10-radeon.conf
końcówka ma wyglądać tak

    Option "TearFree" "on"
    Option "DRI" "3"
EndSection

Nie zaszkodzi. To jest tylko włączenie akceleracji sprzętowej.
« Ostatnia zmiana: Maj 31, 2018, 05:17:32 am wysłana przez ciastek1981 »