Lnux Mint 18 - starszy sprzęt - ATI niska responsywność

  • 35 replies
  • 908 views
Odp: Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« Odpowiedź #15 dnia: Czerwiec 06, 2018, 02:30:04 am »
Niestety rozwiązanie nie pomogło, musiałem wyłączyć ponieważ ekran logowania był cały w artefaktach.
Żonglowałem pamięciami ram, to również nie przyniosło efektów. Przypuszczałem iż szybciej pójdzie, jakie kroki polecicie podjąć dalej? :D

*

Offline dedito

  • ***
  • 127
  • 60
Odp: Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« Odpowiedź #16 dnia: Czerwiec 06, 2018, 09:08:59 am »
Cinnamon wymaga akceleracji 3D (chyba, że już coś się zmieniło) więc jak masz problem ze sterownikiem karty graficznej to takie mogą być efekty.
Sprawdź najpierw czy Mint z XFCE lub Mate działa poprawnie.
Nie widzę też nigdzie abyś zamieścił pełne logi xorga z problemów na Cinnamon.

*

Offline ciastek1981

  • *******
  • 999
  • 114
  • Płeć: Mężczyzna
  • Zbanowany ;)
Odp: Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« Odpowiedź #17 dnia: Czerwiec 06, 2018, 09:35:02 am »
Daj jak dedito (Debianowiec  8) rzuci fachowym okiem) prosi cały wynik

cat /var/log/Xorg.0.log|pastebinit
Tam jeszcze w pliku 10-radeon.conf/20-radeon.conf, przed Option "TearFree" "on" trzeba by wrzucić

Option "AccelMethod" "EXA"*"glamor" jest od "rodziny" R600 _1_ oraz _2_ i _3_

PS Akcelerację sprawdzisz sobie tak

glxinfo | grep -i rendering
« Ostatnia zmiana: Czerwiec 06, 2018, 11:26:14 am wysłana przez ciastek1981 »

*

Offline yahoob3

  • *****
  • 568
  • 109
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« Odpowiedź #18 dnia: Czerwiec 06, 2018, 12:51:52 pm »
Dogrzebałem się do tego: https://forum.linuxmint.pl/index.php?topic=8412.0 może widzieliście.
I tak nieśmiało spytam, czy może spróbować fglrx? O ile się jakiś znajdzie... bo "jacuś" nie mogę zobaczyć.
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

Odp: Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« Odpowiedź #19 dnia: Czerwiec 06, 2018, 13:28:51 pm »
Bez zmiany czegokolwiek

glxinfo | grep -i rendering
direct rendering: Yes"

https://pastebin.com/appaBfq0

Pod ręką miałem Deepina i w trybie live jest ok, YT w  720p bez zacięć.

Poprawienie formatowania tekstu.
« Ostatnia zmiana: Czerwiec 06, 2018, 18:14:43 pm wysłana przez ciastek1981 »

*

Offline dedito

  • ***
  • 127
  • 60
Odp: Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« Odpowiedź #20 dnia: Czerwiec 06, 2018, 14:22:17 pm »
Dogrzebałem się do tego: https://forum.linuxmint.pl/index.php?topic=8412.0 może widzieliście.
I tak nieśmiało spytam, czy może spróbować fglrx? O ile się jakiś znajdzie... bo "jacuś" nie mogę zobaczyć.
fglrx to już zamknięty projekt i nie ruszy na tym systemie bez cofania wersji xorg.
Oczywiście są tacy rzeźnicy, którzy tak robią, choćby tu https://forums.linuxmint.com/viewtopic.php?t=250829 ale ja wolałbym najpierw sprawdzić współczesne metody, niż tak kaleczyć system z czego też mogą być późniejsze kłopoty.

Z logów wynika, że pracuje na sterowniku ati/radeon z wyłączoną akceleracją 3D.
Sprawdziłbym czy dopisanie do konfiguracji xorg linijki Option "DRI" "3" (szerzej opisał to ciastek1981) da jakieś efekty.
W razie dalszych kłopotów warto poczytać: https://wiki.archlinux.org/index.php/ATI#Troubleshooting
« Ostatnia zmiana: Czerwiec 06, 2018, 14:28:39 pm wysłana przez dedito »

*

Offline yahoob3

  • *****
  • 568
  • 109
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« Odpowiedź #21 dnia: Czerwiec 06, 2018, 14:34:44 pm »
Option "DRI" "3"To już próbował i ekran logowania był w artefaktach  :(
Ja bym jednak spróbował "nomodeset" i/lub "radeon.modeset=0" w GRUBie...
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

*

Offline ciastek1981

  • *******
  • 999
  • 114
  • Płeć: Mężczyzna
  • Zbanowany ;)
Odp: Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« Odpowiedź #22 dnia: Czerwiec 06, 2018, 14:36:57 pm »
Cały problem sprowadza się do tego

[    29.077] (==) RADEON(0): DRI3 disabled
Tylko nie wiem jak pójdzie czy z wpisem

Section "Device"
    Identifier "Radeon"
    Driver "radeon"
    Option "AccelMethod" "EXA"
    Option "TearFree" "on"
    Option "DRI" "3"
EndSection

w

/usr/share/X11/xorg.conf.d/20-radeon.conf
czy w

/usr/share/X11/xorg.conf.d/10-radeon.conf
10-radeon.conf jest domyślne i zawiera wpis

Section "OutputClass"
    Identifier "radeon"
    MatchDriver "radeon"
    Driver "radeon"
EndSection

dedito pisał poradniki na debian.pl to jest bardziej rozeznany.

Edyta: Różnica jest taka, że w 10-radeon.conf jest Section "OutputClass", a powinno to wyglądać tak Section "Device", więc pewnie 20-radeon.conf trzeba utworzyć z parametrami jak wyżej.

Jak w tym poradniku https://cubethethird.wordpress.com/2016/06/14/eliminate-screen-tearing-with-amd-gpu-on-ubuntu/

Ogólnie "bajery" są domyślnie włączone dla kart >=R600.
« Ostatnia zmiana: Czerwiec 06, 2018, 14:55:39 pm wysłana przez ciastek1981 »

*

Offline yahoob3

  • *****
  • 568
  • 109
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« Odpowiedź #23 dnia: Czerwiec 06, 2018, 14:45:54 pm »
:) Wiesz, ja to macham brzytwą, jak ta małpa - Ockham.
OK, chowam do kieszeni. Sam jestem ciekawy, bo małżonki netbook ma właśnie radka, ale tam jest problem z temperaturą.

edit:
Cytuj
dedito pisał poradniki na debian.pl to jest bardziej rozeznany.
Od razu wydał mi się "podejrzany" ;)
« Ostatnia zmiana: Czerwiec 06, 2018, 14:56:55 pm wysłana przez yahoob3 »
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

*

Offline ciastek1981

  • *******
  • 999
  • 114
  • Płeć: Mężczyzna
  • Zbanowany ;)
Odp: Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« Odpowiedź #24 dnia: Czerwiec 06, 2018, 14:55:10 pm »
To po co prosimy o logi? Zamiast siedzieć na dobrychtrojanach (tam się niewiele nauczysz), to trzeba podpatrywać fachowców na debian.pl czy dug.net.pl .

Edyta: Jest takie fajne polecenie do sprawdzania

xdpyinfo | grep -i dri
« Ostatnia zmiana: Czerwiec 06, 2018, 15:49:37 pm wysłana przez ciastek1981 »

*

Offline dedito

  • ***
  • 127
  • 60
Odp: Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« Odpowiedź #25 dnia: Czerwiec 06, 2018, 17:05:16 pm »
Option "DRI" "3"To już próbował i ekran logowania był w artefaktach  :(
Ja bym jednak spróbował "nomodeset" i/lub "radeon.modeset=0" w GRUBie...
Tak, pisał o tym, dlatego też zasugerowałem lekturę wiki archa sekcja kłopoty, gdzie jest jedna rada na artefakty: https://wiki.archlinux.org/index.php/ATI#Performance_and.2For_artifacts_issues_when_using_EXA
log autora:
29.013] (II) RADEON(0): EXA: Driver will allow EXA pixmaps in VRAMDobrze by było jakby też dostarczył logi xorg z sesji z tymi artefaktami.

Dla jasności zacytuję sugestię (z wiki archa) na kłopoty z artefaktami:
Cytuj
f having 2D performance issues, like slow scrolling in a terminal or webbrowser, adding Option "MigrationHeuristic" "greedy" as device option may solve the issue.

In addition disabling EXAPixmaps may solve artifacts issues, although this is generally not recommended and may cause other issues.
« Ostatnia zmiana: Czerwiec 06, 2018, 17:12:19 pm wysłana przez dedito »

*

Offline ciastek1981

  • *******
  • 999
  • 114
  • Płeć: Mężczyzna
  • Zbanowany ;)
Odp: Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« Odpowiedź #26 dnia: Czerwiec 06, 2018, 18:10:18 pm »
dedito, u nas trzeba jak dla dzieci  8)

rafall93123, żeby nie kasować, dopisz w configu hash/płotek - # przed Option (będzie traktowane jak tekst), zapisz i przeloguj/uruchom ponownie.

#Option "AccelMethod" "EXA"
potem jeszcze raz

cat /var/log/Xorg.0.log|pastebinit
Edyta: Już się sam pogubiłem bo to 2 minuty sprawdzania, a my lecimy w tygodnie.

Chodzi o ten log z parametrami xx-radeon.conf zobaczymy co go tam boli - artefakty.
« Ostatnia zmiana: Czerwiec 06, 2018, 20:05:49 pm wysłana przez ciastek1981 »

Odp: Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« Odpowiedź #27 dnia: Czerwiec 09, 2018, 22:15:56 pm »
Edytowałem plik 10-radeon.conf i po włączeniu mam czarny ekran konsoli, tryb awaryjny tak samo. Przeszedłem do konsoli i przywróciłem do stanu pierwotnego. Teraz dać te logi co wyżej?

*

Offline dedito

  • ***
  • 127
  • 60
Odp: Lnux Mint 18 - starszy sprzęt - ATI niska responsywność
« Odpowiedź #28 dnia: Czerwiec 10, 2018, 08:26:53 am »
Edytowałem plik 10-radeon.conf i po włączeniu mam czarny ekran konsoli, tryb awaryjny tak samo. Przeszedłem do konsoli i przywróciłem do stanu pierwotnego. Teraz dać te logi co wyżej?
Zgadza się, jeszcze raz wykonaj cat /var/log/Xorg.0.log|pastebinit, logi powiedzą co tam poszło nie tak.