[nieaktualne] fizyczny wyłącznik nie działa

  • 32 replies
  • 1082 views
*

Offline bossot

  • ***
  • 102
  • 9
[nieaktualne] fizyczny wyłącznik nie działa
« dnia: Czerwiec 12, 2018, 11:13:40 am »
Wczoraj zainstalowałem system na 8-letnim laptopie i po wciśnięciu takowego nic się nie dzieje, mimo że w ustawienia / oszczędzanie energii dawałem go na różne działania i potem zastosuj. Jak ma to jakieś znaczenie to wcześniej na dysku był manjaro. Korzystałem wcześniej na tym kompie z minta i wszystko działało, czyli to nie problem sprzętowy tylko coś gdzieś trzeba przestawić.

edit: / było formatowane, ale /home zostało to samo. Być może któryś z plików konfiguracyjnych w nim.
« Ostatnia zmiana: Czerwiec 15, 2018, 10:10:14 am wysłana przez bossot »

*

Offline dedito

  • ***
  • 241
  • 140
Odp: fizyczny wyłącznik nie działa
« Odpowiedź #1 dnia: Czerwiec 12, 2018, 11:20:17 am »
Jaki model laptopa?
Jaka wersja minta?

*

Offline bossot

  • ***
  • 102
  • 9
Odp: fizyczny wyłącznik nie działa
« Odpowiedź #2 dnia: Czerwiec 12, 2018, 14:49:06 pm »
Laptop to Acer aspire 5740G. Mint-a w wersji KDE ściągałem wczoraj więc najnowszy jaki jest (18.3) dzisiaj rano go zaktualizowałem, jądro też.

*

Offline bossot

  • ***
  • 102
  • 9
Odp: fizyczny wyłącznik nie działa
« Odpowiedź #3 dnia: Czerwiec 12, 2018, 15:57:16 pm »
To znowu ja. Jak by miało w czymś pomóc, raport z inxi
System:    Host: krzysiek-Aspire-5740 Kernel: 4.13.0-45-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: KDE Plasma 5.8.9 (Qt 5.6.1) Distro: Linux Mint 18.3 Sylvia
Machine:   System: Acer (portable) product: Aspire 5740 v: Rev
           Mobo: Acer model: Aspire 5740 v: Rev Bios: Phoenix v: V1.22 date: 03/18/2010
CPU:       Dual core Intel Core i3 M 330 (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8510
           clock speeds: max: 2133 MHz 1: 1444 MHz 2: 1379 MHz 3: 1189 MHz 4: 1412 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Madison [Mobility Radeon HD 5650/5750 / 6530M/6550M]
           bus-ID: 02:00.0
           Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1366x768@60.04hz
           GLX Renderer: AMD REDWOOD (DRM 2.50.0 / 4.13.0-45-generic, LLVM 5.0.0)
           GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio:     Card-1 Intel 5 Series/3400 Series High Definition Audio driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Advanced Micro Devices [AMD/ATI] Redwood HDMI Audio [Radeon HD 5000 Series]
           driver: snd_hda_intel bus-ID: 02:00.1
           Sound: Advanced Linux Sound Architecture v: k4.13.0-45-generic
Network:   Card-1: Broadcom NetLink BCM57780 Gigabit Ethernet PCIe driver: tg3 v: 3.137 bus-ID: 03:00.0
           IF: enp3s0 state: down mac: <filter>
           Card-2: Qualcomm Atheros AR928X Wireless Network Adapter (PCI-Express) driver: ath9k bus-ID: 05:00.0
           IF: wlp5s0 state: up mac: <filter>
Drives:    HDD Total Size: 1000.2GB (12.6% used) ID-1: /dev/sda model: HGST_HTS541010A9 size: 1000.2GB
Partition: ID-1: / size: 92G used: 7.7G (9%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 367G used: 108G (31%) fs: ext4 dev: /dev/sda5
           ID-3: swap-1 size: 0.25GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 60.0C mobo: 39.0C gpu: 54.5
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 191 Uptime: 1:10 Memory: 1353.5/3808.2MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35

*

Offline dedito

  • ***
  • 241
  • 140
Odp: fizyczny wyłącznik nie działa
« Odpowiedź #4 dnia: Czerwiec 12, 2018, 17:34:38 pm »
KDE niestety nie używam, więc nie wiem jak tam się ustawia akcje na określone zdarzenia.
Upewnijmy się, że usługa acpid działa:
ps ax | grep -i acpidJeśli w wyniku otrzymasz coś podobnego jak niżej:
900 ?        Ss     7:43 /usr/sbin/acpidznaczyłoby, że usługa działa.
Wtedy spróbowałbym reinstalacji usługi:
sudo apt install --reinstall acpid
« Ostatnia zmiana: Czerwiec 12, 2018, 17:45:43 pm wysłana przez dedito »

*

Offline yahoob3

  • *****
  • 723
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: fizyczny wyłącznik nie działa
« Odpowiedź #5 dnia: Czerwiec 12, 2018, 19:36:38 pm »
edit: / było formatowane, ale /home zostało to samo. Być może któryś z plików konfiguracyjnych w nim.

Żeby to wykluczyć wystarczy założyć konto nowego użytkownika (nie gościa) i się na nie zalogować. Jeśli będzie to samo - słuchaj dedito, jeśli nie - masz dodatkowe info, w którym katalogu szukać ~/ :)
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

*

Offline bossot

  • ***
  • 102
  • 9
Odp: fizyczny wyłącznik nie działa
« Odpowiedź #6 dnia: Czerwiec 12, 2018, 19:47:58 pm »
Na nowym użytkowniku wyskakuje mi pytanie co robić, czyli to coś w ~. Zbyt intensywnie szukać nie zamierzam, bo w ciągu kilku tygodni planuję zmienić kompa.

*

Offline yahoob3

  • *****
  • 723
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: fizyczny wyłącznik nie działa
« Odpowiedź #7 dnia: Czerwiec 12, 2018, 20:08:10 pm »
Z ciekawości byś zobaczył, dał [SOLVED], zostanie dla potomnych. :)
Ja na KDE reaguje jak na flaki, więc nie pomogę. XFCE, to już co innego :)

Może to coś pomoże? https://docs.kde.org/trunk5/en/kde-workspace/kcontrol/powerdevil/index.html

opis do "Button events handling"
« Ostatnia zmiana: Czerwiec 12, 2018, 20:30:03 pm wysłana przez yahoob3 »
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

*

Offline bossot

  • ***
  • 102
  • 9
Odp: fizyczny wyłącznik nie działa
« Odpowiedź #8 dnia: Czerwiec 12, 2018, 20:58:42 pm »
Niestety w ~/.kde4 nie znalazłem pliku z godziną modyfikacji odpowiadającą próbie zmiany ustawień (ani późniejszą), więc nie mam punktu zaczepienia.
« Ostatnia zmiana: Czerwiec 12, 2018, 21:09:32 pm wysłana przez bossot »

*

Offline bossot

  • ***
  • 102
  • 9
Odp: fizyczny wyłącznik nie działa
« Odpowiedź #9 dnia: Czerwiec 12, 2018, 21:09:19 pm »
Ok mam plik tylko co jest w nim nie tak?
[AC]
icon=battery-charging

[AC][HandleButtonEvents]
lidAction=0
powerButtonAction=8
triggerLidActionWhenExternalMonitorPresent=false

[Battery]
icon=battery-060

[Battery][DPMSControl]
idleTime=300

[Battery][DimDisplay]
idleTime=120000

[Battery][HandleButtonEvents]
lidAction=0
powerButtonAction=16
triggerLidActionWhenExternalMonitorPresent=false

[Battery][SuspendSession]
idleTime=600000
suspendType=1

[LowBattery]
icon=battery-low

[LowBattery][BrightnessControl]
value=30

[LowBattery][DPMSControl]
idleTime=120

[LowBattery][DimDisplay]
idleTime=60000

[LowBattery][HandleButtonEvents]
lidAction=0
powerButtonAction=8
triggerLidActionWhenExternalMonitorPresent=false

[LowBattery][SuspendSession]
idleTime=300000
suspendType=1

[migration]
kdedShortcutMigration=true


edit: przez tą pogodę przestaję myśleć, dałem plik ~/.config/powermanagementprofilesrc, skopiowanie sekcji [AC][HandleButtonEvents] z tego konta na którym działa nie pomogło.
« Ostatnia zmiana: Czerwiec 12, 2018, 21:20:01 pm wysłana przez bossot »

*

Offline ciastek1981

  • Respect Mod Authoritah!!!
  • *******
  • 1184
  • 153
  • Płeć: Mężczyzna
  • Sprzątam forum, usuwam reklamy oraz daję bany ;)
Odp: fizyczny wyłącznik nie działa
« Odpowiedź #10 dnia: Czerwiec 13, 2018, 08:41:07 am »
Zobacz tak

sudo xed /etc/default/grub
w wierszu (poniżej) trzeba dopisać "noapic irqpoll"

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
ma to wyglądać tak

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noapic irqpoll"
zapisz plik, a potem jeszcze

sudo update-grub...i zrestartuj.

Później jak coś można przejrzeć wiki Archa.

Edyta: Fizyczny? Znowu coś pokręciłem szukaj pod hasłem "HandlePowerKey".
« Ostatnia zmiana: Czerwiec 13, 2018, 08:57:13 am wysłana przez ciastek1981 »

*

Offline bossot

  • ***
  • 102
  • 9
Odp: fizyczny wyłącznik nie działa
« Odpowiedź #11 dnia: Czerwiec 13, 2018, 12:15:33 pm »
Niestety nie pomogło

*

Offline ciastek1981

  • Respect Mod Authoritah!!!
  • *******
  • 1184
  • 153
  • Płeć: Mężczyzna
  • Sprzątam forum, usuwam reklamy oraz daję bany ;)
Odp: fizyczny wyłącznik nie działa
« Odpowiedź #12 dnia: Czerwiec 13, 2018, 13:02:25 pm »
Pokaż wynik

cat /etc/systemd/logind.conf
możliwe, że trzeba usunąć płotek - # przy

#HandlePowerKey=poweroff
a potem normalnie

sudo systemctl restart systemd-logind
https://wiki.archlinux.org/index.php/Power_management#ACPI_events

Chociaż takie rzeczy normalnie się robi tak jak y3 linkował https://docs.kde.org/trunk5/en/kde-workspace/kcontrol/powerdevil/energy.png (opcje dla przycisku zasilania) albo w środowiskach gtk to dconf.

« Ostatnia zmiana: Czerwiec 13, 2018, 13:29:46 pm wysłana przez ciastek1981 »

*

Offline yahoob3

  • *****
  • 723
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: fizyczny wyłącznik nie działa
« Odpowiedź #13 dnia: Czerwiec 13, 2018, 14:21:23 pm »
           Desktop: KDE Plasma 5.8.9 (Qt 5.6.1) Distro: Linux Mint 18.3 SylviaTylko, że to Q... Qt Plasma :)
Szukałem wciera czy jest jakiś zamiennik dconf, ale coś nie bardzo...
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

*

Offline ciastek1981

  • Respect Mod Authoritah!!!
  • *******
  • 1184
  • 153
  • Płeć: Mężczyzna
  • Sprzątam forum, usuwam reklamy oraz daję bany ;)
Odp: fizyczny wyłącznik nie działa
« Odpowiedź #14 dnia: Czerwiec 13, 2018, 14:29:17 pm »
W pierwszej kolejność ma ustawić co ma robić przycisk zasilania. Przecież dopisałem środowiskach gtk 8)

Więc jak nie pójdzie przycisk to bym sprawdził co się dzieje w tym pliku logind.conf

http://manpages.ubuntu.com/manpages/xenial/man5/logind.conf.d.5.html
https://www.freedesktop.org/software/systemd/man/logind.conf.html

Jest jeszcze takie poleconko do sprawdzania opcji

systemd-inhibit --list
http://manpages.ubuntu.com/manpages/xenial/man1/systemd-inhibit.1.html
https://www.freedesktop.org/software/systemd/man/systemd-inhibit.html
https://www.freedesktop.org/wiki/Software/systemd/inhibit/

Tu jest chyba wszystko rozpisane

https://morfikov.github.io/post/mechanizm-inhibitor-lock-w-systemd/
« Ostatnia zmiana: Czerwiec 13, 2018, 14:49:01 pm wysłana przez ciastek1981 »