[nieaktualne] fizyczny wyłącznik nie działa

  • 32 replies
  • 1081 views
*

Offline bossot

  • ***
  • 102
  • 9
Odp: fizyczny wyłącznik nie działa
« Odpowiedź #15 dnia: Czerwiec 13, 2018, 20:14:50 pm »
Logind.conf wygląda tak:#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.
#
# Entries in this file show the compile time defaults.
# You can change settings by editing this file.
# Defaults can be restored by simply deleting this file.
#
# See logind.conf(5) for details.

[Login]
#NAutoVTs=6
#ReserveVT=6
#KillUserProcesses=no
#KillOnlyUsers=
#KillExcludeUsers=root
#InhibitDelayMaxSec=5
HandlePowerKey=poweroff
HandleSuspendKey=poweroff
HandleHibernateKey=poweroff
HandleLidSwitch=poweroff
#HandleLidSwitchDocked=ignore
PowerKeyIgnoreInhibited=no
SuspendKeyIgnoreInhibited=no
HibernateKeyIgnoreInhibited=no
LidSwitchIgnoreInhibited=no
#HoldoffTimeoutSec=30s
#IdleAction=ignore
#IdleActionSec=30min
#RuntimeDirectorySize=10%
#RemoveIPC=yes
#UserTasksMax=12288
Początkowo handlepowerkey i ta reszta do # były na ignore, zmiana nie pomogła PowerKeyIgnoreInhibited=no i niżej tez do # były wykomentowane, zmiana na yes nie pomogła więc przywróciłem. Niezależnie od ustawień,
Cytuj
systemd-inhibit --list
wygląda tak:
     Who: Telepathy (UID 1000/krzysiek, PID 1524/mission-control)
    What: shutdown:sleep
     Why: Disconnecting IM accounts before suspend/shutdown...
    Mode: delay

     Who: PowerDevil (UID 1000/krzysiek, PID 1644/org_kde_powerde)
    What: handle-power-key:handle-suspend-key:handle-hibernate-key:handle-lid-switch
     Why: KDE handles power events
    Mode: block

     Who: NetworkManager (UID 0/root, PID 872/NetworkManager)
    What: sleep
     Why: NetworkManager needs to turn off networks
    Mode: delay

     Who: ModemManager (UID 0/root, PID 861/ModemManager)
    What: sleep
     Why: ModemManager needs to reset devices
    Mode: delay

Pytanie tylko co go blokuje.


*

Offline yahoob3

  • *****
  • 723
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: fizyczny wyłącznik nie działa
« Odpowiedź #16 dnia: Czerwiec 13, 2018, 20:36:49 pm »
Spróbuj zmienić logind.conf tak (tylko tę część zakomentować):
HandlePowerKey=poweroff
#HandleSuspendKey=poweroff
#HandleHibernateKey=poweroff
#HandleLidSwitch=poweroff
Bo to wygląda tak, że system głupieje bo nie wie, co ma zrobić i nic nie robi bo zgłupiał ;)

(!) Możesz przecież porównać te zapisy na nowym użytkowniku, na którym działa i na starym...

EDIT:
Jeszcze jedno... czy ten klawisz nie nazywa się czasem PowerOff, a nie poweroff?
« Ostatnia zmiana: Czerwiec 13, 2018, 20:48:01 pm wysłana przez yahoob3 »
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

*

Offline bossot

  • ***
  • 102
  • 9
Odp: fizyczny wyłącznik nie działa
« Odpowiedź #17 dnia: Czerwiec 13, 2018, 22:25:14 pm »
Spróbuj zmienić logind.conf tak (tylko tę część zakomentować):
HandlePowerKey=poweroff
#HandleSuspendKey=poweroff
#HandleHibernateKey=poweroff
#HandleLidSwitch=poweroff
Bo to wygląda tak, że system głupieje bo nie wie, co ma zrobić i nic nie robi bo zgłupiał ;)

(!) Możesz przecież porównać te zapisy na nowym użytkowniku, na którym działa i na starym...

EDIT:
Jeszcze jedno... czy ten klawisz nie nazywa się czasem PowerOff, a nie poweroff?
Kopiuj / wklej  z http://manpages.ubuntu.com/manpages/xenial/man5/logind.conf.d.5.html tam jest z małej na liście dostępnych "opcji" wiec tak i u mnie. Zakomentowanie sprawdzę jutro. Inna sprawa że ten plik jest w /etc/systemd, a nie na domowej.

*

Offline yahoob3

  • *****
  • 723
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: fizyczny wyłącznik nie działa
« Odpowiedź #18 dnia: Czerwiec 13, 2018, 23:08:38 pm »
[...] no, przecież. To komenda, a nie nazwa przycisku!
Próbowałeś "halt" zamiast "poweroff"?
Z drugiej strony, to musi gdzieś siedzieć w /home, a nie w /etc. Pomyślimy, iso KDE już jest :)
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

*

Offline bossot

  • ***
  • 102
  • 9
Odp: fizyczny wyłącznik nie działa
« Odpowiedź #19 dnia: Czerwiec 14, 2018, 08:25:52 am »
Halt nie pomogło, ale za to reaguje prawidłowo na zamknięcie pokrywy (grzecznie się wyłącza)

*

Offline ciastek1981

  • Respect Mod Authoritah!!!
  • *******
  • 1184
  • 153
  • Płeć: Mężczyzna
  • Sprzątam forum, usuwam reklamy oraz daję bany ;)
Odp: fizyczny wyłącznik nie działa
« Odpowiedź #20 dnia: Czerwiec 14, 2018, 10:14:39 am »
Wczoraj trochę nie doczytałem, ale jak sprawdzić listę inhibitorów w trybie block i delay było w tym linku do strony morfika

systemd-inhibit --list --mode=block
systemd-inhibit --list --mode=delay
Ciekawe co się stanie jak ustawisz

PowerKeyIgnoreInhibited=yes
systemctl restart systemd-logind.service
« Ostatnia zmiana: Czerwiec 14, 2018, 10:18:31 am wysłana przez ciastek1981 »

*

Offline bossot

  • ***
  • 102
  • 9
Odp: fizyczny wyłącznik nie działa
« Odpowiedź #21 dnia: Czerwiec 14, 2018, 12:31:43 pm »
Niestety bez skutku, dalej PowerDevil jest jako block

*

Offline ciastek1981

  • Respect Mod Authoritah!!!
  • *******
  • 1184
  • 153
  • Płeć: Mężczyzna
  • Sprzątam forum, usuwam reklamy oraz daję bany ;)
Odp: fizyczny wyłącznik nie działa
« Odpowiedź #22 dnia: Czerwiec 14, 2018, 13:16:24 pm »
To już nie wiem, ktoś bardziej obeznany z systemd powinien się wypowiedzieć. Zresztą Mint z KDE jest martwym projektem, który tam jeszcze będzie miał jakieś wsparcie, ale ...

Popatrzyłbym jeszcze tu

https://wiki.archlinux.org/index.php/acpid#Configuration

oraz tu

https://wiki.debian.org/ConfigurePowerButton

https://www.hiroom2.com/2016/10/21/debian-8-shutdown-with-pressing-power-button/

i tu

https://www.hiroom2.com/2016/10/19/ubuntu-16-04-shutdown-with-pressing-power-button/
« Ostatnia zmiana: Czerwiec 14, 2018, 16:23:29 pm wysłana przez ciastek1981 »

Odp: fizyczny wyłącznik nie działa
« Odpowiedź #23 dnia: Czerwiec 14, 2018, 17:40:34 pm »
Witam, ja postąpiłbym inaczej: wpierw wyeliminowałbym dylemat czy nie jest to problem sprzętowy: poprzez instalację na sprzęcie windozy lub innej dystrybucji linuxa, bądź starszej wersji Minta. Ja miałem problem z wyłącznikiem na PC który nie działał na żadnej dystrybucji (z ładowanych dysków do kieszeni sata) windozy, hackintosha, linuxa, bsd. Wyczytałem na forum (pośród przeważających porad dotyczących warstwy softowej, pisanych przez przecież znakomitych fachowców) że może to być związane z gryzieniem się kart ata, faktycznie po wyjęciu karty z pcmcia, pc zaczął zamykać się normalnie, jak dawniej (ok 6 lat temu  ;D), prawdę mówiąc wciąż nie mogę uwierzyć że to szczęście naprawdę spłynęło na mnie, bo przez te lata wyłączałem zasilacz w trakcie standardowego restartu

*

Offline yahoob3

  • *****
  • 723
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: fizyczny wyłącznik nie działa
« Odpowiedź #24 dnia: Czerwiec 14, 2018, 20:34:14 pm »
@javenus: wątek jest dość długi ale kilka rzeczy ustaliliśmy. Problem jest z configiem użytkownika (na nowym wszystko jest OK).

@bossot: OK, KDE zainstalowane (21 sekunda). Wybacz, nie mogłem się powstrzymać, tzn. MSPANC ;)


Grzebałeś coś w "Ustawienia systemowe", "Uruchamianie i wyłączanie", "Sesja pulpitu"?
Zobacz ten filmik: https://www.youtube.com/watch?v=UtJza6NzjEU

Jak mi ktoś powie, że KDE jest "najbliżej" Windows, to chyba... popatrzę na niego z politowaniem.  ;D
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

*

Offline bossot

  • ***
  • 102
  • 9
Odp: fizyczny wyłącznik nie działa
« Odpowiedź #25 dnia: Czerwiec 14, 2018, 23:01:51 pm »
U mnie wygląda tak samo, jedyna różnica jest taka że zaczyna z pustą sesją (co raczej poprawia działanie a nie pogarsza). Zassałem cinnemona, jutro zainstaluję i zobaczę czy dam radę się przestawić (oby krusader doinstalował na tyle mało KDE żeby guzik działał, jako weteran norton i total commandera będę go potrzebował). Bo zaczynam mieć wrażenie że tutaj trzeba by tworzyć nowe konto i skopiować tam wszystko poza konfigami.

edit: co do fizycznej awarii, to poza nowym kontem działał bez problemu w manjaro, mam też win 7  do grania, również bez problemów.

edit2: Manjaro po którym zostawiłem home miało nowszą wersję później niż mint, przypuszczam że któryś config jest dla nowszej wersji któregoś pakietu, i nie jest prawidłowo "czytany".
« Ostatnia zmiana: Czerwiec 14, 2018, 23:13:10 pm wysłana przez bossot »

*

Offline bossot

  • ***
  • 102
  • 9
Odp: [nieaktualne] fizyczny wyłącznik nie działa
« Odpowiedź #26 dnia: Czerwiec 15, 2018, 10:13:23 am »
Zainstalowałem wersję cinamon i chyba ze sobą wytrzymamy, grzecznie pytać co robić aczkolwiek bywa że po kliknięciu w wyłącz jest opóźnienie.

*

Offline yahoob3

  • *****
  • 723
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: [nieaktualne] fizyczny wyłącznik nie działa
« Odpowiedź #27 dnia: Czerwiec 15, 2018, 12:49:46 pm »
Zainstalowałem wersję cinamon i chyba ze sobą wytrzymamy, grzecznie pytać co robić aczkolwiek bywa że po kliknięciu w wyłącz jest opóźnienie.
Tu bez problemu powinno działać po wciśnięciu przycisku ON/OFF - zamknij (wyłącz?) natychmiast... skleroza.
A co do /home, to na 100% coś się pogryzło z Manjaro.
Taka moja rada: jak chcesz bezproblemowo zostawić /home na nowy system, zostaw tylko katalogi użytkownika (Dokumenty, Pulpit, itd.) oraz te katalogi z kropką, które odnoszą się bezpośrednio do programów, np. Thunderbird, FF, idt. Ja zostawiam jeszcze historię basha - przydaje się. Jakieś konfigi z /opt bekapuje w magazynie.
Co prawda nieco więcej jest do ustawiania po wgraniu nowego systemu, ale za to masz prawie pewność, że takich właśnie hocków nie będzie.Pozdrawiam, YB3
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

*

Offline bossot

  • ***
  • 102
  • 9
Odp: [nieaktualne] fizyczny wyłącznik nie działa
« Odpowiedź #28 dnia: Czerwiec 15, 2018, 14:50:38 pm »
Ano trzeba będzie tak robić. Co do opóźnień, to raz (po pierwszej aktualizacji systemu, było tego ze 400 mb) po wciśnięciu w(y)łącznika dostałem komunikat że gnome-keyring nie chce się wyłączyć. Być może opóźnienia też są nim spowodowane. Albo też nałożyły się 2 wersje starsza i nowsza, i nie do końca umiało się to wszystko zamknąć. Ale to jednorazowy przypadek, a kilka restartów od tamtej pory dla testów zrobiłem.

*

Offline ciastek1981

  • Respect Mod Authoritah!!!
  • *******
  • 1184
  • 153
  • Płeć: Mężczyzna
  • Sprzątam forum, usuwam reklamy oraz daję bany ;)
Odp: [nieaktualne] fizyczny wyłącznik nie działa
« Odpowiedź #29 dnia: Czerwiec 15, 2018, 15:50:28 pm »
A co do /home, to na 100% coś się pogryzło z Manjaro.

Przeglądnąłem sobie pliki i foldery w home. W lokalizacji /home/użytkownik/.config/kglobalshortcutsrc w sekcji gdzie jest opisane PowerOff=Power Off, Power Off, Wyłącz to w Mincie ta sekcja nazywa się [kded5], a w Manjaro [org_kde_powerdevil]. Ciekawe czy to ma jakieś znaczenie?