Mint się nie wyłącza

  • 12 replies
  • 416 views
Mint się nie wyłącza
« dnia: Czerwiec 13, 2018, 20:40:24 pm »
Witam,

Problem nie dotyczy samego Minta, bo na Sparky Linuksie również występuje.
Mam laptop Lenovo B570. Kiedyś był na nim Win7, jakiś czas temu wywaliłem go i zainstalowałem Sparky oraz Minta. No i teraz przy próbie wyłączenia system się owszem zatrzymuje, dochodzi do 'system halted', ale 'power off' już nie następuje. Reboot działa, więc doraźnie rebootuję go i przy wyświetleniu logo wciskam włącznik.
Nie muszę dodawać, że Win7 się oczywiście wyłączał.

Przejrzałem fora i prawdopodobnie błąd może być w BIOSie (tu jest jakaś wczesna wersja UEFI). Ale mam najnowszy, nic nowszego producent nie wypuścił.
Próbowałem przekazywać parametry do jądra. Np. acpi=force. Bez rezultatu...

Może ma ktoś pomysł co można jeszcze zrobić? Skompilować własne jądro? Ale z jakimi opcjami?

Pozdrawiam,
Michał

*

Offline kris777

  • ***
  • 208
  • 50
Odp: Mint się nie wyłącza
« Odpowiedź #1 dnia: Czerwiec 13, 2018, 21:13:34 pm »
A czy masz założone hasło w BIOS-e ? ... ktoś wspominał o podobnym problemie ... ale osobiście w to wątpię. A może jakaś usługa / sterownik blokuje zamknięcie systemu ? ... karta wifi / bluetooth ?
« Ostatnia zmiana: Czerwiec 13, 2018, 21:19:12 pm wysłana przez kris777 »

*

Offline yahoob3

  • *****
  • 723
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Mint się nie wyłącza
« Odpowiedź #2 dnia: Czerwiec 13, 2018, 21:17:29 pm »
Pokaż:
inxi -Fxzi zawartość pliku
/etc/default/grubTen laptop ma problem z acpi, z tego co pamiętam.
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

Odp: Mint się nie wyłącza
« Odpowiedź #3 dnia: Czerwiec 13, 2018, 22:16:53 pm »
Pokaż:
inxi -Fxzi zawartość pliku
System:    Host: LaptopMint Kernel: 4.13.0-45-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: LENOVO (portable) product: HuronRiver Platform v: Lenovo B570
           Mobo: LENOVO model: Emerald Lake v: FAB1
           Bios: LENOVO v: 44CN33WW date: 04/07/2011
CPU:       Dual core Intel Core i3-2310M (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8381
           clock speeds: max: 2100 MHz 1: 2074 MHz 2: 2072 MHz 3: 1351 MHz
           4: 1875 MHz
Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel Sandybridge Mobile
           GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio:     Card Intel 6 Series/C200 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.13.0-45-generic
Network:   Card-1: Broadcom BCM4313 802.11bgn Wireless Network Adapter
           driver: bcma-pci-bridge bus-ID: 02:00.0
           IF: wlp2s0b1 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 2000 bus-ID: 03:00.0
           IF: enp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 500.1GB (22.7% used)
           ID-1: /dev/sda model: WDC_WD5000BPVT size: 500.1GB
Partition: ID-1: / size: 28G used: 14G (53%) fs: ext4 dev: /dev/sda5
           ID-2: /home size: 192G used: 85G (47%) fs: ext4 dev: /dev/sda4
           ID-3: swap-1 size: 8.39GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 49.0C mobo: 39.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 208 Uptime: 22 min Memory: 1821.2/7890.9MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35

/etc/default/grub# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT="Linux Mint 18.3 Cinnamon 64-bit"
#GRUB_HIDDEN_TIMEOUT="0"
GRUB_HIDDEN_TIMEOUT_QUIET="true"
GRUB_TIMEOUT="5"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE="640x480"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID="true"

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

GRUB_SAVEDEFAULT="false"


*

Offline yahoob3

  • *****
  • 723
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Mint się nie wyłącza
« Odpowiedź #4 dnia: Czerwiec 14, 2018, 19:29:52 pm »
Ostatnia linijka w "grub"
GRUB_SAVEDEFAULT="false"Skąd to wziąłeś?
Ustawienia zarządzania zasilaniem masz... coś w ten deseń?

I jeszcze pytania:
- Dual boot z Windows, czy tylko MInt?
- W BIOSie ustawiłeś UEFI czy LEGACY?
Łan mor kłeszczyn: Czy działają ci w laptopie klawisze funkcyjne (z Fn lub nie) odpowiadające za ściemnianie i rozjaśnianie ekranu?
Zakomentuj też tę linię (żeby wyglądała tak, jak poniżej):
#GRUB_GFXMODE=640x480
« Ostatnia zmiana: Czerwiec 14, 2018, 19:56:30 pm wysłana przez yahoob3 »
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

Odp: Mint się nie wyłącza
« Odpowiedź #5 dnia: Czerwiec 14, 2018, 20:47:38 pm »
Hmmm...
Konfigurację gruba zapisał Grub Customizer. Wywalę te dwie linijki.
Zasilanie, tak coś w ten deseń


Tylko Mint. Nie mam ustawień w BIOSie UEFI/LEGACY. To dość prymitywna wersja UEFI. Być może jedna z pierwszych tego producenta. Klawisze funkcyjne działają.

*

Offline yahoob3

  • *****
  • 723
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Mint się nie wyłącza
« Odpowiedź #6 dnia: Czerwiec 14, 2018, 20:53:36 pm »
Nie wywalaj, tylko zakomentuj #

EDIT:
System faktycznie pyta co ma zrobić? Próbowałeś innych ustawień tej opcji?
« Ostatnia zmiana: Czerwiec 14, 2018, 20:56:31 pm wysłana przez yahoob3 »
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

Odp: Mint się nie wyłącza
« Odpowiedź #7 dnia: Czerwiec 14, 2018, 21:04:57 pm »
To był skrót myślowy :) Oczywiście zakomentowałem...

Pyta. Pojawia się standardowe okno Uśpij/Hibernuj/Uruchom ponownie/Anuluj/Wyłącz komputer
Nic specjalnego.
Można zmienić ustawienia - któraś z tych powyższych lub 'nic nie rób'
« Ostatnia zmiana: Czerwiec 14, 2018, 21:06:42 pm wysłana przez pixel70 »

*

Offline kris777

  • ***
  • 208
  • 50
Odp: Mint się nie wyłącza
« Odpowiedź #8 dnia: Czerwiec 14, 2018, 21:12:03 pm »
Czy to nie jest czasem taki bug :
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1594023
czyli coś z kernelem ?

*

Offline yahoob3

  • *****
  • 723
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Mint się nie wyłącza
« Odpowiedź #9 dnia: Czerwiec 14, 2018, 21:15:11 pm »
W sumie też o tym myślałem.
@pixel70 spróbuj uruchomić system na oryginalnym jaju 4.10 i zobacz, czy jest ok.

Z tego co tam piszą pomaga acpi=force, ale próbowałeś. Tej wersji?
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"Piszą też, że kernel 4.9 jest ok i działa.

« Ostatnia zmiana: Czerwiec 14, 2018, 21:38:07 pm wysłana przez yahoob3 »
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

*

Offline kris777

  • ***
  • 208
  • 50
Odp: Mint się nie wyłącza
« Odpowiedź #10 dnia: Czerwiec 14, 2018, 21:19:06 pm »
A o tym wcześniej wspominałem ...ale to chyba jakaś ściema ? :-)
https://www.elektroda.pl/rtvforum/topic2912914.html#14057859

Odp: Mint się nie wyłącza
« Odpowiedź #11 dnia: Czerwiec 14, 2018, 21:35:35 pm »
@yahoob3 nie pomogło :(
@kris777 nie mam hasła na BIOS. A wcześniejszy post - tak, w sumie tak się zachowuje. Probowałem acpi=force. Nie pomogło

*

Offline yahoob3

  • *****
  • 723
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Mint się nie wyłącza
« Odpowiedź #12 dnia: Czerwiec 14, 2018, 21:48:43 pm »
No, to może spróbuj kernel albo 4.9, albo najnowszy dostępny - 4.15.0-23 (Menedżer aktualizacji, widok, jądra).
Zobacz, czy to coś pomoże /etc/default/grub:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"
Jakie sterowniki masz zainstalowane do karty graficznej? Tam są dwie czy tylko integra?

EDIT:
Jeszcze jedno;
Przejdź do konsoli: Ctrl+Alt+(Fn)F1 i wykonaj:
sudo shutdown -h nowlub
sudo poweroff
« Ostatnia zmiana: Czerwiec 14, 2018, 21:57:51 pm wysłana przez yahoob3 »
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742