Forum Linux Mint Polska
Pakiety kolidują ze sobą i uniemożliwiają instalację - Wersja do druku

+- Forum Linux Mint Polska (https://forum.linuxmint.pl)
+-- Dział: Wsparcie (https://forum.linuxmint.pl/forumdisplay.php?fid=203)
+--- Dział: Podstawy (https://forum.linuxmint.pl/forumdisplay.php?fid=138)
+--- Wątek: Pakiety kolidują ze sobą i uniemożliwiają instalację (/showthread.php?tid=1143)

Strony: 1 2


Pakiety kolidują ze sobą i uniemożliwiają instalację - rivulek - 04-08-2020

Dzień dobry
Miałem na komputerze jedną rozdzielczość; sterowniki z grafiki nie działały prawidłowo. Odinstalowałem sterowniki które (jak mi się wydawało) powodowały ten problem.
Teraz chciałbym zainstalować sterownik nvidia-440. Niestety próba instalacji zwraca błąd
Kod:
E: niespełnione zalezność. Proszę spróbować wykonać apt --fix-broken install
To [--fix-broken] z kolei zwraca:
Kod:
E: sub-process /usr/bin/dpkg returned and error code (1)
Próbowałem też dpkg --configure -a, ale bezskutecznie. Za każdym razem trzy pakiety powodują uniemożliwienie wykonania polecenia. Autoremove próbowałem wielokrotnie. Poniżej wklejam zdjęcia. Czy jest szansa naprawienia tego?
Uwaga: obecnie nie mam środowiska graficznego (proszę o pomoc w postaci komend terminala).
[Obrazek: jawr3OS.jpg]
[Obrazek: 2fNUbhL.jpg]


RE: Pakiety kolidują ze sobą i uniemożliwiają instalację - dedito - 04-08-2020

Pokaż jakie masz repozytoria (patrz zasady forum).


RE: Pakiety kolidują ze sobą i uniemożliwiają instalację - rivulek - 04-08-2020

Oto repozytoria:
Kod:
System:    Host: luk-System-Product-Name Kernel: 5.4.0-26-generic x86_64 bits: 64 Console: tty 5
           Distro: Linux Mint 20 Ulyana
Repos:     No active apt repos in: /etc/apt/sources.list
           Active apt repos in: /etc/apt/sources.list.d/additional-repositories.list
           1: deb https://dl.winehq.org/wine-builds/ubuntu/ focal main
           Active apt repos in: /etc/apt/sources.list.d/brave-browser-release.list
           1: deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ stable main
           Active apt repos in: /etc/apt/sources.list.d/graphics-drivers-ppa-focal.list
           1: deb http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu focal main
           Active apt repos in: /etc/apt/sources.list.d/lutris-team-lutris-focal.list
           1: deb http://ppa.launchpad.net/lutris-team/lutris/ubuntu focal main
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
           1: deb http://packages.linuxmint.com ulyana main upstream import backport #id:linuxmint_main
           2: deb http://archive.ubuntu.com/ubuntu focal main restricted universe multiverse
           3: deb http://archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
           4: deb http://archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse
           5: deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
           6: deb http://archive.canonical.com/ubuntu/ focal partner



RE: Pakiety kolidują ze sobą i uniemożliwiają instalację - magnus - 04-08-2020

Spróbuj tej metody:

sudo su

for FILE in $(LANG=en dpkg-divert --list | grep nvidia-340 | awk '{print $3}'); do dpkg-divert --remove $FILE; done

exit

sudo apt-get purge nvidia*

Powtórz instalację.


RE: Pakiety kolidują ze sobą i uniemożliwiają instalację - rivulek - 05-08-2020

Dziękuję za odpowiedź. Niestety nie mogę wpisać tej drugiej komendy - tak jakby czegoś w niej brakowało.
[Obrazek: tSwUq3T.jpg]


RE: Pakiety kolidują ze sobą i uniemożliwiają instalację - magnus - 05-08-2020

Pokaż polecenie które wpisujesz.


RE: Pakiety kolidują ze sobą i uniemożliwiają instalację - rivulek - 05-08-2020

(05-08-2020, 13:32)magnus napisał(a): Pokaż polecenie które wpisujesz.

Bardzo proszę:
[Obrazek: TLD5Pvs.jpg]
(obrazek składa się z dwóch kadrów)


RE: Pakiety kolidują ze sobą i uniemożliwiają instalację - magnus - 06-08-2020

To jest jedno polecenie podzielone na dwie linie bo nie mieści się w jednej:

for FILE in $(LANG=en dpkg-divert --list | grep nvidia-340 | awk '{print $3}'); do dpkg-divert --remove $FILE; done

Powinno wyglądać tak:

for FILE in $(LANG=en dpkg-divert --list | grep nvidia-340 | awk '{print $3}'); do dpkg-divert --remove $FILE; done


RE: Pakiety kolidują ze sobą i uniemożliwiają instalację - rivulek - 06-08-2020

Dziękuję za odpowiedź. Teraz wprowadziłem komendę prawidłowo i problem jest częściowo rozwiązany. Niestety przy instalacji sterowników zwraca błąd:
[Obrazek: YpqiQeU.jpg]
Kod:
E: sub-process /usr/bin/dpkg returned and error code (1)
Próbowałem wpisać mu dpkg --configure -a, autoremove, remove - nic z tych rzeczy nie pomogło. Przeszukałem internet, ale nie znalazłem nic co by pomogło.

Dodano po pewnym czasie:
Udało mi się zainstalować ten sterownik, ale niestety wciąż nie mam środowiska graficznego (mogę wejść do konsoli, ale Cinnamon nie uruchamia się). Czy w Mincie Ulyana były jakieś kluczowe zmiany odnośnie grafiki? Od lat instaluję sterowniki graficzne z instrukcji (https://github.com/lutris/docs/blob/master/InstallingDrivers.md) i nigdy nie miałem aż takich problemów.

Dodano po pewnym czasie:
W tej chwili po odinstalowaniu (apt-get purge nvidia*) sterowników Cinnamon uruchamia się normalnie, z dużą rozdzielczością, ale niestety to jest sterownik który nie obsługuje Vulkana. Jakakolwiek zmiana sterownika na wersję nvidia-440 powoduje że środowisko graficzne przestaje działać. Obecnie mam aktywny sterownik xserver-xorg-video-nouveau.


RE: Pakiety kolidują ze sobą i uniemożliwiają instalację - dedito - 07-08-2020

A pokaż co teraz masz po sudo apt update && sudo apt dist-upgrade
Nie wklejaj zdjęć tylko tekst.