Forum Linux Mint Polska
[SOLVED] Aktualizacja Audacious-plugins, błąd libaudqt2 - Wersja do druku

+- Forum Linux Mint Polska (https://forum.linuxmint.pl)
+-- Dział: Wsparcie (https://forum.linuxmint.pl/forumdisplay.php?fid=203)
+--- Dział: Sprzęt i sterowniki (https://forum.linuxmint.pl/forumdisplay.php?fid=118)
+--- Wątek: [SOLVED] Aktualizacja Audacious-plugins, błąd libaudqt2 (/showthread.php?tid=1465)



Aktualizacja Audacious-plugins, błąd libaudqt2 - Traws - 05-02-2021

(Rozwiązane) Witam, wczoraj wyskoczyła aktualizacja audacious do zainstalowania + audacious-plugins i niestety coś się skopało. Próbując reinstalacji uszkodzonego pakietu czyli audacious-plugins przez menedżera pakietów wyskakuje

E: /var/cache/apt/archives/libaudqt2_4.1-0build2~ubuntu18.04_amd64.deb: próba nadpisania "/usr/lib/x86_64-linux-gnu/libaudqt.so.2.3.0", który istnieje także w pakiecie libaudqt5:amd64 4.1-0build1~ubuntu18.04


Kod:
(Odczytywanie bazy danych ... 649691 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu .../libaudqt2_4.1-0build2~ubuntu18.04_amd64.deb ...
Rozpakowywanie pakietu libaudqt2:amd64 (4.1-0build2~ubuntu18.04) ...
dpkg: błąd przetwarzania archiwum /var/cache/apt/archives/libaudqt2_4.1-0build2~ubuntu18.04_amd64.deb (--unpack):
próba nadpisania "/usr/lib/x86_64-linux-gnu/libaudqt.so.2.3.0", który istnieje także w pakiecie libaudqt5:amd64 4.1-0build1~ubuntu18.04
dpkg-deb: błąd: podproces wklej został zabity sygnałem (Przerwany potok)
Wystąpiły błędy podczas przetwarzania:
/var/cache/apt/archives/libaudqt2_4.1-0build2~ubuntu18.04_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Nie udało się zainstalować pakietu. Próba powrócenia do poprzedniego stanu:
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu audacious-plugins:amd64:
audacious-plugins:amd64 zależy od libaudqt2 (>= 4.1-0build2~ubuntu18.04); jednakże:
  Pakiet libaudqt2:amd64 nie jest zainstalowany.

dpkg: błąd przetwarzania pakietu audacious-plugins:amd64 (--configure):
problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu audacious:
audacious zależy od audacious-plugins (>= 4.1); jednakże:
  Pakiet audacious-plugins:amd64 nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu audacious (--configure):
problemy z zależnościami - pozostawianie nieskonfigurowanego
Przetwarzanie wyzwalaczy pakietu libc-bin (2.27-3ubuntu1.4)...
Wystąpiły błędy podczas przetwarzania:
audacious-plugins:amd64
audacious

próbując przez terminal 

Kod:
sudo apt-get --fix-broken install
[sudo] hasło użytkownika marcin:   
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności     
Odczyt informacji o stanie... Gotowe
Naprawianie zależności... Gotowe
Następujące pakiety zostały zainstalowane automatycznie i nie są już więcej wymagane:
  cmake-data libcec4 libcrossguid0 libfstrcmp0 libjsoncpp1 libmicrohttpd12
  libnghttp2-14:i386 libp8-platform2 libpsl5:i386 librhash0 librtmp1:i386
  libshairplay0 libssl1.0.0:i386 libtinyxml2.6.2v5 libuv1
  linux-headers-4.15.0-124 linux-headers-4.15.0-124-generic
  linux-headers-4.15.0-126 linux-headers-4.15.0-126-generic
  linux-headers-4.15.0-128 linux-headers-4.15.0-128-generic
  linux-headers-4.15.0-129 linux-headers-4.15.0-129-generic
  linux-headers-4.15.0-130 linux-headers-4.15.0-130-generic
  linux-headers-4.15.0-132 linux-headers-4.15.0-132-generic
  linux-image-4.15.0-124-generic linux-image-4.15.0-126-generic
  linux-image-4.15.0-128-generic linux-image-4.15.0-129-generic
  linux-image-4.15.0-130-generic linux-image-4.15.0-132-generic
  linux-modules-4.15.0-124-generic linux-modules-4.15.0-126-generic
  linux-modules-4.15.0-128-generic linux-modules-4.15.0-129-generic
  linux-modules-4.15.0-130-generic linux-modules-4.15.0-132-generic
  linux-modules-extra-4.15.0-124-generic
  linux-modules-extra-4.15.0-126-generic
  linux-modules-extra-4.15.0-128-generic
  linux-modules-extra-4.15.0-129-generic
  linux-modules-extra-4.15.0-130-generic
  linux-modules-extra-4.15.0-132-generic linux-tools-4.15.0-124
  linux-tools-4.15.0-124-generic linux-tools-4.15.0-126
  linux-tools-4.15.0-126-generic linux-tools-4.15.0-128
  linux-tools-4.15.0-128-generic linux-tools-4.15.0-129
  linux-tools-4.15.0-129-generic linux-tools-4.15.0-130
  linux-tools-4.15.0-130-generic linux-tools-4.15.0-132
  linux-tools-4.15.0-132-generic python-bluez python-cryptodome python3-distro
  python3-evdev python3-magic
Aby je usunąć należy użyć "sudo apt autoremove".
The following additional packages will be installed:
  libaudqt2
Zostaną zainstalowane następujące NOWE pakiety:
  libaudqt2
0 aktualizowanych, 1 nowo instalowanych, 0 usuwanych i 1 nieaktualizowanych.
1 nie w pełni zainstalowanych lub usuniętych.
Konieczne pobranie 0 B/121 kB archiwów.
Po tej operacji zostanie dodatkowo użyte 466 kB miejsca na dysku.
Kontynuować? [T/n] T
(Odczytywanie bazy danych ... 649630 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu .../libaudqt2_4.1-0build2~ubuntu18.04_amd64.deb ...
Rozpakowywanie pakietu libaudqt2:amd64 (4.1-0build2~ubuntu18.04) ...
dpkg: błąd przetwarzania archiwum /var/cache/apt/archives/libaudqt2_4.1-0build2~ubuntu18.04_amd64.deb (--unpack):
próba nadpisania "/usr/lib/x86_64-linux-gnu/libaudqt.so.2.3.0", który istnieje także w pakiecie libaudqt5:amd64 4.1-0build1~ubuntu18.04
dpkg-deb: błąd: podproces wklej został zabity sygnałem (Przerwany potok)
Wystąpiły błędy podczas przetwarzania:
/var/cache/apt/archives/libaudqt2_4.1-0build2~ubuntu18.04_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


coś tu z tym libaudqt2 się spieprzyło ale nie wiem jak to ogarnąć.

Kod:
sudo dpkg --configure -a
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu audacious-plugins:amd64:
audacious-plugins:amd64 zależy od libaudqt2 (>= 4.1-0build2~ubuntu18.04); jednakże:
  Pakiet libaudqt2:amd64 nie jest zainstalowany.

dpkg: błąd przetwarzania pakietu audacious-plugins:amd64 (--configure):
problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu audacious:
audacious zależy od audacious-plugins (>= 4.1); jednakże:
  Pakiet audacious-plugins:amd64 nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu audacious (--configure):
problemy z zależnościami - pozostawianie nieskonfigurowanego
Przetwarzanie wyzwalaczy pakietu libc-bin (2.27-3ubuntu1.4)...
Wystąpiły błędy podczas przetwarzania:
audacious-plugins:amd64
audacious


Edit: dobra temat do zamknięcia. pogrzebałem i poszło 
sudo dpkg --remove --force-remove-reinstreq libaudqt5 
i reinstalka audaciousa i już nie wyskakuje error żaden Smile


RE: Aktualizacja Audacious-plugins, błąd libaudqt2 - yahoob3 - 05-02-2021

Którego Minta używasz?
Może to jakiś chwilowy błąd od deva? Na początek można by odinstalować (purge) i zainstalować ponownie.


Aktualizacja Audacious-plugins, błąd libaudqt2 - yahoob3 - 05-02-2021

Oznaczam wątek jako rozwiązany.
Zamykam wątek.