Forum Linux Mint Polska
[SOLVED] /boot/grub/i386-pc/normal.mod not found - Wersja do druku

+- Forum Linux Mint Polska (https://forum.linuxmint.pl)
+-- Dział: Wsparcie (https://forum.linuxmint.pl/forumdisplay.php?fid=203)
+--- Dział: Instalacja i uruchamianie (https://forum.linuxmint.pl/forumdisplay.php?fid=132)
+--- Wątek: [SOLVED] /boot/grub/i386-pc/normal.mod not found (/showthread.php?tid=428)



/boot/grub/i386-pc/normal.mod not found - czamikos - 20-07-2019

Hej, na początek zaznaczę, że nie znam się totalnie na Linuxie.

Sytuacja wygląda tak:

Chciałem spróbować jak działa Linux obok Windows 7. W Windows odjąłem 100 GB z partycji systemowej i zostawiłem tą przestrzeń nieprzypisaną. Ściągnąłem Ubuntu wersje 18.04 LTS, nagrałem obraz na penie i załadowałem.
Podczas instalacji nie wybrałem instalacji obok Windows, a tą na samym dole. Następnie przeszedłem do okna, gdzie partycjonuje się dysk.
Miałem 4 partycje: Recovery, Windows (ok. 100MB), partycję NTFS z plikami Windows, dodatkową partycję na pliki oraz przestrzeń nieprzypisaną.

Tą przestrzeń podzieliłem na dwa w Ubuntu:
(/) oraz (/home)/ ext4 z księgowaniem. Zainstalowałem Ubuntu, bez problemu.
Niestety, podczas pierwszego bootowania, wyskoczył jakiś błądi nie udało się uruchomić systemu. Ściągnąłem więc Minta (wersja 19 coś).
Usunąłem partycje dla Ubuntu i sformatowałem je analogicznie, ale tym razem dodałem partycję (/boot) chyba około 1 GB. Podczas instalacji wystąpił błąd.
Uruchamiam komputer, a tam komunikat:

Error: file '/boot/grub/i386-pc/normal.mod not found
Entering rescue mode...
grub rescue>

Uruchamiam instalator Minta - myślę sobie, usunę partycje Linuxa i po problemie.
A tam nie wykrywa mi już dysku twardego!

Co teraz? Pomocy. Proszę o wyjaśnienie dla laika.

P.S. spróbowałem takiego rozwiązania z netu, ale nie pomogło:
wpisałem (w grub rescue): set root=(hd0,msdos1), następnie set prefix=(hd0,msdos1) po czym insmod normal, ale otrzymałem poniższe komunikaty dla poszczególnych partycji:

mdos1,2,3,5 - unknown filesystem (to chyba windows?)
msdos 6,7,8 - file /i386-pc/normal.mod not found


RE: /boot/grub/i386-pc/normal.mod not found - Ulvhedin - 20-07-2019

Stało się tak ponieważ prawdopodobnei ustawiles miejsce bootowania na partycje /boot a nie partycje windowsa. Tam powinna byc ustawiona lokalizacja instalacji GRUB'a. (zazwyczaj)

W chwili obecnej mozesz albo poznownie zainstalowac system i wybrac odpowiednie miejsce na instalacje GRUB lub naprawic. Podczas bootowania systemu powienien miec opcje (klawisz c chyba) to wejscia w tryb GRUB i tam dopiero sprobowac zlokalizowac swoje pliki.

Jesli wybierzesz opcje ponownej instalacji, zrob zrzut ekranu z ekranu w ktorym robisz partycjonowanie.

Pozdrawiam


RE: /boot/grub/i386-pc/normal.mod not found - czamikos - 21-07-2019

(20-07-2019, 23:09)Ulvhedin napisał(a): Stało się tak ponieważ prawdopodobnei ustawiles miejsce bootowania na partycje /boot a nie partycje windowsa. Tam powinna byc ustawiona lokalizacja instalacji GRUB'a. (zazwyczaj)

W chwili obecnej mozesz albo poznownie zainstalowac system i wybrac odpowiednie miejsce na instalacje GRUB lub naprawic. Podczas bootowania systemu powienien miec opcje (klawisz c chyba) to wejscia w tryb GRUB i tam dopiero sprobowac zlokalizowac swoje pliki.

Jesli wybierzesz opcje ponownej instalacji, zrob zrzut ekranu z ekranu w ktorym robisz partycjonowanie.

Pozdrawiam
Nic nie ustawiałem, bo podzieleniu partycji na /, /home i /boot kliknałem dalej. Potem wyskoczył błąd instalatora.

Problemem było to, że po tym ,jak wystąpił problem, po ponownym uruchominiem z pena, Mint nie widział w ogóle dysku twardego.

Ale włożyłem płytkę recovery windows, doszedłem do momentu, w którym należałoby uruchomić naprawę, po czym zrezygnowałem (czyli nic tak naprawdę nie zrobiłem). Po uruchomieniu Minta z pena, wykrywa on już dysk twardy, a cała przestrzeń na linuxa jest z powrotem oznaczona jako dostępna. Nie wiem, czy płytka z recovery pomogła, to raczej przypadek, ale kto wie.
Zaczałem kombinować dalej, ale nie udało się zainstalować żadnego Linuxa (Kali, Parrot) - zawsze wyskakiwał błąd.
Zrobiłem jednocześnie 2 rzeczy:
-zmieniłem partycję na której miał być linux z logicznej na podstawową (choć jak instalowałem Ubuntu, to chyba była też ustawiona na logiczną [ choć głowy nie dam] i nie spowodowało to problemów z grub)
-podzieliłem ją wcześniej na mniejsze części, bo pamiętałem, że podczas robienia skandisku z Win jakaś przestrzeń była wykrywana jako uszkodzona, więc może instalator  nie mógł jej użyć i crashować. Mniejsza partycja = szansa na to, że nie zawiera uszkodzonego obszaru. Nie  wiem, czy dla Linuxa uszkodzony obszar to problem czy nie.

W każdym razie, udało się zainstalować system w całości, otwiera się, podobnie jak Windows.


RE: /boot/grub/i386-pc/normal.mod not found - Ulvhedin - 21-07-2019

Oznacz watek zatem jako rozwiazany.


RE: /boot/grub/i386-pc/normal.mod not found - Ulvhedin - 22-07-2019

Zamykam.