Cześć! Wróciliśmy po ataku ransomware na serwer hostingowy, na którym postawione było nasze Forum. Niestety dane po 10 października 2020 r. uległy zniszczeniu.
Dane użytkowników są bezpieczne - nie doszło do ich wycieku. Jeśli w tym okresie zakładałeś konto na Forum, prosimy zrób to jeszcze raz.

Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Rozwiązane Instalacja Signal, pomocy.
#1
0
Staram się wpisywać w terminalu wszystko w koleiności lecz widocznie jestem jeszcze za tępy by działało.

Proszę o pomoc w jako się okazuję instalacja tego programu sprawia mi problemy. To jest ze strony instalacyjnej:
Kod:
NOTE: These instructions only work for 64 bit Debian-based
# Linux distributions such as Ubuntu, Mint etc.

# 1. Install our official public software signing key
wget -O- https://updates.signal.org/desktop/apt/keys.asc |\
  sudo apt-key add -

# 2. Add our repository to your list of repositories
echo "deb [arch=amd64] https://updates.signal.org/desktop/apt xenial main" |\
  sudo tee -a /etc/apt/sources.list.d/signal-xenial.list

# 3. Update your package database and install signal
sudo apt update && sudo apt install signal-desktop

Kod:
[email protected]:~$ inxi -Fxz
System:
  Host: Asusik-ROG Kernel: 5.3.0-51-generic x86_64 bits: 64 compiler: gcc
  v: 7.5.0 Desktop: Cinnamon 4.0.10 Distro: Linux Mint 19.1 Tessa
  base: Ubuntu 18.04 bionic
Machine:
  Type: Laptop System: ASUSTeK product: ROG Strix G731GT_G731GT v: 1.0
  serial: <filter>
  Mobo: ASUSTeK model: G731GT v: 1.0 serial: <filter>
  UEFI: American Megatrends v: G731GT.303 date: 06/05/2019
Battery:
  ID-1: BAT0 charge: 50.1 Wh condition: 50.1/50.5 Wh (99%)
  model: ASUSTeK ASUS Battery status: Not charging
  Device-1: hidpp_battery_0 model: Logitech Performance MX charge: 5%
  status: Discharging
CPU:
  Topology: Quad Core model: Intel Core i5-9300H bits: 64 type: MT MCP
  arch: Kaby Lake rev: D L2 cache: 8192 KiB
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 38400
  Speed: 881 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 865 2: 858
  3: 806 4: 822 5: 837 6: 826 7: 839 8: 830
Graphics:
  Device-1: Intel vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0
  Device-2: NVIDIA vendor: ASUSTeK driver: nvidia v: 450.80.02
  bus ID: 01:00.0
  Display: x11 server: X.Org 1.19.6 driver: modesetting,nvidia
  unloaded: fbdev,nouveau,vesa resolution: 1920x1080~60Hz
  OpenGL: renderer: GeForce GTX 1650/PCIe/SSE2 v: 4.6.0 NVIDIA 450.80.02
  direct render: Yes
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel
  v: kernel bus ID: 00:1f.3
  Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel
  bus ID: 01:00.1
  Sound Server: ALSA v: k5.3.0-51-generic
Network:
  Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi
  v: kernel port: 5000 bus ID: 00:14.3
  IF: wlo1 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: ASUSTeK driver: r8169 v: kernel port: 3000 bus ID: 03:00.0
  IF: eno2 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 255.97 GiB (53.7%)
  ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW512G8 size: 476.94 GiB
Partition:
  ID-1: / size: 467.96 GiB used: 255.96 GiB (54.7%) fs: ext4
  dev: /dev/nvme0n1p2
Sensors:
  System Temperatures: cpu: 44.0 C mobo: N/A gpu: nvidia temp: 38 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 288 Uptime: 1h 18m Memory: 7.63 GiB used: 2.13 GiB (28.0%)
  Init: systemd runlevel: 5 Compilers: gcc: 7.5.0 Shell: bash v: 4.4.20
  inxi: 3.0.27
#2
0
Żeby wiedzieć co źle robisz trzeba widzieć co robisz, ja się tylko domyślam, że problem tkwi w interpretacji tego co wpisać, może tak będzie prościej:
Kod:
wget -O- https://updates.signal.org/desktop/apt/keys.asc | sudo apt-key add -

Kod:
echo "deb [arch=amd64] https://updates.signal.org/desktop/apt xenial main" | sudo tee -a /etc/apt/sources.list.d/signal-xenial.list

Kod:
sudo apt update && sudo apt install signal-desktop
#3
0
Kod:
wget -O- https://updates.signal.org/desktop/apt/keys.asc

I coś się dzieje.

Kod:
sudo apt-key add -

Nic się nie dzieje. Terminal tak jakby się zawiesza. Wiele minut czekałem i nic.

Kod:
echo "deb [arch=amd64] https://updates.signal.org/desktop/apt xenial main" |\

Też zawiecha a poza tym nie mogę tego wpisać bezpośrednio po powyższym bo zawiecha.

I czy muszę wklejać następne? Rezultat ten sam.. Zawiecha Terminala.
#4
0
Źle wykonałeś pierwszą komendę, widać przecież, że napisałem ją inaczej.
Czy może nie widać?
#5
0
(15-11-2020, 18:29)dedito napisał(a): Źle wykonałeś pierwszą komendę, widać przecież, że napisałem ją inaczej.
Czy może nie widać?

Czyżby?  Kopij/Wklej owej pierwszej komendy:








Kod:
[email protected]:~$ wget -O- https://updates.signal.org/desktop/apt/keys.asc | sudo apt-key add -
--2020-11-15 17:32:04--  https://updates.signal.org/desktop/apt/keys.asc
Translacja updates.signal.org (updates.signal.org)... 54.239.192.50, 54.239.192.52, 54.239.192.109, ...
Łączenie się z updates.signal.org (updates.signal.org)|54.239.192.50|:443... [sudo] hasło użytkownika mateo: połączono.
Żądanie HTTP wysłano, oczekiwanie na odpowiedź... 200 OK
Długość: 3090 (3,0K) [application/pgp-signature]
Zapis do: `STDOUT'

-                   100%[===================>]   3,02K  --.-KB/s    w 0s      

2020-11-15 17:32:04 (1,07 GB/s) - zapisano na standardowe wyjście [3090/3090]


Kopij/wkej. I nadal zawiecha czy jak to nazwać....
#6
0
Teraz dobrze wpisałeś, wcześniej wpisywałeś coś zupełnie innego.
#7
0
Kod:
[email protected]usik-ROG:~$ wget -O- https://updates.signal.org/desktop/apt/keys.asc | sudo apt-key add -
--2020-11-15 17:36:00--  https://updates.signal.org/desktop/apt/keys.asc
Translacja updates.signal.org (updates.signal.org)... [sudo] hasło użytkownika mateo: 54.239.192.50, 54.239.192.52, 54.239.192.109, ...
Łączenie się z updates.signal.org (updates.signal.org)|54.239.192.50|:443... połączono.
Żądanie HTTP wysłano, oczekiwanie na odpowiedź... 200 OK
Długość: 3090 (3,0K) [application/pgp-signature]
Zapis do: `STDOUT'

-                   100%[===================>]   3,02K  --.-KB/s    w 0,001s   

2020-11-15 17:36:01 (2,32 MB/s) - zapisano na standardowe wyjście [3090/3090]



Niestety, proszę spróbować ponownie.
[sudo] hasło użytkownika mateo:
Niestety, proszę spróbować ponownie.
[sudo] hasło użytkownika mateo:         
OK
[email protected]:~$

Dodano po pewnym czasie:
Ok... teraz pokaże całość komentarza :-)

Kod:
[email protected]:~$ wget -O- https://updates.signal.org/desktop/apt/keys.asc | sudo apt-key add -
--2020-11-15 17:36:00--  https://updates.signal.org/desktop/apt/keys.asc
Translacja updates.signal.org (updates.signal.org)... [sudo] hasło użytkownika mateo: 54.239.192.50, 54.239.192.52, 54.239.192.109, ...
Łączenie się z updates.signal.org (updates.signal.org)|54.239.192.50|:443... połączono.
Żądanie HTTP wysłano, oczekiwanie na odpowiedź... 200 OK
Długość: 3090 (3,0K) [application/pgp-signature]
Zapis do: `STDOUT'

-                   100%[===================>]   3,02K  --.-KB/s    w 0,001s   

2020-11-15 17:36:01 (2,32 MB/s) - zapisano na standardowe wyjście [3090/3090]



Niestety, proszę spróbować ponownie.
[sudo] hasło użytkownika mateo:
Niestety, proszę spróbować ponownie.
[sudo] hasło użytkownika mateo:         
OK
[email protected]:~$ echo "deb [arch=amd64] https://updates.signal.org/desktop/apt xenial main" |\
>   sudo tee -a /etc/apt/sources.list.d/signal-xenial.list
deb [arch=amd64] https://updates.signal.org/desktop/apt xenial main
[email protected]:~$ sudo apt update && sudo apt install signal-desktop
Pobieranie:1 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]
Stary:2 http://archive.ubuntu.com/ubuntu bionic InRelease                     
Stary:3 http://ppa.launchpad.net/clipgrab-team/ppa/ubuntu bionic InRelease     
Pobieranie:4 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88,7 kB]
Pobieranie:5 https://updates.signal.org/desktop/apt xenial InRelease [2 316 B]
Stary:6 http://ppa.launchpad.net/lutris-team/lutris/ubuntu bionic InRelease   
Stary:7 https://brave-browser-apt-release.s3.brave.com stable InRelease       
Stary:8 https://repo.skype.com/deb stable InRelease                           
Stary:9 http://archive.canonical.com/ubuntu bionic InRelease                   
Pobieranie:11 http://archive.ubuntu.com/ubuntu bionic-backports InRelease [74,6 kB]
Pobieranie:10 http://ppa.launchpad.net/teejee2008/ppa/ubuntu bionic InRelease [15,4 kB]
Pobieranie:12 https://updates.signal.org/desktop/apt xenial/main amd64 Packages [1 163 B]
Pobieranie:13 http://security.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [48,9 kB]
Pobieranie:14 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [59,5 kB]
Pobieranie:15 http://security.ubuntu.com/ubuntu bionic-security/multiverse amd64 DEP-11 Metadata [2 464 B]
Pobieranie:16 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 DEP-11 Metadata [295 kB]
Pobieranie:17 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 DEP-11 Metadata [288 kB]
Błąd:10 http://ppa.launchpad.net/teejee2008/ppa/ubuntu bionic InRelease       
  Następujące podpisy nie mogły zostać zweryfikowane z powodu braku klucza publicznego: NO_PUBKEY B5B116B72D0F61F0
Pobieranie:18 http://archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 DEP-11 Metadata [2 468 B]
Pobieranie:19 http://archive.ubuntu.com/ubuntu bionic-backports/universe amd64 DEP-11 Metadata [9 288 B]
Stary:20 https://dl.winehq.org/wine-builds/ubuntu bionic InRelease             
Ign.:21 http://repo.vivaldi.com/stable/deb stable InRelease                   
Stary:22 http://repo.vivaldi.com/stable/deb stable Release             
Błąd:24 http://packages.linuxmint.com tessa InRelease               
  Nie udało się przetłumaczyć nazwy "packages.linuxmint.com"
Czytanie list pakietów... Gotowe       
W: Błąd GPG: http://ppa.launchpad.net/teejee2008/ppa/ubuntu bionic InRelease: Następujące podpisy nie mogły zostać zweryfikowane z powodu braku klucza publicznego: NO_PUBKEY B5B116B72D0F61F0
E: Repozytorium 'http://ppa.launchpad.net/teejee2008/ppa/ubuntu bionic InRelease' jest niepodpisane.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
#8
0
A nie możesz zainstalować go z flathuba z menedżera oprogramowania?
[Obrazek: dnNVQjFl.png]
#9
0
Przepraszam za ten chaos ale naprawdę nie dość, że jestem wkurzony to jestem nadal jestem głupkiem w tym.

Dodano po pewnym czasie:
(15-11-2020, 18:42)yahoob3 napisał(a): A nie możesz zainstalować go z flathuba z menedżera oprogramowania?
[Obrazek: dnNVQjFl.png]

O jest. Hurra, jest :-)

Dodano po pewnym czasie:
Teraz mogę... dopiero teraz manager oprogramowania w ogóle działa.. Wcześniej naprawdę nic nie działało...
#10
0
Nie ma się czym wkurzać tylko na spokojnie stosować wskazówki,czytać i przede wszystkim pokazywać co się robi, bez tego będzie ciężko.


Skocz do:




Użytkownicy przeglądający ten wątek: 1 gości