Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
zniekształcone wyświetlanie planszy gry Frozen Bubble
#11
0
(08-09-2020, 17:18)dedito napisał(a): Spróbuj wcisnąć F2 i  okienku tam wpisz mate-terminal lub kliknij PPM na pulpicie i powinna być opcja otwarcia termianala.
W terminalu wpisz mate-panel --replace
Wpisałem to polecenie, lecz nie sytuacja się nie zmieniła.
Następnie z terminala wydałem polecenie „reboot” i  menu wybrałem opcję odzyskiwania, co poskutkowało przywróceniem paska zadań. Wykonałem więc próbę uruchomienia rzeczonej gry, lecz niestety pomimo wybrania innego sterownika karty graficznej plansza gry po poleceniu Alt+F jest nadal zniekształcona. Podjąłem jeszcze jedną próbę wyboru sterownika o najniższym numerze. lecz problem nadal pozostaje nierozwiązany. Czyżby oznaczało to, że ta dystrybucja Linux Mint nie jest jednak w stanie spełnić mojego oczekiwania w opisanym zakresie? Jaki jeszcze czynnik może wchodzić w grę skoro w PCLinuxOS MATE pracującym w tej samej konfiguracji sprzętowej opisany problem nie występuje?
[/quote]
Odpowiedz
#12
0
Dla pewności zapytam.
Ta gra jest natywna na Linuksa? Nie uruchamiana przez wine?
Ta sama wersja gry?
Odpowiedz
#13
0
(09-09-2020, 16:35)dedito napisał(a): Dla pewności zapytam.
Ta gra jest natywna na Linuksa? Nie uruchamiana przez wine?
Ta sama wersja gry?
Tak, jak najbardziej.
Odpowiedz
#14
0
To sprawdź na jakim sterowniku pracuje karta tam gdzie jest ok.
Odpowiedz
#15
0
(11-09-2020, 18:41)dedito napisał(a): To sprawdź na jakim sterowniku pracuje karta tam gdzie jest ok.
Nie wiem jak to sprawdzić w PCLinuxOS MATE.
Odpowiedz
#16
0
Tak samo jak tu, użyj inxi.
Plik logu xorg też pewnie coś podpowie.
Odpowiedz
#17
0
Oto wynik wydania polecenia. A wersja rzeczonej gry nosi numer 2.2.1. Czy coś z tego wynika?

Kod:
System:
  Kernel: 5.7.19-pclos1 x86_64 bits: 64 compiler: gcc v: 10.2.0
  Desktop: MATE 1.24.1 Distro: PCLinuxOS 2020
Machine:
  Type: Desktop Mobo: MICRO-STAR model: 770-C45 (MS-7599) v: 1.0
  serial: <filter> BIOS: American Megatrends v: 1.13 date: 09/04/2010
CPU:
  Info: Quad Core model: AMD Phenom II X4 965 bits: 64 type: MCP arch: K10
  rev: 3 L2 cache: 2048 KiB
  flags: lm nx pae sse sse2 sse3 sse4a svm bogomips: 27268
  Speed: 800 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 800 2: 800
  3: 3400 4: 800
Graphics:
  Device-1: NVIDIA GK208B [GeForce GT 730] vendor: ZOTAC driver: nouveau
  v: kernel bus ID: 01:00.0
  Device-2: vendor: Avermedia driver: N/A bus ID: 03:00.0
  Display: server: X.Org 1.20.8 driver: nouveau,v4l resolution:
  1: 1600x1200~60Hz 2: 1600x1200~60Hz
  OpenGL: renderer: NV106 v: 4.3 Mesa 20.1.6 direct render: Yes
Audio:
  Device-1: AMD SBx00 Azalia vendor: Micro-Star MSI driver: snd_hda_intel
  v: kernel bus ID: 00:14.2
  Device-2: NVIDIA GK208 HDMI/DP Audio vendor: ZOTAC driver: snd_hda_intel
  v: kernel bus ID: 01:00.1
  Device-3: vendor: Avermedia driver: N/A bus ID: 03:00.0
  Sound Server: ALSA v: k5.7.19-pclos1
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: Micro-Star MSI driver: r8169 v: kernel port: e800 bus ID: 04:00.0
  IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 298.09 GiB used: 50.57 GiB (17.0%)
  ID-1: /dev/sda vendor: Western Digital model: WD3200AAJB-56WGA0
  size: 298.09 GiB
Partition:
  ID-1: / size: 144.06 GiB used: 22.92 GiB (15.9%) fs: ext4 dev: /dev/sda5
  ID-2: /home size: 145.26 GiB used: 27.65 GiB (19.0%) fs: ext4
  dev: /dev/sda6
Swap:
  ID-1: swap-1 type: partition size: 3.90 GiB used: 0 KiB (0.0%)
  dev: /dev/sda1
Sensors:
  System Temperatures: cpu: 30.2 C mobo: N/A gpu: nouveau temp: 35.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 187 Uptime: 10m Memory: 15.65 GiB used: 519.6 MiB (3.2%)
  Init: SysVinit runlevel: 5 Compilers: gcc: 10.2.0 Packages: 2587
  Shell: Bash v: 4.4.23 inxi: 3.1.06
[[email protected] ~]$
Odpowiedz
#18
0
Porównując prawidłową konfiguracje:
Kod:
Graphics:
  Device-1: NVIDIA GK208B [GeForce GT 730] vendor: ZOTAC driver: nouveau
  v: kernel bus ID: 01:00.0
  Device-2: vendor: Avermedia driver: N/A bus ID: 03:00.0
  Display: server: X.Org 1.20.8 driver: nouveau,v4l resolution:
  1: 1600x1200~60Hz 2: 1600x1200~60Hz
  OpenGL: renderer: NV106 v: 4.3 Mesa 20.1.6 direct render: Yes
do nieprawidłowej
Kod:
Graphics:
  Device-1: NVIDIA GK208B [GeForce GT 730] vendor: ZOTAC driver: nouveau
  v: kernel bus ID: 01:00.0
  Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa
  resolution: 1600x1200~60Hz, 1600x1200~60Hz
  OpenGL: renderer: NV106 v: 4.3 Mesa 20.0.8 direct render: Yes
Widzę, że jest nowsza Mesa i inne sterownik serwera Xorg
Jest też jeszcze załadowany jakiś tuner TV.
Warto jeszcze porównać logi Xorg.
Odpowiedz
#19
0
(14-09-2020, 07:05)dedito napisał(a): Widzę, że jest nowsza Mesa i inne sterownik serwera Xorg
Jest też jeszcze załadowany jakiś tuner TV.
Warto jeszcze porównać logi Xorg.
To nie jest tuner, lecz karta przechwytywania wideo. A jaką składnię ma polecenie Xorg?
Odpowiedz
#20
0
Chodzi o logi w /var/log/ gdzie znajdziesz pliki Xorg.0.log Xorg.1.log itd...
Odpowiedz


Skocz do:




Użytkownicy przeglądający ten wątek: 1 gości