Ocena wątku:
  • 2 głosów - średnia: 3.5
  • 1
  • 2
  • 3
  • 4
  • 5
Problem ze sterownikiem do karty graficznej
#1
0
Dzień dobry,
zainstalowałem minta na innym komputerze z kartą graficzną GeForce 6600. Już po uruchomieniu instalki systemu systemu zauważyłem, że obraz nie jest poprawnie wyświetlany, brakuje rozdzielczości 1680 x 1050, gdyż taką obsługuje mój monitor, ponadto obraz ,,ucieka" czyli np. nie widać paska z menu start. Wpisałem komendy które pokazały, że jest problem ze sterownikiem. W jaki sposób mogę to naprawić? Czy trzeba pobrać skądś sterownik czy użyć innego rozwiązania? Poniżej wklejam wyniki z terminala. Dodam, że na Windows 7 działa wszystko ok.

Kod:
[email protected]:~$ inxi -Fx
System:
  Host: dominik-P31-DS3L Kernel: 4.15.0-20-generic x86_64 bits: 64
  compiler: gcc v: 7.3.0 Desktop: Cinnamon 4.0.8
  Distro: Linux Mint 19.1 Tessa base: Ubuntu 18.04 bionic
Machine:
  Type: Desktop Mobo: Gigabyte model: P31-DS3L v: x.x
  serial: <root required> BIOS: Award v: F5 date: 10/02/2007
CPU:
  Topology: Dual Core model: Intel Core2 Duo E7200 bits: 64 type: MCP
  arch: Penryn rev: 6 L2 cache: 3072 KiB
  flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 bogomips: 10132
  Speed: 1619 MHz min/max: N/A Core speeds (MHz): 1: 1619 2: 1642
Graphics:
  Device-1: NVIDIA NV43 [GeForce 6600] driver: nouveau v: kernel
  bus ID: 01:00.0
  Display: x11 server: X.Org 1.19.6 driver: nouveau
  unloaded: fbdev,modesetting,vesa resolution: 1440x900~60Hz
  OpenGL: renderer: NV43 v: 2.1 Mesa 18.0.5 direct render: Yes
Audio:
  Device-1: Intel NM10/ICH7 Family High Definition Audio
  vendor: Gigabyte GA-D525TUD driver: snd_hda_intel v: kernel
  bus ID: 00:1b.0
  Sound Server: ALSA v: k4.15.0-20-generic
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: Gigabyte driver: r8169 v: 2.3LK-NAPI port: d000 bus ID: 03:00.0
  IF: enp3s0 state: down mac: 00:1d:7d:9f:1d:88
  Device-2: Ralink RT2561/RT61 802.11g PCI driver: rt61pci v: 2.3.0
  port: d000 bus ID: 04:00.0
  IF: wlp4s0 state: down mac: 00:0e:2e:76:67:13
Drives:
  Local Storage: total: 113.51 GiB used: 11.58 GiB (10.2%)
  ID-1: /dev/sda vendor: Samsung model: HM060HI size: 55.89 GiB
  ID-2: /dev/sdb type: USB vendor: Kingston model: DataTraveler 3.0
  size: 57.62 GiB
Partition:
  ID-1: / size: 19.86 GiB used: 6.47 GiB (32.6%) fs: ext4 dev: /dev/sda5
Sensors:
  System Temperatures: cpu: 48.0 C mobo: N/A gpu: nouveau temp: 45 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 160 Uptime: 8m Memory: 1.45 GiB used: 606.6 MiB (40.8%)
  Init: systemd runlevel: 5 Compilers: gcc: 7.3.0 Shell: bash v: 4.4.19
  inxi: 3.0.27
[email protected]:~$ xrandr
Screen 0: minimum 320 x 200, current 1440 x 900, maximum 4096 x 4096
DVI-I-1 connected primary 1440x900+0+0 (normal left inverted right x axis y axis) 410mm x 257mm
  1440x900      59.89*+  74.98 
  1280x1024    75.02    60.02 
  1280x960      60.00 
  1152x864      75.00 
  1024x768      75.03    70.07    60.00 
  832x624      74.55 
  800x600      72.19    75.00    60.32    56.25 
  640x480      75.00    72.81    66.67    59.94 
  720x400      70.08 
DVI-I-2 disconnected (normal left inverted right x axis y axis)
TV-1 disconnected (normal left inverted right x axis y axis)

Tak dla porównania, na innym komputerze, z którego teraz piszę na tym samym monitorze wygląda to tak:

Kod:
Graphics:
  Device-1: Intel 82Q963/Q965 Integrated Graphics vendor: Hewlett-Packard
  driver: i915 v: kernel bus ID: 00:02.0
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa
  resolution: 1680x1050~60Hz
  OpenGL: renderer: Mesa DRI Intel 965Q v: 2.1 Mesa 18.0.5
  direct render: Yes

Tutaj niby wszystko działa ok, chociaż wcale jakoś nie śmiga ten komputer, ale jakość obrazu jest bardzo dobra. Tylko że też jest to: unloaded: fbdev,vesa, ale za to jest modesetting. Czy w związku z tym na tym komputerze jest wszystko w porządku?
Odpowiedz
#2
0
Ten kod z konsoli trzeba umieszczać pomiędzy znacznikami 
Kod:
[code]...[/code]

Tak to powinno wyglądać:


Kod:
Graphics:
  Device-1: Intel 82Q963/Q965 Integrated Graphics vendor: Hewlett-Packard
  driver: i915 v: kernel bus ID: 00:02.0
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa
  resolution: 1680x1050~60Hz
  OpenGL: renderer: Mesa DRI Intel 965Q v: 2.1 Mesa 18.0.5
  direct render: Yes

To ten przycisk
[Obrazek: 7GkCtKsl.png]

Wszelkie informacje potrzebne przed założeniem posta:

Jak zadawać pytania na forum?

Ułatwiasz w ten sposób administratorom czytanie twojego posta i przyczyni się do szybszego rozwiązania twojego problemu.
Kto nie próbuje, ten nie umie. Nie ma głupich pytań. Są tylko głupi ludzie.   Tongue
Odpowiedz


Skocz do:




Użytkownicy przeglądający ten wątek: 1 gości