Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Drukarka Samsung M2026 przestała działać.
#11
0
W pierwszej kolejności uruchom deinstalatory - do drukarki i skanera. Potem uruchom jak powyżej instalatory osobno.

EDIT:
Gdyby wyskoczył jakiś błąd, skopiuj go i wklej na forum.
Odpowiedz
#12
0
Uruchomiłem deinstalatory kolejno. Potem instalatory . Niby wszystko ok. Podłączam kabel od drukarki i nic się nie dzieje. Zawsze samo po podłączeniu kabla wykrywało drukarkę . Teraz nie. I z panelu Drukarki daje dodaj drukarkę ale jej nie widzi. Nie można dodać.
Odpowiedz
#13
0
Drukarkę instaluj podłączoną i włączoną. To nie Windows Smile

Jeśli powyższe nie zadziała...
Hmmm... spróbuj wykonać po kolei takie polecenia:
Kod:
sudo apt-get install --reinstall cups cups-browsed cups-client cups-common cups-daemon cups-server-common
oraz
Kod:
sudo systemctl daemon-reload
Gdyby nie ruszyło dodawanie drukarki, wykonaj jeszcze:
Kod:
sudo cp /usr/share/cups/cupsd.conf.default /etc/cups/cupsd.conf
oraz
Kod:
sudo service cups restart

Wg tego przepisu nie zadziała?
https://forum.linuxiarze.pl/index.php/to...0#msg15918
Odpowiedz
#14
0
OK... po kolei bo może gdzieś popełniasz błąd:

- uruchom dwuklikiem plik install.sh, uruchom w terminalu,
- naciśnij Enter, gdy zapyta o zgodę na instalację,
- wyświetli się licencja - naciśnij q, potem y i Enter,
- przy następnym pytaniu o firewall wciśnij n i enter
dopiero teraz instaluje się sterownik.

Można spróbować przez przeglądarkę internetową wpisując adres: localhost:631/admin i zalogować się swoim loginem i hasłem...

A kabel masz dobry? Tak mi przyszło do głowy? USB jak sądzę...
Odpowiedz
#15
0
Próbowałem wszystkiego. Nie działa. Może kabel jest winny? Albo porty USB?
Odpowiedz
#16
0
Po podpięciu do USB, przy załączonej drukarce, wpisz w terminalu dmesg | tail i lsusb i pokaż co zwróci.
Odpowiedz
#17
0
Kod:
enovo-G580:~$ dmesg | tail
[   21.896006] NET: Registered protocol family 38
[   22.515262] IPv6: ADDRCONF(NETDEV_CHANGE): wlp2s0: link becomes ready
[   23.084731] Bluetooth: RFCOMM TTY layer initialized
[   23.084741] Bluetooth: RFCOMM socket layer initialized
[   23.084745] Bluetooth: RFCOMM ver 1.11
[   74.523668] [UFW BLOCK] IN=wlp2s0 OUT= MAC= SRC=fe80:0000:0000:0000:0abb:f925:e92b:cd7b DST=ff02:0000:0000:0000:0000:0000:0000:0001 LEN=89 TC=0 HOPLIMIT=1 FLOWLBL=375756 PROTO=UDP SPT=22161 DPT=161 LEN=49
[   74.690326] [UFW BLOCK] IN=wlp2s0 OUT= MAC= SRC=fe80:0000:0000:0000:0abb:f925:e92b:cd7b DST=ff02:0000:0000:0000:0000:0000:0000:0001 LEN=89 TC=0 HOPLIMIT=1 FLOWLBL=375756 PROTO=UDP SPT=22161 DPT=161 LEN=49
[   74.856691] [UFW BLOCK] IN=wlp2s0 OUT= MAC= SRC=fe80:0000:0000:0000:0abb:f925:e92b:cd7b DST=ff02:0000:0000:0000:0000:0000:0000:0001 LEN=89 TC=0 HOPLIMIT=1 FLOWLBL=375756 PROTO=UDP SPT=22161 DPT=161 LEN=49
[  113.927122] kauditd_printk_skb: 14 callbacks suppressed
[  113.927123] audit: type=1400 audit(1612552297.619:26): apparmor="DENIED" operation="capable" profile="/usr/sbin/cups-browsed" pid=1731 comm="cups-browsed" capability=23  capname="sys_nice"
[email protected]:~$ lsusb
Bus 002 Device 003: ID 5986:0295 Acer, Inc
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 003: ID 105b:e065 Foxconn International, Inc. BCM43142A0 Bluetooth module
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[email protected]:~$
Odpowiedz
#18
0
Jedynie te dwa wpisy z dmesg mają powiązanie z dukarką:
Kod:
[  113.927122] kauditd_printk_skb: 14 callbacks suppressed
[  113.927123] audit: type=1400 audit(1612552297.619:26): apparmor="DENIED" operation="capable" profile="/usr/sbin/cups-browsed" pid=1731 comm="cups-browsed" capability=23  capname="sys_nice"
ale powinno być troszkę więcej tych wpisów, no i w lsusb też nie widać drukarki.
Sprawdź czy ta drukarka jest sprawna, zmień, kabel usb, zmień port usb ...
Instrukcja obsługi: http://h10032.www1.hp.com/ctg/Manual/c05790128
Odpowiedz
#19
0
Drukarka i kabel sprawne. Zainstalowałem ją na Q4 Debian który jest na komputerze stacjonarnym i działa. A na laptopie pod mintem nie chce. Co jeszcze mogę sprawdzić? Pojawia się komunikat że drukarka może być niepodłączona. i status :Unable to locate printer "hostname"
 Jeszcze zgodnie z instrukcją próbowałem 
Kod:
[email protected]:~$ sudo system-config-printer
[sudo] hasło użytkownika adam:     
/usr/share/system-config-printer/system-config-printer.py:315: DeprecationWarning: Gtk.ActionGroup.list_actions is deprecated
  for action in printer_manager_action_group.list_actions ():
/usr/share/system-config-printer/system-config-printer.py:316: DeprecationWarning: Gtk.Action.set_sensitive is deprecated
  action.set_sensitive (False)
/usr/share/system-config-printer/system-config-printer.py:324: DeprecationWarning: Gtk.ActionGroup.get_action is deprecated
  act = printer_manager_action_group.get_action (action)
/usr/share/system-config-printer/system-config-printer.py:354: DeprecationWarning: Gtk.UIManager.ensure_update is deprecated
  self.ui_manager.ensure_update ()
/usr/share/system-config-printer/system-config-printer.py:355: DeprecationWarning: Gtk.UIManager.get_accel_group is deprecated
  self.PrintersWindow.add_accel_group (self.ui_manager.get_accel_group ())
/usr/share/system-config-printer/system-config-printer.py:364: DeprecationWarning: Gtk.UIManager.get_action is deprecated
  action = self.ui_manager.get_action ("/new-printer")
/usr/share/system-config-printer/system-config-printer.py:365: DeprecationWarning: Gtk.Action.create_menu_item is deprecated
  newprinteritem = action.create_menu_item ()
/usr/share/system-config-printer/system-config-printer.py:663: DeprecationWarning: Gtk.Action.get_proxies is deprecated
  for widget in action.get_proxies ():
/usr/share/system-config-printer/system-config-printer.py:976: DeprecationWarning: urllib.parse.splittype() is deprecated as of 3.8, use urllib.parse.urlparse() instead
  (scheme, rest) = urllib.parse.splittype (object.device_uri)
/usr/share/system-config-printer/system-config-printer.py:2236: DeprecationWarning: Gdk.threads_enter is deprecated
  Gdk.threads_enter ()
/usr/share/system-config-printer/system-config-printer.py:2187: DeprecationWarning: Gdk.threads_leave is deprecated
  Gdk.threads_leave ()
[email protected]:~$
Odpowiedz
#20
0
A na Q4 stosowałeś tą samą procedurę instalacji?
Odpowiedz


Skocz do:




Użytkownicy przeglądający ten wątek: 1 gości