Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Toshiba P750 - nie działa podświetlenie klawiatury
#11
0
(26-02-2021, 15:43)dedito napisał(a): Kopiemy dalej:
Kod:
ls /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS620A:00
Kod:
ls /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS6205:00
Kod:
ls /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS1900:00

Kod:
[email protected]:~$ ls /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS620A:00
driver  modalias  physical_node  protection_level  status     uevent
hid     path      power          reset_protection  subsystem

Kod:
[email protected]:~$ ls /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS6205:00
driver  modalias  physical_node  rfkill  subsystem
hid     path      power          status  uevent

Kod:
[email protected]:~$ ls /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS1900:00
available_kbd_modes  leds                        subsystem
cooling_method       modalias                    touchpad
driver               path                        uevent
hid                  physical_node               usb_sleep_charge
iio:device0          power                       usb_sleep_music
kbd_backlight_mode   sleep_functions_on_battery  version
kbd_type             status
Odpowiedz
#12
0
Ok, dokopaliśmy się.
To teraz pokaż co masz ustawione w:
Kod:
cat /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS1900:00/available_kbd_modes
Kod:
cat /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS1900:00/kbd_backlight_mode
Odpowiedz
#13
0
(26-02-2021, 16:05)dedito napisał(a): Ok, dokopaliśmy się.
To teraz pokaż co masz ustawione w:
Kod:
cat /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS1900:00/available_kbd_modes
Kod:
cat /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS1900:00/kbd_backlight_mode

Kod:
[email protected]:~$ cat /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS1900:00/available_kbd_modes
0x2 0x8 0x10
Kod:
[email protected]:~$ cat /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS1900:00/kbd_backlight_mode
8
Odpowiedz
#14
0
Wg dokumentacji:
Cytat:* 0x1  -> FN-Z
* 0x2  -> AUTO (also called TIMER)
* 0x8  -> ON
* 0x10 -> OFF
Ty masz tylko 2, 8, 10
Ustawione masz 8, czyli podświetlenie powinno być aktywne.
Spróbuj pobawić się w przestawianie (jako root):
Kod:
echo 2 > /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS1900:00/kbd_backlight_mode
potem
Kod:
echo 10 > /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS1900:00/kbd_backlight_mode
lub (bo te tryby 0x to chyba podano w systemie szesnastkowym)
Kod:
echo 16 > /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS1900:00/kbd_backlight_mode
i znowu
Kod:
echo 8 > /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS1900:00/kbd_backlight_mode
Może to spowoduje, że podświetlenie w końcu się załączy.
W Biosie patrzyłeś czy nie ma jakiejś blokady?
Aktualizacja Bios do ostatniej wersji wykonana?
Odpowiedz
#15
0
(26-02-2021, 17:37)dedito napisał(a): Wg dokumentacji:
Cytat:* 0x1  -> FN-Z
* 0x2  -> AUTO (also called TIMER)
* 0x8  -> ON
* 0x10 -> OFF
Ty masz tylko 2, 8, 10
Ustawione masz 8, czyli podświetlenie powinno być aktywne.
Spróbuj pobawić się w przestawianie (jako root):
Kod:
echo 2 > /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS1900:00/kbd_backlight_mode
potem
Kod:
echo 10 > /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS1900:00/kbd_backlight_mode
lub (bo te tryby 0x to chyba podano w systemie szesnastkowym)
Kod:
echo 16 > /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS1900:00/kbd_backlight_mode
i znowu
Kod:
echo 8 > /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS1900:00/kbd_backlight_mode
Może to spowoduje, że podświetlenie w końcu się załączy.
W Biosie patrzyłeś czy nie ma jakiejś blokady?
Aktualizacja Bios do ostatniej wersji wykonana?

Kod:
[email protected]:~$ sudo -i
[sudo] hasło użytkownika szychal:         
[email protected]:~# echo 2 > /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS1900:00/kbd_backlight_mode
[email protected]:~# echo 10 > /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS1900:00/kbd_backlight_mode
-bash: echo: błąd zapisu: Zły argument
[email protected]:~# echo 16 > /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS1900:00/kbd_backlight_mode
[email protected]:~# echo 8 > /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS1900:00/kbd_backlight_mode
[email protected]:~#
nie pomoglo. wciskajac klawisz FN+Z pojawia sie tylko obrazek. na windowsie dzialalo wszystko. Ale do niego nie wroce. wole miec klawiature przyciemniona niz sytem zamulony. dzieki za pomoc
Odpowiedz
#16
0
To spróbuj jeszcze tak (jako root):
Kod:
echo 2 >> /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS1900:00/kbd_backlight_mode
potem
Kod:
echo 16 >> /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS1900:00/kbd_backlight_mode
i znowu
Kod:
echo 8 >> /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS1900:00/kbd_backlight_mode

W Biosie patrzyłeś czy nie ma jakiejś blokady?
Aktualizacja Bios do ostatniej wersji wykonana?

Takie coś: https://www.youtube.com/watch?t=108&v=ok...e=youtu.be
Odpowiedz
#17
0
(26-02-2021, 19:23)dedito napisał(a): To spróbuj jeszcze tak (jako root):
Kod:
echo 2 >> /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS1900:00/kbd_backlight_mode
potem
Kod:
echo 16 >> /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS1900:00/kbd_backlight_mode
i znowu
Kod:
echo 8 >> /sys/devices/LNXSYSTM:00/LNXSYBUS:00/TOS1900:00/kbd_backlight_mode

W Biosie patrzyłeś czy nie ma jakiejś blokady?
Aktualizacja Bios do ostatniej wersji wykonana?

Takie coś: https://www.youtube.com/watch?t=108&v=ok...e=youtu.be
w biosie wszytko ok. co prawda nigdy go nie aktualizowalem bo sie boje Smile
Odpowiedz
#18
0
A jak ustawisz w BIOS na ON to się załącza?
Odpowiedz
#19
0
(26-02-2021, 22:23)dedito napisał(a): A jak ustawisz w BIOS na ON to się załącza?
w biosie wszystko sie swieci. no nic. najlepsze ze przez jakis czas mi sie palil NUM LOCK po wykonywaniu wszystkich komend ktore mi napisales . teraz znowu sie nie pali jak go wlacze. nie ma problemu . dziekuje
Odpowiedz
#20
0
Jaka decyzja w sprawie wątku?
Zamykamy, zostawiamy otwarty na inne pomysły?
Odpowiedz


Skocz do:




Użytkownicy przeglądający ten wątek: 1 gości