Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Bluetooth nie znajduje żadnych urządzeń
#11
0
(05-09-2021, 21:14)yahoob3 napisał(a): Bez przesady z tym terminalem. Miałem na myśli żebyś się wklikal do tego katalogu.
pkexec nemo i masz Nemo jako admin.
Co do karty... Działała lub działa pod innym systemem? Bo wynik rfkill jest co najmniej zastanawiający.

odnośnie usunięcia pliku z katalogu -> ok

"pkexec nemo" -> może to głupie, ale nie bardzo rozumiem o co chodzi. Nie jestem aż tak biegły z architektury Linuxa.

co do WiFi -> czy mógłbyś rozwinąć swoją wypowiedź. Karta WiFi działa pod innymi systemami. Sprawdzone na windows 10 i Linux Mint 19.3
Odpowiedz
#12
0
W terminalu wpisz pkexec nemo
Odpowiedz
#13
0
(06-09-2021, 07:53)dedito napisał(a): W terminalu wpisz pkexec nemo

wpisałem w/w komendę do terminala

Kod:
[email protected]:~$ sudo pkexec nemo
[sudo] hasło użytkownika maciej:     
Cannot run program nemo: No such file or directory
[email protected]:~$

i dalej nie rozumiem. Tak jak pisałem nie jestem osobą biegły z architektury/budowy Linuxa

Dodano po pewnym czasie:
(05-09-2021, 21:14)yahoob3 napisał(a): Bez przesady z tym terminalem. Miałem na myśli żebyś się wklikal do tego katalogu.
pkexec nemo i masz Nemo jako admin.
Co do karty... Działała lub działa pod innym systemem? Bo wynik rfkill jest co najmniej zastanawiający.

byłem w tym katalogu ale wspomnianych plików w nim nie ma.

Cytat:Spróbuj jeszcze usunąć (jako administrator) starszy sterownik "BCM43142A0-105b-e065.hcd" z lokalizacji:

/lib/firmware/brcm/. Zostaw tylko ten nowszy: "BCM43142A0-0a5c-21d7.hcd" - restart komputera po tym.
Odpowiedz
#14
0
Rozwiązałem problem niedziałającego modułu Bluetooth temat do zamknięcia.
Odpowiedz
#15
0
Podziel się jak. Może ktoś skorzysta.
Odpowiedz
#16
1
Better response on post RE: Bluetooth nie znajduje żadnych urządzeńPrzepraszam, że tak późno odpowiadam. Problem rozwiązałem w następujący sposób:



w terminalu użyłem komendy:

Kod:
lsusb


sprawdziłem producenta i model modułu bluetooth

w moim przypadku:

Bus 003 Device 006: ID 105b:e065 Foxconn International, Inc. BCM43142A0 Bluetooth module

czyli pobrałem sterownik BCM43142A0-105b-e065 używając w terminalu komendy:

Kod:
wget https://github.com/winterheart/broadcom-bt-firmware/raw/master/brcm/BCM43142A0-105b-e065.hcd


po prawidłowym pobraniu pliku

w terminalu użyłem komendy:

Kod:
sudo cp BCM43142A0-105b-e065.hcd /lib/firmware/brcm/


restart komputera



przydatne linki

https://forum.linuxmint.pl/showthread.php?tid=1740

https://forum.linuxmint.pl/showthread.php?tid=73

Dodano po pewnym czasie:
Po ostatniej aktualizacji systemu pojawił się problem. Mianowicie po uruchomieniu komputera system nie widzi modułu Bluetooth, dopiero gdy wykonam restart komputera z poziomu systemu moduł jest widziany i tak jest za każdym razem. Może ktoś spotkał się z takim problemem i wie jak go rozwiązać, żeby system od razu po uruchomieniu widział moduł, a nie dopiero po restarcie.
Odpowiedz
#17
0
Rzuć okiem na ten wątek: https://forums.linuxmint.com/viewtopic.php?t=306834
Jeśli po komendach w nim podanych coś wyskoczy w terminalu - podrzuć na forum.
Odpowiedz
#18
0
(04-10-2021, 20:33)yahoob3 napisał(a): Rzuć okiem na ten wątek: https://forums.linuxmint.com/viewtopic.php?t=306834
Jeśli po komendach w nim podanych coś wyskoczy w terminalu - podrzuć na forum.

wyniki wykonania poszczególnych komend po uruchomieniu komputera

Kod:
service bluetooth status

Kod:
[email protected]:~$ service bluetooth status
● bluetooth.service - Bluetooth service
     Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor pre>
     Active: inactive (dead)
       Docs: man:bluetoothd(8)

paź 10 12:00:37 maciej-Lenovo-G510 systemd[1]: Condition check resulted in Blue>
paź 10 12:02:05 maciej-Lenovo-G510 systemd[1]: Condition check resulted in Blue>
paź 10 12:09:14 maciej-Lenovo-G510 systemd[1]: Condition check resulted in Blue>
lines 1-8/8 (END)

Kod:
sudo systemctl enable bluetooth.service

Kod:
[email protected]:~$ sudo systemctl enable bluetooth.service
[sudo] hasło użytkownika maciej:     
Synchronizing state of bluetooth.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable bluetooth

Kod:
sudo systemctl start bluetooth.service

po wykonaniu komendy nic nie wyskoczyło
Odpowiedz
#19
0
Po pierwszej komendzie wyskoczyło, że masz "inactive (dead)" BT.

Sprawdź, czy po wykonaniu "enable" i "start bluetooth.service" polecanie service bluetooth status zwróci coś podobnego (zwróć uwagę na 4 linijkę):
Kod:
[email protected]:~$ service bluetooth status
● bluetooth.service - Bluetooth service
     Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor pre>
     Active: active (running) since Sat 2021-10-09 13:23:45 CEST; 2 days ago
       Docs: man:bluetoothd(8)
   Main PID: 707 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 6866)
     Memory: 2.9M
     CGroup: /system.slice/bluetooth.service
             └─707 /usr/lib/bluetooth/bluetoothd

Warto sprawdzić jeszcze raz stan "przełączników" poleceniem rfkill list.

Nie masz czasem trybu samolotowego włączonego? U mnie to, np. Fn+F7.
Sprawdź, czy na uruchomionym systemie Live BT działa.
Odpowiedz
#20
0
(11-10-2021, 21:18)yahoob3 napisał(a): Po pierwszej komendzie wyskoczyło, że masz "inactive (dead)" BT.

Sprawdź, czy po wykonaniu "enable" i "start bluetooth.service" polecanie service bluetooth status zwróci coś podobnego (zwróć uwagę na 4 linijkę):
Kod:
[email protected]:~$ service bluetooth status
● bluetooth.service - Bluetooth service
     Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor pre>
     Active: active (running) since Sat 2021-10-09 13:23:45 CEST; 2 days ago
       Docs: man:bluetoothd(8)
   Main PID: 707 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 6866)
     Memory: 2.9M
     CGroup: /system.slice/bluetooth.service
             └─707 /usr/lib/bluetooth/bluetoothd

Warto sprawdzić jeszcze raz stan "przełączników" poleceniem rfkill list.

Nie masz czasem trybu samolotowego włączonego? U mnie to, np. Fn+F7.
Sprawdź, czy na uruchomionym systemie Live BT działa.

Wykonanie jeszcze raz komend
Cytat:Sprawdź, czy po wykonaniu "enable" i "start bluetooth.service" polecanie service bluetooth status

dało taki sam efekt jak pisałem w poprzednim poście

Natomiast są z miany w komendzie rfkill list w stosunku do poprzednich razy (komenda wykonana po uruchomieniu komputera)
Kod:
[email protected]:~$ rfkill list
0: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
[email protected]:~$

Jeślibym miał włączony tryb samolotowy to by mi również nie działało WiFi.

rfkill list - wykonane po restarcie komputera
Kod:
[email protected]:~$ rfkill list
0: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: ideapad_bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
3: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
4: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
[email protected]:~$
Odpowiedz


Skocz do:




Użytkownicy przeglądający ten wątek: 1 gości